Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 02/01/2013, à 20:13

ladsy

ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Bonjour,

Encore un sujet sur les ATI et leur performances ... (ma précédente MSI 8600 GTS me cassait pas autant les pieds).

J'ai réussi jusqu'à maintenant à configurer tip/top ma bountoutou 12.10 en laissant (cette fois) les pilotes fglrx-update fournis dans les paquetages d'upgrade.
J'ai fini par trouver via un man aticonfig que xorg.conf ne faisait pas tout ... et maintenant, j'ai mis dans mon .profile une commande du type :

aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=600,800 --od-commitclocks --od-gettemperature --effective=now --pxl

En gros, ça permet de dire la fréquence max du processeur 600 et de la mémoire 800 et la vitesse de rotation des ventilateurs (ici 8%) à la volée.

Du coup, j'ai fait quelques benchs ....
Sachant que ma HD 6850 devrait normalement faire bonne figure ici : http://doc.ubuntu-fr.org/classement_glxgears
Disons que j'arrive rarement à faire mieux que 22.000 là ou on l'aurait attendue au moins au dessus d'une HD5670 soit vers 65.000.
Je me disais : ptet que ça viens du fait que je teste avec Unity en tache de fond du coup je ne m'affolais pas.
Oui mais ...

Si je change la fréquence de ma carte-graphique, la logique voudrait que les performances changent non ? ... et ce, quelques soient les paramétrages potentiellement foireux, voir les pilotes potentiellement merdiques que j'emploie ... en gros, quelques soit fglrx et ma mauvaise optimisation de xorg.conf.

Bon alors j'ai fait ces tests-ci :

user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=200,400 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 200
                  New Memory Peak : 400
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 55.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ vblank_mode=0 glxgears
20767 frames in 5.0 seconds = 4153.212 FPS
20775 frames in 5.0 seconds = 4154.963 FPS
20537 frames in 5.0 seconds = 4107.218 FPS
20639 frames in 5.0 seconds = 4127.779 FPS
^C
user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=400,800 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 400
                  New Memory Peak : 800
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 58.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ vblank_mode=0 glxgears
20402 frames in 5.0 seconds = 4080.342 FPS
20810 frames in 5.0 seconds = 4161.823 FPS
20902 frames in 5.0 seconds = 4180.255 FPS
22611 frames in 5.0 seconds = 4522.128 FPS
21218 frames in 5.0 seconds = 4243.508 FPS
21211 frames in 5.0 seconds = 4242.012 FPS
21161 frames in 5.0 seconds = 4232.194 FPS
21018 frames in 5.0 seconds = 4203.537 FPS
^C
user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=800,1200 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 800
                  New Memory Peak : 1200
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 61.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ vblank_mode=0 glxgears
20617 frames in 5.0 seconds = 4123.285 FPS
20868 frames in 5.0 seconds = 4173.276 FPS
20855 frames in 5.0 seconds = 4170.853 FPS
21372 frames in 5.0 seconds = 4274.330 FPS
20902 frames in 5.0 seconds = 4180.281 FPS
21121 frames in 5.0 seconds = 4224.187 FPS
20691 frames in 5.0 seconds = 4138.071 FPS
^C
user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=800,800 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 800
                  New Memory Peak : 800
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 63.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ vblank_mode=0 glxgears
20247 frames in 5.0 seconds = 4049.308 FPS
20808 frames in 5.0 seconds = 4161.595 FPS
21734 frames in 5.0 seconds = 4346.788 FPS
20791 frames in 5.0 seconds = 4158.153 FPS
^C
user@machine:~$ 

Je ne sais pas vous, mais moi j'en déduis que les benchs glxgears ne changent pas !
A j'attendais qu'ils varient entre ... allez disons 22.000 à 800 MHz - et 11.000 à 400 MHz, voir 5.000 à 200 MHz.

Je précise car j'anticipe une question ... Le changement de fréquence GPU/Mémoire marche en temps réel sitôt la commande tapée. Je suis convaincu de cela pas seulement car c'est affiché dans le résultat de la ligne de commande, mais car si je dépasse de trop les fréquences supportées par la carte graphique, l'écran gèle quasi aussitôt - obligé de rebooter au bouton off - ! ... donc il réagit à une sur-fréquence et ce même si le processeur est pas chargé soit quasi en idle.


D'où la question bête .... pourquoi ?

Pourquoi les perfs ne changent pas en fonction de la fréquence du GPU ?


Merci d'avance.


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#2 Le 02/01/2013, à 23:02

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Tant que j'y suis pendant que j'ai encore mon PC avec ma vielle MSI 8600 GTS ... sous Ubuntu 10.10, Gnome 2.32 et installé convenablement :
user@MSI8600GTS:~$ glxgears
63892 frames in 5.0 seconds = 12778.202 FPS
63918 frames in 5.0 seconds = 12783.516 FPS
63939 frames in 5.0 seconds = 12787.616 FPS
63920 frames in 5.0 seconds = 12783.975 FPS

Dites moi que je sais pas paramétrer xorg.conf car là je vais carrément payer pour que l'on me débarasse de ma HD6850 vu tout ce qu'elle me fait chier !


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#3 Le 03/01/2013, à 05:21

fcn50

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Salut,

Premierement, je site la page de ton lien:

Sinon je tiens à rappeler que glxgears n'est pas un benchmark à part entière, pour plusieurs raisons puisqu'il ne donne aucune information viable et tangible pour avoir une idée des performances de sa carte graphique :

Deuxiemement, c'est fgl_glxgears la commande pour AMD et pour finir, si tu mets Vsync dans CCC tu auras 60 FPS ce qui est tout a fait normal. A quoi ca sert d'avoir 2'000'000'000 de FPS sur un ecran capable uniquement de 60?

Pour mieux se rendre compte des "perfs" j'utilise ce lien qui me donne une vue d'ensemble qui me sert de reference:

http://ie.microsoft.com/testdrive/Perfo … edReading/


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#4 Le 03/01/2013, à 21:32

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Bonjour,
Merci pour t'être penché sur mon problème.

> juste "avoir une idée des performances"
oui, oui, j'en suis bien conscient. Mais mon objectif n'est pas d'avoir la plus grosse, mais juste de comparer.
Dans le cas présent la fréquence n'influe pas sur la performance et ça je ne comprends pas pourquoi.

Alors, en effet, fgl_gears est le glxgear spécifique à ATI (j'ai fini par le comprendre hier soir en fait big_smile ).
Mais bon, il faut bien se donner un ordre d'idée, d'ailleurs même cette page de ubuntu-fr mélange les résultats ATI / nVidia avec le même outil. Et en plus, je crois qu'employer fgl_gear ou glxgear ne change rien au problème ... les 2 devraient donner des résultats dépendant de la fréquence du GPU / mémoire.

Du coup, revoici mon test :

user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=200,400 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 200
                  New Memory Peak : 400
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 56.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=400,800 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 400
                  New Memory Peak : 800
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 57.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
9966 frames in 5.0 seconds = 1993.200 FPS
10158 frames in 5.0 seconds = 2031.600 FPS
10199 frames in 5.0 seconds = 2039.800 FPS
9638 frames in 5.0 seconds = 1927.600 FPS
^C
user@machine:~$ vblank_mode=0 fgl_glxgears
Using GLX_SGIX_pbuffer
8322 frames in 5.0 seconds = 1664.400 FPS
9589 frames in 5.0 seconds = 1917.800 FPS
9709 frames in 5.0 seconds = 1941.800 FPS
9959 frames in 5.0 seconds = 1991.800 FPS
^C
user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=800,1200 --od-commitclocks --od-gettemperature --effective=now --pxlPPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 800
                  New Memory Peak : 1200
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 59.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ vblank_mode=0 fgl_glxgears
Using GLX_SGIX_pbuffer
9123 frames in 5.0 seconds = 1824.600 FPS
9837 frames in 5.0 seconds = 1967.400 FPS
10114 frames in 5.0 seconds = 2022.800 FPS
9835 frames in 5.0 seconds = 1967.000 FPS
^C
user@machine:~$ aticonfig -v --pplib-cmd "set fanspeed 0 8" --od-enable --od-setclocks=800,800 --od-commitclocks --od-gettemperature --effective=now --pxl
PPLIB command execution is Successful!
AMD Overdrive(TM) enabled

Default Adapter - AMD Radeon HD 6800 Series 
                  New Core Peak   : 800
                  New Memory Peak : 800
Clocks persisted for the Default Adapter - AMD Radeon HD 6800 Series 

Default Adapter - AMD Radeon HD 6800 Series 
                  Sensor 0: Temperature - 61.00 C
PowerXpress: Integrated GPU is active (Power-Saving mode).
user@machine:~$ vblank_mode=0 fgl_glxgears
Using GLX_SGIX_pbuffer
8352 frames in 5.0 seconds = 1670.400 FPS
9819 frames in 5.0 seconds = 1963.800 FPS
9876 frames in 5.0 seconds = 1975.200 FPS
9680 frames in 5.0 seconds = 1936.000 FPS
^C
user@machine:~$ 

Pour moi, je ne vois pas de changement. hmm
Les "perfs" de cette carte graphique ne varient pas en fonction de la fréquence ... dur.


> Vsync dans CCC tu auras 60 FPS
hein ? C'est quoi CCC ? Catalyst Control Center ?
Sur le coup, j'avais entendu ça : http://www.youtube.com/watch?v=XkOYGrZQqmU big_smile
Je crois que je ne l'ai tout simplement utilisé depuis que j'ai installé ma 12.10.
Pour moi, je n'ai aucun Vsync activé dans ma config.

Si tu me parles de Vsync car tu as lu "vblank_mode=0", attention, je n'ai fait que suivre la reco de la page web. Mais comme tu l'as vu dans mon nouveau test, j'ai tenté avec et sans ... et en fait ça ne change rien au résultat.
J'ai bien désactivé Vsync dans  ccsm par contre. Of course ! Tout ce qui ressemble à un Vsync je le désactive en général.
Pour exemple, un extrait de mon Gestionaire de Configuration CompizConfig :
- Composite plugin
-- Fréquence de rafaîchissement : 75
- OpenGL Plugin :
- Filtre de texture rapide
- Eclairage : non coché
- Sync vers VBlank : non coché
- Compression de texture / Framebuffer object / Vertext buffer / Always use buffer swapping : coché
De plus,  cat xorg.conf | grep sync donne un résultat vide, donc au minimum c'est par défaut et certainement je n'emploie pas de Vsync.

> A quoi ca sert d'avoir 2'000'000'000 de FPS sur un ecran capable uniquement de 60?
Attention, je ne partage pas ton point de vue là.
Avec des animations belles, on a besoin d'une carte un peu musclée pour avoir une vitesse d'affichage plus rapide.
Je prends un exemple que j'ai remarqué.
Je joue à 0ad pendant 1h.
Et bien une fois revenu sur Unity et terminé de jouer ... les fenêtre Nautilus et Cairo dock (j'ai un beau thème Mac OS X avec Cairo) me semblent réellement plus "spontané" et "fluide". Je sais pas ce qui se passe entre la carte graphique et 0ad, mais ça booste !
J'aimerai bien avoir cette spontannéité quand je n'utilise pas 0ad de toute ma session.
Donc, les perfs, ça joue quand même ... un peu.
Enfin moi je le sent bien. Une fois encore, même si je joue encore comme un gros gamin et si je bidouille ma bountou pour la rendre un peu belle ( sinon j'aurais installé une slackware avec mwm comme je faisais sur mon 486 en l'an 96 big_smile ) , j'ai passé l'âge de benchmarker la plus grosse !


Bon, je viens de lancer amdcccle (enfin big_smile).
Je ne vois pas d'option Vsync en fait roll
Ce serait où pour vérifier s'il te plait ?
Partout ou je viens de parcourir, je pense au mieux à cela :
Plus de paramètres : Attendre le rafraîchissement vertical : barre vers Performance.
Option d'affichage / Sans déchirement : Activez le bureau sans déchirement pour réduire le déchirement (car s'il est désactivé, ça active l'option 'attendre le rafraîchissement').


Alors le résultat du test de ton intéressante page web :
How fast can uour browser speed read ?
Using Mozilla Firefox 18 (béta 7 des PPA)
Total Billobard Draws: 392
Average Draw Duration: 25ms
Last Draw Duration : 04 ms
Window Size 1920x1079
J'ai fait un F11 sur Firefox de façon à ce que la page web prenne tout l'écran.

Dernière modification par ladsy (Le 03/01/2013, à 21:43)


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#5 Le 03/01/2013, à 21:36

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Dis moi Faucon,
Tu as aussi une ATI ... et en plus HD7750 une fanless.

1) t'en pense quoi ? Car ma 6850 me dégoute d'ATI ...
.. si tu en es satisfait et si tu me confirmes qu'elle ne fait pas varier à fond pendnat les jeux le ventilo de ton alimentation comme le faisait ma précédente fanless - 8600 GTS - je risque de me la payer, elle rentre dans mes prix.

2) Tu peux me donner ton xorg.conf et tes autres paramètres que je zieute ?

et le résultat de ta page web big_smile

Dernière modification par ladsy (Le 03/01/2013, à 21:45)


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#6 Le 04/01/2013, à 06:43

fcn50

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

CCC=Catalyst Control Centre, Vsync=Bureau sans dechirement.

How fast can uour browser speed read ? Resultat en secondes a la fin (je ne met pas le test en plein ecran)? J'utilise Iron (fork de chromium) car FF est devenu un vrai boulet.

Bien sur que les perfs de la CG jouent un role mais tout mauvais reglage peu reduire ces perfs a 0. C'est un tout.

Ma 7750 me convient pleinement (je ne joue pas), elle ne fait pas touner le ventilo de mon alim plus vite pour la simple raison que l'alim est fanless. lol

J'evite les conseils d'achats. En ayant conseille a qq'un (budget 500E) de ne pas prendre une alim noname (economie 20-40E) car c'est le composant le plus important de tout systeme electrique, je me suis fait insulter a tel point de devoir le signaler au modo. Je m'abstient donc volontier. Il y des comparatifs/avis sur le net et assez d'infos pour faire un achat judicieux. A toi de voir d'apres tes besoins qui ne sont pas les memes que les miens.

faucon50 a écrit :

A quoi ca sert d'avoir 2'000'000'000 de FPS sur un ecran capable uniquement de 60

Je persiste, c'est le GPU, la ram de la CG, le CPU, l'environnement et reglages qui font la difference pas le FPS. Si un ecran est a 60 il restera a 60Hz, 120 a 120Hz, etc etc... A nouveau, c'est un tout.

Je ne peux te donner mon xorg.conf, je suis a 10'000 km de mon ordi et le verrai a nouveau au printemps, desole.

Mais question perfs en general, la premiere chose que je fais, c'est de ne pas installer unity/gnome 3 mais Xfce "en install mini" car les deux precites sont des vrais boulets.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#7 Le 04/01/2013, à 11:31

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

> comparatifs/avis sur le net
C'est en suivant les comparatifs du net que j'ai acheté ma HD 6850.
Du coup, le bon vieux retour d'expérience est ce qu'il y a de mieux.
PcInpact disait qu'elle était inaudible dans ses tests ...

Non en général j'insulte pas quand on me conseille un truc. J'insulte après, quand je constate après achat qu'on ma conseillé de la merde big_smile
De toute façon, je crois que je vais revendre mon ati et prendre la première nVidia fanless que je trouve. Au moins j'aurais au pire le comportement de ma vielle 8600 GTS que je n'arrive même pas à trouver en ce moment.

Une alim Fanless ? Tiens je croyais que ça se faisait plus depuis les retours aux vendeurs de ma vielle Zalman (que j'avais gardé 5 jours). Ca tiens la route maintenant. Il faut que je me remette à la page. Ma Seasonic me convient bien, elle fait de toute façon quasi pas de bruits et pourtant ... je suis exigeant.

Iron >
Bon, j'ai fais les tests sous chromium, ça me va bien quand je veux lancer vite le navigateur.
Using Google Chrome 22
FPS : 20
Total Billboard Draws : 387
Average Draw Duration: 49ms
Last Draw Duration: 49ms
toujours en grand écran
Un rien moins de perf on dirait avec Chromium.

xfce >
Et bien moi xfce, c'est dans l'une de mes VM. Je trouve que c'est moche en écran de machine hôte ... et trop spartiate en fait. En plus c'est pas demain que je lacherai nautilus.

Dernière modification par ladsy (Le 04/01/2013, à 11:34)


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#8 Le 04/01/2013, à 15:17

fcn50

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

ladsy a écrit :

Du coup, le bon vieux retour d'expérience est ce qu'il y a de mieux.
PcInpact disait qu'elle était inaudible dans ses tests ...

Les gouts et les couleurs... Tous jurent que par Itruc et Imachin etc etc... Perso, je ne voudrait aucun prodruit de la pomme verolee meme si on me payais, comme quoi. J'ai mes exigences et je sais ce que je veux et je recherche les caracteristiques techniques que je souhaite ou du moins le meilleurs compromis possible. Certains bouffe tous les jours chez Mc do et trouvent ca super et le conseil! Pour choisir en connaissance de cause il faut lire, beaucoup lire et encore lire.

Mon alim fanless 400w ne m'a jamais fait defaut depuis le temps que je l'ai malgre la config "assez gourmande".

Pour Xfce il est bien clair que si tu prends l'install standard, ca fait pas bander un phoque. Mais personnallise a son gout, c'est autre chose (j'utilise aussi nautilus comme gestionnaire de fichiers par defaut). Resultat, depuis que je l'ai fais miens (Xfce) je suis content de ne pas m'emmerder avec unity/gnome3 et leurs bugs a gogo. A nouveau les gouts et les couleurs.

Sur Iron/Chromium il faut activer l'acceleration qui ne l'est pas d'office (barre d'adresse>about:gpu)! En combien de secondes le test est-il effectue? C'est ecrit en plein milieu du test a la fin du defilement des lettres.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#9 Le 04/01/2013, à 21:48

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

> Sur Iron/Chromium il faut activer l'acceleration qui ne l'est pas d'office
Alors, je suis allé sur cette page et j'ai pas trouvé comment modifier quoique ce soit.
Néanmoins ta remarque est très fructueuse car j'ai vu que certaines choses n'étaient pas activées.

Affichage sous Windows de about:gpu sous chromium 23

Canvas: Hardware accelerated
Compositing: Hardware accelerated
3D CSS: Hardware accelerated
CSS Animation: Accelerated
WebGL: Hardware accelerated
WebGL multisampling: Hardware accelerated
Flash 3D: Hardware accelerated
Flash Stage3D: Hardware accelerated
Texture Sharing: Hardware accelerated
Video Decode: Hardware accelerated
... je passe la suite

Affichage sous Ubuntu 12.10 et chromium 22 :

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Software only, hardware acceleration unavailable
3D CSS: Unavailable. Hardware acceleration unavailable
CSS Animation: Software only, hardware acceleration unavailable
WebGL: Unavailable. Hardware acceleration unavailable
WebGL multisampling: Unavailable. Hardware acceleration unavailable
Flash 3D: Unavailable. Hardware acceleration unavailable
Flash Stage3D: Unavailable. Hardware acceleration unavailable
Texture Sharing: Unavailable. Hardware acceleration unavailable
undefined: Software only, hardware acceleration unavailable

Je ne comprenais pas le coup du test ... en fait c'est parce qu'il était plutôt long et que je perdais patience.
Alors j'ai testé autant sous Windows 7 Edition Integrale que Ubuntu 12.10 (même bécane dual-boot).
Le résultat est sans appel !

Chromium / GNU-Linux
FPS : 19
totall  : 16882
Average Draw Duration : 51 ms
temps : 969 seconds

Google Chrome 23 / Windows
FPS : 60
Total Billboard Draws 787
temps : 7 seconds

Firefox 17 / Windows
FPS : 60
temps : 6 seconds

Donc, soit les pilotes ATI fglrx fournis dans avec Quantal (Version installée : 2:9.000-ubuntu3) sont des drivers de merde ... soit Unity pompe les 80% des ressources graphiques ... soit j'ai paramétré mes fichiers comme une merde.

Etrangement je penche pour la solution 1 ou 3. J'avais eu des difficultés à installer les drivers proprio sur Quantal, je crois que je vais les mettre là ...


chtit édit de 22h06 :
J'ai collé les pilotes fglrx-update.
Constaté que sous Unity le changement n'était pas probant.
J'ai installé le paquet motif-clients ... pour que cette fois le gestionnaire de fenêtre ne puisse pas être incriminé....
Comme j'avais dédié un compte de connexion distante ... et bien cette fois je me suis connecté sur ce compte, mais sous "mwm".
1) .. instant d'émotion, me voici revenu au temps du gestionnaire de fenêtre de ma fac du temps de ma licence d'info.
2) voici les test du coup ...

chromium-browser
1096x987
FPS : 20
Total Billboard Draws : 16870
Average Draw Duration : 49ms
Last Draw Duration : 47ms
Temps : 931 Seconds

user@machine:~$ fgl_glxgears 
Using GLX_SGIX_pbuffer
17346 frames in 5.0 seconds = 3469.200 FPS
18625 frames in 5.0 seconds = 3725.000 FPS
18618 frames in 5.0 seconds = 3723.600 FPS
18495 frames in 5.0 seconds = 3699.000 FPS
user@machine:~$ vblank_mode=0 glxgears
42260 frames in 5.0 seconds = 8451.905 FPS
42321 frames in 5.0 seconds = 8464.150 FPS
42364 frames in 5.0 seconds = 8472.775 FPS
user@machine:~$ glxgears
41844 frames in 5.0 seconds = 8368.727 FPS
41808 frames in 5.0 seconds = 8361.530 FPS
42257 frames in 5.0 seconds = 8451.239 FPS
42256 frames in 5.0 seconds = 8451.046 FPS
42207 frames in 5.0 seconds = 8441.286 FPS

Donc ... et bien sous fgl_glxgears comme sous glxgear on voit que les performances sont multipliées par 2 à la louche.
Ca donne bien une idée de ce que bouffe Unity à lui seul.
Mais dans tous les cas, c'est plus bas que ce à quoi on peut s'attendre avec une carte de ce niveau.

Il m'a été impossible de passer la taille de l'écran en 1920x1080 car F11 laisse quand même les bords du gestionnaire de fenêtre mwm ... du coup, il faudrait en réalité augmenter le temps (ou refaire mes test sous Unity). Mais on voit bien qu'en fait le temps est similaire.

Pour moi, même si le gestionnaire de fenêtre mange des ressources, en gestion de performance "brute" le problème n'est pas le gestionnaire de fenêtre et réside :
- soit dans la configuration
- soit dans le pilote

autres périgrinations de 23h13 avant d'aller se coucher car j'en ai marre pour ce soir.
Après fglrx-update, j'ai voulu voir ce que ça donnait avec les Catalyst 12.10 téléchargés sur le site d'ATI/AMD ..... ceux qui supportent pas Xserver v1.13 ... big_smile
Le cat /var/log/Xorg.0.log donne :

[    25.529] (II) LoadModule: "fglrx"
[    25.529] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
[    25.646] (EE) Failed to load /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension
[    25.646] (II) UnloadModule: "fglrx"
[    25.646] (II) Unloading fglrx
[    25.646] (EE) Failed to load module "fglrx" (loader failed, 7)

Déjà après désinstallation complète des fglrx-updates, installation fglrx-catalyst (appelons ainsi), et bien fglrx se lance pas car tout simplement c'est pas le bon xserver. Je me retrouve en 1400xqqchose. Les résultats sous chromium et glxgear / fgl_gears sont aussi mauvais.
Bon ensuite j'ai galéré pour remettre les bon fglrx-updates.

Dernière modification par ladsy (Le 05/01/2013, à 00:19)


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#10 Le 05/01/2013, à 06:08

fcn50

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Vire tout ce qui est fglrx* et xorg.conf puis reboot et installe catalyst 12.11 beta (pas le pilote fourni par buntu) comme indique dans cette doc au point 2.4 (--buildandinstallpkg) puis reboot et donne le retour de fglrxinfo.

http://doc.ubuntu-fr.org/catalyst

Pour activer l'acceleration dans chromium: about:flags et coche un truc du genre: ignorer la liste du rendu gpu,,, dans la partie supperieur des flags et redamarrage chromium puis verifie about:gpu que tout soit au vert.

ladsy a écrit :

sont des drivers de merde

Je serais tente de dire que les drivers AMD sont de merde meme sous win... Et nvidia fait maintenant autant dans le merdique qu'AMD, y'a qu'a voir le forum!

Je suis a + ou - a 12 secondes pour speed reading sous Iron 22 et avec Chromium (17-19) j'ai meme reussi 6s avec une HD 5450.

P.S. Si tu veux un conseil... vu que c'est la soupe a la grimace, tente l'install catalyst 12.11 Beta comme dit et si c'est merdique, vire cet crotte intermediaire de buntu 12.10 et installe la 12.04 LTS qui fonctionne tres bien et est supportee 5 ans. Perso je suis sous 12.04 et c'est un vrai metronome alors que la 12.10 est une reussite dans le genre navet, oignon, de quoi faire une bonne soupe. Y'a qu'a lire le forum...

Dernière modification par faucon50 (Le 05/01/2013, à 15:38)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#11 Le 05/01/2013, à 20:42

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Salut,

Bon, et bien maintenant j'ai activé des trucs via l'option about:flags.

Graphics Feature Status
Canvas: Hardware accelerated
Compositing: Hardware accelerated on all pages
3D CSS: Hardware accelerated
CSS Animation: Accelerated
WebGL: Hardware accelerated
WebGL multisampling: Hardware accelerated
Flash 3D: Hardware accelerated
Flash Stage3D: Hardware accelerated
Texture Sharing: Hardware accelerated
undefined: Hardware accelerated

ça a été fructueux puisque je suis passé à 13 secondes ....
Donc visiblement, il y a des choses qu'il faut que je modifie quelques part puisque même Firefox est aussi lent que Chromium par défaut.

13 secondes au premier coup et 11 en rejouant cela 3 fois ensuite (60 FPS affiché cette fois, pas 19 ou 22), c'est toujours pas les 6 que j'ai sous Windows ...
... mais a ira pour ce soir, la suite au prochain épisode.

édit de 21h22, j'ai quand même voulu savoir quelle option dans about:flag était responsable ...
C'est majoritairement :
Ignorer la liste de rendu logiciel Mac, Windows, Linux, Chrome OS
Cette option remplace la liste intégrée de rendu logiciel et active l'accélération graphique pour les configurations système non compatibles.
Si on a Désactiver affiché, alors ça booste, si on a "Activer" afficher alors ça donne dans about:gpu :

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Software only, hardware acceleration unavailable
3D CSS: Unavailable. Hardware acceleration unavailable
CSS Animation: Software only, hardware acceleration unavailable
WebGL: Unavailable. Hardware acceleration unavailable
WebGL multisampling: Unavailable. Hardware acceleration unavailable
Flash 3D: Unavailable. Hardware acceleration unavailable
Flash Stage3D: Unavailable. Hardware acceleration unavailable
Texture Sharing: Unavailable. Hardware acceleration unavailable
undefined: Software only, hardware acceleration unavailable

Il faudrait donc que je clique quelques part sur Ubuntu sur "Imposer la liste de rendu logiciel".

> Revenir en 12.04
J'y ai pensé mais non.
Non car en fait je me suis aperçu que le transfert de (GROS - 20 Go) fichiers sur mon disque USB de 2 To formaté en ntfs était achtement plus rapide sous 12.10 que 12.04 ... en 12.04 je suis à 5 Mo de débit et environ 20 de tête en 12.10 je crois.
La ntfs semblant être mieux gérée avec le dernier noyau, je dois rester ...

> Bétat 12.11
Hélas, j'avais déjà testé il y a 1 mois, c'est la même cagade que le 12.10.... il n'est tout simplement pas chargé de mon souvenir.

Dernière modification par ladsy (Le 05/01/2013, à 22:27)


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#12 Le 18/01/2013, à 13:08

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Je reviens sur mon (maintenant vieux) topic du fait qu'il y a eu du nouveau aujourd'hui : la parution des Catalyst 13.1.

Sitôt paru, sitôt téléchargé, sitôt installé.

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* fglrx-updates fglrx-updates fglrx fglrx-amdcccle-updates fglrx-updates fglrx-amdcccle fglrx-dev fglrx-updates-dev
sh ./amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run
sudo dpkg -i fglrx*.deb
sudo apt-get install xvba-va-driver

Aucune modification du /etc/X11/xorg.conf ...

Donc avec la même configuration partout et après reboot, et sous Unity on se retrouve avec les performances suivantes :

tests Unity :
user@machine$fgl_glxgears 
Using GLX_SGIX_pbuffer
15863 frames in 5.0 seconds = 3172.600 FPS
17183 frames in 5.0 seconds = 3436.600 FPS
17236 frames in 5.0 seconds = 3447.200 FPS
17440 frames in 5.0 seconds = 3488.000 FPS
17370 frames in 5.0 seconds = 3474.000 FPS
user@machine:~$ glxgears 
33462 frames in 5.0 seconds = 6692.369 FPS
33822 frames in 5.0 seconds = 6764.385 FPS
34061 frames in 5.0 seconds = 6812.081 FPS
34077 frames in 5.0 seconds = 6815.296 FPS
34048 frames in 5.0 seconds = 6809.585 FPS

chromium-browser
1920x1080
FPS : 20
Total Billboard Draws : 16888
Average Draw Duration : 48ms
Last Draw Duration : 46ms
Temps : 1058 Seconds

Soit en gros 50 % de plus dans certains tests ... et surtout, j'ai le sentiment que ça boote plus vite (enfin dès que l'on passe au niveau graphique). Même FF s'affiche un poil plus vite.

Et maintenant, les mêmes tests avec MWM pour ne pas avoir les surcharges d'Unity :

chromium-browser v23
1920x1023
FPS : 21
Total Billboard Draws : 16876
Temps : 1023 Seconds

glxdemo   glxgears  glxheads  glxinfo   
user@machine$ glxgears 
36316 frames in 5.0 seconds = 7263.171 FPS
36634 frames in 5.0 seconds = 7326.794 FPS
36653 frames in 5.0 seconds = 7330.402 FPS
36649 frames in 5.0 seconds = 7329.642 FPS
36439 frames in 5.0 seconds = 7287.663 FPS
36612 frames in 5.0 seconds = 7322.364 FPS
user@machine$ fgl_glxgears 
Using GLX_SGIX_pbuffer
17608 frames in 5.0 seconds = 3521.600 FPS
18951 frames in 5.0 seconds = 3790.200 FPS
19095 frames in 5.0 seconds = 3819.000 FPS
19088 frames in 5.0 seconds = 3817.600 FPS
19091 frames in 5.0 seconds = 3818.200 FPS
18981 frames in 5.0 seconds = 3796.200 FPS

Là, on aurait même des perfs en moins ...
En sentiment, ça va plus vite ... mais en perf benchmarckées, rien n'est moins évident.

Je reste avec ces pilotes ... visiblement ATI ne s'est une fois de plus pas trop cassé la tête.

Dernière modification par ladsy (Le 18/01/2013, à 14:53)


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

#13 Le 18/01/2013, à 14:43

michael

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

Je suis un peu réticent à l'idée d'installer les drivers à la main, mais vu comme les pilotes proposés pour Ubuntu 12.10 sont pourris, et que les Catalyst publiés aujourd'hui supportent officiellement Quantal... Y'a des chances d'avoir un paquet "officiel" dans les jours qui viennent, ou bien il va falloir mettre les mains dans le cambouis? ^^

Hors ligne

#14 Le 18/01/2013, à 14:54

ladsy

Re : ATI HD8650 - performances glxgears faibles quelque soit la fréquence

> il va falloir mettre les mains dans le cambouis? ^^
De ce que j'ai pu remarquer en matière de mises à jour ... autant mettre les ATI et tu verras si on a la chance d'avoir un paquet dédié.


ubuntu 14.04 x86-64 - dual boot W7Pro
P5Q-EM - 8Go - SB X-Fi Xtrem - 3 SSD Samsung 840EVO 500 Go en raid 0 (sur Raid carte-mère)
écran LG W2756VC - Gigabyte HD6850 1 Go
gérant du cabinet Aditamus : http://www.aditamus.fr

Hors ligne

Haut de page ↑