Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 06/11/2005, à 20:48

nico1984

probleme de detection ide

Bonjour à tous,
Je viens d'installer la nouvelle distribution d'ubuntu (sur une partition sata).
Lorsque j'ai voulu monter mes disques durs ide, je me suis aperçu que dans le repertoire /dev, seul 1 de mes disques (sur 3) y figuré.
Je mentionne le fait que je dispose d'une carte mère azus P5WD2, voici sa discription de stockage:
Intel ICH7R South Bridge:
*1 x UltraDMA 100/66/33
*4 x Serial ATA I/II 3.0Gb/s with Intel Matrix Storage Technology with RAID 0, 1, 5, 10 support

Silicon Image 3132 SATA controller:
*1 x Internal Serial ATA I/II
*1 x External Serial ATA

ITE IDE controller:
* 2 x UltraDMA 133/100/66

Il semblerait que les controleur IDEs: "* 2 x UltraDMA 133/100/66" ne soient pas reconnus!!
J'ai essayé plusieurs manipes, mais en vain.
Les dernières idées que l'on m'a proposées sont :
1) rajouter un modul dans le noyau qui contiendrait "une pseudo mise à jour de mon chipset"
2) recompiler le noyau en modifiant la configuration de mes "IDE"

J'attend vos avis, ainsi que les differentes procédures détaillées en cas d'éventuelles solutions.
Je compte sur vous, je ne sais plus quoi faire :-)
merci

#2 Le 07/11/2005, à 03:05

sylware

Re : probleme de detection ide

Poste ici la sortie de "sudo lspci -v"

Hors ligne

#3 Le 08/11/2005, à 15:24

nico1984

Re : probleme de detection ide

0000:00:1f.1 IDE interface: Intel Corp.: Unknown device 27df (rev 01) (prog-if 8a [Master SecP PriP])
        Subsystem: Asustek Computer, Inc.: Unknown device 8179
        Flags: bus master, medium devsel, latency 0, IRQ 22
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at ffa0 [size=16]

0000:00:1f.2 IDE interface: Intel Corp.: Unknown device 27c0 (rev 01) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Asustek Computer, Inc.: Unknown device 2601
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 23
        I/O ports at 5800 [size=8]
        I/O ports at 5400 [size=4]
        I/O ports at 5000 [size=8]
        I/O ports at 4800 [size=4]
        I/O ports at 4400 [size=16]
        Memory at c7effc00 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [70] Power Management version 2

0000:00:1f.3 SMBus: Intel Corp.: Unknown device 27da (rev 01)
        Subsystem: Asustek Computer, Inc.: Unknown device 8179
        Flags: medium devsel
        I/O ports at 0400 [size=32]

0000:01:04.0 Unknown mass storage controller: Integrated Technology Express, Inc.: Unknown device 8211 (rev 11)
        Subsystem: Asustek Computer, Inc.: Unknown device 8138
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 3
        I/O ports at 7400 [size=8]
        I/O ports at 7000 [size=4]
        I/O ports at 6800 [size=8]
        I/O ports at 6400 [size=4]
        I/O ports at 6000 [size=16]
        Expansion ROM at c7fa0000 [disabled] [size=128K]
        Capabilities: [80] Power Management version 2

#4 Le 10/11/2005, à 02:16

sylware

Re : probleme de detection ide

Bon bin on voit 2 controlleurs IDE et ce qui semble un controleur SATA.
Est-ce que tu peux poster ici le contenu de /proc/partitions de /proc/devices /proc/diskstats et le contenu du répertoir /proc/ide

Hors ligne

#5 Le 10/11/2005, à 19:07

nico1984

Re : probleme de detection ide

alors dans  /proc/partitions
major minor  #blocks  name

   3    64   80043264 hdb
   3    65   80027766 hdb1
   8     0  120060864 sda
   8     1   15727603 sda1
   8     2          1 sda2
   8     5   88959906 sda5
   8     6    4883728 sda6
   8     7     979933 sda7
   8     8    9502416 sda8
253     0   80027766 dm-0
253     1   15727603 dm-1
253     2   88959906 dm-2
253     3    4883728 dm-3
253     4     979933 dm-4
253     5    9502416 dm-5

Hors ligne

#6 Le 10/11/2005, à 19:09

nico1984

Re : probleme de detection ide

Dans /proc/device
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  6 lp
  7 vcs
10 misc
13 input
14 sound
29 fb
81 video4linux
108 ppp
116 alsa
128 ptm
136 pts
180 usb
195 nvidia
216 rfcomm
254 devfs

Block devices:
  1 ramdisk
  2 fd
  3 ide0
  8 sd
  9 md
65 sd
66 sd
67 sd
68 sd
69 sd
70 sd
71 sd
128 sd
129 sd
130 sd
131 sd
132 sd
133 sd
134 sd
135 sd
253 device-mapper
254 mdp

Hors ligne

#7 Le 10/11/2005, à 19:09

nico1984

Re : probleme de detection ide

dans  /proc/diskstats
  1    0 ram0 0 0 0 0 0 0 0 0 0 0 0
   1    1 ram1 0 0 0 0 0 0 0 0 0 0 0
   1    2 ram2 0 0 0 0 0 0 0 0 0 0 0
   1    3 ram3 0 0 0 0 0 0 0 0 0 0 0
   1    4 ram4 0 0 0 0 0 0 0 0 0 0 0
   1    5 ram5 0 0 0 0 0 0 0 0 0 0 0
   1    6 ram6 0 0 0 0 0 0 0 0 0 0 0
   1    7 ram7 0 0 0 0 0 0 0 0 0 0 0
   1    8 ram8 0 0 0 0 0 0 0 0 0 0 0
   1    9 ram9 0 0 0 0 0 0 0 0 0 0 0
   1   10 ram10 0 0 0 0 0 0 0 0 0 0 0
   1   11 ram11 0 0 0 0 0 0 0 0 0 0 0
   1   12 ram12 0 0 0 0 0 0 0 0 0 0 0
   1   13 ram13 0 0 0 0 0 0 0 0 0 0 0
   1   14 ram14 0 0 0 0 0 0 0 0 0 0 0
   1   15 ram15 0 0 0 0 0 0 0 0 0 0 0
   3    0 hda 0 0 0 0 0 0 0 0 0 0 0
   3   64 hdb 31 61 380 118 0 0 0 0 0 118 118
   3   65 hdb1 6 24 0 0
   8    0 sda 17736 2090 461785 83812 2647 8043 85528 178597 0 53534 262412
   8    1 sda1 301 307 0 0
   8    2 sda2 0 0 0 0
   8    5 sda5 289 307 0 0
   8    6 sda6 17559 453026 8450 67600
   8    7 sda7 83 104 0 0
   8    8 sda8 551 5450 2241 17928
253    0 dm-0 0 0 0 0 0 0 0 0 0 0 0
253    1 dm-1 0 0 0 0 0 0 0 0 0 0 0
253    2 dm-2 0 0 0 0 0 0 0 0 0 0 0
253    3 dm-3 0 0 0 0 0 0 0 0 0 0 0
253    4 dm-4 0 0 0 0 0 0 0 0 0 0 0
253    5 dm-5 0 0 0 0 0 0 0 0 0 0 0
   2    0 fd0 0 0 0 0 0 0 0 0 0 0 0

Hors ligne

#8 Le 10/11/2005, à 19:11

nico1984

Re : probleme de detection ide

et enfin dans /proc/ide
drivers  hda  hdb  ide0

Merci pour ton aide sylware wink

Hors ligne

Haut de page ↑