Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 27/01/2013, à 16:40

adgenodux

[RESOLU] Munin - liens symboliques plugins restent inactifs (rouges)

Bonjour la Communauté,

Voilà plusieurs semaines que je m'acharne à l'installation d'un serveur de dev basé sur ubuntu server 10.04LTS...

Etant apprenti linux, je me construis en parallèle depuis quelques jours une base de connaissances pour réduire les multiples recherches sur les mêmes problèmes et ainsi structurer mes données pour les retrouver plus vite.

Pour compléter, je souhaite installer une système d'analyse de logs (je pense à loganalyzer) car c'est infernal, je me retrouve avec des fenêtres consoles à gogo avec des "tail -f" qui tournent en permanence...

Pour le moment, ça refait quelques jours que j'essaye de me réinstaller munin.
Réinstaller car je l'avais installé il y a une semaine mais je m'étais planté dans mes déclarations Vhosts et finalement munin a pris la place de mon www pendant 4 jours sad

Je me suis donc résolu à le désinstaller et à recommencer cependant maintenant, je n'arrive plus à "activer" mes liens symboliques pour les plugins que j'ai installé... roll

Je fais donc

>sudo ln -s /usr/share/munin/lenomduplugin /etc/munin/plugins/lenomduplugin

qui crée donc bien tous les liens dans le dossier /etc/munin/plugins/

cependant, contrairement aux plugins "Apache" qui sont dans le même répertoire, installés par défaut et qui sont bien en "vert" et visibles sur mondomain/munin (mais vides !), tous mes liens sont en "rouge" et je n'ai donc aucun tableau...

C'est suite au premier problème avec munin que j'ai commencé ma base de connaissances donc je n'ai pas encore enregistré d'infos à son sujet, je complète ma base quand ça fonctionne avec multiples tests et screenchots pour bien me mettre mes propres exemples et résultats... je gagne déjà un temps dingue rien que pour retrouver les infos sur l'utilisation de la console...

Quelqu'un aurait-il une idée à me suggérer pour enfin retrouver mes beaux graphs que j'avais en première install ?

Merci de votre aide,

Cordialement,

Adgenodux

Dernière modification par adgenodux (Le 27/01/2013, à 22:49)

Hors ligne

#2 Le 27/01/2013, à 22:50

adgenodux

Re : [RESOLU] Munin - liens symboliques plugins restent inactifs (rouges)

Bien,

le travail finissant par payer, je suis parvenu à recréer mes liens symboliques...
d'abord en les effaçant puis en demandant la liste des plugins directement installables, il y a un script qui fait ça via la commande

>sudo munin-node-configure --suggest --shell

elle affiche également les commandes à copier/coller (en sudo ou root) pour créer les liens symboliques pour les plugins à associer

le problème est donc résolu

Hors ligne

  • Accueil
  • » Forum
  • » Serveurs
  • » [RESOLU] Munin - liens symboliques plugins restent inactifs (rouges)

Haut de page ↑