Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#176 Le 16/04/2012, à 09:38

mac-gyver31

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

oscour a écrit :

En fait ce post est plutôt tournée vers l'intégration d'un ordi dans un domaine windows 2003 dans le cadre d'un serveur LTSP.

Un serveur LTSP ??  Tu veux dire Linux Terminal Server Project ?
T'es sûr ? Car je ne vois pas bien le rapport, et c'est la première vois que je vois cette chose évoquée dans les posts de cette discussion


Il est temps d'enlever les fenêtres, et de construire un monde ouvert.

Hors ligne

#177 Le 29/04/2012, à 19:46

florian_boy

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour,
Je suis entrain d'installer un machine Ubuntu 10.4 et je voulais l'intégrer dans mon domaine AD.
J'ai repris en intégral le script proposé en 1er page, modifié les nom de domaine, tenté de modifié le AD-vol.conf, mais là, j'ai pas tout capté ...
J'ai lancé le script comme expliqué, il n'y a pas eu de bug ou autre mais à la fin, lors du test d'identification au domaine, j'ai ceci :

Error: Lsass Error [code 0x00080047]
40290 (0x9D62) LW_ERROR_LDAP_TIMEOUT - Unknown error

Après avoir redémarré l'ordi, j'ai remarqué qu'il n'y avais pas de dossier LIkewise dans mon "home" et qu'il m'avait été imposible d'ouvrir un session avec un compte AD
Si quelqu'un a une idée, merci ...

Un autre truc, ce ne sont pas des dossier personnel que je veux monter dans le fichier AD-vol.conf, mais des partitions présente sur le serveur, chaque personne ayant sa propre partition, alors si quelqu'un peux m'aider à bien définir les volumes à monter ou bien m'expliquer les codes de ce fichier, ce serai super.
Merci
Cordialement,

Hors ligne

#178 Le 01/06/2012, à 12:40

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Je reviens tardivement, florian_boy, mais as-tu résolu ton problème ?

Hors ligne

#179 Le 29/01/2013, à 14:42

Gaelephant

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Script testé (et approuvé) dans le cadre d'une jonction "simple" d'un poste client Ubuntu 12.04 à un AD (win 2003).
Sachant que je galérais dans la modification à la main des fichiers de conf krb5 et smb, ce script m'a débloqué.
Plus qu'à le détailler/modifier pour l'adapter plus précisément à mes besoins, mais sur le principe, exécuté tel quel, il fonctionne parfaitement, du moins sur la partie "se loguer avec les identifiants de la base AD", ce qui est déjà un bon point de départ.

Hors ligne

#180 Le 29/01/2013, à 15:17

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

ok pour le log.
et concernant le montage automatique des partitions ?
Quels sont tes besoins spécifiques ? toujours le problème de partitions particulières ?

Hors ligne

#181 Le 30/01/2013, à 14:06

Gaelephant

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Gaelephant a écrit :

Script testé (et approuvé) dans le cadre d'une jonction "simple" d'un poste client Ubuntu 12.04 à un AD (win 2003).
Sachant que je galérais dans la modification à la main des fichiers de conf krb5 et smb, ce script m'a débloqué.
Plus qu'à le détailler/modifier pour l'adapter plus précisément à mes besoins, mais sur le principe, exécuté tel quel, il fonctionne parfaitement, du moins sur la partie "se loguer avec les identifiants de la base AD", ce qui est déjà un bon point de départ.

Histoire de préciser tout de même :
Le but final est de virer le Win2003 d'un serveur de fichier pour le remplacer par un linux (vraisemblablement Ubuntu).
Mais le DC resterait (pour le moment du moins) sous Win2003. Débutant sous linux, avant le lancer le grand chambardement, je souhaite faire quelques essais. J'ai donc commenté toutes les lignes faisant référence aux partages, puisque pour le moment, souhaitant avancer tranquillement par étapes, je ne m'intéresse qu'à la jonction d'un poste linux à l'AD. Histoire d'être sûr qu'au moins ça soit réalisable facilement et rapidement avant d'aller fouiller plus loin. D'autant plus qu'au final, les partages ne devront pas "être accessible depuis un linux", mais "être accessible depuis un windows tout en étant hébergé par un linux". Meme si l'un n'empêche pas l'autre, j'vais y aller doucement.

Script testé sur Ubuntu 12.04 client, tel quel, sans modification : fonctionne directement.
Cela dit, pas de dossier /etc/gdm/ chez moi (Unity oblige), du coup j'ai viré les lignes concernant gdm, et j'ai rajouté les lignes

allow-guest=false
greeter-hide-users=true

au fichier /etc/lightdm/lightdm.conf. Je pense que ça doit facilement se rajouter au script.
Au reboot de la machine, écran de connexion où il faut entrer identifiant puis mdp pour se logguer. Les identifiants locaux fonctionnent, les identifiants réseaux également, et ce sans avoir à rajouter un "DOMAIN\" avant le login. Bref, complètement transparent pour l'utilisateur.

Script testé sur Ubuntu 12.04 server tel quel, sans modification : échec à l'installation de likewise.
J'ai résolu le problème en modifiant dans le script la partie apt-get concernant likewise et en mettant à la place un simple

sudo dpkg -i ./likewise-open_6.1.0.406-0ubuntu5_i386.deb

en ayant au préalable téléchargé le .deb à la main (j'ai malencontreusement oublié de noter l'url où je l'ai choppé) et placé dans le même répertoire que le script. Ensuite, l'installation se déroule sans le moindre soucis.
Mais au reboot et à la connexion, ça n'est pas la même histoire :
- identifiant_local / pass : ça marche
- identifiant_réseau / pass : erreur (j'ai plus le message exact en tête, mais même message que lorsqu'on tape un mauvais password)
- identifiant@domain / pass : idem
- DOMAIN\identifiant / pass : erreur : ACCESS DENIED
Le access denied est je pense plutôt bon signe : il ne trouve pas d'erreur dans le duo log/pass, il n'arrive juste pas à ouvrir une session.
Avec comme question principale : il n'arrive pas à ouvrir une session, ou bien il pourrait y arriver mais refuse de le faire parce que "quelque chose" le lui interdit (par exemple, au pif, une ligne foireuse sur un fichier de conf planqué quelque part qui dise qu'il n'y a que la personne qui a installé l'os qui peut s'y connecter).
Encore en train de fouiller dans les fichiers de log voir où il peut bien y avoir une erreur, sans trouver pour le moment.Comme c'est le seul moyen qui me vienne à l'esprit pour tester si la jonction du poste à l'AD est bien effective, c'est gênant.
D'un autre côté, étant vraiment un gros débutant dans le monde linux, j'ai très bien pu foirer quelque part.

A noter qu'avant de tester ce script, et ce sur les deux OS, version classique et version server, j'avais déjà bidouillé les fichiers de conf de samba et de kerberos, suivi quelques tentatives de tuto sur le net sans succès, et donc je ne me suis pas particulièrement inquiété du fait que contrairement à annoncé, il ne m'a pas été demandé lors de l'installation les serveurs et royaumes kerberos.
D'autant plus que ça a fonctionné directement sur la version "client". Histoire d'exclure la possibilité que l'ancien fichier krb5.conf du server soit la cause du problème, j'ai directement copié à la place celui du client avant de faire mes tests.
Et ça m'embêterait beaucoup d'avoir à refaire une réinstallation complète de l'OS, vu que j'ai dégagé l'iso et que j'ai un débit foireux pour la retélécharger.

En espérant que ce retour d'expérience serve, par exemple à une amélioration du script smile

Hors ligne

#182 Le 30/01/2013, à 14:34

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Salut,

C'est vrai que pour tester, il vaut mieux partir d'un OS nouveau et fraichement à jour que de quelque chose bidouillé surtout concernant kerberos. Je ne comprends pas toujours ce que je fais et trouver une erreur d'une ancienne bidouille c'est pas gagné.

Concernant 12.04, je n'ai fait aucun test. Cependant, dans le script il y a ces deux lignes :

add-apt-repository ppa:likewise-open/likewise-open-ppa
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AAFDD5DB

Cela fait appel à un dépot externe car dans les dépôts de la 10.4 il y avait un  likewise bugué que le ppa corrigeait. Je pense que dans la 12.04 ce bug doit être corrigé et le ppa plus nécessaire, voire même dépassé pouvant peut-etre causer des problèmes d'identification. Je pense donc qu'il faudrait que tu testes en enlevant ces deux lignes du script et partir sur une base clean avec le dépôt officiel de 12.04.

A propos de la connexion, as-tu essayé le test de connexion inclus dans le script ?

Hors ligne

#183 Le 30/01/2013, à 15:17

Gaelephant

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Divad a écrit :

Concernant 12.04, je n'ai fait aucun test. Cependant, dans le script il y a ces deux lignes :

add-apt-repository ppa:likewise-open/likewise-open-ppa
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AAFDD5DB

Cela fait appel à un dépot externe car dans les dépôts de la 10.4 il y avait un  likewise bugué que le ppa corrigeait. Je pense que dans la 12.04 ce bug doit être corrigé et le ppa plus nécessaire, voire même dépassé pouvant peut-etre causer des problèmes d'identification. Je pense donc qu'il faudrait que tu testes en enlevant ces deux lignes du script et partir sur une base clean avec le dépôt officiel de 12.04.

Justement, je test sur deux versions de 12.04, la classique et la server.
J'avais déjà essayé d'installer likewise depuis les dépôts offi sur la version client, en essayant de suivre pas à pas un tuto, mais sans succès : des erreurs à l'installation, ça foirait à un moment où un autre, j'avais laissé tombé.
Sur la "classique", ces deux lignes de ton script ne posent aucun problème, et tout fonctionne parfaitement, ça installe depuis les dépots indiqué, tout roule.
Sur la "server", l'installation de likewise pose soucis. Le même script, les mêmes lignes, une erreur ou les mots dpkg, --configure et likewise apparaissaient sur la même ligne.
Du coup j'ai récupéré le .deb depuis "https://launchpad.net/ubuntu/+source/likewise-open" (vive l'historique du navigateur pour retrouver l'adresse), et là l'installation se passe correctement.

Divad a écrit :

A propos de la connexion, as-tu essayé le test de connexion inclus dans le script ?

Oui, testé, et affichant un magnifique succès et me recommandant de redémarrer.
D'ailleurs, pour preuve que la connexion est possible, si j'essaye de co un utilisateur n'existant pas, l'erreur est "login incorrect", alors qu'avec un utilisateur réseau existant, l'erreur est "access is denied". De plus, un "getent passwd" me donne le même résultat sur la version "client" (dont la jonction à l'AD est effective et réussie) et sur la version server (où là j'ai des "access is denied").

J'ai fait le tour des fichiers que j'avais modifié de façon indépendante sur le client et sur le server pour traquer les différences, sans avoir trouvé pour le moment. Bah, si je ne trouve pas, effectivement, réinstaller directement au propre la version server reste possible. Mais ça serait tellement plus agréable de comprendre pourquoi là ça ne fonctionne pas comme attendu.

Accessoirement, j'ai récupéré la fin du auth.log, qui concerne ma tentative de connexion avec le compte Admin du réseau :

srvtest login[902]: pam_winbind(login:auth): getting password (0x00000388)
srvtest login[902]: pam_winbind(login:auth): pam_get_item returned a password
srvtest login[902]: pam_winbind(login:auth): request wbcLogonUser failed: WBC_ERR_AUTH_ERROR, PAM error: PAM_SYSTEM_ERR (4), NTSTATUS: NTSTATUS_ACCESS_DENIED, Error message was: Access denied
srvtest login[902]: pam_winbind(login:auth): internal module error (retval = PAM_SYSTEM_ERR(4), user = 'DOMAINE\Administrateur")
srvtest login[902]: pam_winbind(login:auth): FAILED LOGIN (1) on '/dev/tty3' FOR 'DOMAINE\Administrateur', Authentification failure

Ce qui me laisse supposer que c'est du côté de /etc/pam.d/system-auth et du fichier pam_winbind.so qu'il va falloir chercher.

Hors ligne

#184 Le 30/01/2013, à 15:38

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

hum, il y a peut-être un problème dans la configuration des fichiers. Dans tous les cas, je pense que le mieux est de repartir sur une installation propre. Car même si tu corriges une erreur et que cela marche, tu ne seras jamais sûr que la correction soit bonne étant donné que d'autres bidouilles ont pu affecter le système. Et si le problème persiste après réinstallation, au moins tu repars sur qqch de sain et propre. Travailler en production sur un Os bidouillé n'est jamais bon, d'autant plus pour un serveur. Il vaut mieux savoir de A à Z ce qu'on y a fait, cela facilitera la maintenance ultérieure.

par rapport à likewise, le message "dpkg, --configure et likewise " confirme qu'il y a eu un problème lors de l'installation du ppa. Et le deb que tu récupères est celui du dépôt officiel. ( d’ailleurs quelle version as-tu prise ?)

Je suis désolé pour l'iso parti à la poubelle, mais je te conseille de :
- récupérer l'iso wink !
- réinstaller au propre
- tester le script en entrant bien les noms de domain, et en supprimant les deux lignes mentionnées ci-dessus
- bidouiller si besoin
- garder l'iso ( ça peut resservir parfois !)

Hors ligne

#185 Le 30/01/2013, à 15:53

Gaelephant

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Divad a écrit :

par rapport à likewise, le message "dpkg, --configure et likewise " confirme qu'il y a eu un problème lors de l'installation du ppa. Et le deb que tu récupères est celui du dépôt officiel. ( d’ailleurs quelle version as-tu prise ?)

C'est "amusant" de voir que le likewise proposé par ton script fonctionne sur le client, mais pas sur le serveur, et que la version "dépot officiel" ne fonctionne pas sur le client, mais semble fonctionner au poil sur le serveur. Enfin amusant. Façon de parler.

J'ai pris le paquet "likewise-open_6.1.0.406-0ubuntu5_i386.deb" dans la liste dispo sous "Precise Pangolin". vu que la machine sur laquelle je fais mes tests est une vieille bête.

C'est reparti pour une install propre, alors. Je reviendrais donner des nouvelles.

Hors ligne

#186 Le 31/01/2013, à 16:26

Gaelephant

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

De retour après test sur Ubuntu server 12.04.1, à partir d'une install neuve, propre, et juste après mise à jour.
Toujours sur la partie "jonction à l'AD".
Réussite smile

A part un léger détail, ton script indique que

Lors de l'installation, il vous sera demandé :
- Royaume Realm Kerberos par defaut : ex : DOMAINE
- Serveur Kerberos du Royaume : ex : 192.168.0.010 nomduserveur
- Serveur administratif du royaume Kerberos : ex : nomduserveur

Hors, lors de l'exécution du script, le seul moment où il m'a été demandé quelque chose, c'est lors de la phase de test, l'identifiant, le nom de domaine et le pass. Ce qui n'a pas empêché de déboucher sur un SUCCESS (que j'avais déjà eu lors de mes tests précédents cela dit).
Différence notable avec mes précédents tests : pas besoin de se logguer sous la forme DOMAIN\user, entrer le nom d'un utilisateur réseau non créé sur la machine fonctionne directement.

Tout ça pour dire que si tu réactualises ton script avec une version du paquet likewise "à jour", toute la partie "jonction à l'AD" fonctionne sur ubuntu 12.04, client comme server.
Plus qu'à fouiller sur la partie "partage" pour voir ce que je vais en faire smile
Encore bravo, proposer un truc qui marche et qui facilite la vie, c'est méritoire !

Hors ligne

#187 Le 31/01/2013, à 17:29

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Super ! Comme quoi, une bonne installation enlève pas mal de problème ! smile
J'ai mis à jour le premier poste en disant d'effacer les lignes mentionnées pour 12.04
Je pense que d'ici quelques mois, il va falloir que je me replonge là dedans ( 10.4 devient vieux!  ) Je remettrai le script à jour.

Merci à toi aussi de faire profiter de ton travail !!

Hors ligne

#188 Le 28/05/2013, à 04:41

Nathaly01

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour,
D'abord, merci pour votre travail et le script que vous nous proposé ...
J'ai utilisé le script sur Ubuntu 12.04.2 et j'avais auparavant modifié le fichier /etc/lightdm/lightdm.conf en rajoutant cette ligne : greeter-show-manual-login=true
Le script s'est déroulé parfaitement, succès.
Seulement il y a quelques problèmes. Avec les compte AD, ubuntu utilise l'Anglais pour le nom des dossiers ainsi que pour les menus alors que tout devrait être en français.
En plus, lorsque je monte une partition/dossier (partage) du serveur 2003 sur laquelle j'ai tout les droit, et bien là, j'ai juste le droit de lire.
Pourtant dans l'observateur d'événement, sécurité, je retrouve bien mes ouvertures de session AD depuis le poste ubuntu en "succès", mais les droits sur les dossiers ne sont pas pris en compte ...
Avez vous une idée du pourquoi ??
Merci

Hors ligne

#189 Le 04/06/2013, à 22:29

Nathaly01

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonsoir,
J'ai résolu mon problème de droit dans les partages, en faite, j'avais fait une grosse bêtise dans les autorisations !!!
Mais j'arrive vraiment pas à résoudre mon problème de la langue du système ...
    comptes locaux    ==>   en Français
    comptes  AD         ==>   en Anglais

J'ai tentée d'avoir le choix de la langue à l'ouverture de session grâce à "lightdm-gtk-greeter", mais sa ne fonctionne pas.
En espérant avoir une réponse ...

Merci

PS : Je viens de voir que je n'ai plus accès à mon imprimante réseau ni à mon scaner et ce, sur tous les comptes, autan locaux que comptes AD ...

Dernière modification par Nathaly01 (Le 06/06/2013, à 00:07)

Hors ligne

Haut de page ↑