Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 03/02/2013, à 20:54

Hube

[RESOLU] Problèmes de paquets avec apt

Bonsoir,

Je suis sous 12.04lts et j'essaie de réinstaller openshot après avoir essayé d'autres softs mais ça ne va pas...

sudo apt-get install openshot

donne ceci comme résultat:
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
openshot : Dépend: melt mais ne sera pas installé
            Dépend: python-mlt3 mais ne sera pas installé ou
                     python-mlt2 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

et ça ne veut plus s'installer...
Que faire pour installer cet openshot???

Hube.

Dernière modification par Hube (Le 04/02/2013, à 19:20)

Hors ligne

#2 Le 03/02/2013, à 21:27

f.x0

Re : [RESOLU] Problèmes de paquets avec apt

Bonjour Hube,

ouvres un terminal
tapes

cat -n /etc/apt/sources.list

et postes le retour de la commande

puis tapes

ls /etc/apt/sources.list.d

et postes le retour de la commande

puis tapes

cat /etc/apt/sources.list.d/*

et postes le retour de la commande


SOPI

Hors ligne

#3 Le 03/02/2013, à 23:50

Hube

Re : [RESOLU] Problèmes de paquets avec apt

cat -n /etc/apt/sources.list

     1	# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423)]/ precise main restricted
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://be.archive.ubuntu.com/ubuntu/ precise main restricted
     6	deb-src http://be.archive.ubuntu.com/ubuntu/ precise main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	deb http://be.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    11	deb-src http://be.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    12	
    13	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14	## team. Also, please note that software in universe WILL NOT receive any
    15	## review or updates from the Ubuntu security team.
    16	deb http://be.archive.ubuntu.com/ubuntu/ precise universe
    17	deb-src http://be.archive.ubuntu.com/ubuntu/ precise universe
    18	deb http://be.archive.ubuntu.com/ubuntu/ precise-updates universe
    19	deb-src http://be.archive.ubuntu.com/ubuntu/ precise-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://be.archive.ubuntu.com/ubuntu/ precise multiverse
    27	deb-src http://be.archive.ubuntu.com/ubuntu/ precise multiverse
    28	deb http://be.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    29	deb-src http://be.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    30	
    31	## N.B. software from this repository may not have been tested as
    32	## extensively as that contained in the main release, although it includes
    33	## newer versions of some applications which may provide useful features.
    34	## Also, please note that software in backports WILL NOT receive any review
    35	## or updates from the Ubuntu security team.
    36	deb http://be.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    37	deb-src http://be.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    38	
    39	deb http://security.ubuntu.com/ubuntu precise-security main restricted
    40	deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
    41	deb http://security.ubuntu.com/ubuntu precise-security universe
    42	deb-src http://security.ubuntu.com/ubuntu precise-security universe
    43	deb http://security.ubuntu.com/ubuntu precise-security multiverse
    44	deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
    45	
    46	## Uncomment the following two lines to add software from Canonical's
    47	## 'partner' repository.
    48	## This software is not part of Ubuntu, but is offered by Canonical and the
    49	## respective vendors as a service to Ubuntu users.
    50	# deb http://archive.canonical.com/ubuntu precise partner
    51	# deb-src http://archive.canonical.com/ubuntu precise partner
    52	
    53	## This software is not part of Ubuntu, but is offered by third-party
    54	## developers who want to ship their latest software.
    55	deb http://extras.ubuntu.com/ubuntu precise main
    56	deb-src http://extras.ubuntu.com/ubuntu precise main
    57	deb http://liveusb.info/multisystem/depot all main
    58	deb-src http://liveusb.info/multisystem/depot all main

ls /etc/apt/sources.list.d

bisigi-ppa-precise.list       otto-kesselgulasch-gimp-precise.list       stebbins-handbrake-snapshots-precise.list.save
bisigi-ppa-precise.list.save  otto-kesselgulasch-gimp-precise.list.save  sunab-kdenlive-release-precise.list
google-chrome.list            screenlets-ppa-precise.list                sunab-kdenlive-release-precise.list.save
google-chrome.list.save       screenlets-ppa-precise.list.save           upubuntu-com-chat-precise.list
google-talkplugin.list        shiki-mediainfo-precise.list               upubuntu-com-chat-precise.list.save
google-talkplugin.list.save   shiki-mediainfo-precise.list.save
jitsi.list.save               stebbins-handbrake-snapshots-precise.list

cat /etc/apt/sources.list.d/*

 
deb-src http://ppa.launchpad.net/bisigi/ppa/ubuntu precise main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/talkplugin/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/talkplugin/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://download.jitsi.org/deb unstable/
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
deb-src http://ppa.launchpad.net/screenlets/ppa/ubuntu precise main
deb http://ppa.launchpad.net/shiki/mediainfo/ubuntu precise main
deb-src http://ppa.launchpad.net/shiki/mediainfo/ubuntu precise main
deb http://ppa.launchpad.net/shiki/mediainfo/ubuntu precise main
deb-src http://ppa.launchpad.net/shiki/mediainfo/ubuntu precise main
deb http://ppa.launchpad.net/stebbins/handbrake-snapshots/ubuntu precise main
deb-src http://ppa.launchpad.net/stebbins/handbrake-snapshots/ubuntu precise main
deb http://ppa.launchpad.net/stebbins/handbrake-snapshots/ubuntu precise main
deb-src http://ppa.launchpad.net/stebbins/handbrake-snapshots/ubuntu precise main
deb http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu precise main
deb-src http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu precise main
deb http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu precise main
deb-src http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu precise main
deb http://ppa.launchpad.net/upubuntu-com/chat/ubuntu precise main
deb-src http://ppa.launchpad.net/upubuntu-com/chat/ubuntu precise main
deb http://ppa.launchpad.net/upubuntu-com/chat/ubuntu precise main
deb-src http://ppa.launchpad.net/upubuntu-com/chat/ubuntu precise main

Hors ligne

#4 Le 04/02/2013, à 00:15

f.x0

Re : [RESOLU] Problèmes de paquets avec apt

Tu as les dépôts partner désactivés, je pense qu'il vaut mieux les activer.
pour cela
tapes

gksudo gedit /etc/apt/sources.list

et enlèves le signe # et l'espace devant ces 2 lignes

# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

pour que cela devienne

deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

Enregistres ton fichier
Quittes gedit
et tapes

sudo apt-get update

Maintenant on va essayer de désinstaller puis de réinstaller openshot

sudo apt-get -f remove --purge openshot
sudo apt-get -f install openshot

postes le retour de ces 2 commandes


SOPI

Hors ligne

#5 Le 04/02/2013, à 08:07

Hube

Re : [RESOLU] Problèmes de paquets avec apt

Bonjour,

sudo apt-get -f remove --purge openshot

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libopencv-highgui2.3 libopencv-features2d2.3 python-pygoocanvas
  libqimageblitz4 python-pywapi libopencv-imgproc2.3 python-gdata
  libgoocanvas-common libopencv-calib3d2.3 python-utidylib
  libopencv-objdetect2.3 python-beautifulsoup libtidy-0.99-0 python-webkit
  libopencv-flann2.3 python-oauth2 libopencv-core2.3 python-feedparser
  python-rsvg python-evolution openshot-doc libgoocanvas3
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  openshot*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 2 non mis à jour.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 438858 fichiers et répertoires déjà installés.)
Suppression de openshot ...
Purge des fichiers de configuration de openshot ...

sudo apt-get -f install openshot

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 openshot : Dépend: python-mlt3 mais ne sera pas installé ou
                     python-mlt2 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Le problème subsiste...

Hube.

Dernière modification par Hube (Le 04/02/2013, à 08:10)

Hors ligne

#6 Le 04/02/2013, à 19:09

f.x0

Re : [RESOLU] Problèmes de paquets avec apt

Essaies ceci :

sudo apt-get clean
sudo apt-get autoremove --purge
sudo apt-get dist-upgrade
sudo add-apt-repository ppa:jonoomph/openshot-edge
sudo apt-get update
sudo apt-get -f install openshot

SOPI

Hors ligne

#7 Le 04/02/2013, à 19:19

Hube

Re : [RESOLU] Problèmes de paquets avec apt

FORT DE CAFE !!!!! wink wink wink wink wink wink
Ta solution m'a permis de réinstaller Openshot.
un tout grand MERCI !

Hube

Hors ligne

#8 Le 04/02/2013, à 20:42

f.x0

Re : [RESOLU] Problèmes de paquets avec apt

Je suis content pour toi que cela fonctionne Hube big_smile


Bonne continuation sur Gnu/Linux !!! tongue


SOPI

Hors ligne

#9 Le 04/02/2013, à 21:15

Hube

Re : [RESOLU] Problèmes de paquets avec apt

Encore merci.
Bien l'bonjour à ton pingouin! lol lol lol

Hors ligne

#10 Le 04/02/2013, à 21:43

f.x0

Re : [RESOLU] Problèmes de paquets avec apt

C'est très gentil, mais tu as mis mon pingouin dans tous ses états tongue


Dernière modification par f.x0 (Le 04/02/2013, à 21:43)


SOPI

Hors ligne

Haut de page ↑