Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 11/02/2013, à 22:27

Autiwa

[Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Je viens d'acheter une clé usb transcend jetflash 780, 16Gio.

Je la branche sur mon ordinateur Ubuntu et elle n'est absolument pas détectée. Je pensais au début que c'était simplement dû à une clé non formatée. Mais en lançant Gparted, j'ai pu constater qu'il n'y avait que mes deux disques durs interne, et absolument pas de clé usb.

J'ai testé deux ports usb différents. J'ai testé mon ancienne clé usb 2.0, aucun soucis.

Quelqu'un a une idée du soucis? Est-ce que vous voyez des commandes à tester, des choses à faire? J'ai cherché un peu sur le net, mais je n'ai rien trouvé de bien probant.

SOLUTION :
Il s'avère que les ports avant de mon ordinateur ne détectent pas ma clé usb. Les ports arrières me permettent pourtant d'utiliser la clé. À noter que les ports avant sont fonctionnels, vu que je branche d'autres périphériques usb sans aucun soucis dessus.

Dernière modification par Autiwa (Le 13/02/2013, à 18:58)


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#2 Le 12/02/2013, à 00:11

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Tu as quoi comme carte USB3 ?

lspci

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 12/02/2013, à 00:13

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Je n'ai pas de ports usb 3.0, mais il me semblait que c'était rétrocompatible.

Voici le résultat de lspci :

00:00.0 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: NVIDIA Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: NVIDIA Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP77 Ethernet (rev a2)
00:0b.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:10.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:12.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:08.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
01:0a.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI
02:00.0 VGA compatible controller: NVIDIA Corporation C77 [GeForce 8200] (rev a2)

Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#4 Le 12/02/2013, à 00:29

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Effectivement, ça devrait...
Avec ta clef branchée, fais cette commande pour voir si elle est au moins détectée.

lsusb

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 12/02/2013, à 00:31

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046d:c061 Logitech, Inc. RX1500 Laser Mouse
Bus 003 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 003 Device 003: ID 0b38:0003 Gear Head Keyboard

J'ai aussi fait la commande en enlevant la clé, et j'ai le même nombre d'entrée.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#6 Le 12/02/2013, à 00:45

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Oui, je vois qu'elle est absente.
Il faut trouver le moyen de connaître ses identifiants VID:PID pour forcer udev à la prendre en tant que USB2.
C'est un peu récent comme clef et elle ne doit pas encore être dans les listes des périphériques connus.

Ce qui est bizarre c'est que "frafra", le gars qui développe "multisystem" livre son soft sur ces clefs là.
Il faut lui poser la question...


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 12/02/2013, à 00:47

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Je pourrai peut-être chopper les VID:PID sur le mac que j'ai au travail. Reste à trouver comment obtenir ces trucs sur le mac. Avec un peu de chance lsusb fonctionne aussi sous mac et j'aurais les infos.

Merci de te pencher sur mon problème en tout cas !


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#8 Le 12/02/2013, à 00:49

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

J'ai aussi posé la question à "frafra" : http://forum.ubuntu-fr.org/viewtopic.php?pid=12549101


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#9 Le 12/02/2013, à 10:46

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Je viens de tester et la clé usb est correctement détectée sous mac. J'ai pu y transférer des fichiers sans soucis. Ça doit donc être ce que tu dis, clé usb non encore supportée sous linux. C'est étrange mais c'est l'explication qui me semble la plus logique compte tenu des tests qu'on a fait.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#10 Le 12/02/2013, à 11:14

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Via la commande system_profiler SPUSBDataType sous mac j'ai récupéré les infos suivante, au cas où ça puisse aider, je pense qu'il y a le VID PID :

        Mass Storage Device:

          Capacity: 15,8 GB (15 804 137 472 bytes)
          Removable Media: Yes
          Detachable Drive: Yes
          BSD Name: disk1
          Product ID: 0x1000
          Vendor ID: 0x8564
          Version: 10.75
          Serial Number: 427272644
          Speed: Up to 480 Mb/sec
          Manufacturer: JetFlash
          Location ID: 0x26200000 / 2
          Current Available (mA): 500
          Current Required (mA): 200
          Partition Map Type: Unknown
          S.M.A.R.T. status: Not Supported

Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#11 Le 12/02/2013, à 16:28

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Yes...

Product ID: 0x1000
Vendor ID: 0x8564

Je sais qu'on peut rajouter ça dans une liste spéciale de "udev" mais je ne me rappelle plus comment... hmm
Quand j'ai des périphériques USB non reconnus je les rajoutes en créant un règle dans "udev" comme celle ci:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="8564", ATTRS{idProduct}=="1000", MODE="0666"

Il faut mettre ça dans un fichier dans la répertoire /etc/udev/rules.d, par exemple 51_JetFlash et redémarrer "udev".

gksu gedit /etc/udev/rules.d/51_JetFlash

Tu recopies (copier/coller) la ligne de la règle dedans, tu sauves puis:

sudo service udev restart

EDIT: post corrigé, j'avais inversé vid et pid dans la règle sad

Dernière modification par Maisondouf (Le 12/02/2013, à 16:38)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#12 Le 12/02/2013, à 19:42

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Je viens de tester. Ayant déjà un fichier "51_*", j'ai appelé le fichier "52_JetFlash.rules".

Voyant que ça ne fonctionnait pas, j'ai même redémarré l'ordi, mais rien n'y fait, la clé est toujours invisible.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#13 Le 12/02/2013, à 20:57

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Je viens de retrouver le système de gestion USB : http://wiki.debian.org/fr/HowToIdentifyADevice/USB
En fait, vires le fichier que je t'ai fait fabriquer, mets à jours les USBid .

sudo update-usbids

Le fichier /var/lib/usbutils/usb.ids va être rechargé depuis la base de données des prériphériques.
Je viens de le faire sur mon PC, mais les id 8564:1000 ne sont pas dedans....
Il faut donc éditer ce fichier

gksu gedit /var/lib/usbutils/usb.ids

et rajouter ces codes dedans, tu verrsa c'est classé par ordre.
Les tiens sont a mettre juste avant "9016  Sitecom"
Donc tu rajoutes:

8564   Transcend
         1000 JetFlash 16go USB3

Je suppose qu'il faut redémarrer le PC pour être sur et puis tester....

Dernière modification par Maisondouf (Le 12/02/2013, à 23:37)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#14 Le 12/02/2013, à 21:24

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

J'ai voulu éditer, mais j'ai droit à un "Le fichier que vous avez ouvert contient des caractères non valides. Si vous poursuivez l'édition du fichier, vous pourriez endommager ce document.
Vous pouvez aussi choisir un autre codage de caractères et essayer à nouveau."

J'ai essayé utf-8 et iso8859-15, mais aucun n'a donné quoi que ce soit donc je n'ai pas modifié pour l'instant, en attendant plus d'infos.

[edit]
Finalement j'ai édité avec vim qui ne m'a pas insulté quand j'ai voulu éditer le fichier
[/edit]

Dernière modification par Autiwa (Le 12/02/2013, à 23:38)


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#15 Le 12/02/2013, à 22:00

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Après redémarrage, ça ne fonctionne toujours pas.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#16 Le 12/02/2013, à 23:36

Maisondouf

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Autiwa a écrit :

Note: Tu as oublié le "/" juste avant "var/lib"

je corrige


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#17 Le 13/02/2013, à 10:46

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Merci pour la correction :-)

Je viens de tester dans une machine virtuelle Ubuntu sur mon mac. Aucun soucis, la clé est bien détectée, et je n'ai pas eu besoin d'éditer des fichiers.

Il semblerait donc que ce soit un problème hardware, beaucoup plus emmerdant pour moi. Je ne sais pas quoi faire. On dirait que pour pouvoir utiliser ma clé, il faudrait que j'achète un nouvel ordinateur... Pourtant il ne me semblait pas si obsolète que ça.

Pour info, j'ai :

AMD Phenom II X4 920 - Quad Core Socket AM2+ 0.045 micron Cache L2 2 Mo Cache L3 6 Mo
Corsair XMS2 DHX 4 Go (kit 2x 2 Go) DDR2-SDRAM PC6400 CL4 - TWIN2X4096-6400C4DHX
Shuttle SN78SH7 - Mini-Barebone (NVIDIA GeForce 8200)

Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#18 Le 13/02/2013, à 18:57

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Sur les conseils d'un copain, j'ai testé la clé usb sur les ports arrières de ma tour. Résultat, ça fonctionne. Je ne comprends absolument pas pourquoi mais les faits sont là.

Du coup ce n'est pas des plus pratiques pour la faire fonctionner...

Un immense merci à Maisondouf pour le temps qu'il a passé à essayer de résoudre mon problème. À partir de là je pense qu'il n'y a plus rien à faire d'autre que me résigner à ne pas pouvoir utiliser les ports avant de ma bécane.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#19 Le 25/10/2013, à 21:21

sathor

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Salut,

J'ai le même problème sous Xubuntu. Mes ports fonctionnais très bien sous Ubuntu et j'ai même fait la réinstall de Xubuntu avec ces ports USB en façade. Mais À présent seules les prises arrière fonctionnent...  Et je n'ai pas trouver de solution sad

pour info v'la mon lsusb :
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Sans savoir interpréter ce qui est écrit, j'ai bien 8 prises USB sur mon pc. (6 derrière, 2 devant). Au moment du lsusb, les deux ports avant sont occupés par deux clés différentes.

Hors ligne

#20 Le 25/10/2013, à 21:25

Autiwa

Re : [Résolu] Clé usb non détectée, mais fonctionnelle : quelles solutions?

Bonjour,

Il me semble que ton problème est un peu différent du mien.

Dans mon cas, les ports avants semblent moins alimentés que les ports arrières. Ma clé USB 3.0 doit demander plus que mon autre clé USB 2.0 que j'ai testé. En conséquence, les deux clés fonctionnent à l'arrière, mais seule la clé USB 2.0 fonctionne à l'avant, les ports avant doivent être un peu plus cheap je suppose.

Si cette information ne permet pas de résoudre ton problème, c'est qu'il doit être différent du mien. Auquel cas, je te suggère de poster dans un sujet à toi afin d'en augmenter la visibilité en trouvant un titre aussi explicite que possible.

Bonne chance !


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

Haut de page ↑