Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 03/10/2007, à 19:59

nokcy

Soucis avec alsa-oss

bisoir !

Alors voila j'ai un soucis avec alsa-oss ( pour rappel il est censer faire passer un flux oss d'un logiciel audio en flux alsa pour biensur permetre a plusieur appli d'emetre du son en memetemps )

Dans mon contexte c wine et teamspeak, sous feisty ct tres simple je mettait wine sur alsa, et je faisait passer teamspeak par aoss , sa roulait niquel, mais la i m'en veut par aoss j'ai aucun son ( a moins de fermer tte mes appli utilisant le son )

Alors je sait pas trop si y'a une config a faire sous gutsy pour faire tourner aoss correctement ^^

I need help tongue

#2 Le 03/10/2007, à 20:17

Tycho Brahe

Re : Soucis avec alsa-oss

Bonjour,

nokcy a écrit :

Dans mon contexte c wine et teamspeak

Nul besoin de wine, teamspeak dispose d'une version linux et en plus se trouve dans les dépots tongue
Je te conseil de désinstaller ça et de le réinstaller proprement en utilisant Synaptic smile Ca peut sembler bête (ou pas), mais j'ai eu exactement le même genre de soucis avec l'installateur teamspeak (pour linux) fournit sur le site officiel, mais pas avec la version installée via Synaptic.

Dernière modification par Tycho Brahe (Le 03/10/2007, à 20:18)


Loi de Newton :
Si tu restes à glander sous le pommier, tu pourrais bien prendre une pomme sur la gueule.

Hors ligne

#3 Le 03/10/2007, à 23:15

Nokcy

Re : Soucis avec alsa-oss

C bien la version des dépots de gusty que j'ai installé pour teamspeak via synaptic ^^ c vrai j'avait pas précisé tongue

#4 Le 03/10/2007, à 23:39

Tycho Brahe

Re : Soucis avec alsa-oss

Et as-tu bien modifié la commande de lancement de teamspeak pour le lancer avec alsa-oss ? (ou bien lancé directement avec la commande "aoss teamspeak")

Si ce n'est pas déjà fait :
Système >> Préférences >> Menu principal (pour modifier le lançeur situé dans le menu des applications)
Click droit sur le lançeur TeamSpeak >> Propriétées
Dans "Commande" mettre "aoss teamspeak"

Dernière modification par Tycho Brahe (Le 03/10/2007, à 23:41)


Loi de Newton :
Si tu restes à glander sous le pommier, tu pourrais bien prendre une pomme sur la gueule.

Hors ligne

#5 Le 04/10/2007, à 00:16

nokcy

Re : Soucis avec alsa-oss

Tycho Brahe a écrit :

Et as-tu bien modifié la commande de lancement de teamspeak pour le lancer avec alsa-oss ? (ou bien lancé directement avec la commande "aoss teamspeak")

Si ce n'est pas déjà fait :
Système >> Préférences >> Menu principal (pour modifier le lançeur situé dans le menu des applications)
Click droit sur le lançeur TeamSpeak >> Propriétées
Dans "Commande" mettre "aoss teamspeak"

Deja fait dsl javait pas précisé non plus mais sa paraissait evident tongue

sinon un debut de piste j'ai sa dans la console :

nokcy@nokcy-desktop:~$ aoss teamspeak
ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.

#6 Le 04/10/2007, à 18:38

nokcy

Re : Soucis avec alsa-oss

nokcy a écrit :
Tycho Brahe a écrit :

Et as-tu bien modifié la commande de lancement de teamspeak pour le lancer avec alsa-oss ? (ou bien lancé directement avec la commande "aoss teamspeak")

Si ce n'est pas déjà fait :
Système >> Préférences >> Menu principal (pour modifier le lançeur situé dans le menu des applications)
Click droit sur le lançeur TeamSpeak >> Propriétées
Dans "Commande" mettre "aoss teamspeak"

Deja fait dsl javait pas précisé non plus mais sa paraissait evident tongue

sinon un debut de piste j'ai sa dans la console :

nokcy@nokcy-desktop:~$ aoss teamspeak
ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.

Ptit up personne n'a une idée ? le paquet qui est foireux ?

#7 Le 25/10/2007, à 19:55

Tycho Brahe

Re : Soucis avec alsa-oss

Gros bump de sujet pour cause de solution trouvée.

J'ai eu exactement le même soucis depuis mon passage sous gutsy. Après des recherches (pas évidentes je l'accorde), je suis tombé sur ce topic (en anglais) qui détaille le soucis et explique comment le réparer.

Pour ceux qui ne comprennent pas parfaitement l'anglais, ou qui ont la flemme d'aller sur le lien, on peut résumer tout ceci : tout est a cause de l'utilisation d'une version 64 bit. La solution : installer ce paquet smile

J'ai dl et installé le paquet, maintenant aoss teamspeak ne me renvois plus d'erreur et j'ai le son. Je ne peut pas encore parler sur ts, mais je pense que ceci provient d'un mauvais réglage que j'ai fait en voulant bidouiller dans tout les sens (corrigé, cf edit).

Edit : pour les soucis de micro, ouvrir gnome-volume-control et suivre ce qui est indiqué dans ce topic.

Dernière modification par Tycho Brahe (Le 26/10/2007, à 23:21)


Loi de Newton :
Si tu restes à glander sous le pommier, tu pourrais bien prendre une pomme sur la gueule.

Hors ligne

#8 Le 01/11/2007, à 21:24

nokcy

Re : Soucis avec alsa-oss

Merci beaucoup sa marche effectivement nikel smile si j'ai bien compris c les libs aoss pour amd64 qui ne sont pas inclus ds les sources ubuntu c dommage hmm

Pour moi sa fonctionne mais le son est achurer sur ts

#9 Le 03/11/2007, à 18:06

Pouet69

Re : Soucis avec alsa-oss

Salut

J'avais aussi  l'erreur ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.
Merci pour ton paquet Tycho ça a résolu le problème smile
Par contre comme nocky le son est haché sous TS. Je vais voir si je peux arranger ça...

#10 Le 08/03/2008, à 12:03

Id2ndR

Re : Soucis avec alsa-oss

Moi j'ai le son haché et surtout un volume relatif trop faible (je ne parle pas du micro que j'ai réglé). Même en mettant le volume de sortie au maximum dans les options de Teamspeak, je n'entends pas assez les voix en comparaison d'autres applications.

Si quelqu'un a aussi ce problème (voir une explication/solution), j'aimerai le savoir.

J'utilise une Ubuntu 32bits et aoss pour utiliser alsa. J'utilise la version des dépôts sur Ubuntu Gutsy.

Hors ligne

#11 Le 27/04/2008, à 03:47

arona59

Re : Soucis avec alsa-oss

bonjour, j'ai moi-même était confronté à ce problème et je remercie de ce package, cependant j'ai toujours une erreur avec la commande:

aoss playonlinux --run "Steam"

qui est:

arona@arona-desktop:~$ aoss playonlinux --run "Steam"
PlayOnLinux v2.6

Checking python : 				[ Ok ]
preloader: Warning: failed to reserve range 00000000-60000000
preloader: Warning: failed to reserve range 00000000-60000000
dir: C:\Program Files\Steam\bin\ *.mix
dir: C:\Program Files\Steam\bin\ *.asi
dir: C:\Program Files\Steam\bin\ *.flt
Your Open Sound System driver did not let us configure small enough sound fragments.
This may cause delays and other problems in audio playback with certain applications.
Your Open Sound System driver did not let us configure small enough sound fragments.
This may cause delays and other problems in audio playback with certain applications.
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  30
This sound card's driver does not support direct access
The (slower) DirectSound HEL mode will be used instead.

auriez vous la solution svp,merci?

Hors ligne

#12 Le 27/04/2008, à 18:52

arona59

Re : Soucis avec alsa-oss

personne pour m'aider?

Hors ligne

#13 Le 08/09/2008, à 21:58

Reivax46

Re : Soucis avec alsa-oss

J'ai moi aussi le son haché sur le TS, tu as trouvé une solution pouet69?

Hors ligne

Haut de page ↑