Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 17/02/2013, à 18:29

rahinsoo

Carte Lan non reconnu.

Bonjour,

J'ai installé ubuntu 12.04 sur mon PC fixe : carte mère ASUS CROSSHAIR IV FORMULA.
Je n'arrive pas à me connecter sur le net ni en réseau en filaire.
J'ai l'impression qu'il n'y a pas de pilote pour la carte réseau : Marvell 8059 Gigabit LAN controller GameFirst.

Lors d'une "ifconfig" on peu détecter du mouvement sur Lo mais rien en eth0 (au cas ou cette information puisse être utile)

Merci d'avance


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#2 Le 17/02/2013, à 18:35

Korak

Re : Carte Lan non reconnu.

Bonjour,

As-tu testé en session Live (Essayer Ubuntu sans l'installer)? Si non, fait-le.

L'idéal est de le faire avec un câble réseau branché entre ton PC et ta box.


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#3 Le 17/02/2013, à 20:15

rahinsoo

Re : Carte Lan non reconnu.

En effet je n'ai pas testé la session live. yikes

Mais qu'est ce que ça change entre la version live et la version installé?
Pourquoi ça marcherais en live et non pas en installation?

Dans tous les cas je testerais le live dans la soirée ou demain smile


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#4 Le 18/02/2013, à 13:10

rahinsoo

Re : Carte Lan non reconnu.

Essai de la version Live.
Le résultat est identique, il est impossible de me connecter au réseau. :'(
Si les pilotes n'existent pas est-il possible d'utiliser les pilotes windows via Wine ou une autre solution?

Merci d'avance big_smile


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#5 Le 18/02/2013, à 13:26

Korak

Re : Carte Lan non reconnu.

Ouvre un terminal et donne le retour de la commande:

lspci

Comme tu n'as pas de réseau, donne uniquement la ligne concernant la carte réseau.

Exemple sur mon PC:

04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

La première ligne est la carte réseau filaire et la deuxième est la carte réseau Wi-Fi.

J'oubliais de répondre à tes questions:

rahinsoo a écrit :

Mais qu'est ce que ça change entre la version live et la version installé?
Pourquoi ça marcherais en live et non pas en installation?

Dans la théorie, ça ne change rien. Dans la pratique, on a parfois des surprises.

rahinsoo a écrit :

Si les pilotes n'existent pas est-il possible d'utiliser les pilotes windows via Wine ou une autre solution?

Oui mais pas avec Wine. Plutôt avec NDISWrapper.

Dernière modification par Korak (Le 18/02/2013, à 14:00)


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#6 Le 18/02/2013, à 21:43

rahinsoo

Re : Carte Lan non reconnu.

Pour commencer, après la commande lspci, les informations relative à la carte réseau :

04:00.0 Ethernet controller : Marvell Technoligy Group Ltd. Ykon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] (rev 11)

Je ne sais pas trop ce que peuvent t'apporter ces indications supplémentaires.:/

Merci pour les réponses, si il n'y a pas d'autres moyen, je testerais donc d'installer les pilotes windows. big_smile

Je vois par aileur qu'avec la page de cette outils il y a un lien de tout les pilotes lié à linux... j'ai pas l'impression que Marvell en fasse partit.:/

J'attend ton retour avant de tester NDISWrapper. smile


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#7 Le 18/02/2013, à 22:08

Korak

Re : Carte Lan non reconnu.

rahinsoo a écrit :

Pour commencer, après la commande lspci, les informations relative à la carte réseau :

04:00.0 Ethernet controller : Marvell Technoligy Group Ltd. Ykon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] (rev 11)

Ça veut dire que ta carte réseau est reconnue.

Ajoute une carte réseau (de préférence filaire) à ton PC juste pour faire des tests.


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#8 Le 19/02/2013, à 14:23

rahinsoo

Re : Carte Lan non reconnu.

Déjà un point positif si la carte est reconnue.
Mais le fait qu'elle soit reconnu implique forcément que le pilote est bon?

Pour ce qui est de la carte réseau, tu parlais d'une carte réseau externe? si c'est le cas  je n'en ai pas sauf (peut-être) en wifi.

Cette opération est pour tester si une connexion se fait?

Dernière modification par rahinsoo (Le 19/02/2013, à 14:23)


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#9 Le 19/02/2013, à 17:16

Korak

Re : Carte Lan non reconnu.

rahinsoo a écrit :

le fait qu'elle soit reconnu implique forcément que le pilote est bon?

Non, pas forcément.

rahinsoo a écrit :

Pour ce qui est de la carte réseau, tu parlais d'une carte réseau externe? si c'est le cas  je n'en ai pas sauf (peut-être) en wifi.

Je parle d'une carte réseau qui fonctionne directement sans te prendre la tête. Quelle soit interne, externe, filaire ou Wi-Fi importe peut tant quelle fonctionne.

rahinsoo a écrit :

Cette opération est pour tester si une connexion se fait?

Non, c'est pour avoir une connexion réseau active et pouvoir faire toutes les mises-à-jour d'Ubuntu. Ces mises-à-jour peuvent régler ton problème de connexion avec la carte réseau d'origine.

Si les mises-à-jour ne règlent pas le problème, la carte réseau que tu as ajoutée te permettra de donner le retour des commandes demandées en faisant un copier/coller du retour des commandes sans devoir les recopier manuellement sur un autre PC.

Dernière modification par Korak (Le 19/02/2013, à 17:19)


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#10 Le 19/02/2013, à 22:33

rahinsoo

Re : Carte Lan non reconnu.

Dans ce cas je vais chercher si j'ai une carte réseau à ajouter:D


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#11 Le 20/02/2013, à 10:57

Haleth

Re : Carte Lan non reconnu.

Et t'as configurer ton réseau ?


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#12 Le 20/02/2013, à 20:44

rahinsoo

Re : Carte Lan non reconnu.

Pour ce qui est du réseau je l'ai configuré comme un serveur big_smile

iface eth0 inet static
        name LAN
        address 192.168.1.50
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.254

J'ai fais cette modif pour voir si ça règlerai le problème... ça n'a pas été le cas hmm

Dernière modification par rahinsoo (Le 20/02/2013, à 20:45)


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#13 Le 20/02/2013, à 20:45

Haleth

Re : Carte Lan non reconnu.

Balance un peu le résultat de ifconfig, route -n etc etc
Dit nous comment tu test ton réseau. Ping la gateway serait un bon début


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#14 Le 22/02/2013, à 06:01

AlexandreP

Re : Carte Lan non reconnu.

Autre chose intéressante à tester pour voir si un pilote est reconnu et utilisé pour la carte réseau en question: la commande sudo lshw -C network permet de lister les interfaces réseau reconnues (et on a déjà convenu que ta carte réseau était reconnue, donc c'est bon signe), ainsi que leurs propriétés.

administrateur@nom_de_l'ordinateur:~$ sudo lshw -C network
[sudo] password for administrateur: 

  *-network
       description: Ethernet interface
       produit: Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB]
       fabriquant: Marvell Technology Group Ltd.
       identifiant matériel: 0
       information bus: pci@0000:04:00.0
       nom logique: eth0
       version: 11
       numéro de série: 54:42:49:69:d7:f1
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
       ressources: irq:42 mémoire:f2220000-f2223fff portE/S:a000(taille=256) mémoire:f2200000-f221ffff

Ce qui nous intéresse particulièrement est la section Fonctionnalités: si un pilote est reconnu pour cette carte, il sera listé dans cette section:

fonctionnalités: pm msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
ressources: irq:42 mémoire:f2220000-f2223fff portE/S:a000(taille=256) mémoire:f2200000-f221ffff

Ainsi, dans cet exemple (tiré de mon propre ordinateur), la carte réseau utilise le pilote sky2.


Si le module n'est pas chargé, la commande ci-dessous devrait permettre de charger le module:

sudo modprobe sky2

Dernière modification par AlexandreP (Le 22/02/2013, à 06:08)


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#15 Le 23/02/2013, à 15:10

rahinsoo

Re : Carte Lan non reconnu.

Et bien je vais essayer tout ça ce week-end o/


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#16 Le 27/02/2013, à 22:02

rahinsoo

Re : Carte Lan non reconnu.

Bon alors : Toujours aucun résultat :

ifconfig :

eth0      Link encap:Ethernet  HWaddr 20:cf:30:3b:57:d5  
          inet adr:192.168.1.50  Bcast:192.168.1.255  Masque:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:51 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:2303 erreurs:0 :0 overruns:0 frame:0
          TX packets:2303 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:183996 (183.9 KB) Octets transmis:183996 (183.9 KB)

pour sudo lshw -C network :

*-network                     
       description: Ethernet interface
       produit: Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB]
       fabriquant: Marvell Technology Group Ltd.
       identifiant matériel: 0
       information bus: pci@0000:04:00.0
       nom logique: eth0
       version: 11
       numéro de série: 20:cf:30:3b:57:d5
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 firmware=N/A ip=192.168.1.50 latency=0 link=no multicast=yes port=twisted pair
       ressources: irq:83 mémoire:fe7fc000-fe7fffff portE/S:c800(taille=256) mémoire:fe7c0000-fe7dffff

Balance un peu le résultat de ifconfig, route -n etc etc
Dit nous comment tu test ton réseau. Ping la gateway serait un bon début

Tu peux me donner toutes ces commandes pour que je test ?

La carte à l'air d'être détecté et le module chargé, étrange non ?


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#17 Le 27/02/2013, à 22:08

Haleth

Re : Carte Lan non reconnu.

ifconfig -a
route -n
arp -n
cat /etc/resolv.conf

Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#18 Le 12/03/2013, à 20:06

rahinsoo

Re : Carte Lan non reconnu.

Alors les résultats sont : (avec du temps x) )

ifconfig -a

eth0      Link encap:Ethernet  HWaddr 20:cf:30:3b:57:d5  
          inet adr:192.168.1.50  Bcast:192.168.1.255  Masque:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:51 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:55 erreurs:0 :0 overruns:0 frame:0
          TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:4028 (4.0 KB) Octets transmis:4028 (4.0 KB)


route -n

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    100    0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

arp -n   -> rien
cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

Pour moi je ne vois toujours pas où est le problème hmm


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

#19 Le 12/03/2013, à 22:32

Korak

Re : Carte Lan non reconnu.

J'ai comme l'impression que ta box (passerelle) est à l'adresse 192.168.1.255.

Et que tu ne passes pas par elle.


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#20 Le 13/03/2013, à 10:32

Haleth

Re : Carte Lan non reconnu.

J'ai comme l'impression que ta box (passerelle) est à l'adresse 192.168.1.255.

Ce serait bien pourri: c'est l'@ broadcast sur ce subnet

Que te donne un ping 192.168.1.254 ?
Peut-tu vérifier que c'est bien l'adresse de ta box ? que ta box répond aux ping (ICMP echo request) ?

Btw, c'est quoi ta box ?
Tu as le DHCP activée sur celle-ci ?
Pourquoi ne pas utiliser dhclient ?

sudo dhclient -v eth0

Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#21 Le 24/03/2013, à 12:42

rahinsoo

Re : Carte Lan non reconnu.

J'ai testé tout ça sans aucun résultat hmm

root@rahinsoo-PC:~# ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
From 192.168.1.50 icmp_seq=1 Destination Host Unreachable
From 192.168.1.50 icmp_seq=2 Destination Host Unreachable
From 192.168.1.50 icmp_seq=3 Destination Host Unreachable
From 192.168.1.50 icmp_seq=4 Destination Host Unreachable
From 192.168.1.50 icmp_seq=5 Destination Host Unreachable
From 192.168.1.50 icmp_seq=6 Destination Host Unreachable
From 192.168.1.50 icmp_seq=7 Destination Host Unreachable
From 192.168.1.50 icmp_seq=8 Destination Host Unreachable

j'ai rien pour le groadcast

l'adresse de la box est bien 190.164.1.254 mais elle ne répond pas au ping, je n'arrive donc pas à me connecter sur elle.

J'ai une freebox et le DHCP activé avec une fin de plage d'adresse à 192.168.1.50, comme j'ai forcé le pc à 50 c'est peut-être une des cause du non fonctionnement.
Testé avec 51... même résultat.

Pour la question du dhclient :

root@rahinsoo-PC:~# dhclient -v eth0
Internet Systems Consortium DHCP Client 4.1-ESV-R4
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/20:cf:30:3b:57:d5
Sending on   LPF/eth0/20:cf:30:3b:57:d5
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

sinon j'ai essayé :

root@rahinsoo-PC:~# /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                          RTNETLINK answers: File exists
Failed to bring up eth0.
                                                                         [ OK ]

Je me demande si il n'y pas un problème de ma part quelque part hmm


config :
Hardware ---> ASUS UL80VT
OS --------->Windows7/Ubuntu 10.10

Hors ligne

Haut de page ↑