Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash vient d'être divulguée, il est recommandé de mettre à jour son système (plus de détails)

*** 28 sept. nouvelle mise à jour (4.2-2ubuntu2.5 ou 4.3-7ubuntu1.4) *** pour mettre à jour, lancez dans un terminal :
sudo apt-get update ; sudo apt-get upgrade bash

#1 Le 07/03/2013, à 00:03

Crone123

[Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Bonjour,
Si vous cherchez une réponse pour un SSH avec Xforwarding qui vous envoie le message:

X11 forwaring request failed on channel 0

et que vous venez de désactiver l'IPV6
La solution se trouve ici: http://forum.ubuntu-fr.org/viewtopic.ph … #p13014291

J'ai installé un serveur openssh sur tous mes ordis pour pouvoir y accéder quand je veux depuis n'importe quel ordi du réseau.
En tapant:

sudo apt-get install openssh-server

La configuration par défaut me permet d'utiliser l'option -X qui lance une connexion graphique.
Je peux donc lancer des programmes graphiques sur l'ordi distant comme si j'y étais.

Seulement voilà, depuis quelques temps, et sans avoir rien modifié (sauf peut être fait une MAJ avec le gestionnaire de MAJ) 2 de mes ordis n'acceptent plus les connexions graphiques, et s'y connecter renvoie ce message:

X11 forwarding request failed on channel 0

Je précise donc que je n'ai modifié la configuration par défaut sur aucun ordi, et qu'elle contient bien:

X11Forwarding yes
X11DisplayOffset 10

Comme initialement configuré.

Quelqu'un saurait comment corriger le problème?
Merci smile

EDIT: PS: Je suis sur Ubuntu 12.04 LTS sur tous les ordis.

Dernière modification par Crone123 (Le 24/03/2013, à 23:41)

Hors ligne

#2 Le 07/03/2013, à 09:02

tiramiseb

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Salut,

Que donnent les commandes suivantes, sur le serveur ET sur le client ?

dpkg -l | grep xauth
grep XAuthLocation /etc/ssh/*

Et sur le serveur uniquement, que donne la commande suivante ?

grep ssh /var/log/auth.log | tail -n 30

(sources : http://orgrim.net/post/2011/10/21/X11-f … -channel-0 et http://www.linuxquestions.org/questions … -a-945709/)


PS : http://lmgtfy.com/?q=X11+forwarding+req … +channel+0

Dernière modification par tiramiseb (Le 07/03/2013, à 09:02)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#3 Le 07/03/2013, à 15:17

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

J'ai déjà cherché sans trouver, c'est bien pour ça que je poste....

*********@ACER-VALENTIN:~$ grep ssh /var/log/auth.log | tail -n 30
Mar  5 14:51:17 ACER-VALENTIN sshd[821]: Server listening on 0.0.0.0 port 22.
Mar  5 14:51:17 ACER-VALENTIN sshd[821]: Server listening on :: port 22.
Mar  6 18:16:06 ACER-VALENTIN sshd[6690]: Accepted password for ********* from 192.168.1.11 port 46547 ssh2
Mar  6 18:16:06 ACER-VALENTIN sshd[6690]: pam_unix(sshd:session): session opened for user ******** by (uid=0)
Mar  6 18:17:17 ACER-VALENTIN sshd[6927]: Received disconnect from 192.168.1.11: 11: disconnected by user
Mar  6 18:17:17 ACER-VALENTIN sshd[6690]: pam_unix(sshd:session): session closed for user *********
Mar  6 20:07:26 ACER-VALENTIN sshd[9487]: Accepted password for *********** from 192.168.1.13 port 34342 ssh2
Mar  6 20:07:26 ACER-VALENTIN sshd[9487]: pam_unix(sshd:session): session opened for user ********** by (uid=0)
Mar  6 20:07:26 ACER-VALENTIN sshd[9726]: error: Failed to allocate internet-domain X11 display socket.
Mar  6 20:11:04 ACER-VALENTIN sshd[9726]: Received disconnect from 192.168.1.13: 11: disconnected by user
Mar  6 20:11:04 ACER-VALENTIN sshd[9487]: pam_unix(sshd:session): session closed for user ************
Mar  6 22:53:44 ACER-VALENTIN sshd[14892]: Accepted password for ******** from 192.168.1.11 port 46667 ssh2
Mar  6 22:53:44 ACER-VALENTIN sshd[14892]: pam_unix(sshd:session): session opened for user ********* by (uid=0)
Mar  6 22:53:45 ACER-VALENTIN sshd[15122]: error: Failed to allocate internet-domain X11 display socket.
Mar  6 23:29:00 ACER-VALENTIN sshd[15122]: Received disconnect from 192.168.1.11: 11: disconnected by user
Mar  6 23:29:00 ACER-VALENTIN sshd[14892]: pam_unix(sshd:session): session closed for user *********
*********@ACER-VALENTIN:~$

Sur un serveur qui accepte les connexion graphiques, et qui peut se connecter en graphique ailleurs (en tant queclient):

*******@ACER-VALENTIN4:~$ dpkg -l | grep xauth
ii  xauth                                  1:1.0.6-1                               X authentication utility
*******@ACER-VALENTIN4:~$ grep XAuthLocation /etc/ssh/*
grep: /etc/ssh/ssh_host_dsa_key: Permission non accordée
grep: /etc/ssh/ssh_host_ecdsa_key: Permission non accordée
grep: /etc/ssh/ssh_host_rsa_key: Permission non accordée
*******@ACER-VALENTIN4:~$ sudo grep XAuthLocation /etc/ssh/*
[sudo] password for *****: 
*******@ACER-VALENTIN4:~$

Sur un serveur qui n'accepte pas les connexion graphiques (log plus haut), mais qui peut ouvrir des connexion graphiques sur un autre serveur (en tant que client):

*******@ACER-VALENTIN:~$ dpkg -l | grep xauth
ii  xauth                                  1:1.0.6-1                                           X authentication utility
*******@ACER-VALENTIN:~$ grep XAuthLocation /etc/ssh/*
grep: /etc/ssh/ssh_host_dsa_key: Permission non accordée
grep: /etc/ssh/ssh_host_ecdsa_key: Permission non accordée
grep: /etc/ssh/ssh_host_rsa_key: Permission non accordée
*******@ACER-VALENTIN:~$ sudo grep XAuthLocation /etc/ssh/*
[sudo] password for ********: 
********@ACER-VALENTIN:~$

J'ai l'impression que ça renvoie exactement la même chose....

J'ai essayé aussi d'avoir le log sur un serveur qui marche, et l'erreur:

error: Failed to allocate internet-domain X11 display socket.

n'est pas présente.

Merci smile

Dernière modification par Crone123 (Le 07/03/2013, à 15:27)

Hors ligne

#4 Le 07/03/2013, à 15:27

tiramiseb

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Là je ne vois pas dans quel sens avancer...

Si je te détaille mon approche tu comprendras mieux ce que je cherches :

« Failed to allocate internet-domain X11 display socket » ne me semble pas être un message "brut", un message qui décrit son problème. On dirait qu'il y a un problème sous-jascent qui génère cette erreur... J'espérais que, dans les logs, on voit quelque chose.

Qu'est-ce que ça donne si tu rends ton client ssh plus verbeux (ajout de l'argument "-v" ou "-vv" voire "-vvv" à ta commande ssh -X) ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 07/03/2013, à 15:32

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Avec -v:

Authenticated to 192.168.1.10 ([192.168.1.10]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.UTF-8
X11 forwarding request failed on channel 0

Avec -vv:

Authenticated to 192.168.1.10 ([192.168.1.10]:22).
debug1: channel 0: new [client-session]
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug2: callback start
debug2: x11_get_proto: /usr/bin/xauth  list unix:10.0 2>/dev/null
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: channel 0: request x11-req confirm 1
debug2: client_session2_setup: id 0
debug2: fd 3 setting TCP_NODELAY
debug2: channel 0: request pty-req confirm 1
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.UTF-8
debug2: channel 0: request env confirm 0
debug2: channel 0: request shell confirm 1
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 100 id 0
X11 forwarding request failed on channel 0
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0

Avec -vvv:

Authenticated to 192.168.1.10 ([192.168.1.10]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug2: callback start
debug2: x11_get_proto: /usr/bin/xauth  list unix:10.0 2>/dev/null
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: channel 0: request x11-req confirm 1
debug2: client_session2_setup: id 0
debug2: fd 3 setting TCP_NODELAY
debug2: channel 0: request pty-req confirm 1
debug1: Sending environment.
debug3: Ignored env SHELL
debug3: Ignored env TERM
debug3: Ignored env XDG_SESSION_COOKIE
debug3: Ignored env SSH_CLIENT
debug3: Ignored env WINDOWID
debug3: Ignored env OLDPWD
debug3: Ignored env USER
debug3: Ignored env LS_COLORS
debug3: Ignored env PATH
debug3: Ignored env MAIL
debug3: Ignored env PWD
debug1: Sending env LANG = fr_FR.UTF-8
debug2: channel 0: request env confirm 0
debug3: Ignored env SHLVL
debug3: Ignored env HOME
debug3: Ignored env LOGNAME
debug3: Ignored env SSH_CONNECTION
debug3: Ignored env LESSOPEN
debug3: Ignored env DISPLAY
debug3: Ignored env LESSCLOSE
debug3: Ignored env COLORTERM
debug3: Ignored env _
debug2: channel 0: request shell confirm 1
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 100 id 0
X11 forwarding request failed on channel 0
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0

Merci smile

Hors ligne

#6 Le 07/03/2013, à 16:19

tiramiseb

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Que donne la commande suivante exécutée sur le serveur ?

/usr/bin/xauth  list unix:10.0

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 07/03/2013, à 16:43

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

ACER-VALENTIN/unix:10  MIT-MAGIC-COOKIE-1  4904314e86ab16031f4287773073ea58

Hors ligne

#8 Le 07/03/2013, à 17:06

tiramiseb

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Ça l'a l'air bon, chez moi il donne quelque chose d'équivalent...
Là je sèche... sad


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#9 Le 07/03/2013, à 17:09

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

tiramiseb a écrit :

Ça l'a l'air bon, chez moi il donne quelque chose d'équivalent...
Là je sèche... sad

Et c'est bien pour ça que Google ne répondais pas a ma question sad
L'erreur est survenue d'un coup sur 2 de mes ordis, donc j'ai rien touché, je ne sais pas pourquoi ça fait ça....et j'ai pas trop envie de ré-installer Ubuntu pour corriger ça....

Hors ligne

#10 Le 07/03/2013, à 17:55

Purdey

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Bonjour,

J'ai eu le même pb que toi dans une config similaire (sauf que le serveur sshd est sur 10.04LTS, mais ça change pas grand chose).
Après avoir beaucoup ramé, j'ai résolu le pb bêtement : le fichier /etc/network/interfaces avait été commenté. Par quoi ou qui je sais pas.
En le remettant par défaut à :

auto lo
iface lo inet loopback

Le forwarding X11 a de nouveau fonctionné. Bien sur, je sais pas pourquoi, c'est juste une relation cause à effet...
De fait, c'est la config que j'ai sur tous mes pc. Ça devrait pas manger de pain que tu vérifies/modifies ce fichier sur tes postes incriminés avant d'y mettre le feu.

PS : un reboot de la machine est nécessaire après la modif (ou un service  qqchose restart mais je connais pas qqchose --> reboot).


Ubuntu 12.04.2 LTS 64bit |Intel® Core™2 Quad CPU Q8200 @ 2.33GHz × 4|ati radeonhd RV730

Hors ligne

#11 Le 07/03/2013, à 18:08

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Bonjour,
Mon fichier interfaces contient:

auto lo
iface lo inet loopback

Il n'est pas commenté sad
Merci smile

Hors ligne

#12 Le 07/03/2013, à 18:18

Purdey

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Ah, zut. J'étais à fond de mes compétences là. Désolé.


Ubuntu 12.04.2 LTS 64bit |Intel® Core™2 Quad CPU Q8200 @ 2.33GHz × 4|ati radeonhd RV730

Hors ligne

#13 Le 07/03/2013, à 22:16

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Purdey a écrit :

Ah, zut. J'étais à fond de mes compétences là. Désolé.

Ceci dit c'était pas une mauvaise idée, pareil des fois les bugs qu'on a quand on change le nom de la machine mais là ça corrige pas le problème sad

Hors ligne

#14 Le 24/03/2013, à 21:33

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

J'ai du nouveau concernant mon problème:
J'ai maintenant une 3ème machine qui ne fonctionne plus en graphique, mais je sais ce que j'ai modifié dessus:
J'ai juste désactivé l'IPV6.

En gros les 2 premières je voulais installer un VPN et donc l'IPV6 était un peu gênant donc je l'ai viré, et le serveur, je voulais configurer un nat pour lequel l'IPV6 me pose aussi des problèmes donc je l'ai viré et juste après le SSH graphique n'as plus fonctionné. (donc ça viens de là..)

Quelqu'un saurait comment le refaire marcher?
Merci smile

Hors ligne

#15 Le 24/03/2013, à 23:35

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Problème résolu:
Solution trouvée ici: http://marionote.wordpress.com/2011/12/ … -resolved/
Il faut rajouter:

AddressFamily inet

Dans:
/etc/ssh/sshd_config

Relancer ensuite le ssh:

sudo service ssh restart

Et ça fonctionne smile (reconnexion nécessaire si vous étiez déjà connecté au serveur par SSH)

Hors ligne

#16 Le 25/03/2013, à 09:11

Purdey

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Bonjour crone123,

Finalement qui du serveur ou du client failed le tunneling X?


Ubuntu 12.04.2 LTS 64bit |Intel® Core™2 Quad CPU Q8200 @ 2.33GHz × 4|ati radeonhd RV730

Hors ligne

#17 Le 25/03/2013, à 16:08

Crone123

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Bonjour,
C'est le serveur qui posait problème. La configuration du client finalement n'est pas a changer.

→ J'ai maintenant essayé la solution sur les 3 serveurs qui avaient le problème, elle a fonctionné a chaque fois. smile

Hors ligne

#18 Le 27/03/2013, à 10:33

Purdey

Re : [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Ok, merci:D


Ubuntu 12.04.2 LTS 64bit |Intel® Core™2 Quad CPU Q8200 @ 2.33GHz × 4|ati radeonhd RV730

Hors ligne

  • Accueil
  • » Forum
  • » Serveurs
  • » [Résolu]SSH X11 forwarding ne fonctionne plus après désactivation IPV6

Haut de page ↑