Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 28/10/2007, à 14:08

Insomniak.fr

Problème nvidia-glx, passage de Feisty à Gutsy

Salut smile

J'ai un gros problème... depuis mon passage à Gutsy, nvidia-glx ne marche plus.

Sous feisty, je n'avais aucun problème... Au démarrage de gutsy, j'ai un problème nvidia, je fais donc

sudo dpkg-reconfigure xserver-xorg

et je choisi nv, ça marche. Mais si je refait la manip en choisisant nvidia au lieu de nv, ça ne marche pas... sad

J'ai essayé de désinstaller/installer le drivers, sans effets...

Pourriez-vous m'aider ? Pour information, je tourne sous Kubuntu...

#2 Le 01/11/2007, à 12:10

cube45

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Bonjour,
J'ai exactement le même problème en utilisant Ubuntu avec gnome, sauf que quand je me connecte avec nvidia-glx, un message (en anglais) me dit quelque chose du genre:

Ubuntu runs in low-graphcs mode...

et me disant qu'ils ne pouvaient pas détecter ma carte graphique et mon écran
et 3 choix : "configure", "shutdown" ou "continue"
.
en faisant ctrl+alt+F1, connexion root puis

#/etc/init.d/gdm stop
#startx

Le serveur ne se lance pas, erreur avec

API mismatch:...

une erreur qui n'apparait pas dans le log mais qui me dit que le module nvidia du noyau et le module du serveur X ne correspondent pas et me demande de corriger ce problème et de relancer le serveur X.
Vient ensuite une erreur qui cette fois-ci est dans le log dont voici un extrait:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(== ) NVIDIA(0): RGB weight 888
(== ) NVIDIA(0): Default visual is TrueColor
(**) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly.
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Merci de nous aider,
cube45
EDIT:J'arrive à lancer le serveur X avec la bonne résolution soit en modifiant le fichier /etc/X11/xorg.conf
soit en faisant un dpkg-reconfigure xserver-xorg ce qui revient au même.
Le problème est que je n'ai plus les beaux effets de bureau :'(
ça me manque tellement de pouvoir faire des reonds dans l'eau big_smile

Dernière modification par cube45 (Le 01/11/2007, à 12:14)

Hors ligne

#3 Le 01/11/2007, à 12:14

donnlaur

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Bonjour.Je crois que tu dois ajouter dans le fichier xorg.conf cette ligne dans la section screen :

Option "NoPowerConnectorCheck" "1"

Voila. Bonne chance.

Donnlaur.

Hors ligne

#4 Le 01/11/2007, à 12:59

cube45

Re : Problème nvidia-glx, passage de Feisty à Gutsy

désolé, mais ça ne change rien.
d'autres propositions?
Mon /etc/X11/xorg.conf (qui ne marche pas), pour qu'il marche, il suffit de remplacer nvidia par nv

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "nVidia Corporation G70 [GeForce Go 7600]"
    Driver        "nvidia"
    Busid        "PCI:1:0:0"
    Option        "AddARGBVisuals"    "True"
    Option        "AddARGBGLXVisuals"    "True"
    Option        "NoLogo"    "True"
EndSection

Section "Monitor"
    Identifier    "Écran générique"
    Option        "DPMS"
    Horizsync    28-72
    Vertrefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation G70 [GeForce Go 7600]"
    Monitor        "Écran générique"
    Defaultdepth    24
    Option "NoPowerConnectorCheck" "1"
    SubSection "Display"
        Modes        "1440x900"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen "Default Screen"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
   
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
    Inputdevice    "Synaptics Touchpad"
EndSection
Section "Module"
    Load        "glx"
EndSection

$lspci|grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1)

j'ai un PC toshiba satellite P100-197

Hors ligne

#5 Le 01/11/2007, à 13:45

mesob

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Bonjour, j'ai posté une solution qui a marché chez moi pour la carte graphique Nvidia sous gutsy.
dites-moi si cela fonctionne aussi chez vous.
http://forum.ubuntu-fr.org/viewtopic.php?id=156445
mesob

#6 Le 01/11/2007, à 17:07

Chiuchu

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Salut,

Chez moi ça corrige le problème (qui est exactement le meme que celui du topic). Si c'est pareil chez vous, un petit [résolu] ne ferait de mal à personne ...

smile

Hors ligne

#7 Le 01/11/2007, à 19:38

cube45

Re : Problème nvidia-glx, passage de Feisty à Gutsy

J'ai fait comme décrit dans le message et ça n'a pas fonctionné. c'est alors qu'en faisant un uname -r , je me suis souvenu que j'utilisait une version plus ancienne du kernel.J'ai donc changé grâce à grub et gnome s'est lancé correctement lol cela a-t-il un lien avec la manipulation faite précédement, certainement, toujour est-il que ça marche et que j'ai retrouvé ma pluie big_smile

Hors ligne

#8 Le 01/11/2007, à 21:26

alainvc

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Bonjour à tous,

Je suis passé aujourd'hui de Ubuntu 7.04 à 7.10.  Tout s'est bien passé jusqu'à ce qu'il me demande d'installer les drivers proprio pour ma carte vidéo (ATI Raedon X300 SE)... Au redémarrage, écran noir, plus rien.  Avec l'aide d'eMerzh, j'ai pu virer tout, redémarrer puis lancer les fouilles... pour finalement réinstaller les drivers proprio, et ca a marché.  Seul souci, une luminosité trop importante.

Au final j'ai remis une ancienne version de xorg.info et maintenant tout est nickel-chrome...

Voilà ce qui marche chez moi, si ca peut aider... :
Section "Device"
    Identifier    "ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]"
    Driver        "fglrx"
    Busid        "PCI:3:0:0"
EndSection

Section "Monitor"
    Identifier    "HC194D"
    Option        "DPMS"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]"
    Monitor        "HC194D"
    Defaultdepth    24
    SubSection "Display"
        Depth    1
        Modes        "1280x1024"    "1024x768"    "832x624"    "800x600"    "720x400"    "640x640"    "640x480"    "640x400"
    EndSubSection
    SubSection "Display"
        Depth    4
        Modes        "1280x1024"    "1024x768"    "832x624"    "800x600"    "720x400"    "640x640"    "640x480"    "640x400"
    EndSubSection
    SubSection "Display"
        Depth    8
        Modes        "1280x1024"    "1024x768"    "832x624"    "800x600"    "720x400"    "640x640"    "640x480"    "640x400"
    EndSubSection
    SubSection "Display"
        Depth    15
        Modes        "1280x1024"    "1024x768"    "832x624"    "800x600"    "720x400"    "640x640"    "640x480"    "640x400"
    EndSubSection
    SubSection "Display"
        Depth    16
        Modes        "1280x1024"    "1024x768"    "832x624"    "800x600"    "720x400"    "640x640"    "640x480"    "640x400"
    EndSubSection
    SubSection "Display"
        Depth    24
        Modes        "1280x1024"    "1024x768"    "832x624"    "800x600"    "720x400"    "640x640"    "640x480"    "640x400"
    EndSubSection
EndSection

Si ca peut en aider quelques-uns, tant mieux !

Hors ligne

#9 Le 01/11/2007, à 23:35

LucG

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Avec l'aide d'eMerzh, j'ai pu virer tout, redémarrer puis lancer les fouilles... pour finalement réinstaller les drivers proprio, et ca a marché.

Bonjour,
J'ai le même pb, comment as-tu fait pour tout virer et tout installer ?
Je viens de faire évoluer 7.04 vers 7.10, après redémarrage, un assistant m'a proposé d'installer les ilotes propriétaires pour ma nvidia geforce FX 5200, j'ai bêtement accepté.
Au redémarrage, l'initialisation semble correcte puis écran noir avec le moniteur qui annonce "Out of range ...".
Je relance en mode recovery, j'essaie de désinstaller les pilotes en faisant :

sudo apt-get --purge remove nvidia-glx nvidia-glx-legacy nvidia-settings nvidia-kernel-common linux-restricted-modules-`uname -r` linux-restricted-modules-common
sudo rm /etc/init.d/nvidia-*

J'obtiens une réponse qui m'indique qu'aucun pilote nvidia n'a été installé.
J'essaie ensuite de modifier xorg.conf mais il est introuvable à cette adresse /etc/X11/xorg.conf
en fait, c'est /X11/ qui est introuvable dans /etc/
Merci pour toute aide

#10 Le 02/11/2007, à 16:18

LucG

Re : Problème nvidia-glx, passage de Feisty à Gutsy

Bon, finalement, j'ai appris plusieurs choses :
- me déplacer correctement dans les répertoires en mode recovery (X11 était bien à sa place!)
- utiliser un éditeur (nano) et corriger xorg.conf (mettre nv à la place nvidia )
- relancer le serveur X
- appliquer cette manip, lue dans plusieurs topics de ce forum :

éditer /etc/default/linux-restricted-modules-common en modifiant le code par DISABLED_MODULES="nvidia nvidia_legacy

Plus aucun problème depuis mais les pilotes nvidia ne sont toujours pas activés et je n'ose plus réessayer!

Haut de page ↑