Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 04/10/2007, à 17:48

Jonathan82

Re : Probleme connection internet via wifi

jonathan@jonathan-laptop:~$ sudo dhclient wlan0
Password:
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device

Hors ligne

#27 Le 05/10/2007, à 00:54

Jonathan82

Re : Probleme connection internet via wifi

jonathan@jonathan-laptop:~$ sudo dhclient wlan0
There is already a pid file /var/run/dhclient.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device

Hors ligne

#28 Le 05/10/2007, à 08:13

Mornagest

Re : Probleme connection internet via wifi

C'est bizarre, parce qu'elle est reconnue, ta clé... essaie via Wicd ou Network-manager (liens dans ma signature pour la doc).

Mais j'ai un doute quand même.  En redémarrant le PC, c'est pareil pour iwconfig ?

Edit : sinon, tu devrais essayer les pilotes pour Windows XP wink

Dernière modification par Mornagest (Le 05/10/2007, à 08:14)

Hors ligne

#29 Le 05/10/2007, à 12:38

Jonathan82

Re : Probleme connection internet via wifi

Salut Mornagest,

j'ai istallé ndiswrapper via Synaptic, c'est la version 1.38-lubuntul. j'ai installé les 4 paquets differents. Comme ca ne marché tjs pas j'ai installé ndisgtk. j'ai testé les driver de vistaX64, VistaX86, Win98, WinXP,... Quand je mets install dans ce programmme j'ai une icone qui me dits : Driver driver is already installed.
Mais dans l'autre fenetre j'ai : Hardware presents : No

Hors ligne

#30 Le 05/10/2007, à 17:29

Jonathan82

Re : Probleme connection internet via wifi

j'ai essayé avec network manager mais ca n'a rein changé. j'ai 2 icones reseau maintenant...
j'applique la ligne pour revenir a la configuration initiale?
''sudo cp /etc/network/interfaces.bak /etc/network/interfaces''

Hors ligne

#31 Le 06/10/2007, à 19:30

Jonathan82

Re : Probleme connection internet via wifi

je relance...

Hors ligne

#32 Le 20/10/2007, à 11:27

michael123

Re : Probleme connection internet via wifi

Je n'avais pas réussi à configurer le MD96290 avec Ubuntu7.10 beta. La connection prenait quelques secondes et puis se coupait.

J'ai réessayé avec succès avec la version définitive 7.10:
- réinstallation complète de Ubuntu 7.10
- connection par le cable lan
- installation des 2 packages "ndiswrapper"  de ubuntu (System/Synaptic Package Manager):
  - ndiswrapper-common
  - ndiswrapper-utils-1.9
- configuration de ndiswrapper dans un terminal (Applications/Accesories/Terminal):
 

sudo ndiswrapper -i /media/sda5/Driver/WinXP/wlan/RTL8187B_6.1074.0406.2007/Win2000/net8187b.inf

(si vous avez toujours le volume 'Recover' qui est en standard sur le MD96290)
   le choix pour Win2000 est inspiré par: http://ubuntuforums.org/showthread.php?p=3528133

ATTENTION : Quand ndiswrapper est lancé par une ligne dans /etc/modules, le pilote ne fonctionne pas correctement!

gksudo gedit /etc/modules

- enlever la dernière ligne:

ndiswrapper

Dernière modification par michael123 (Le 22/10/2007, à 20:54)

Hors ligne

#33 Le 22/10/2007, à 21:16

michael123

Re : Probleme connection internet via wifi

Le pilote realtek (*)ne se marie pas très bien avec ndiswrapper. J'ai relu attentivement le post sur http://ubuntuforums.org/showthread.php?p=3528133, et j'ai trouvé la réponse!

(*)pour récapituler, is s'agit du pilote Win2000 pour:

$ sudo lsusb
...
Bus 005 Device 003: ID 0bda:8189 Realtek Semiconductor Corp. 
...

La solution magique:
après l'invocation du module ndiswrapper, il faut impérativement lancer un sudo iwlist wlan0 scan. Après cela, le 'network manager' de ubuntu reprend correctement le contrôle de wlan. Il vous est donc par exemple d'introduire le mot de passe WPA par l'interface graphique ubuntu.

example:

sudo modprobe ndiswrapper
sudo iwlist wlan0 scan

Bien sûr il est plus facile d'automatiser la solution:

- créez un fichier $HOME/wlan0.sh:

gksudo gedit $HOME/wlan0.sh

- introduisez les ligne suivantes dans ce script:

modprobe ndiswrapper
iwlist wlan0 scan
# eventuellement: --
#iwconfig wlan0 ap 00:14:C1:04:75:C4
#iwconfig wlan0 essid VOTRE_ESSID key "s:VOTRE_MOT_DE_PASSE"
# pas certain si c'est important: 
iwconfig wlan0 commit

activez le script au démarrage (la commande runlevel sert à retrouver le niveau d'exécution actuel):

cd /etc/init.d
sudo cp $HOME/wlan0.sh .
sudo chmod 755 ./wlan0.sh
runlevel
--> résultat: N 2
cd /etc/rc2.d
sudo ln -s /etc/init.d/wlan0.sh S99wlan0.sh

Redémarez votre système et le wlan0.sh devrait être opérationel.

Maintenant: le son -- tout tuyau est le bienvenu:)

Hors ligne

#34 Le 23/10/2007, à 22:15

michael123

Re : Probleme connection internet via wifi

le son fonctionne aussi sur le Medion md92690:
- voici ma configuration alsa: http://pastebin.ca/747134 (=script alsa-info.sh)
  Il s'agit donc d'un HDA Intel, 82801G et Realtek ALC883.
- le tuyau: http://ubuntuforums.org/archive/index.php/t-429182.html
--> la solution: editer /etc/modprobe.d/alsa-base

gksudo gedit /etc/modprobe.d/alsa-base

ajouter une ligne à la fin:

options snd-hda-intel model=auto

Dernière modification par michael123 (Le 23/10/2007, à 22:16)

Hors ligne

#35 Le 03/11/2007, à 13:20

michael123

Re : Probleme connection internet via wifi

Malgré mes posts précédents, mon WLAN n'est toujours pas stable sous gutsy (7.10) régulièrement, après quelques minutes, la connection se coupe.

Il semble que "avahi-daemon" -- aparamment un truc pour apple -- interfère dans la connetion wlan (tail -f /var/log/syslog). Je l'ai désactivé et pour l'instant, la connection semble stable:

cd /etc/rc2.d
sudo mv S24avahi-daemon SXXavahi-daemon
sudo reboot

j'utilise ndiswrapper, sans le wlan0.sh décrit précédemment. Simplement dans /etc/modules, j'ajoute à la fin

ndiswrapper

Pour l'instant j'utilise la version win98 des drivers realtech RTL8187B.

En espérant que tout fonctionne maintenant...

Hors ligne