Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 09/04/2013, à 17:31

gomgom13

[RESOLU]Wicd/ Voyager ne voit pas les réseaux

Bonjour cher-e-s tou-te-s,

J'en peux plus, je craque, au secours:
Après bien des galères pour comprendre que mon DD était mort et puis l'avoir changé, et puis avoir eu du mal à installer Voyager 12.10, Wicd ne voit plus les réseaux de ma résidence! Alors qu'en live-usb cela fonctionnait (mais plus maintenant, j'ai essayé).
Après l'installation je n'ai fait que mettre des données sur le disque.

Cependant je dois dire que j'avais désactivé ma connexion Wifi (avec le raccourci clavier) pendant l'installation parce que je pensais que c'était ça qui la faisait planter (débit trop faible).

Bref mon EEEPC était près pour faire les MaJ, j'ai voulu le reconnecter, et là, aucun réseau n’apparaît! Je précise que c'est un réseau non-sécurisé qui fonctionne très bien sur mon PC de bureau (Ubuntu 12.04) .

Donc j'ai fait:

 sudo rfkill unblock all 

puis

 sudo rfkill list 

et rien n'est bloqué.

un

 ifconfig 

indique aucune erreur mais aucun débit non plus, aucun octet ni recus ni transmis.

Un

 sudo ifup wlan0 

donne

 Ignoring unknow interface wlan0=wlan0.

J'ai également vérifié que la connexion était activée dans le BIOS.

Un

 sudo lshw -C network 

reconnaît bien ma carte Wifi et ne signale aucun problème...

Vais-je vraiment devoir installer Network-Manager alors Wicd semble mieux fonctionner? Et cela a-t-il une chance de vraiment marcher?

Quelqu'un aurait-il une idée? Je suis perdu et sens le désespoir m'envahir!

HELP, I Need someone! (comme dit la chanson)

Dernière modification par gomgom13 (Le 12/04/2013, à 11:03)

Hors ligne

#2 Le 09/04/2013, à 18:21

ljere

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

tu peux très bien installer network manager en parallèle, peux tu donner le retour de

cat /etc/network/interfaces

ainsi que ton

ifconfig

et

iwconfig

athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#3 Le 09/04/2013, à 20:11

gomgom13

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

Bonsoir Ljere, et merci de ton aide.

La première commande de donne rien: je la tape dans le terminal mais n'ai aucun retour...

Je te recopie le résultat de

ifconfig

, paragraphe wlan0

Link encap:Ethernet  HWaddr 00:15:af:da:e8:b1
UP BROADCAST MULTICAST  MTU:1500 Metric:1
Packets reçus:0 erreurs:0  :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

Quand a

ifconfig

, la commande retourne:

wlan0    IEEE 802.11bgn   ESSID:off/any
                       Mode:Managed  Access point: Not-Associated  Tx-Power=20 dBm
                       Retry  long limit:7  RTS thr:off   Fragment thr:off
                       Power Management: off

lo                    no wireless extensions.

eth0                no wireless extensions.
 

Qu'en dis-tu?

Si je comprends qqchose ma carte wifi n'est pas associée avec la fonction wifi?

Merci encore!

Hors ligne

#4 Le 09/04/2013, à 20:35

ljere

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

pour commencer tu fais

sudo gedit /etc/network/interfaces

et tu le remplis avec

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

puis tu redémarres


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#5 Le 09/04/2013, à 21:17

gomgom13

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

Je viens d'installer Network Manager et de le lancer en console, comme indiqué dans la doc.

Je me connecte bien au réseau, j'arrive sur la page de login du réseau, il me dis que je suis bien connecté... mais impossible d'aller sur la Toile, ni de faire les mises à jour...

Alors je viens de voir le message de Ljere et de corriger le fichier /etc/network/interfaces comme suggéré.

Je redémarre... et aucune amélioration. Pourtant les paramètres réseau de network manager sont les mêmes que celui de l'ordi dont je vous écris! (DHCP automatique...)

Que dois-je faire maintenant?

Hors ligne

#6 Le 10/04/2013, à 06:02

gomgom13

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

J'ai aussi ré-éssayé avec Wicd après la manip' indiquée par Ljere mais rien a changé... wicd ne voit toujours pas les reseaux... et là je ne sais plus où chercher...

Une idée les ami-e-s?

Dernière modification par gomgom13 (Le 10/04/2013, à 06:41)

Hors ligne

#7 Le 10/04/2013, à 07:13

rodofr

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

Bon, on vient à ton secours...

Réinstaller Network Manager déjà dans les archives
sudo dpkg -i /var/cache/apt/archives/*.deb
puis comme tu as fait avant et...

connexion mais pas d'internet
terminal :
sudo dhclient

Le dhclient Automatisation de la gestion des adresses IP dynamiques ne fonctionne pas quant on met sa clé wifi par exemple pour certaines machines avec network manager. Faut le faire en manuel. En terminal suffit de faire sudo dhclient et cela marche sans problème normalement et après cela reste. Si cela va pas on fera plus complexe, on l'installera en boot.

Dernière modification par rodofr (Le 10/04/2013, à 07:24)


Live DVD/USB Voyager Une autre façon de voir Ubuntu

Hors ligne

#8 Le 10/04/2013, à 07:39

gomgom13

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

Merci Rodofr, ça fonctionne avec Network Manager!

Je fais les mises à jour et je ré-essaye avec Wicd.

Pour l'installer en boot, je suis preneur.

Merci encore, pour cette idée (que j'aurais du avoir, désolé) et pour cette distrib qui m'a l'air bien sympa!

Hors ligne

#9 Le 10/04/2013, à 08:02

rodofr

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

gksudo leafpad /etc/rc.local
mettre au-dessus d'exit
dhclient
ou
sudo dhclient
ou
dhclient -r; dhclient

A tester les trois si une marche ok...Bon surf voyager
wink


Live DVD/USB Voyager Une autre façon de voir Ubuntu

Hors ligne

#10 Le 10/04/2013, à 08:06

ljere

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

le sudo n'est pas nécessaire dans /etc/rc.local donc dhclient tout seul devrait suffire


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#11 Le 10/04/2013, à 22:11

gomgom13

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

Cher-e-s tou-te-s,

Grâce à vous j'ai pu connecter mon ordi au Wifi.

Je me demandais que pouvait m'apporter les manip' que vous me proposez... est-ce pour améliorer Wicd ou pour quand je me connecterai à d'autres réseau?

En tout cas je viens de la faire même si je pouvais me reconnecter sans problème après un redémarrage.

Que pensez-vous de ce retour:

└─ $ ▶ gksudo leafpad /etc/rc.local
/home/david/.gtkrc-2.0:13: error: unexpected character `=', expected character `]'

Dernière question (j'espère), je laisse tomber Wicd?

Encore merci pour votre aide!

Dernière modification par gomgom13 (Le 11/04/2013, à 06:06)

Hors ligne

#12 Le 11/04/2013, à 07:59

ljere

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

dhclient est une commande qui est pour l'ensemble du réseau donc tu peux soit utilisé wicd ounetwork c'est toi qui choisi
pour cette erreur il s'agit d'une erreur de frappe dans le fichier gtkrc donc rien de dramatique

/home/david/.gtkrc-2.0:13: error: unexpected character `=', expected character `]'

voici la solution /viewtopic.php?pid=11396491
il faut faire pareil avec le compte root

sudo leafpad /root/.gtkrc-2.0

athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#13 Le 12/04/2013, à 11:00

gomgom13

Re : [RESOLU]Wicd/ Voyager ne voit pas les réseaux

Encore merci Ljere et Rodofr,

Que l'Open Source vous bénisse!

Bonne continuation, soyez binairement heureux!

Hors ligne

Haut de page ↑