Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 11/09/2005, à 11:51

IntoX94

Freeze avec nVidia

Depuis que j'ai exécuté ces commandes:

sudo apt-get install nvidia-glx
sudo apt-get install nvidia-settings
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
sudo nvidia-glx-config enable
sudo gedit /usr/share/applications/NVIDIA-Settings.desktop

Et modifié le fichier, puis rebooter mon PC, mon écran freeze au bout de 15/30 secondes.
Tout est bloqué sauf la souris. J'ai une geforce FX5200. :s
Que faire?

Hors ligne

#2 Le 20/09/2005, à 19:16

IntoX94

Re : Freeze avec nVidia

up

Hors ligne

#3 Le 21/09/2005, à 01:41

SirBQF

Re : Freeze avec nVidia

Quel noyau utilise tu ? Moi j'ai le soucis avec le noyau 2.6.11 mais pas avec le 2.6.10-5

Hors ligne

#4 Le 23/09/2005, à 16:14

IntoX94

Re : Freeze avec nVidia

Non, moi le soucis est avec le 2.6.10-5

Hors ligne

#5 Le 23/09/2005, à 16:21

Tao

Re : Freeze avec nVidia

Tu n'as pas activé de fonctions expérimentales de nvidia dans ton /etc/X11/xorg.conf ? J'avais ce genre de freeze avec renderaccel.

Dernière modification par Tao (Le 23/09/2005, à 16:22)

Hors ligne

#6 Le 23/09/2005, à 16:42

IntoX94

Re : Freeze avec nVidia

Apperement non, voici mon fichier xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr-latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV34 [GeForce FX 5200]"
	Driver		"nv"
	BusID		"PCI:1:0:0"
	Option		"NoLogo"
EndSection

Section "Monitor"
	Identifier	"LCD17WYM DTE"
	Option		"DPMS"
	HorizSync	31-80
	VertRefresh	56-75
	EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV34 [GeForce FX 5200]"
	Monitor		"LCD17WYM DTE"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

Hors ligne

#7 Le 23/09/2005, à 16:50

Tao

Re : Freeze avec nVidia

hum, les drivers proprio ne sont pas activé... C'est fait exprès parce que ça plantait trop ou bien tu n'as pas lu le message d'erreur de "sudo nvidia-glx-config enable" ?

Sinon je ne vois pas de problème particulier dans ton fichier, je ne sais pas d'où vient ton problème...

Tu pourrais toujours essayer d'installer les derniers drivers à partir du site nvidia, mais c'est un peu plus compliqué et je ne suis pas sur que ça change quelque chose. Pour plus de détails sur leur installation, fais une recherche sur ce forum.

Hors ligne

#8 Le 23/09/2005, à 16:51

webatou

Re : Freeze avec nVidia

Y'a une ligne à rajouter dans xorg.conf
J'avais le même type de problème avec mon ancienne configuration.

Par contre, je me souviens plus qu'est ce qu'il faut rajouter roll


Linux Ubuntu 8/04

Hors ligne

#9 Le 23/09/2005, à 16:55

webatou

Re : Freeze avec nVidia

Bon, rapide le gars big_smile

En fait, il faut rajouter:
Option "NvAgp" "1"
dans xorg.conf dans la section device

Pour info, voici à quoi corresponde les différentes options possibles:
0 = Desactive le pilote agp
1 = Utilise NvAgp , le pilote nvidia
2 = Utilise le pilote du kernel Agpgart ( celui d'origine )
3 = Utilise le pillote du kernel et en cas d'echec bascule sur le pilote
nvidia

Voilà, voilà tongue


Linux Ubuntu 8/04

Hors ligne

#10 Le 23/09/2005, à 18:11

IntoX94

Re : Freeze avec nVidia

Puis je fais sudo nvidia-glx-config enable? Bon je vais tester

Hors ligne

#11 Le 23/09/2005, à 18:15

IntoX94

Re : Freeze avec nVidia

J'ai ce message lorsque je fait sudo nvidia-glx-config enable

Error: your X configuration has been altered.
This script cannot proceed automatically. If you believe that this
not correct, you can update the md5sum entry executing the following
command:
md5sum /etc/X11/xorg.conf | sudo tee /var/lib/xfree86/xorg.conf.md5sum
otherwise edit manually /etc/X11/xorg.conf to change the Driver section
from nv to nvidia.

Après, je redemarre X et rien ne freeze comment savoir si ça marche?

Dernière modification par IntoX94 (Le 23/09/2005, à 18:22)

Hors ligne

#12 Le 09/11/2005, à 14:19

IntoX94

Re : Freeze avec nVidia

up :'(

Hors ligne

#13 Le 09/11/2005, à 14:32

poulet

Re : Freeze avec nVidia

J'ai le meme type de pb avec une nvidia geforce 4 Ti 4200 ...

Pour recup ton X, il faut que tu executes

md5sum /etc/X11/xorg.conf | sudo tee /var/lib/xfree86/xorg.conf.md5sum

dans un terminal, ce qui te permet d'avoir a nouveau une interface graphique, mais le probleme ne sera pas resolu...

c'est deja ca ...


"Boire sans soif et faire l'amour en tout temps, il n'y a que ça qui nous distingue des autres bêtes"
Beaumarchais -Le mariage de Figaro-
http://www.string-emil.de/  Un peu de ficelle dans un monde brute...

Hors ligne

#14 Le 09/11/2005, à 18:01

IntoX94

Re : Freeze avec nVidia

:s

Hors ligne

#15 Le 23/11/2005, à 13:44

:s

Re : Freeze avec nVidia

up

#16 Le 23/11/2005, à 22:54

Kitty

Re : Freeze avec nVidia

Je te conseille de refaire ta configuration du serveur X.
Pour cela, tape dans un terminal :

sudo dpkg-reconfigure xorg-server

Tu réponds aux questions, en choisissant le driver nvidia.

Tu redémarres, et normalement, ça devrait fonctionner.

Hors ligne

Haut de page ↑