Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 31/10/2011, à 10:56

chlag

[PHP]: activer la bibliothèque graphique gd.

Bonjour,
J'ai installé la version 5.3.6-13ubuntu3.2 de php et je voulais activer la bibliothèque graphique gd en modifiant le fichier php.ini, seulement je ne retrouve pas la ligne gd.iso dans ce dernier( en consultant le le phphinfo je constate que la bibliotheque graphique n'est pas activée)
Ma question est donc: Comment dois-je faire pour activer la bibiotheque graphique?
Merci d'avance pour l'aide.


Ubuntu 12.04 LTS \n \l

Hors ligne

#2 Le 31/10/2011, à 11:03

sputnick

Re : [PHP]: activer la bibliothèque graphique gd.

C'est pas gd.iso mais gd.so.

tape en console :

grep -r gd /etc/php*

Si ca te retourne une ligne du genre :

;extension gd.so

il faut decommenter cette ligne, sinon il faut la rajouter (sans commentaire ; )


bashfr.org(random);
<arciks1994> dou tu connai qel age j'ai ?

Hors ligne

#3 Le 31/10/2011, à 11:28

chlag

Re : [PHP]: activer la bibliothèque graphique gd.

Salut,
Un:

grep -r gd /etc/php*

donne:

/etc/php5/conf.d/gd.ini:extension=gd.so
/etc/php5/apache2/conf.d/gd.ini:extension=gd.so
/etc/php5/apache2/php.ini:[gd]
/etc/php5/apache2/php.ini:; a gd image. The warning will then be displayed as notices
/etc/php5/apache2/php.ini:; http://php.net/gd.jpeg-ignore-warning
/etc/php5/apache2/php.ini:;gd.jpeg_ignore_warning = 0
/etc/php5/cli/conf.d/gd.ini:extension=gd.so
/etc/php5/cli/php.ini:[gd]
/etc/php5/cli/php.ini:; a gd image. The warning will then be displayed as notices
/etc/php5/cli/php.ini:; http://php.net/gd.jpeg-ignore-warning
/etc/php5/cli/php.ini:;gd.jpeg_ignore_warning = 0

Et quand je fais:

vi /etc/php5/conf.d/gd.ini

je trouve bien que la ligne extension=gd.so est bien décomentée cependant le problème persiste.
Comment faire maintenant?


Ubuntu 12.04 LTS \n \l

Hors ligne

#4 Le 31/10/2011, à 11:35

sputnick

Re : [PHP]: activer la bibliothèque graphique gd.

A tu redémarré le serveur HTTP ?


bashfr.org(random);
<arciks1994> dou tu connai qel age j'ai ?

Hors ligne

#5 Le 31/10/2011, à 12:15

chlag

Re : [PHP]: activer la bibliothèque graphique gd.

oui:

#  /etc/init.d/apache2 force-reload

En outre le tableau gd apparait dans le fichier phpinfo().....

En fait le fond du problème est le suivant:

J'ai le script qui suit:

// echiqier.php
<?php
Header ("Content-type: image/png");
$largeur = 400;
$hauteur = 400;
$nombre = 8;
$image = ImageCreate ($largeur, $hauteur);
$jaune = ImageColorAllocate ($image, 255, 255, 0);
$noire = ImageColorAllocate ($image, 0, 0, 0);

$n = $p = 0;

for ($i=0; $i<$largeur; $i+=$largeur/$nombre)
{
for ($j=0; $j<$hauteur; $j+=$hauteur/$nombre)
{
if (($p + $n++) % 2)
ImageFilledRectangle ($image, $i, $j, $i+$largeur/$nombre,
$j+$hauteur/$nombre, $jaune);
else
ImageFilledRectangle ($image, $i, $j, $i+$largeur/$nombre,
$j+$hauteur/$nombre, $noire);
}
$p++;
}
ImagePNG ($image);
ImageDestroy;
?>

qui me permettrais, en principe, de visualiser un echiquier mais en faisant dans la barre d'adresse de firefox un:

http://localhost/echiquier.php

j'obtiens le message:

L'image “http://localhost/echiquier.php” ne peut être affichée car elle contient des erreurs.

et ce qui me chifonne c'est que n'arrive pas à trouver l'erreur.


Ubuntu 12.04 LTS \n \l

Hors ligne

#6 Le 31/10/2011, à 12:59

sputnick

Re : [PHP]: activer la bibliothèque graphique gd.

Donc si le tableau apparaît, c'est qu'il "connait" son pote gd, tu avait du oublier de redémarrer

Que donnes

# php -i | grep -i gd

?

Chez moi ton code marche et j'ai :


# php -i | grep -i gd
/etc/php5/cli/conf.d/gd.ini,
gd
GD Support => enabled
GD Version => 2.0

Ou plutot la version web ? Il y a bien enabled ?


bashfr.org(random);
<arciks1994> dou tu connai qel age j'ai ?

Hors ligne

#7 Le 02/11/2011, à 10:47

chlag

Re : [PHP]: activer la bibliothèque graphique gd.

Bonjour,

# php -i | grep -i gd

donne:

Additional .ini files parsed => /etc/php5/cli/conf.d/gd.ini,
gd
GD Support => enabled
GD Version => 2.0
gd.jpeg_ignore_warning => 0 => 0

Le problème persiste: pas d'affichage de l'echiquier.


Ubuntu 12.04 LTS \n \l

Hors ligne

#8 Le 03/11/2011, à 01:06

sputnick

Re : [PHP]: activer la bibliothèque graphique gd.

Si tu lance en console sur le meme serveur :

php gd.php

Ça affiche quoi ?


bashfr.org(random);
<arciks1994> dou tu connai qel age j'ai ?

Hors ligne

#9 Le 06/11/2011, à 08:32

chlag

Re : [PHP]: activer la bibliothèque graphique gd.

Bonjour,

php gd.php

donne:

Could not open input file: gd.php


Ubuntu 12.04 LTS \n \l

Hors ligne

#10 Le 28/04/2013, à 12:33

lemoineo

Re : [PHP]: activer la bibliothèque graphique gd.

Un peu tard mais comme la réponse n'est pas dans le post
L'installation de gd doit se faire via

sudo apt-get install php5_gd 

C'est plus propre qu'une modif dans le php.ini mais un peu étonnant
Voilà


mon boulot : développeur PHP ?
mes galeries : http://lemoineo.free.fr
Utilisateur Linux dans mes loisirs
le Kitesurf me permet de décrocher du PC !

Hors ligne

#11 Le 26/09/2013, à 15:57

Thy.9

Re : [PHP]: activer la bibliothèque graphique gd.

Juste pour compléter la réponse de LemoineO : Il faut un "-" entre "5" et "gd", pas un "_", ce qui donne :

sudo apt-get install php5-gd

Cela a bien fonctionné sur une installation Ubuntu 12.04 LTS.

Hors ligne

#12 Le 25/08/2014, à 01:28

kis2a

Re : [PHP]: activer la bibliothèque graphique gd.

chlag a écrit :

Bonjour,
J'ai installé la version 5.3.6-13ubuntu3.2 de php et je voulais activer la bibliothèque graphique gd en modifiant le fichier php.ini, seulement je ne retrouve pas la ligne gd.iso dans ce dernier( en consultant le le phphinfo je constate que la bibliotheque graphique n'est pas activée)
Ma question est donc: Comment dois-je faire pour activer la bibiotheque graphique?
Merci d'avance pour l'aide.


meme probleme

Ubuntu Linux 12.04.4
Linux 3.2.0-67-generic on x86_64
php 5.3.10-1ubuntu3.13

php info

il semble que

extension=gd.so

  est dans

/etc/php5/cgi/conf.d/gd.ini

gd.ini

; configuration for php GD module
extension=gd.so

Rien a faire gd ne fonctionne pas

errreur sur scrypt upload image

08-24-2014 06:45 PM 	PHP Warning: getimagesize(): SSL operation failed with code 1. OpenSSL Error messages: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol in upload_img.php on line 726 	
08-24-2014 06:45 PM 	PHP Warning: getimagesize(): Failed to enable crypto in upload_img.php on line 726 	
08-24-2014 06:45 PM 	PHP Warning: getimagesize(https://my_site_web/images/personel_images/legends.png): failed to open stream: operation failed in upload_img.php on line 726 

ou est l'erreur sad

tous marcher impect , il me semble que cela est venu depuis les dernières mises a jour

dernieres update:

apt-get -y  install krb5-locales
apt-get -y  install libc-bin
apt-get -y  install libgssapi-krb5-2
apt-get -y  install libk5crypto3
apt-get -y  install libssl-dev
apt-get -y  install libssl-doc
apt-get -y  install multiarch-support
apt-get -y  install openssl
apt-get -y  install subversion

Dernière modification par kis2a (Le 25/08/2014, à 01:38)

Hors ligne

#13 Le 31/08/2014, à 21:09

kis2a

Re : [PHP]: activer la bibliothèque graphique gd.

personne ?

Hors ligne

#14 Le 02/10/2014, à 12:02

chris52

Re : [PHP]: activer la bibliothèque graphique gd.

Toujours personne ? J'ai le même problème !

Hors ligne

Haut de page ↑