Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 27/04/2013, à 16:34

TcpDump

Iphone 4/5 non reconnu - Ubuntu 10.04 LTS

Bonjour à tous,

Voici mon premier post parmis vous et il est vrai que la plupart du temps
je trouve mon bonheur assez rapidement en visitant le forum de Ubuntu-fr.org

Cependant, voici mon problème de reconnaissance Iphone 4 (jailbreak IOS5) et Iphone 5 (non jailbreak IOS6)
Comme certains site le démontre, le montage automatique est reconnu nativement sur Ubuntu 10.04

URL : Montage automatique de l'Iphone

Ce qui était mon cas, jusqu'à ce que je fasse un clic droit sur l'icone Iphone du bureau et que je clic sur " démonté "...

A partir de là plus de reconnaissance automatique, que ce soit pour le Iphone 4 ou le Iphone 5 !

Linux Desktop 2.6.32-46-generic #108-Ubuntu SMP Thu Apr 11 15:55:01 UTC 2013 i686 GNU/Linux
Apr 27 15:57:01 Desktop kernel: [419934.168030] usb 1-5: new high speed USB device using ehci_hcd and address 26
Apr 27 15:57:01 Desktop kernel: [419934.304382] usb 1-5: configuration #1 chosen from 4 choices
Bus 001 Device 026: ID 05ac:1297 Apple, Inc.

J'ai tenté d'installer IFUSE, mais sans succès.

||/ Nom                           Version                       Description
+++-=============================-=============================-==========================================================================
ii  ifuse                         1.1.1-1ubuntu1~lucid1         FUSE module for iPhone and iPod Touch devices
-16:15:19-[Desktop~] $ ifuse /media/iphone/
Failed to connect to lockdownd service on the device.
Try again. If it still fails try rebooting your device.

Je pensais pouvoir faire marche arrière assez rapidement en remontant l'Iphone, mais ce n'est pas le cas.

Auriez-vous des suggestions afin de m'aiguiller ?

En remerciant par avance ceux qui répondront sur ce sujet, et très bonne journée à tous.

Hors ligne

#2 Le 27/04/2013, à 23:38

nexus66

Re : Iphone 4/5 non reconnu - Ubuntu 10.04 LTS

Salut.
As-tu cherché dans ton utilitaire des disques s'il reconnaisse ta machine en machine non montée ? Si oui, essaie de la monter via l'utilitaire.
Si ça ne marche pas, essaie de rebooter ta machine en appuyant simultanément pendant quelques secondes sur le bouton Home et Power de ta machine jusqu'à ce que ton Iphone redémarre tout seul.

Si ça marche pas encore, je t'invite à mettre à jour usbmuxd/libimobiledevice (1.0.6/1.0.4) en suivant cette documentation ou bien de taper ces commandes :

sudo add-apt-repository ppa:pmcenery/ppa
sudo apt-get update
sudo apt-get install libimobiledevice2 libimobiledevice-utils usbmuxd libusbmuxd1 libgpod4 libgpod-common
sudo apt-get dist-upgrad

Puis redémarres ton PC et branche ton Iphone.

Et au pire des cas tu peux installer des programmes similaires à Itunes ou bien Itunes lui même sur Ubuntu (En suivant ce Tutorial).

Enfin, j'espère que je t'ai aidé avec mon message.
Bonne chance.

Dernière modification par nexus66 (Le 27/04/2013, à 23:39)


Un jour on vivra dans un monde libre sans argent et sans banques.
Tout le monde s'adhérera à l'Open Source et le partage sera la devise de toute personne.

Hors ligne

#3 Le 28/04/2013, à 13:13

TcpDump

Re : Iphone 4/5 non reconnu - Ubuntu 10.04 LTS

Bonjour et merci pour ta réponse

Actuellement les 2 Iphones sont reliés au PC :

Iphone 4 :

Apr 28 12:59:47 El3ktr0 kernel: [495700.752031] usb 1-3: new high speed USB device using ehci_hcd and address 48
Apr 28 12:59:47 El3ktr0 kernel: [495700.889039] usb 1-3: configuration #1 chosen from 4 choices

Iphone 5 :

Apr 28 12:59:41 El3ktr0 kernel: [495694.808528] usb 1-5: new high speed USB device using ehci_hcd and address 47
Apr 28 12:59:41 El3ktr0 kernel: [495694.943297] usb 1-5: configuration #1 chosen from 4 choices

et aucune détection dans l'utilitaire de disque.

Capture.png

J'ai effectué un redémarrage des Iphones en cliquant quelques
secondes sur HOME et POWER mais rien de plus ne se passe ... (même testé le mode DFU)

J'ai donc mis à jours mes paquets comme tu m'avais invité :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libimobiledevice1 est déjà la plus récente version disponible.
libimobiledevice-utils est déjà la plus récente version disponible.
usbmuxd est déjà la plus récente version disponible.
libusbmuxd1 est déjà la plus récente version disponible.
libgpod4 est déjà la plus récente version disponible.
libgpod-common est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

J'ai désintallé le tout, resinstallé, redémarré mon poste Ubuntu, sans succès.

J'ai tenté d'installer Itune via Wine mais l'installation ne se fait pas correctement.

J'ai essayé Amarok mais aucune détection ne se fait non plus.

J'ai tenté d'utiliser Clementine, le soft se lance mais voici le
message d'erreur en boucle à son lancement en ligne de commande :

usbmuxd_send: Error -1 when sending: Relais brisé (pipe)]

J'avoue que ce souci est entrain de me retourner le cerveau,
je ne sais plus où donner de la tête pour remonter mes Iphones.

Hors ligne

#4 Le 28/04/2013, à 14:36

nexus66

Re : Iphone 4/5 non reconnu - Ubuntu 10.04 LTS

Salut.
Je crois que ton problème est lié à ta version d'OS qu'Ubuntu ne la gère pas correctement. J'ai un ami qui a un Iphone 4 et lorsqu'il le branche sur mon PC équipé d'un Ubuntu 12.04, l'Iphone est monté normalement sans aucun souci.
En tout cas. J'ai cherché sur le forum est j'ai trouvé ce message qui a aidé des gens (Mais à utiliser avec précaution) ou bien ce message (En anglais).
La solution est d'ajouter des dépôts non officiels à vos sources:

sudo add-apt-repository ppa:pmcenery/ppa
sudo apt-get update
sudo apt-get dist-upgrade

Sinon tu peux utiliser cette solution vue sur ce forum (En anglais) :

sudo apt-get install libimobiledevice-utils;idevicepair unpair && idevicepair pair

et si ça donne rien essaies cette commande :

sudo apt-get install libimobiledevice-utils;idevicepair unpair && idevicepair pair && idevicepair validate

J'espère que je t'aide là à résoudre ton problème.

Dernière modification par nexus66 (Le 28/04/2013, à 14:38)


Un jour on vivra dans un monde libre sans argent et sans banques.
Tout le monde s'adhérera à l'Open Source et le partage sera la devise de toute personne.

Hors ligne

Haut de page ↑