Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/11/2007, à 20:38

scholi

Shockwave sous firefox

Voila, je viens d'écrire dans la documentation la marche à  suivre pour voir des sites nécessitant shockwave

http://doc.ubuntu-fr.org/tutoriel/shockwave

Je crée ce topic pour poser des questions suite à  cette documentation.


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#2 Le 21/11/2007, à 00:04

mtgrpg

Re : Shockwave sous firefox

J'avais lu je sais plus o๠qu'il existe un plugin pour Firefox (sur Linux) qui permet d'utiliser n'importe quel programme comme un plugin dans Firefox. Et avec ça on peut (enfin, moi j'ai pas réussi, mais il paraà®t que ça marche) lire les applettes Shockwave dans Firefox (Linux) en utilisant comme plugin Firefox (Windows)…

Hum, c'est pas très précis, mais ça fait un moment que j'ai vu ça, et j'ai pas retenté depuis (la flemme).

En espérant tout de même que ça aide… big_smile

EDIT>> Après une petite googlification, il me semble que ce programme miracle s'appelle mozplugger.

Dernière modification par mtgrpg (Le 21/11/2007, à 00:11)


^[:wq
Help!

Hors ligne

#3 Le 21/11/2007, à 11:29

cuistot

Re : Shockwave sous firefox

bonjour et merci pour votre aide

je viens de poster une question sans vraiment lire jusqu'au bout votre tutohttp://forum.ubuntu-fr.org/viewtopic.ph … 8#p1338998

j'ai donc suivi la manip avec un petit doute quand j'ai copié la phrase dans le terminal dans mozpluggerrc, mais cela semblait fonctionner, j'ai réussi à  faire un essai avec la version windows de firefox.
mais quand j'essaie avec la version linux (ubuntu dapper drake), il me demande de telecharger un fichier de type ; applicaion/octet-stream à  partir de : ...tot/.mozilla/firefox/ricxa9sh.default/cache.

j'ai du faire une erreur

merci de m'aider

pascal


texte à  méditer: Quand on ne travaillera plus les lendemains des jours de repos, la fatigue sera vaincue.  Alphonse Allais

Hors ligne

#4 Le 21/11/2007, à 12:08

cuistot

Re : Shockwave sous firefox

j'avais unproblème, suite à  mes manip et j'ai du supprimer ces lignes du tuto http://doc.ubuntu-fr.org/installer_shockwave

 application/x-director: dir,dcr,dxr,cst,cct,cxt,w3d,fgd,swa: Macromedia Director file 
      swallow(firefox.exe) fill: wine "C:\\Program Files\\Mozilla Firefox\\firefox.exe" -chrome "file://Z:$file"

du fichier mozpluggerrc elles provoquaient des bugs dans la version linux de firefox.
tout est rentré dans l'ordre, je peux lire le fichier shockwave avec la version de windows mais pas avec la version linux.
j'essaie encore

merci
pascal


texte à  méditer: Quand on ne travaillera plus les lendemains des jours de repos, la fatigue sera vaincue.  Alphonse Allais

Hors ligne

#5 Le 21/11/2007, à 17:26

scholi

Re : Shockwave sous firefox

bon ben c'est pas si grave que ça d'utiliser la version windows... Perso en 4 ans j'ai du voir 2 sites shockwaves....


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#6 Le 21/11/2007, à 18:04

cuistot

Re : Shockwave sous firefox

c'est vrai, je vais garder la version qui tourne avec wine.
mais juste une question avant le clore ce post....
je trouve que ca rame avec firefox windows est ce une realité ou simplement le fait que c'est de l'image 3d?

merci pour votre aide

pascal


texte à  méditer: Quand on ne travaillera plus les lendemains des jours de repos, la fatigue sera vaincue.  Alphonse Allais

Hors ligne

#7 Le 21/11/2007, à 21:25

scholi

Re : Shockwave sous firefox

Je pense que le problème vient de la 3D, car même les jeux son plus rapide sous wine que sous windows (ai-je entendu).


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#8 Le 21/11/2007, à 21:37

Michel38

Re : Shockwave sous firefox

scholi a écrit :

Je crée ce topic pour poser des questions suite à  cette documentation.

J'espère que les modos vont virer ce tutoriel, ou bien on passe sous Linux ou bien on reste sous Windxxxx. Wine est la plus grosse connerie qui ait été inventée !
Désolé pour ce coup de gueule hmm


Every day is a school day ... Your Ubuntu User number is # 572
Portable ASUS Dual Core T2130 de chez Iventive - 1.86 GHz - RAM:2 Go - DD 160 Go - Hardy Heron 8.04.4 LTS - Noyau 2.6.24.24 Generic - LiveBox Sagem 4 Mo
Mon Blog http://mdoucet.wordpress.com/

Hors ligne

#9 Le 22/11/2007, à 18:27

scholi

Re : Shockwave sous firefox

c'est bien au moins c'est vachement bien argumenté ce que tu dis.

En plus je suis sur que tu profites juste du travail des autres et que tu développes rien pour linux et évidement quand le programme que Monsieur veut n'existe pas, Monsieur râle...

Je pense que les modos vont plutôt virer ton post...


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#10 Le 22/11/2007, à 18:46

xabilon

Re : Shockwave sous firefox

Bonjour

Est-il utile de rappeler que l'un des piliers des logiciels libres est justement ... la liberté de choix.

Donc la liberté d'utiliser Wine ou pas. Je ne suis pas trop partisan de Wine non plus, mais si ça existe c'est que c'est utile, il n'y a aucune raison de censurer son existence.

Sinon, supprimons également tout ce qui a trait au P2P, au dual-boot, aux codecs propriétaires, supprimons le support du .doc dans OpenOffice, etc ...

Je rappelle aussi que le wiki est en modification libre. Tu peux supprimer le tutoriel si tu veux.
Prends tes responsabilités, dans ce cas-là  ...


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#11 Le 22/11/2007, à 18:53

michel2652

Re : Shockwave sous firefox

Bonjour,

xabilon a écrit :

supprimons également tout ce qui a trait au P2P, au dual-boot, aux codecs propriétaires, supprimons le support du .doc dans OpenOffice, etc ...

Ouais, supprimons les modos.
Heu, non ----->[]

A+

#12 Le 22/11/2007, à 20:45

Michel38

Re : Shockwave sous firefox

scholi a écrit :

c'est bien au moins c'est vachement bien argumenté ce que tu dis.

En plus je suis sur que tu profites juste du travail des autres et que tu développes rien pour linux et évidement quand le programme que Monsieur veut n'existe pas, Monsieur rà¢le...

Je pense que les modos vont plutà´t virer ton post...

Surtout que ce plugin est installé par défaut !!!
capturete3.th.png


Every day is a school day ... Your Ubuntu User number is # 572
Portable ASUS Dual Core T2130 de chez Iventive - 1.86 GHz - RAM:2 Go - DD 160 Go - Hardy Heron 8.04.4 LTS - Noyau 2.6.24.24 Generic - LiveBox Sagem 4 Mo
Mon Blog http://mdoucet.wordpress.com/

Hors ligne

#13 Le 22/11/2007, à 21:05

frenchy82

Re : Shockwave sous firefox

Bonjour,

Pas sur sur que cela veuille dire que cela soit fonctionnel sad

Des jeux sont souvent (parfois) en shockwave sur le net comme sur le site gaming zone.
Ok c'est pas indispensable, ok je peux expliquer le pourquoi du comment a mes enfants de ce non fonctionnement sous linux (sachant que tous leurs copains sont sous windows)

Mais si wine peut m'aider a resoudre cette énorme injustice (humour) ... je suis plutot pour.

En ce qui me concerne, les petits jeux en flash ont l'avantage d'être varies, vite testés mais surtout sans installation et suffisant pour le moment chez moi big_smile

à‰videmment j'ai signé la pétition pour shockwave sous linux et souhaite sinceremment que cela évolue

cordialement

ps : Merci scholi pour ce tuto (meme  si chez moi cela rame severe)

Dernière modification par frenchy82 (Le 22/11/2007, à 21:06)

Hors ligne

#14 Le 22/11/2007, à 22:20

mtgrpg

Re : Shockwave sous firefox

Michel38 a écrit :

Surtout que ce plugin est installé par défaut !!!
http://img160.imageshack.us/img160/9104 … te3.th.png

Oui mais non en fait.

Ce plugin (libflashplayer.so ou npwrapper.libflashplayer.so) est bien le lecteur Flash, et pas Shockwave. Pourquoi il s’appelle comme ça, je sais pas, mais si j’essaie d’aller sur http://www.isketch.net/isketch.shtml (par exemple), bah ça marche pas… sad

En outre, il n’est PAS installé par défaut. Il faut l’installer soi-même, comme tous les trucs pas libres.

Et Adobe dit lui-même que Shockwave n’existe pas pour Linux. Et je pense qu’on peut leur faire confiance là  dessus, ils seraient trop contents de pouvoir se vanter que leur truc fonctionne sur Linux !

Dernière modification par mtgrpg (Le 22/11/2007, à 22:23)


^[:wq
Help!

Hors ligne

#15 Le 23/11/2007, à 00:35

Michel38

Re : Shockwave sous firefox

mtgrpg a écrit :
Michel38 a écrit :

Surtout que ce plugin est installé par défaut !!!
http://img160.imageshack.us/img160/9104 … te3.th.png

Oui mais non en fait.

Ce plugin (libflashplayer.so ou npwrapper.libflashplayer.so) est bien le lecteur Flash, et pas Shockwave. Pourquoi il s’appelle comme ça, je sais pas, mais si j’essaie d’aller sur http://www.isketch.net/isketch.shtml (par exemple), bah ça marche pas… sad

En outre, il n’est PAS installé par défaut. Il faut l’installer soi-même, comme tous les trucs pas libres.

Et Adobe dit lui-même que Shockwave n’existe pas pour Linux. Et je pense qu’on peut leur faire confiance là  dessus, ils seraient trop contents de pouvoir se vanter que leur truc fonctionne sur Linux !

Bonsoir,
Désolé mais j'ai été trompé par le nom, il s'est installé avec les ubuntu-restricted-extra que j'ai installé ... donc pas par défaut hmm


Every day is a school day ... Your Ubuntu User number is # 572
Portable ASUS Dual Core T2130 de chez Iventive - 1.86 GHz - RAM:2 Go - DD 160 Go - Hardy Heron 8.04.4 LTS - Noyau 2.6.24.24 Generic - LiveBox Sagem 4 Mo
Mon Blog http://mdoucet.wordpress.com/

Hors ligne

#16 Le 23/11/2007, à 00:46

did

Re : Shockwave sous firefox

Salut,

Je me souviens avoir testé CrossOver (application payante basée sur Wine) il y a quelque temps et celle-ci permet d'installer simplement le plugin shockwave sur la version Linux de Firefox.

Dernière modification par did (Le 23/11/2007, à 00:51)

Hors ligne

#17 Le 04/05/2009, à 23:33

louison95

Re : Shockwave sous firefox

bonjour j'ai essayer sur mon eeepc de suivre les démarche mais j'arrive pas à lancer l'instalateur firefox xp il me met un message d'erreur et me dit l'arrêt à cette ligne dans le gestionnaire : [/home/louison/Bureau/Firefox Setup 3.0.10.exe]
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
zipinfo:  cannot find zipfile directory in one of /home/louison/Bureau/Firefox Setup 3.0.10.exe or
          /home/louison/Bureau/Firefox Setup 3.0.10.exe.zip, and cannot find /home/louison/Bureau/Firefox Setup 3.0.10.exe.ZIP, period


j'ai essayer l'autre où l'on tape wine firefox machin . exe ça me met ceci :
louison@louison-laptop:~$ wine Firefox Setup 3.0.10.exe
wine: created the configuration directory '/home/louison/.wine'
fixme:system:SetProcessDPIAware stub!
fixme:iphlpapi:NotifyAddrChange (Handle 0x7cea69f8, overlapped 0x7cea69dc): stub
fixme:shell:DllCanUnloadNow stub
wine: configuration in '/home/louison/.wine' has been updated.
wine: could not load L"C:\\windows\\system32\\Firefox.exe": Module introuvable
louison@louison-laptop:~$


je tient à présicer que j'ai easypeasy
merci de m'aider

#18 Le 16/12/2011, à 19:43

Gaspra

Re : Shockwave sous firefox

Salut,

Je viens de suivre ton tuto pour accéder à un site fonctionnant avec shockwave player. Pas d'chance, lors de l'installation, il me dit "Format incorrect". Il ne parvient jamais à finaliser l'installation donc je ne peux pas m'en servir. Une idée ? J'ai installé la version française sur ubuntu 11.04.

merci

Hors ligne

#19 Le 19/12/2011, à 20:35

Gaspra

Re : Shockwave sous firefox

0 idée ?

Hors ligne

Haut de page ↑