Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 13/04/2013, à 18:54

jorges

failed to connect to serveur vnc (openstack)

Bonjour à tous je travaille sur une solution de cloud computing en l'occurence openstack.Dans mon interface d'administration je peux créer une instance et y accéder via ssh,cependant je ne parvient pas à accéder à l'instance à partir de la console vnc car je reçoit l'erreur failed to connect to serveur!!!durant l'installation d'openstack j'ai installer les paquets suivants pour vnc:apt-get install novnc nova-consoleauth
mon fichier nova.conf se présente comme suit:
--dhcpbridge_flagfile=/etc/nova/nova.conf
--dhcpbridge=/usr/bin/nova-dhcpbridge
--logdir=/var/log/nova
--state_path=/var/lib/nova
--lock_path=/run/lock/nova
--allow_admin_api=true
--use_deprecated_auth=false
--auth_strategy=keystone
--scheduler_driver=nova.scheduler.simple.SimpleScheduler
--s3_host=192.168.1.11
--ec2_host=192.168.1.11
--rabbit_host=192.168.1.11
--cc_host=192.168.1.11
--nova_url=http://192.168.1.11:8774/v1.1/
--routing_source_ip=192.168.1.11
--glance_api_servers=192.168.1.11:9292
--image_service=nova.image.glance.GlanceImageService
--iscsi_ip_prefix=192.168.5
--sql_connection=mysql://novadbadmin:novasecret@10.10.10.2/nova
--ec2_url=http://192.168.1.11:8773/services/Cloud
--keystone_ec2_url=http://192.168.1.11:5000/v2.0/ec2tokens
--api_paste_config=/etc/nova/api-paste.ini
--libvirt_type=kvm
--libvirt_use_virtio_for_bridges=true
--start_guests_on_host_boot=true
--resume_guests_state_on_host_boot=true
# vnc specific configuration
--novnc_enabled=true
--novncproxy_base_url=http://192.168.1.11:6080/vnc_auto.html
--vncserver_proxyclient_address=127.0.0.1
--vncserver_listen=127.0.0.1
# network specific settings
--network_manager=nova.network.manager.FlatDHCPManager
--public_interface=eth0
--flat_interface=eth1
--flat_network_bridge=br100
--fixed_range=192.168.5.0/24
--floating_range=192.168.1.024
--network_size=32
--flat_network_dhcp_start=192.168.5.2
--flat_injected=False
--force_dhcp_release
--iscsi_helper=tgtadm
--connection_type=libvirt
--root_helper=sudo nova-rootwrap
--verbose

s'il vous plait si quelqu'un aurait la solution à mon problème,prière de bien vouloir me laisser un commentaire.Merci d'avance

Hors ligne

#2 Le 08/05/2013, à 13:18

diablotin84

Re : failed to connect to serveur vnc (openstack)

Bonjour,

Je me permet de me joindre à la conversation car je rencontre exactement le même problème que toi jorges, as-tu fini par trouver une solution à ton problème ?
Merci

Hors ligne

#3 Le 08/05/2013, à 20:39

jorges

Re : failed to connect to serveur vnc (openstack)

Malheureusement j'ai pas trouvé de solution à cela certain demande de désactiver le proxy du navigateur pour que ça marche je l'ai fais sans succès faudrait le faire de ton coté peut être ça marchera chez toi!!!!!

Hors ligne

Haut de page ↑