Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 07/05/2013, à 11:55

Bybeu

[résolu - contournement] minidlna autostart boot veut pas

Bonjour
Mon minidlna ne démarre plus en auto. Il ne démarre qu'avec la commande minidlna ou avec sudo service minidlna start.
Je l'ai réinstallé, et il a démarré tout seul en suivant. Mais au reboot, il ne démarre toujours pas.
J'ai essayé un truc trouvé sur un forum anglais : sudo update-rc.d minidlna default mais j'ai un message

System start/stop links for /etc/init.d/minidlna already exist

J'ai regardé les dossiers dans /etc/ mais je sais pas s'il manque quelque chose:

sudo ls -laFR | grep minid
-rw-r--r--   1 minidlna minidlna  2601 mai    7 11:06 minidlna.conf
-rw-r--r--   1 minidlna minidlna  2602 mai    7 08:47 minidlna.conf~
-rw-r--r--   1 root root   589 juil. 21  2011 minidlna
-rwxr-xr-x   1 root root  4195 juil. 21  2011 minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 K20minidlna -> ../init.d/minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 K20minidlna -> ../init.d/minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 S20minidlna -> ../init.d/minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 S20minidlna -> ../init.d/minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 S20minidlna -> ../init.d/minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 S20minidlna -> ../init.d/minidlna*
lrwxrwxrwx   1 root root    18 mars   7 17:25 K20minidlna -> ../init.d/minidlna*

et le script /etc/init.d/minidlna, mais là ça me dépasse.
Comment réactiver l'autostart en demon/service s'il vous plaît?
Ça a commencé quand j'ai essayé de changer le niveau de log pour résoudre des problèmes.
Help

Merci

PS:

runlevel
N 2

Dernière modification par Bybeu (Le 12/05/2013, à 01:14)

Hors ligne

#2 Le 07/05/2013, à 12:21

grandtoubab

Re : [résolu - contournement] minidlna autostart boot veut pas

salut,
Pour que minidlna démarre automatiquement il faut mettre le daemon à yes dans /etc/default/minidlna
http://forum.ubuntu-fr.org/viewtopic.ph … #p11967371


Linux tout seul sur le disque dur  Acer Aspire T650 :=))
RAM: 1,7 Gio, CPU: Intel® Pentium(R) 4 CPU 3.06GHz × 2. Carte graphique Gallium 0.4 on ATI RC410 (Radeon Xpress200)
Partition 1: Debian Jessie & Gnome Version 3.12, Kernel  3.16.3-031603-generic
Partition 2: Ubuntu Trusty 14.04 & Unity

Hors ligne

#3 Le 07/05/2013, à 12:41

Bybeu

Re : [résolu - contournement] minidlna autostart boot veut pas

Je comprends pas. J'ai fait un arrêt du PC au lieu d'un reboot et là le démon c'est lancé!!!
Ensuite un reboot et il est toujours là ???
Après j'ai lu ton message et j'ai vérifié le fichier /etc/default/minidlna qui m'avait échappé (celui de 589 octets dans ma liste). Il est bien a START_DAEMON="yes"
Ensuite, crois-moi ou pas... tiens:

ls -lc /etc/default/mini*
-rw-r--r-- 1 root root 589 mars   7 17:25 /etc/default/minidlna

la date d'installation initiale !!!

Linux me rend fada
<!-- J'ai mis [résolu?] parce que j'aurais aimé comprendre -->


Merci grandtoubab

EDIT: Après plusieurs reboot il ne redémarre plus en auto sad

Dernière modification par Bybeu (Le 07/05/2013, à 13:54)

Hors ligne

#4 Le 11/05/2013, à 12:27

fxeon

Re : [résolu - contournement] minidlna autostart boot veut pas

Salut, j'ai l'impression que minidlna démarre avant que le réseau soit établi, parfois le réseau démarre plus vite donc ça marche d'autres fois non

Hors ligne

#5 Le 11/05/2013, à 17:38

Bybeu

Re : [résolu - contournement] minidlna autostart boot veut pas

Une dépendance à l'état du réseau non satisfaite et non gérée donc?
Et si on rajoute un sleep 300 au début du script (mais lequel?) c'est la bonne façon de faire?
Merci pour la piste en tout cas.

Hors ligne

#6 Le 11/05/2013, à 18:40

grandtoubab

Re : [résolu - contournement] minidlna autostart boot veut pas

salut,
Aucun problème de démarrage du daemon minidlna chez moi.
Faut peut etre mieux regarder les log avant de partir dans des suppositions hasardeuses smile


Linux tout seul sur le disque dur  Acer Aspire T650 :=))
RAM: 1,7 Gio, CPU: Intel® Pentium(R) 4 CPU 3.06GHz × 2. Carte graphique Gallium 0.4 on ATI RC410 (Radeon Xpress200)
Partition 1: Debian Jessie & Gnome Version 3.12, Kernel  3.16.3-031603-generic
Partition 2: Ubuntu Trusty 14.04 & Unity

Hors ligne

#7 Le 11/05/2013, à 18:57

Bybeu

Re : [résolu - contournement] minidlna autostart boot veut pas

Bonjour grandtoubab

Oui, j'avais bien vu le /var/log/minidlna.log, muet quand le service ne démarre pas et très peu bavard quand je le lance à la main.

J'avais essayé de le rendre plus verbeux en rajoutant log_level=debug dans /etc/minidlna.conf (pour trouver pourquoi le serveur ne m'affichait pas les fichiers video sur la tv), et c'est depuis qu'il ne démarre plus (ou quand il veut) en auto même après avoir commenté et même retiré l'entrée de conf de log.

Hors ligne

#8 Le 11/05/2013, à 19:58

fxeon

Re : [résolu - contournement] minidlna autostart boot veut pas

Hors ligne

#9 Le 12/05/2013, à 01:12

Bybeu

Re : [résolu - contournement] minidlna autostart boot veut pas

Super fixeon
Ça marche aussi pour moi (12.04 itou). J'ai posté ton lien sur le bug enregistré dans le lauchpad.

Et une galère de moins, une!
Merci mille fois.

Dernière modification par Bybeu (Le 12/05/2013, à 01:18)

Hors ligne

#10 Le 12/05/2013, à 09:26

grandtoubab

Re : [résolu - contournement] minidlna autostart boot veut pas

Salut,
Comme j'aime bien bricoler aussi j'installe la derniere version à la main :
je la récupère ici
http://sourceforge.net/projects/minidlna/
D'abord je sauve l'ancien

@ubuntu-desktop:/usr/bin$ sudo cp minidlna minidlna.old

je decompresse puis substitue le binaire:

@ubuntu-desktop:~/Linux/minidlna/minidlna_1.1.0_static/usr/sbin$ sudo service minidlna stop
@ubuntu-desktop:~/Linux/minidlna/minidlna_1.1.0_static/usr/sbin$ sudo cp minidlnad /usr/bin/minidlna

ça donne

@ubuntu-desktop:/usr/bin$ minidlna -V
Version 1.1.0

et je redémarre en recréant la base de données

@ubuntu-desktop:/usr/bin$ sudo service minidlna force-reload
 * Restarting DLNA/UPnP-AV media server minidlna                                                            [ OK ] 
@ubuntu-desktop:/usr/bin$ 

13 minutes pour constituer la base de données

/var/cache/minidlna$ ls -alrt
total 38716
drwxr-xr-x 20 root root     4096 mars   8 14:33 ..
drwxr-xr-x  3 root root     4096 mai   12 09:28 art_cache
drwxr-xr-t  3 root root     4096 mai   12 09:28 .
-rw-r--r--  1 root root 39632896 mai   12 09:41 files.db
@ubuntu-desktop:/var/cache/minidlna$ ps -edf | grep minidlna
root     15148     1  0 09:28 ?        00:00:00 /usr/bin/minidlna -f /etc/minidlna.conf -P /var/run/minidlna/minidlna.pid -R

Et après le reboot pas de problème

@ubuntu-desktop:/var/log$ cat minidlna.log
[2013/05/12 09:54:27] minidlna.c:154: warn: received signal 15, good-bye
[2013/05/12 09:55:18] minidlna.c:1063: warn: Starting MiniDLNA version 1.1.0.
[2013/05/12 09:55:19] minidlna.c:1107: warn: HTTP listening on port 8200

Dernière modification par grandtoubab (Le 12/05/2013, à 10:14)


Linux tout seul sur le disque dur  Acer Aspire T650 :=))
RAM: 1,7 Gio, CPU: Intel® Pentium(R) 4 CPU 3.06GHz × 2. Carte graphique Gallium 0.4 on ATI RC410 (Radeon Xpress200)
Partition 1: Debian Jessie & Gnome Version 3.12, Kernel  3.16.3-031603-generic
Partition 2: Ubuntu Trusty 14.04 & Unity

Hors ligne

#11 Le 12/05/2013, à 12:44

Bybeu

Re : [résolu - contournement] minidlna autostart boot veut pas

Cool
Dans le /etc/minidlna.conf de la nouvelle version il doit y avoir l'option pour log_level fonctionnelle (entre autres nouveautés sûrement) et les commentaires qui vont bien avec.
Je suis pas assez fort en linux et pas assez confiant dans mes capacités pour avoir tenté le remplacement: je me suis promis de rester sage en restant scotché à la 12.04 avec ce premier ubuntu qui marche maintenant assez correctement. En plus c'est un vieux pc, alors méfiance.
Je vais pouvoir maintenant m'attaquer au(x) problème(s) de fonctionnement de minidlna.

Merci pour votre aide et à bientôt les amis pour de nouvelles aventures.

Hors ligne

#12 Le 02/07/2013, à 08:41

Mitch69

Re : [résolu - contournement] minidlna autostart boot veut pas

Bonjour,

Ou trouvez-vous les paquets pour minidlna 1.1.0 ?

Merci.

Hors ligne

Haut de page ↑