Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 10/07/2013, à 12:21

Axel93bis

Problème sur webinject (plugin Nagios)

Bonjour,

J'essaye de créer un scénario de test de connexion sur une url via webinject. J'ai codé le case de la manière suivante :

<case
    id="6"
    description="Espace adherent"
    method="post"
    url="https://mon-espace-adherent.XXXXXXXXXXXXXXXXXXXXXXXXXX/Identification"
    postbody="user=user&password=password"
    verifypositive="EA TEST"
    errormessage="Site Espace adherent non joiniable"
/>

J'ai mis les user et password attendu mais j'ai toujours un message d'erreur.

Test: testcases.xml - 6

Verify : "EA TEST"
Failed Positive Verification
Failed - No Response
TEST CASE FAILED : Site Espace adherent non joiniable
Response Time = 21.072 sec

Je ne comprend pas pourquoi il ne tente pas de se connecter automatiquement
J'ai créé d'autres case sans authentification et ils fonctionnent bien. Je pense donc que j'ai un souci avec le fonctionnement de postbody

Si quelqu'un vois mon erreur, merci

Hors ligne

#2 Le 10/07/2013, à 14:24

inbox

Re : Problème sur webinject (plugin Nagios)

Salut,

Je ne connais pas le sujet, mais une recherche sur "webinject postbody" me renvoie ici.

Le truc sur postbody a écrit :

postbody – the trick here is to use httpfox download here . Also LiveFox will do the trick.
Now perform the login via web and look to your post code, just paste that here.

En résumé, utilise l'extension "httpfox" ou "livefox". Ensuite, connecte toi sur ton site web et cherche dans le code généré. Enfin, copie ce code dans ton fichier de configuration.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 10/07/2013, à 16:10

Axel93bis

Re : Problème sur webinject (plugin Nagios)

JE viens de faire le test. Dans le POST j'ai la ligne suivante :

__RequestVerificationToken=0SSKSReQGs31sXF7yxkxBBEOxsPkCZKo%2B0DgZ0EIrGaSEL%2FqnXmfSIX1Guc4Gib5cADZFk3c20frDw3zesrevx8IoH3CP1MgDnI2gMuBr9RKd9aforNjFT5PwZ2TmQq%2B2FM5WQMt62KJ7LMIvgj0X2dp6mvSHIe3PuuAERGtpwcBDXJs&NumeroContrat="user"&MotDePasse="password"

(J'ai supprim&é le user et le password, mais ils sont bien dans le post)
Par contre j'ai le message suivant (surement au moment du verifynegative)

Verify Negative: "maintenance"
Passed Negative Verification
Failed - No Response

Je comprend pas pourquoi je tombe en timeout lors du verify alors que sur tous les autres j'ai aucun soucis

Hors ligne