Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/07/2013, à 08:48

nereu

permission non accordé en disque externe FAT

Bonjour
J'ai un disque externe dans lequel Je ne peux pas écrire.
J'ai déjà utilisé les commandes chown et chmod, en root, J'ai déjà ouvert dolphin ( Je suis soius kubuntu) en root, et rien ne se passe.
Quand je tape chown ... etc. on me répond " permission non accordé " par rapports aux fichiers et Je continue de ne pas pouvoir écrit lá dessus.
Pour être précis, voilà les commandes:

chown -R <user> /media/usb1    (c'est son point de montage)
et encore, avec chmod:


chmod -R a+rw /media/usb1

Hier, il 'est arrivé la même chose avec une clé, et J'ai résolu le problème en la formatant, mais, avec le disque, je ne peux pas faire cela!

Je ne comprends pas pourquoi, si le disque appartient á root et si j'entre en tant que root, il n'y a pas de changements.

Le disque est en Fat parce qu'il y a des fichiers à regarder sur un dvd de salon.

Merci.

Hors ligne

#2 Le 20/07/2013, à 09:58

slasher-fun

Re : permission non accordé en disque externe FAT

Bonjour,

Le système de fichier FAT ne supporte pas les permissions de type Unix, donc tu ne peux pas y utiliser chown/chmod.

Hors ligne

#3 Le 20/07/2013, à 11:06

Postmortem

Re : permission non accordé en disque externe FAT

Salut,
Pour un disque externe ou une clé en FAT, c'est au moment du montage qu'il faut renseigner les options afin de pouvoir y accéder en tant que simple user.
Y'a moyen de faire ça dans le fichier /etc/fstab mais il doit y avoir possibilité de renseigner ca ailleurs, dans la conf du logiciel qui s'occupe de monter automatiquement les supports USB que l'on branche.
Je ne sais pas où ça se passe sur kubuntu.


Trusty Tahr (64 bits), Athlon64 3800+, ATI Radeon HD4870

Mot' a dit : « Un Hellfest sans Slayer, c'est comme une galette-saucisse sans saucisse ! »

Hors ligne

#4 Le 20/07/2013, à 21:21

nereu

Re : permission non accordé en disque externe FAT

Merci Postmortem, mais, en réalité, Je suis aussi sur Ubuntu, donc, si tu sais comment cela se fait chez gnome, Je te remercie.

Hors ligne

#5 Le 21/07/2013, à 12:44

Postmortem

Re : permission non accordé en disque externe FAT

Salut,
Peux tu renvoyer le résultat de ces commandes lorsque ton disque est branché :

mount
ls -la /media
getfacl /media/*
ls -la /media/*

Trusty Tahr (64 bits), Athlon64 3800+, ATI Radeon HD4870

Mot' a dit : « Un Hellfest sans Slayer, c'est comme une galette-saucisse sans saucisse ! »

Hors ligne

#6 Le 29/07/2013, à 09:35

Postmortem

Re : permission non accordé en disque externe FAT

Bonjour,
Je ne sais pas si nereu va repasser et/ou si le pb est résolu... J'ai néanmoins des questions de mon coté.
Je pensais que les droits accordés lors du montage d'une clé usb était défini via udev... Mais apparemment non car si je cherche dans les fichiers de règles (sous /lib/udev/rules.d), je ne vois que ça qui me fait penser à des droits :

$ grep -i usb *
[...]
50-udev-default.rules:SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0664"
[...]

Et lorsque je branche une clé en FAT, voici les droits que j'ai :

$ ls -l /media/XXXXX/
total 8
drwx------ 14 XXXXX XXXXX 8192 janv.  1  1970 D021-BC66
$ mount
[...]
/dev/sdf1 on /media/XXXXX/D021-BC66 type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2)

Sinon, c'est bien udev qui accorde un "nom fixe" à la clé dans /dev ou dans ses sous-répertoires ? Mais où est cette règle ??
Et quel logiciel s'occupe de monter la clé ?
En gros, je m'y perds !!


Trusty Tahr (64 bits), Athlon64 3800+, ATI Radeon HD4870

Mot' a dit : « Un Hellfest sans Slayer, c'est comme une galette-saucisse sans saucisse ! »

Hors ligne

Haut de page ↑