Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/01/2008, à 23:50

omeega

Proftpd, Vsftpd .... tout ça ne fonctionne pas . Why?

Bonsoir,

Je suis un grand débutant de ubuntu et meme du monde linux.
J'apprend assez vite vu que je bosse en informatique (ancien dev et nouveau réseau).


ça fait 1 mois que je planche dessus, j'ai essayé avec vsftpd, j'ai cru un pb de config qui m'a échape alors j'ai essayé Gproftpd ... mais je bloque tjr.

Je fonctionne avec firestarter et une freebox v5 mode routeur activé et NAT.


Voilà  mon probleme :

De chez moi ça fonctionne, mais de chez quelqu'un d'autre, avec filezilla ça ne fonctionne pas, l'identification est OK mais ça reste bloqué sur la commande LIST.

Or le probleme suplémentaire est que lorsque je le fais avec le Internet explorer du pc en externe avec protocole ftp://******.fr la connection se fait et on voit les fichiers se lister et j'y ai accés.


Le client doit il ouvrir ses ports lui aussi ? (cela m'étonnerai car avant d'ouvrir les ports du routeur, je pouvais me connecter a des ftp de free.fr)

Le client doit il avoir une config spéciale dans firefox ?

Ais- Je fait une érreur de config ?

Comment je l'ai installé


***********Routeur freebox***********

Capture-Routeur.png


**********Firestarter***************

CaptureFirestarter.png




Sur Gproftpd :

***************Partie serveur******************
gproftpdcapture.png

capture2.png

capture3.png

capture4.png
************Partie utilisateur*******************
(l'utilisateur existe bien sur le systeme et le groupe ftp existe bien aussi, il y a bien les accés en liste écriture lecture etc etc ...)
capture5.png
************Code de la config******************

ServerType standalone
DefaultServer on
Umask 022
ServerName "192.168.0.1"
ServerIdent on "My FTPD"
ServerAdmin xxx@xxx.fr
IdentLookups off
UseReverseDNS off
Port 21
PassivePorts 40000 41000
MasqueradeAddress 82.207.xxx.xxx
TimesGMT off
MaxInstances 30
MaxLoginAttempts 3
TimeoutLogin 300
TimeoutNoTransfer 120
TimeoutIdle 120
DisplayLogin welcome.msg
User nobody
Group nobody
DirFakeUser off nobody
DirFakeGroup off nobody
DefaultTransferMode binary
AllowForeignAddress off
AllowRetrieveRestart on
AllowStoreRestart on
DeleteAbortedStores off
TransferRate RETR 1500
TransferRate STOR 70
TransferRate STOU 70
TransferRate APPE 70
SystemLog /var/log/secure
RequireValidShell off
#gp_random_username_length 6
#gp_random_password_length 6
#gp_randomize_case lower
#gp_useradd_homedir_path /var/ftp
#gp_html_path /var/www/html/ftp.htm
#gp_welcome_name welcome.msg
<IfModule mod_tls.c>
TLSEngine off
TLSRequired off
TLSVerifyClient off
TLSProtocol TLSv1
TLSLog /var/log/proftpd_tls.log
TLSRSACertificateFile /etc/gproftpd/gproftpd.pem
</IfModule>
<IfModule mod_ratio.c>
Ratios off
SaveRatios off
RatioFile "/restricted/proftpd_ratios"
RatioTempFile "/restricted/proftpd_ratios_temp"
CwdRatioMsg "Please upload first!"
FileRatioErrMsg "FileRatio limit exceeded, upload something first..."
ByteRatioErrMsg "ByteRatio limit exceeded, upload something first..."
LeechRatioMsg "Your ratio is unlimited."
</IfModule>
<Limit LOGIN>
  AllowUser azrael
  DenyALL
</Limit>

<Anonymous /var/ftp/azrael>
User azrael
Group ftp
AnonRequirePassword on
MaxClients 5 "The server is full, hosting %m users"
DisplayLogin welcome.msg
<Limit LOGIN>
Allow from all
Deny from all
</Limit>
AllowOverwrite on
<Limit LIST NLST  STOR STOU  APPE  RETR  RNFR RNTO  DELE  MKD XMKD SITE_MKDIR  RMD XRMD SITE_RMDIR  PWD XPWD  SIZE  STAT  CWD XCWD  CDUP XCUP >
AllowAll
</Limit>
<Limit SITE  SITE_CHMOD  SITE_CHGRP  MTDM >
DenyAll
</Limit>
</Anonymous>

#2 Le 10/01/2008, à 00:03

huguette

Re : Proftpd, Vsftpd .... tout ça ne fonctionne pas . Why?

tu veux faire quoi en concret ?:D
paske c'est long à  lire ...

Dernière modification par huguette (Le 10/01/2008, à 00:03)

Hors ligne

#3 Le 10/01/2008, à 00:09

Uggy

Re : Proftpd, Vsftpd .... tout ça ne fonctionne pas . Why?

Diverses infos:
- Il y a 2 modes en FTP: Actif et Passif
Les connexions ne se font pas dans le meme sens
- Il y a 2 canaux en FTP: Control et DATA.
- Le port 20 n'est pas un port destination (mais le port source du canal DATA en ACTIF)

Bref tout cela peut poser des problèmes au niveau des FireWall. Le tient bien sur mais aussi celui qui est du coté du client.

Je ne connais pas Gproftpd mais donner les logs coté serveur et les logs cotés clients seraient un plus.

Dans tous les cas revois bien les différentes notions actif/passif/control/data et précise tout cela pour tes tests.

Hors ligne

#4 Le 10/01/2008, à 00:24

omeega

Re : Proftpd, Vsftpd .... tout ça ne fonctionne pas . Why?

@huguette:

Ce que je veux faire c'est découvrir pourquoi ça ne fonctionne pas comme ça.

Ce que je veux faire c'est monter des services , les faire fonctionner en test, les sécuriser puis passer a autre chose, c'est tout bète mais j'aime bien savoir comment ça fonctionne et comment le faire fonctionner.

Je suis curieux et je veux savoir c'est tout.

@ Uggy :

Je connais bien le mode passif et le mode actif, ce serveur est censé fonctionner en mode passif et tout les ports sont ouverts pour qu'il agisse en ce sens.

Oui, j'avais inversé le port de connection avec le port data en actif désolé, mais ça ne résoud a rien mon probleme.

Pour le firewall, j'ai tout affiché dans le premier post donc de mon cà´té je ne vois pas le probleme. Du cà´té client, c'est un XP pro bannal sans firewall mais juste le routeur deriere  qui ne devrait pas gener car elle peut se connecter sur des FTP de free.fr.


ça fait 1 mois que j'ai tout vu et revus et là  j'ai la cervelle en compote, si qq1 a une réponse plus concrète ou un début d'explication ?

Hors ligne

#5 Le 10/01/2008, à 00:42

Uggy

Re : Proftpd, Vsftpd .... tout ça ne fonctionne pas . Why?

omeega a écrit :

Je connais bien le mode passif et le mode actif, ce serveur est censé fonctionner en mode passif et tout les ports sont ouverts pour qu'il agisse en ce sens.

Ok.
Tu es bien sur que le client est configuré pour faire du passif ?



omeega a écrit :

Oui, j'avais inversé le port de connection avec le port data en actif désolé, mais ça ne résoud a rien mon probleme.

Effectivement ca montre juste que tout n'etait pas tres tres clair wink


omeega a écrit :

Du côté client, c'est un XP pro bannal sans firewall mais juste le routeur deriere

Et ce routeur ne fait donc pas Firewall ?

omeega a écrit :

qui ne devrait pas gener car elle peut se connecter sur des FTP de free.fr.

Connexion FTP vers free en Actif ou en Passif ????



omeega a écrit :

ça fait 1 mois que j'ai tout vu et revus et là j'ai la cervelle en compote, si qq1 a une réponse plus concrète ou un début d'explication ?

Visiblement tu veux veux pas donner les logs demandés... Bonne chance..
A+

Hors ligne