Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 15/05/2013, à 04:12

maccam

[Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Bonjour,

Je viens d'installer Ubuntu 13.04 sur mon Asus Vivobook S400CA et j'ai un léger problème, si je suis a côté de mon routeur j'arrive a avoir ma wifi mais avec un signal faible. Par contre dès que je change de pièce je perd ma wifi...
J'ai regarder dans les pilotes propriétaires mais je n'ai rien qui apparais...
Quelqu'un à une solution?

PS : avec windows je n'ai pas ce problème

Dernière modification par maccam (Le 05/06/2013, à 21:38)

Hors ligne

#2 Le 15/05/2013, à 07:42

malbo

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

maccam,
Peux-tu répondre à ce post : http://forum.ubuntu-fr.org/viewtopic.ph … #p13550951


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#3 Le 18/05/2013, à 02:45

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Petit up car c'est vraiment pas pratique le wifi :'(

Hors ligne

#4 Le 21/05/2013, à 21:24

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Voici ce que j'ai pour ma carte wifi si ca peux aider :

maccam@maccam-S400CA:~$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1bcf:2883 Sunplus Innovation Technology Inc. 
Bus 001 Device 006: ID 03eb:8807 Atmel Corp. 
maccam@maccam-S400CA:~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation 3rd Gen Core Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 7 Series/C210 Series Chipset Family Thermal Management Controller (rev 04)
02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)

Hors ligne

#5 Le 23/05/2013, à 22:55

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Up

Hors ligne

#6 Le 24/05/2013, à 17:01

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Voici ma carte wifi : Qualcomm Atheros AR9485WB-EG Wireless

Hors ligne

#7 Le 27/05/2013, à 22:34

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

up

Hors ligne

#8 Le 02/06/2013, à 16:30

alban_yaka

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Bonjour maccam,

J'ai fait l'acquisition d'un vivobook il y a quelques jours et j'avais exactement le même problème que toi : un wifi très bon sous W7 mais très faible avec Ubuntu, même près de la box.

J'ai résolu le problème en installant les drivers Atheros et en utilisant ndiswrapper (voir le tuto de ndiswrapper).
Attention cependant, il semblerait que la version de ndiswrapper présente dans les dépôts est buggée, il faut donc télécharger la dernière version (1.58 je crois) sur soundforge et fait le make/make install "à la main".

En espérant t'avoir aidé (en tout cas maintenant je capte maintenant un signal wifi de bonne qualité partout).
Alban.

PS : il te faudra le nom exact de ta carte wifi, tu l'obtiens en tapant lspci dans la console puis il te suffit d'aller sur le site d'atheros chopper le drivers (j'ai pris la version windows XP).

Dernière modification par alban_yaka (Le 02/06/2013, à 16:32)

Hors ligne

#9 Le 03/06/2013, à 20:21

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

merci mais le probleme m est toujours pas resolut... j ai bien installer ndiswrapper en sudo make/make install j ai telecharger mon driver et unzip puis lancer
sudo ndiswrapper -i netathw.inf
sudo ndiswrapper -i netathwx.inf
pour mes 2 fichiers .inf mais ma connection reste la mm (j ai telecharger la version 32bit du driver comme indiquer sur le forum)

Hors ligne

#10 Le 04/06/2013, à 19:17

alban_yaka

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Il faut charger un seul driver : netathw.inf (l'autre est utilisé pour les anciennes versions de windows)
As tu désactivé le driver d'ubuntu ? Si non, alors tu as deux drivers chargés en même temps.
Dans le terminal tu fais "lsmod". Chez moi le mod qui gère le wifi de base s'apelle "ath9k". Tu le désactive avec "sudo modprobe -r ath9k". tu active le driver ndiswrapper avec "sudo modprobe ndiswrapper".
Si tu ne veux pas avoir à refaire la manip à chaque démarrage il faut blacklisté ath9k et lancer ndiswrapper au démarrage. La manip' est expliquée dans le tuto.

Hors ligne

#11 Le 05/06/2013, à 17:58

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

J ai fait presque tous ce que tu m'as dit j arrive bien a desactiver ath9k et activer mon driver. Il me trouve tous les reseaux en bonne qualite mais il n'arrive pas a faire la connection.... j ai verifier le mot de passe et tt est OK donc je comprend pas pourquoi il ne se connecte pas aux reseaux alors qu'ils les identifient clairement...

Je n ai pas encore blacklister ath9k tant que ce probleme n est pas resolut ca peut venir de ca?

Hors ligne

#12 Le 05/06/2013, à 18:09

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

A la commande iwconfig on me retourne :

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"AmusantechienneV2"  
          Mode:Managed  Frequency:2.457 GHz  Access Point: C8:D7:19:22:98:4B   
          Bit Rate=150 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=41/70  Signal level=-69 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:117   Missed beacon:0

Et a la commande  ndiswrapper -l j'ai:

netathw : driver installed
netathwx : driver installed
	device (168C:0032) present (alternate driver: ath9k)

Peut etre que mon probleme viens de netathwx qui est aussi installer mais j arrive pas a le desinstaller avec la commande sudo ndiswrapper -r netathwx.inf , on me retourne:

couldn't delete /etc/ndiswrapper/netathwx.inf: No such file or directory

(j'ai fait cette commande dans le directory ou j'ai fait mes make/make install et aussi la ou j'ai mes fichiers .inf)

Hors ligne

#13 Le 05/06/2013, à 21:37

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Probleme resolu en installant le paquet ndisgtk ou j ai pu desinstaller en mode graphique mon driver en trop et maintenant ce fonctionne bien.
Merci

Hors ligne

#14 Le 06/06/2013, à 05:59

malbo

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Merci pour le retour. Je viens de donner le lien vers la présente discussion dans la liste des portables Asus concernant ton modèle d'ordi VivoBook S400CA : http://doc.ubuntu-fr.org/liste_portables_asus#s


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#15 Le 13/08/2013, à 17:43

jromkjrom

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Il y a même une solution sans ndiswrapper qui est sortie , un backport

1. Open Dash and search for Terminal and open it
2. wget https://www.kernel.org/pub/linux/kernel … 618.tar.xz
3. tar xvf backports-20130618.tar.xz
4. cd backports-20130618
5. make defconfig-ath9k
6. make
7. sudo make install

Juste testé sur le vivobook S400c, fonctionne a merveille !

Hors ligne

#16 Le 12/09/2013, à 23:53

maccam

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Je viens de réinstaller Ubuntu 13.04 sur mon S400 et après la mise a jour tous fonctionnais parfaitement!!!!

Hors ligne

#17 Le 29/09/2013, à 17:59

flo360

Re : [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

jromkjrom a écrit :

Il y a même une solution sans ndiswrapper qui est sortie , un backport

1. Open Dash and search for Terminal and open it
2. wget https://www.kernel.org/pub/linux/kernel … 618.tar.xz
3. tar xvf backports-20130618.tar.xz
4. cd backports-20130618
5. make defconfig-ath9k
6. make
7. sudo make install

Juste testé sur le vivobook S400c, fonctionne a merveille !

Wow merci ! Problème corrigé sur mon Asus N55JV (Atheros 9485).

Hors ligne

  • Accueil
  • » Forum
  • » WiFi
  • » [Resolu] probleme carte wifi signal faible Qualcomm Atheros AR9485WB

Haut de page ↑