Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 14/09/2013, à 12:57

jfrax023

problème graphique Ubuntu 12.04.03

Bonjour alors voila je sais que la question a déjà été traiter a diverses endroit mais en suivant plusieurs tuto je n ai pas réussi a régler mon problème .
Tous d abord mon pc est un Asus S551LB  avec un i5 4200u et une carte graphique Nvidia 740m.
Donc après plusieurs essai infructueux pour installer Ubuntu 13.04 le cd se bloquant après le menu grub , j ai finit par réussir a installer la version 12.04.03 mais au démarrage j ai un message d erreur avec marquer unknow chipset x0180 et après il est marque can not broken pipe, ou l écran ce bloque sur les quatre point de chargement de Ubuntu.J ai essayer d installer les pilote propriétaire avec le script sgfxi ça n a rien donner j ai essayez bumblebee et ça marche pas j ai des message d erreur et en regardant sur le ubuntu.fr j ai appris que avec la version 12.04.03 bumblebee entrais en conflit avec Nvidia-prime .Comme je suis un débutant je ne sais pas ce que je doit faire et ni vers quelle tuto me tourner , voila pourquoi je me tourne vers vous pour m aider.
En remerciant ce qui essaierons de m aidez merci.
jfrax023

Désoler si j ai fait des fautes ou n ai pas fournit assez de renseignement.
Voici se que me donne la commande lspci -vnn | grep '\''[030[02]\]'
VGA compatible controller [03021]: Intel Corporation Device [8086:0a16] (rev09) (prog-if 00 [VGA controller)
3D controller [0302]: NVIDIA Corporation Device [10de:1292] (rev a1)

Hors ligne

#2 Le 14/09/2013, à 16:47

Pam547

Re : problème graphique Ubuntu 12.04.03

Bonjour,

J'ai eu un problème similaire.

J'ai réussi à faire tourner la version live et la version installé par la suite qu'en rajoutant un option.

Dans la fenêtre du grub, il est possible de rajouter des options ... en appuyant sur "e".

J'ai réussi à le démarrer en rajoutant toutes ces options : "pmedia=usbflash pfix=ram,nox acpi=off apm=off nosmp noapic nodma nopcmcia"

Au final seul l'option acpi=off m'était indispensable. Et encore des problèmes pour éteindre ... mais au moins il démarre !


Art.9.(code civil)  Chacun a droit au respect de sa vie privée.

Art.12.(déclaration universelle des DDH) Nul ne sera l'objet d'immixtions arbitraires dans sa vie privée, sa famille, son domicile ou sa correspondance, ni d'atteintes à son honneur et à sa réputation. Toute personne a droit à la protection de la loi contre de telles immixtions ou de telles atteintes.

Hors ligne

#3 Le 15/09/2013, à 10:36

jfrax023

Re : problème graphique Ubuntu 12.04.03

Bonjour
J ai regarder au démarrage de grub après avoir appuyez sur e comme dit j ai sur l écran 2 ligne avec écrit
set gfxplayload=keep
linux       /casper/vmlinuz  file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity quiet splash--
initrd      /casper/initrd.lz

Et ce que je doit ecrire ce que vous m avez marquez a la suite?Comme je ne mi connait pas beaucoup je ne veut pas faire n importe quoi .
merci d avance

Hors ligne

#4 Le 15/09/2013, à 11:34

Pam547

Re : problème graphique Ubuntu 12.04.03

linux       /casper/vmlinuz  file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity quiet "C'est ici que j'ai mis les options" splash--


Art.9.(code civil)  Chacun a droit au respect de sa vie privée.

Art.12.(déclaration universelle des DDH) Nul ne sera l'objet d'immixtions arbitraires dans sa vie privée, sa famille, son domicile ou sa correspondance, ni d'atteintes à son honneur et à sa réputation. Toute personne a droit à la protection de la loi contre de telles immixtions ou de telles atteintes.

Hors ligne

#5 Le 16/09/2013, à 11:42

jfrax023

Re : problème graphique Ubuntu 12.04.03

Bonjour bon j ai essayez se que tu m'a dit ça n'a pas marcher de toute manière désormais je voudrai me concentrer sur le problème graphique de la version 12.04.03 vu que j ai réussi à l installer il ne reste plus qu à régler ce problème j ai penser à une chose mon ordi à un écran tactile et ce que ça peut créé un problème ?Sinon si quelqu un sais se que je doit faire ça m aiderai ce soir je voudrai essayez de supprimer nvidia prime mais et ce que apprêt l avoir fait je pourrai installer bumblebee qui me semble la solution la plus approprié à mon cas merci d avance .
Jfrax023

Hors ligne

#6 Le 16/09/2013, à 13:49

Pam547

Re : problème graphique Ubuntu 12.04.03

Re ...

Ce doit être dans une console virtuelle tty que tu as pu récupérer l'information de

lspci -vnn | grep '\''[030[02]\]'

Tu devrais renvoyer les résultats des commandes demandés ici.

 /etc/X11/xorg.conf
/var/log/Xorg.0.log

pour les mettre dans un fichier tu devrais pouvoir faire :

cat /etc/X11/xorg.conf > fichier.log
puis copier le contenu de ce fichier là où tu pourras le récupérer.

Pareil avec /var/log/Xorg.0.log

Edit : Effectivement en faisant une copie du fichier avec la commande cp c'est aussi simple big_smile

Dernière modification par Pam547 (Le 16/09/2013, à 23:25)


Art.9.(code civil)  Chacun a droit au respect de sa vie privée.

Art.12.(déclaration universelle des DDH) Nul ne sera l'objet d'immixtions arbitraires dans sa vie privée, sa famille, son domicile ou sa correspondance, ni d'atteintes à son honneur et à sa réputation. Toute personne a droit à la protection de la loi contre de telles immixtions ou de telles atteintes.

Hors ligne

#7 Le 16/09/2013, à 14:09

jfrax023

Re : problème graphique Ubuntu 12.04.03

Yop merci oui comme dit j ai accès à la console tty je vais faire ce que tu ma dit merci en tous cas.
Bonne journée

Hors ligne

#8 Le 16/09/2013, à 15:34

Pam547

Re : problème graphique Ubuntu 12.04.03

Re ...

Si le fichier xorg.conf n'existe pas, tu devrais commencer par le créer.

http://doc.ubuntu-fr.org/xorg

Je viens de remarquer que sur la 13.04 avec laquelle je tourne il n'existe pas ... En même temps l'affichage fonctionne hmm


Art.9.(code civil)  Chacun a droit au respect de sa vie privée.

Art.12.(déclaration universelle des DDH) Nul ne sera l'objet d'immixtions arbitraires dans sa vie privée, sa famille, son domicile ou sa correspondance, ni d'atteintes à son honneur et à sa réputation. Toute personne a droit à la protection de la loi contre de telles immixtions ou de telles atteintes.

Hors ligne

#9 Le 16/09/2013, à 16:31

jfrax023

Re : problème graphique Ubuntu 12.04.03

C est sûre qu il y a quelque chose à voir à ce niveau car des que je veut lancer la commande startx j obtient un message d erreur me parlant de ce fichier j vais regardez tous ça et je tien au courent merci en tous cas.

Hors ligne

#10 Le 16/09/2013, à 22:28

jfrax023

Re : problème graphique Ubuntu 12.04.03

yop bon bah voila ou j en suis je ne suis pas sur d interprétez correctement ce qui mes renvoyez  il semble que mon écran n est pas détecter mais je me trompe peut être donc voila mon fichier /etc/X11/xorg.conf sachant que je n ai pas de fichier /var/log/Xorg.0.log du moins en tapant nano /var/log/Xorg.0.log

fichier /etc/X11/xorg.conf

#Warning: This file is autogenerated by nvidia-prime. All changes to this fille will be lost.
Section "ServerLayout"
          Identifier "layout"
          Screen 0 nvidia"
          inactive "intel"
EndSection

Section "Screen"
        Identifier "nvidia"
        Device  "nvidia"
        # Uncomment thisline if your computer has no display devices connected to
        # the NVIDIA GPU. Leave it commented if you have display device
        # connected to the NVIDIA GPU that you would like to use.
        Option "UseDisplayDevice" "none"
EndSection

Section "Device"
       Idntifier "intel"
       Driver "modesetting"
EndSection

Section "Screen"
      Identifier "intel"
      Device "intel"
EndSection


Voila une chose me trouble la première est pourquoi la section screen arbord "intel"
SVP rappelez vous que je débute chez linux donc soyez indulgent merci d avance.

Hors ligne

#11 Le 16/09/2013, à 23:23

Pam547

Re : problème graphique Ubuntu 12.04.03

As-tu suivi cette procédure ?

Dans le terminale :

cd /
sudo find -name Xorg.0.log

Ceci pour être sûr que Xorg.0.log n'existe pas.


Art.9.(code civil)  Chacun a droit au respect de sa vie privée.

Art.12.(déclaration universelle des DDH) Nul ne sera l'objet d'immixtions arbitraires dans sa vie privée, sa famille, son domicile ou sa correspondance, ni d'atteintes à son honneur et à sa réputation. Toute personne a droit à la protection de la loi contre de telles immixtions ou de telles atteintes.

Hors ligne

#12 Le 16/09/2013, à 23:53

jfrax023

Re : problème graphique Ubuntu 12.04.03

Yop ok il a trouver mes sous ce nom ./var/log/Xorg.0.log
Vu que je suis à l hôtel (taff) j suis en hot spot et donc ne peut pas me log en tty je recopy le renvoie et le post...

Hors ligne

#13 Le 17/09/2013, à 20:39

jfrax023

Re : problème graphique Ubuntu 12.04.03

Bonjour desoler hier la fatigue ma emporter donc voila le fichier /var/log/Xorg.0.log

[      20.820]
X.Org X Server 1.13.3
Release Date: 2013-03-07
[        20.820] X Protocol Version 11, Revision 0
[        20.820] Build Operating System: Linux2.6.42-37-generic x86_64 Ubuntu
[        20.820] Current Operating System: Linux pseudo-S551LB 3.8.0-30-generic #44"precise1-Ubuntu SMP Fri Aug 23 18:32:41 UTC 2013 x86_64
[        20.820] Kernel command line: BOOT_IMAGE=/vmlinuz-3.8.0-30-generic.efi.signed root=UUID=648d4486-0a1c-4820-bab0-c1cca9f7e624 ro quiet splash vt.handoff=7
[        20.820] Build Date: 07 June 2013 09:48:0BAM
Bonjour desoler hier la fatigue ma emporter donc voila le fichier /var/log/Xorg.0.log

[      20.820]
X.Org X Server 1.13.3
Release Date: 2013-03-07
[        20.820] X Protocol Version 11, Revision 0
[        20.820] Build Operating System: Linux2.6.42-37-generic x86_64 Ubuntu
[        20.820] Current Operating System: Linux pseudo-S551LB 3.8.0-30-generic #44"precise1-Ubuntu SMP Fri Aug 23 18:32:41 UTC 2013 x86_64
[        20.820] Kernel command line: BOOT_IMAGE=/vmlinuz-3.8.0-30-generic.efi.signed root=UUID=648d4486-0a1c-4820-bab0-c1cca9f7e624 ro quiet splash vt.handoff=7
[        20.820] xorg-server 2:1.13.3-0ubuntu6"precise2 (For technical support please see http://www.ubuntu.com/support)
[        20.820] Current version of pixman: 0.24.4
[        20.820]       Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[        20.820] Markers:  (--) probed, (**) from config file, (==) default setting,(++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[        20.820] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Sep 17 19:06:38 2013
[        20.931] (==) Using config file: "/etc/X11/xorg.conf"
[        20.931] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[        21.046] (==) ServerLayout "layout"
[        21.047] (**) |-->Screen "nvidia" (1)
[        21.047] (**) |      |-->Monitor "<default monitor>"
[        21.047] (**) |      [-->Device "nvidia"
[        21.047] (==) No monitor specified for screen "nvidia".
               Using a default monitor configuration.
[        21.047] (**) |-->Inactive Device "intel"
[        21.047] (==) Automatically adding devices
[        21.047] (==) Automatically enabling devices
[        21.047] (==) Automatically adding GPU devices
[        21.064] (WW) The dirctory "/usr/share/font/X11/cyrillic" does not exist.
[        21.064]          Entry deleted from path.
[        21.064] (WW) The dirctory "/usr/share/font/X11/100dpi/" does not exist.
[        21.064]          Entry deleted from path.
[        21.064] (WW) The dirctory "/usr/share/font/X11/75dpi/" does not exist.
[        21.064]          Entry deleted from path.
[        21.065] (WW) The dirctory "/usr/share/font/X11/100dpi" does not exist.
[        21.065]          Entry deleted from path.
[        21.065] (WW) The dirctory "/usr/share/font/X11/75dpi" does not exist.
[        21.065]          Entry deleted from path.
[        21.065] (WW) The dirctory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/trueType" does not exist.
[        21.065] (==) FontPath set to:
               /usr/share/fonts/X11/mics,
               /usr/share/fonts/X11/Type1,



Donc voila le fichier je vais aussi poster se que me renvoie la commande startx ça peut servir .
merci

Hors ligne

#14 Le 17/09/2013, à 23:44

classdroogies

Re : problème graphique Ubuntu 12.04.03

Salut,

Je tenterai de renommer le fichier xorg.conf, afin de voir si tu peux lancer le serveur d'affichage sur le GPU Intel :

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Si cela ne marche pas essayer de forcer l'utilisation de pilote Intel :

sudo nano /etc/X11/xorg.conf

Puis y mettre :

Section "Device"
       Idntifier "intel"
       Driver "intel"
EndSection

Il faudrait détaillé un peu plus. Quel pilote et comment l'as-tu installer....

Je te renvois sur ces 2 documentations au cas où.

http://doc.ubuntu-fr.org/nvidia_optimus

https://wiki.ubuntu.com/Bumblebee?actio … ee_Project

De plus je vois une erreur dans le fichier Xorg.conf :

 Screen 0 nvidia"
 Screen 0 "nvidia"

Manque les guillemets, mais j'imagine que c'est une faute de frappe...

Dernière modification par classdroogies (Le 17/09/2013, à 23:45)

Hors ligne

#15 Le 18/09/2013, à 07:28

jfrax023

Re : problème graphique Ubuntu 12.04.03

Bonjour et désoler oui se doit être une faute de frappe sinon je vais essayez se que tu ma dit ce soir pour ce qui et de l installations des potes en faire ils sont déjà intégrer je n ai rien installer en plus j attend les conseilles de personne (comme vous ) qui veulent bien se pencher sur mon cas .
Pour ce qui est de la doc optimus et bumblebee dans ce que j ai lu la version 12.04.03 intègre nvidia-prime c d ailleurs lui qui génère mon fichier Xorg.conf et d après se qu il dise il ne faut pas installer bumblebee car ça entre en conflit avec nvidia-prime . J ai bien pensser à supprimer nvidia-prime t installer bumblebee mais je ne suis pas sur que ce soit la bonne solution bref ce soir j essais ce que tu ma dit et je posterai se que me renvoie la commande startx qui devrait fournir des détails sur les erreurs rencontrer et si il faut d autre chose n hésiter pas a me le dire.
Merci

Hors ligne

#16 Le 18/09/2013, à 07:48

jfrax023

Re : problème graphique Ubuntu 12.04.03

Une chose vient de me revenir lors de mes nombreux essai pour installer une distribution Linux un à fonctionner c était opensuze 12.3 .Ma question cette distribution est basée sur rpm si je me trompe pas serait il possible de récupérer des informations? Ou peut être regardez les fichiers xorg savoir se qui diffère de ubuntu .Je connais pas le distribution rpm et quand j avais essayez je n avais pas trop apprécié mais si sa peut aidez à débloquer la situation ...

Hors ligne

#17 Le 18/09/2013, à 08:29

classdroogies

Re : problème graphique Ubuntu 12.04.03

Salut,

jfrax023 a écrit :

pour ce qui et de l installations des potes en faire ils sont déjà intégrer je n ai rien installer

Tu es certain de ne rien avoir installé ?

Il y a le pilote libre nouveau intégré par défaut pour les cartes nvidia, mais il ne gère pas la vidéo hybride...

jfrax023 a écrit :

Pour ce qui est de la doc optimus et bumblebee dans ce que j ai lu la version 12.04.03 intègre nvidia-prime c d ailleurs lui qui génère mon fichier Xorg.conf

Donne tes sources parce que je ne trouve aucune information la dessus ?

Dans ton cas ce n'est à mon avis pas qu'un simple problème de xorg.conf, qui, pour info n'est plus indispensable dans bon nombre de configuration.

Je pense que tu devrais refaire une installation en suivant scrupuleusement les indications de la doc, suivit d'une installation de bumblebee.

Je t'invite à lire ce fil de discussion lancé par l'un des dev de bumblebee :

http://forum.ubuntu-fr.org/viewtopic.php?id=1230851

Dernière modification par classdroogies (Le 18/09/2013, à 08:29)

Hors ligne

#18 Le 18/09/2013, à 08:42

jfrax023

Re : problème graphique Ubuntu 12.04.03

Bonjour voilà le lien pour la page bumblebee ubuntu première encadrer jaune
http://doc.ubuntu-fr.org/bumblebee .
Et oui pour l instant je n ai rien installer car j ai refait l installation et comme j ai mis c est nvidia-prime qui génère automatiquement le fichier xorg.conf il sont intégrer de base à la version 12.04.03 pour ce qui est de l installation de bumblebee lors de la première installation j ai essayez de l installer et il y a bien conflit message d erreur d ou la question que je me pose et ce que je devrai essayez en supprimant nvidia-prime ?

Hors ligne

#19 Le 18/09/2013, à 08:52

classdroogies

Re : problème graphique Ubuntu 12.04.03

jfrax023 a écrit :

Bonjour voilà le lien pour la page bumblebee ubuntu première encadrer jaune
http://doc.ubuntu-fr.org/bumblebee .

Merci pour l'info, je n'avais pas vu qu'il avait une page dédié bumblebee roll

Dans ce cas je dirais de désinstaller nvidia-prime, et d'essayer d'installer bumblebee, mais comme tu as pu le voir je ne suis pas expert sur le sujet. tongue

Va voir le fil de discussion si ce n'est pas déjà fait.

Hors ligne

#20 Le 18/09/2013, à 20:09

jfrax023

Re : problème graphique Ubuntu 12.04.03

yop bon voila ce que me renvoie startx a vrai dire c pas encouragent:/

startx(je passe le devant)
xauth: error in locking autority file /home/dtraktou/.Xauthoritary
xauth: error in locking autority file /home/dtraktou/.Xauthoritary  ( ça je capte pas j ai essayez sudo pareille les deux même phrase!!)



Fatal server error:
Server is already active for display 0
             if this server is no longer running, remove /tmp/.X0-lock  and start again.       (j ai voulu le supprimer mais il était marquer protéger en écriture de peur de faire des betise j ai rien fait en attendent conseil .)
(EE)
Please consult the The X.org Foundation support at http://wiki.x.org for help.
(EE)
X10:      fatal 10 error 11 (Resource temporarily unavailable) on X server ":0"
             after 7 requests (7 Known processed) with 0 events remaining.
xauth:       error in locking authority file /home/dtraktou/.Xauthority



Donc voila j arrive pas trop a comprendre cette histoire d authority root devrais avoir toute autorisation faut il supprimer se fichier /tmp/.X0-lock ?
merci

Hors ligne

#21 Le 18/09/2013, à 21:03

classdroogies

Re : problème graphique Ubuntu 12.04.03

Donne le retour :

ls -l .Xauthority 

Tu n'es peut-être pas le propriétaire du fichier, et c'est pour ça que ça plante. Si c'est le cas soit le supprimer, soit changer le proprio avec la commande chown.

Pour le fichier /tmp/.X0-lock, tu peux d'abord vérifier l’existence d'une session d'affichage :

ps aux | grep `cat /tmp/.X0-lock`

Si aucun retour, de ce style :

root  2283  0.5  5.1 27796 6536 ?    S  Apr21  59:03 [X]

Alors tu peux supprimer le fichier :

rm -rf /tmp/.X0-lock

Après tout ceci retenter une connexion...

As-tu essayer de faire la manip pour démarrer avec le GPU Intel ?

Hors ligne

#22 Le 18/09/2013, à 22:35

jfrax023

Re : problème graphique Ubuntu 12.04.03

Donc la commande ls –l  Xauthority renvoi
-root-------  en gros les droit son à root
J ai essayé de la commande pour supprimer le fichier /tmp/.X0-lock
Reboot pareille après retenter et startx même message d erreur
En gros j essaie demain de passer par Intel mais franchement j suis perdu la ...

Hors ligne

#23 Le 19/09/2013, à 08:09

classdroogies

Re : problème graphique Ubuntu 12.04.03

jfrax023 a écrit :

Donc la commande ls –l  Xauthority renvoi
-root-------  en gros les droit son à root

Et donc , tu as fait une suppression du fichier .Xauthority, un changement de propriétaire ?

Pour un changement de propriétaire :

sudo chown $user:$user ~/.Xauthority

Tu remplaces $user par le nom de ton utilisateur, a priori dtraktou

Hors ligne

#24 Le 19/09/2013, à 20:00

jfrax023

Re : problème graphique Ubuntu 12.04.03

Slt donc j ai changer le propriétaire du fichier Xauthority donc Nouveau startx

_XSERVTransSocketUNIXCreatListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTServerListeners: server already running

Fatal server error:
Cannot establish any listening socket - Make sure an X server isn't already running (EE)
Même message que d habitude X10 fatal 10 error ..... Comme la fin du message 20 même nombre et tout je vais essayez la solution Intel  que tu m'a donner

Hors ligne

#25 Le 19/09/2013, à 20:06

jfrax023

Re : problème graphique Ubuntu 12.04.03

Bon bah pareille exactement le même message d erreur comment je fait pour savoir si un processus graphique et lancer j ai fait la commande top mais y a plein de truc don 2 qui son en mouvement les autre bouge pas?

Hors ligne

Haut de page ↑