Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 18/01/2008, à 23:19

dudur

awstast ne pointe pas sur l'URL du site

Bonsoir,

j'installe awstats en suivant la procédure décrite dans le lien suivant http://doc.ubuntu-fr.org/awstats?s=awstats
tout va bien le fichier txt est genere mais au moment ou je teste par /site/cgi-bin/awstats.pl je rçois le message suivant :

Not Found

The requested URL /cgi-bin/awstats.pl was not found on this server.

j'ai fait et refait ce qui est ecrit epluché le forum je n'y comprends rien ! si quelqu'un a une idée

Merci d'avance

Hors ligne

#2 Le 20/01/2008, à 20:38

dudur

Re : awstast ne pointe pas sur l'URL du site

up

personne n'a d'idée la dessus ?

Je genère le fichier texte sans problèmes mais pas de stats y aurait il un problème d'alias ?

je ne vois  dans usr/share/awstats ni /classes ni /css

-------------------------------------------------------------------------------------

Alias /awstatsclasses "/usr/share/awstats/classes/"
Alias /awstatscss "/usr/share/awstats/css/"
Alias /awstats-icon "/usr/share/awstats/icon/"

ScriptAlias home/web/uam-karate.com/stats  /usr/lib/cgi-bin/awstats.pl

# mêmes paramètres que dans awstats.*.conf
<Directory /usr/lib/cgi-bin/>
  DirectoryIndex awstats.pl
  UseCanonicalName off
#  AuthName "Statistiques awstats"
#  AuthType Basic
#  Require valid-user
#  AuthUserFile /che/min/.passwdstats
  Options +ExecCGI
  AllowOverride None
  Order allow,deny
  Allow from all
</Directory>
------------------------------------------------------------------------------------------------
je ne vois plus quoi faire sinon renoncer à  des stats !

Hors ligne

#3 Le 22/01/2008, à 20:15

Captaine74

Re : awstast ne pointe pas sur l'URL du site

J'ai trouvé une astuce : J'ai changé la ligne

ScriptAlias /stats /usr/lib/cgi-bin/awstats.pl

en

ScriptAlias /stats /usr/lib/cgi-bin/

Il suffit ensuite d'appeler http://mondomaine/stats/awstats.pl

Dernière modification par Captaine74 (Le 22/01/2008, à 20:22)

Hors ligne

#4 Le 05/12/2008, à 12:55

jokker

Re : awstast ne pointe pas sur l'URL du site

Meme probleme, meme solution, mais pas moyen d'avoir l'alias...

#5 Le 09/03/2011, à 23:21

SpyKee

Re : awstast ne pointe pas sur l'URL du site

Pour obtenir l'alias il suffit d'enlever la ligne DirectoryIndex awstats.pl, soit la configuration suivante :

Alias /awstatsclasses "/usr/share/awstats/classes/"
Alias /awstatscss "/usr/share/awstats/css/"
Alias /awstats-icon "/usr/share/awstats/icon/"

ScriptAlias home/web/uam-karate.com/stats  /usr/lib/cgi-bin/awstats.pl

# mêmes paramètres que dans awstats.*.conf
<Directory /usr/lib/cgi-bin/>
  UseCanonicalName off
#  AuthName "Statistiques awstats"
#  AuthType Basic
#  Require valid-user
#  AuthUserFile /che/min/.passwdstats
  Options +ExecCGI
  AllowOverride None
  Order allow,deny
  Allow from all
</Directory>

Dernière modification par SpyKee (Le 09/03/2011, à 23:21)

Hors ligne

Haut de page ↑