Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 01/10/2007, à 07:58

miraks

[résolu] NTFS externe et accents

Depuis que j'ai fait la migration vers Kubuntu Gutsy, le montage de disques externes en NTFS se fait automatiquement en ntfs-3g. big_smile

Par contre, le problème, c'est que je ne peux pas voir tous les fichiers contenants des accents.
Ceci car le montage se fait sans le support utf8. sad

Si je monte à  la main en faisant "pmount -c utf8 /dev/sda1", là  ca marche bien.

Mais comment faire pour que ca monte en utf8 aussi en automatique ?

Dernière modification par miraks (Le 17/02/2008, à 13:31)

Hors ligne

#2 Le 01/10/2007, à 08:10

dionysos_crucifie

Re : [résolu] NTFS externe et accents

bonjour

il faut modifier le fichier /etc/fstab

gksudo gedit /etc/fstab

et rajouter nls=utf8 dans les options de montage du disque ntfs
http://doc.ubuntu-fr.org/installation/p … hiers_ntfs


"Sans la musique, la vie serait une erreur" - F. Nietzsche
Le site du Mirabellug - le LUG de Nancy (54)

Hors ligne

#3 Le 01/10/2007, à 08:29

miraks

Re : [résolu] NTFS externe et accents

Si je ne me trompe pas, j'ai rien dans le fstab pour ce disque (je ne peux pas vérifier pour le moment). Ce qui est normal car c'est un disque externe qui doit être monté automatiquement par "hal".

Dernière modification par miraks (Le 01/10/2007, à 08:29)

Hors ligne

#4 Le 01/10/2007, à 09:47

dionysos_crucifie

Re : [résolu] NTFS externe et accents

tu peux essayer de regarder la config de gconf :

gksudo gconf-editor

dans l'arborescence :
System / Storage / ntfs ou nfts-3g tu as des options de montage par défaut pour les systemes de fichiers
pour ntfs j'ai mount_options [umask=222,utf8,exec]
alors que pour ntfs je n'ai que mountoptions [locale=,exec]
peut etre qu'en rajoutant utf8 ici tu auras les accents


"Sans la musique, la vie serait une erreur" - F. Nietzsche
Le site du Mirabellug - le LUG de Nancy (54)

Hors ligne

#5 Le 01/10/2007, à 10:03

miraks

Re : [résolu] NTFS externe et accents

dionysos_crucifie a écrit :

tu peux essayer de regarder la config de gconf :

gksudo gconf-editor

dans l'arborescence :
System / Storage / ntfs ou nfts-3g tu as des options de montage par défaut pour les systemes de fichiers
pour ntfs j'ai mount_options [umask=222,utf8,exec]
alors que pour ntfs je n'ai que mountoptions [locale=,exec]
peut etre qu'en rajoutant utf8 ici tu auras les accents

Merci, je vais essayer de trouver l'equivalent sous Kubuntu (KDE).

Hors ligne

#6 Le 01/10/2007, à 10:26

dionysos_crucifie

Re : [résolu] NTFS externe et accents

bon ben j'ai vraiment du mal à lire ce matin lol

Depuis que j'ai fait la migration vers Kubuntu Gutsy, le montage de disques externes en NTFS se fait automatiquement en ntfs-3g. big_smile


"Sans la musique, la vie serait une erreur" - F. Nietzsche
Le site du Mirabellug - le LUG de Nancy (54)

Hors ligne

#7 Le 02/10/2007, à 07:33

miraks

Re : [résolu] NTFS externe et accents

dionysos_crucifie a écrit :

tu peux essayer de regarder la config de gconf :

gksudo gconf-editor

dans l'arborescence :
System / Storage / ntfs ou nfts-3g tu as des options de montage par défaut pour les systemes de fichiers
pour ntfs j'ai mount_options [umask=222,utf8,exec]
alors que pour ntfs je n'ai que mountoptions [locale=,exec]
peut etre qu'en rajoutant utf8 ici tu auras les accents

Je n'ai pas trouvé l'equivalent sur KDE sad

Quelqu'un sait il où puis je règler ces options par défaut sous KDE ?

Hors ligne

#8 Le 02/10/2007, à 08:26

dionysos_crucifie

Re : [résolu] NTFS externe et accents

j'ai booté sur un live cd et j'ai peut etre trouvé un truc :
dans System Settings / Avancé / Disk et Sytèmes de Fichiers
passe en mode administrateur et fais un clic droit sur la partition concernée puis Modifier et Avancé
tu peux passer des options donc essaye utf8


"Sans la musique, la vie serait une erreur" - F. Nietzsche
Le site du Mirabellug - le LUG de Nancy (54)

Hors ligne

#9 Le 02/10/2007, à 13:29

miraks

Re : [résolu] NTFS externe et accents

dionysos_crucifie a écrit :

j'ai booté sur un live cd et j'ai peut etre trouvé un truc :
dans System Settings / Avancé / Disk et Sytèmes de Fichiers
passe en mode administrateur et fais un clic droit sur la partition concernée puis Modifier et Avancé
tu peux passer des options donc essaye utf8

Je vais essayer ce soir, mais il me semble que je peux trouver dans ce panel que les disques déjà montés. Donc les internes.

Je vais essayer:
1- brancher le disque externe
2- débrancher l'utf8 avec l'appli que tu dis
3- démonter  le disque externe
4- le rebrancher et vérifier

Hors ligne

#10 Le 02/10/2007, à 19:42

miraks

Re : [résolu] NTFS externe et accents

Bon ca ne fonctionne toujours pas, mais j'avance.
Pour résumer:
1-Si je lance "pmount /dev/sda1" ou "pmount-hal /dev/sda1", le disque externe est correctement monté, c'est à dire que je vois aussi les fichiers avec accents.
J'ai alors dans le /etc/mtab:

/dev/sda1 /media/TVIX fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=512 0 0

2-Si je monte automatiquement le dique dur,  le disque externe n'est pas correctement monté, c'est à dire que je ne vois pas les fichiers avec accents.
J'ai alors dans le /etc/mtab:

/dev/sda1 /media/TVIX fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=512 0 0

Que dois-je faire pour qu'il se monte correctement en automatique ?

Encore merci pour votre aide.

PS: Milles excuses le pb ne semble pas venir de utf8 !

Hors ligne

#11 Le 02/10/2007, à 19:51

dionysos_crucifie

Re : [résolu] NTFS externe et accents


"Sans la musique, la vie serait une erreur" - F. Nietzsche
Le site du Mirabellug - le LUG de Nancy (54)

Hors ligne

#12 Le 29/10/2007, à 09:34

miraks

Re : [résolu] NTFS externe et accents

Je viens de constater un autre problème qui semble lié :
1-Je branche mon disque dur externe NTFS en USB sur ma Kubuntu 7.10 (ntfs-3g et ntfs-config sont installés)
Il se monte automatiquement.
2-J’essaye de créer un nouveau répertoire avec un accent exemple "ré"
==> J’ai une erreur. sad Alors que ca fonctionne avec "re"

Avez vous le même comportement ?

PS: Depuis la mise à jour sur la version officielle de Gutsy, le pmount ne monte plus le disque externe avec support des accents. sad

Dernière modification par miraks (Le 29/10/2007, à 09:36)

Hors ligne

#13 Le 04/11/2007, à 21:17

le_Actarus_d_Euphore

Re : [résolu] NTFS externe et accents

Bonjour à tous !!
Je passais par là par hasard :Det je me suis dit aller vas y file un coup de main !! (une chance que l inscription ne prenne pas une plombe)
voilà ma solution pour le probléme des caractéres accentués sur partition NTFS monté sous linux.
demontez la partition ntfs si elle est montée en auto puis telechargez :
fuse-2.7.1.tar.gz   sur fuse.sf.net
ntfs-3g-1.1104.tgz sur ntfs-3g.org
puis
decompression (tar xzvf nomdelarchive)
puis ./configure
make
make install
pour chacuns.
(et faire le tout sur une jambe l index de la main droite sur le nez ! lol non là je rigole lol)
ensuite montez la partoche ntfs et voilà !! normalement ça marche !! si y a pas de soucis de locales evidemment mais pour des francophones je pense que ça doit aller !!
++ wink

#14 Le 04/11/2007, à 21:56

miraks

Re : [résolu] NTFS externe et accents

le_Actarus_d_Euphore merci pour la réponse.

Je ne suis pas sur que le problème provienne des versions de fuse et de ntfs-3g car avec les versions packagées dans gutsy, ca fonctionne très bien si je fais:

mount -t ntfs-3g /dev/sda1 /home/s/test

Dans ce cas là, le mtab contient:

/dev/sda1 /home/s/test fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=512 0 0

Je pense donc que le problème vient plutôt de la façon dont pmount (ou pmount-hal) utilise la commande mount.
Je ne suis pas sûr que les bonnes options soient passées.

Dans tout les cas, merci pour l'interet que tu portes à ma question.

Dernière modification par miraks (Le 04/11/2007, à 22:07)

Hors ligne

#15 Le 08/01/2008, à 11:45

Florut

Re : [résolu] NTFS externe et accents

Désolé pour les faux espoirs Miraks roll mais je n'ai pas de solution mais le même problème : je fais donc remonter le sujet tongue

Mes fichiers accentués ne s'affichent pas quand je monte automatiquement ma partition ntfs sur mon disque externe avec HAL.
Quand je la monte normalement (sans jeu de mot) avec la commande mount tout fonctionne correctement.

Une idée quelqu'un ?

Dernière modification par Florut (Le 08/01/2008, à 11:48)

Hors ligne

#16 Le 30/01/2008, à 11:44

Adrienb1

Re : [résolu] NTFS externe et accents

miraks a écrit :

Bon ca ne fonctionne toujours pas, mais j'avance.
Pour résumer:
1-Si je lance "pmount /dev/sda1" ou "pmount-hal /dev/sda1", le disque externe est correctement monté, c'est à  dire que je vois aussi les fichiers avec accents.
J'ai alors dans le /etc/mtab:

/dev/sda1 /media/TVIX fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=512 0 0

2-Si je monte automatiquement le dique dur,  le disque externe n'est pas correctement monté, c'est à  dire que je ne vois pas les fichiers avec accents.
J'ai alors dans le /etc/mtab:

/dev/sda1 /media/TVIX fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=512 0 0

Que dois-je faire pour qu'il se monte correctement en automatique ?

Encore merci pour votre aide.

PS: Milles excuses le pb ne semble pas venir de utf8 !

Bonjour,
J'ai exactement le meme probleme, je l'ai aussi constaté sur les fichiers/dossiers qui ont des caracteres asiatiques.

Par contre sous Ubuntu (Gnome) pas de soucis, gnome utiliserait-il pmount ? , comment donc configurer kde pour qu'il utilise pmount ?
Si qqn a des éléments de réponse, merci d'avance.

Hors ligne

#17 Le 30/01/2008, à 12:10

miraks

Re : [résolu] NTFS externe et accents

Je pense que le problème provient de pmount (KDE) et donc il n'y a pas le probleme sous GNOME qui utilise automount (ou quelque chose comme ca).

Hors ligne

#18 Le 30/01/2008, à 12:12

Florut

Re : [résolu] NTFS externe et accents

Bon en fait j'ai trouvé. Il faut paramétrer la langue du système ("locale") en utf8. Elle est paramétrée par défaut en fr_FR@euro ou fr_FR.iso8859-1 et comme hal monte le ntfs en utf8 mieux vaut tout passer en utf-8.

Malheureusement je ne suis plus sur Ubuntu en ce moment donc difficile de vous aider... regardez du côté de ces posts pour passer en utf-8 :
http://forum.ubuntu-fr.org/viewtopic.php?id=142082
http://forum.ubuntu-fr.org/viewtopic.php?id=179468

Hors ligne

#19 Le 30/01/2008, à 12:36

Adrienb1

Re : [résolu] NTFS externe et accents

Voici ce que donne mon locale :

adrien@laptop:~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:fr:en_GB:en
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=fr_FR.UTF-8


Je pense que ça vient d'autre chose ^

Hors ligne

#20 Le 30/01/2008, à 13:07

Florut

Re : [résolu] NTFS externe et accents

Autant pour moi je me suis embrouillé : la "vraie" solution est là  section "local issues". Je me souviens maintenant c'est ensuite que j'avais un problème avec l'encodage.


Bon voilà  la section pour vous éviter de chercher :

Locale issues

If you use KDE, you may have problem with filenames containing non-latin characters. This happens because kde's mounthelper is not parsing correctly the policies and locale option. There is a workaround for this:

1) Remove the "/sbin/mount.ntfs-3g" which is a symlink. code: rm /sbin/mount.ntfs-3g

2) Replace it with a new bash script containing:

#!/bin/bash
/bin/ntfs-3g $1 $2 -o locale=en_US.UTF-8 #put your own locale here

3) Make it executable: chmod +x /sbin/mount.ntfs-3g

There is only a problem with partition labels containing spaces, so if you have such a label, replace the space with an underscore, otherwise when you try to mount it you will get an error

Hors ligne

#21 Le 30/01/2008, à 17:24

Adrienb1

Re : [résolu] NTFS externe et accents

Merci beaucoup, ça fonctionne chez moi smile

Je précise qu'en plus des caractères accentués les caractères coréens et chinois passent aussi (sans doute aussi le reste) que ce soit en lecture ou en écriture.

Dernière modification par Adrienb1 (Le 30/01/2008, à 17:31)

Hors ligne

#22 Le 12/02/2008, à 21:39

Mederel

Re : [résolu] NTFS externe et accents

Merci infiniment wink
Je tourne sous Gentoo mais cette dernière manipulation fonctionne aussi et résoud enfin le problème.

#23 Le 17/02/2008, à 13:32

miraks

Re : [résolu] NTFS externe et accents

Effectivement ca fonctionne ! Merci !

Hors ligne

#24 Le 18/05/2008, à 13:02

Laloi

Re : [résolu] NTFS externe et accents

Florut a écrit :

Autant pour moi je me suis embrouillé : la "vraie" solution est là  section "local issues". Je me souviens maintenant c'est ensuite que j'avais un problème avec l'encodage.


Bon voilà  la section pour vous éviter de chercher :

Locale issues

If you use KDE, you may have problem with filenames containing non-latin characters. This happens because kde's mounthelper is not parsing correctly the policies and locale option. There is a workaround for this:

1) Remove the "/sbin/mount.ntfs-3g" which is a symlink. code: rm /sbin/mount.ntfs-3g

2) Replace it with a new bash script containing:

#!/bin/bash
/bin/ntfs-3g $1 $2 -o locale=en_US.UTF-8 #put your own locale here

3) Make it executable: chmod +x /sbin/mount.ntfs-3g

There is only a problem with partition labels containing spaces, so if you have such a label, replace the space with an underscore, otherwise when you try to mount it you will get an error

Merci pour la technique. Chez moi elle ne marchait pas avec Gutsy, mais elle fonctionne nickel avec Hardy.

Par contre changer le nom de la partition ne réglait pas le problème des espaces (pour choisir le point de montage il choisissait l'ancien nom de la aprtition). Pour régler ce problème, j'ai ajouté des guillemets autours de $2 big_smile

#25 Le 03/06/2008, à 19:36

no_name

Re : [résolu] NTFS externe et accents

Bonjour,

Je me permet un up du sujet parce que j'ai le même problème sous Kubuntu 8.04 avec un DD externe en ntfs et des fichiers accentués.

Apparement la solution a été trouvée donc Youpiiii.

Sauf que je suis sous Linux depuis le week-end dernier seulement et que je ne comprends pas ce qu'il faut faire.

Je ne suis pas réfractaire à la bidouille (je me débrouillais pas trop mal sous Windows) mais là je débute vraiment.

Quelqu'un aurait-il l'amabilité de m'expliquer plus clairement ce qu'il faut faire ?

En plus j'ai bien peur d'avoir le problème de l'espace dans la partition puisque mon DD externe est reconnu en tant que "OneTouch4 Mini".


Merci d'avance

Haut de page ↑