Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 02/04/2007, à 09:59

acouphenix

[Tuto] Installer LabView 8

Bonjour, je vous montre la démarche pour installer LabView 8 pour linux.

LabView est un logiciel de développement pour créer des interfaces de mesures par GPIB/LAN/USB par exemple.

Exemple : Une interface qui commande un oscilloscope et un voltmètre pour récupérer les courbes et les valeurs toutes les heures.

Bref, un logiciel qui nous facilite la vie.

Bon, je veux l'installer sous Linux mais le problème c'est que les packages sont sous la forme RPM donc suivant leur ReadMe, il faut Mandriva, OpenSuse, Fedora... Ah misère, faut installer ça en dual-boot.
En cherchant sur des forums, j'ai trouvé qu'on peut l'installer sur Ubuntu.

- Mettre le CD de LabView et allez dans son contenu.
- Avant de faire ./INSTALL, le script pense que rpm est dans /bin/rpm alors que dans ubuntu, il est dans /usr/bin/rpm. Donc il faut faire un lien symbolique.

sudo apt-get install rpm alien
sudo ln -s /usr/bin/rpm /usr/rpm

- Le script utilise libdb.so donc :

sudo apt-get install libdb1-compat

- Installons

sudo ./INSTALL

- Les choix par défaut sont sur 'y'. Pour les drivers NI-488.2 et VISA, je ne les installe pas car je ne les utilise pas sachant que les programme seront utilisés sur des stations windows.

- Une fois, l'installation faite. Si on lance LabView, il nous dit qu'il manque 'libOSMesa.so.4'

sudo apt-get install libosmesa6
sudo ln -s /usr/lib/libOSMesa32.so.6 /usr/lib/libOSMesa.so.4

Vous pouvez utiliser libOSMesa16.so.6 si ça bug au niveau de l'affichage.

Voilà, cela marche, faire un 'labview' pour lancer la bestiole.

PS : LabView est payant sous Linux donc pas très 'free'

Hors ligne

#2 Le 30/09/2007, à 17:36

zest

Re : [Tuto] Installer LabView 8

Bonjour,

Voici le message que j'obtiens quand je tente de lancer l'installation :

alain@hansel:~$ cd /media/cdrom0/
alain@hansel:/media/cdrom0$ sudo ./INSTALL 
Password:
sudo: unable to execute ./INSTALL: Permission denied
alain@hansel:/media/cdrom0$

A noter que la commande pour créer le lien symbolique que j'ai tapée :

sudo ln -s /usr/bin/rpm /bin/rpm

au lieu de :

sudo ln -s /usr/bin/rpm /usr/rpm

Je précise ma version d'Ubuntu : 7.04
et celle de Labview : Labview 8

Merci de votre aide

Dernière modification par zest (Le 04/10/2007, à 20:07)

Hors ligne

#3 Le 06/10/2007, à 18:24

RaphdeSavoie

Re : [Tuto] Installer LabView 8

Si il affiche permission denied, cela veut dire que le root ne peut pas executer le fichier. Pour corriger cela, j'ai tout copié sur mon disque dans un dossier, et changé les permissions d'install : sudo chmod 777 install (l'install est désormais lisible, modifiable et executable par tout le monde).

   Par contre j'ai un probleme, je viens d'installer labview, mais où le trouver ? Comment le lancer ? C'est assez frustrant ! Merci d'avance!

   Raph

#4 Le 09/10/2007, à 20:22

zest

Re : [Tuto] Installer LabView 8

J'ai copié tout le contenu du cd labview dans un dossier nommé "labview" sur le bureau. J'ai ensuite modifié les permissions de tout le contenu de ce dossier depuis le navigateur de fichiers en sélectionnant tous les fichiers puis clic-droit puis propriétés puis j'ai coché "Autoriser l'éxécution du fichier comme un programme" (je ne sais malheureusement pas comment faire tout ça en ligne de commande...:/)
Ensuite, retour à la ligne de commande ;

sudo ./INSTALL

Pour exécuter labview il m'a suffit de taper "labview" après avoir effectué comme l'a expliqué acouphenix plus haut :

sudo apt-get install libosmesa6
sudo ln -s /usr/lib/libOSMesa32.so.6 /usr/lib/libOSMesa.so.4

et enfin la fenêtre "Getting started" de Labview8 s'est affichée...

ps : chez moi le fichier labview est situé dans /usr/local/bin/
L'installation a créé les dossiers suivants dans /usr/local :
lv80 et natinst

Dernière modification par zest (Le 16/10/2007, à 18:22)

Hors ligne

#5 Le 18/06/2008, à 22:12

PenB

Re : [Tuto] Installer LabView 8

ben chez moi ça ne marche pas. Lors de l'installation ça me sort :

Proceed? [Ynq] 
Installing...
erreur: Dépendances requises:
	/bin/sh est nécessaire pour labview82-rte-8.2-1.i386
erreur: Dépendances requises:
	/bin/sh est nécessaire pour labview-rte-aal-1.1-1.i386
erreur: Dépendances requises:
	/bin/sh est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6 est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.0) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.1) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.1.2) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.1.3) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.2) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.2.4) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libc.so.6(GLIBC_2.3) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libdl.so.2 est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libdl.so.2(GLIBC_2.0) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libdl.so.2(GLIBC_2.1) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libgcc_s.so.1 est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libgcc_s.so.1(GCC_3.0) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libm.so.6 est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libpthread.so.0 est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libpthread.so.0(GLIBC_2.0) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libpthread.so.0(GLIBC_2.1) est nécessaire pour niwebpipeline20_dep-2.0-5.i586
	libz.so.1 est nécessaire pour niwebpipeline20_dep-2.0-5.i586
erreur: Dépendances requises:
	labview82-rte est nécessaire pour labview82-core-8.2-1.i386
	/bin/sh est nécessaire pour labview82-core-8.2-1.i386
	/bin/sh est nécessaire pour labview82-desktop-8.2-1.i386


Would you like to install NI Example Finder (LabVIEW 8.2)? [Ynq]

C'est bizarre car j'ai bien dash installé (qui ne l'a pas ?)
libc6 est installé. J'ai créé

$ sudo ln -s /usr/lib/libc.so /usr/lib/libc.so.6

je relance l'installation et il me resort que qu'il me manque libc.so.6

quelqu'un aurait-il la moindre idée


OS actuel : Fedora 16 avec un vrai Gnome 3 ^ ^
Ubuntiste de Ubuntu Breezy Badger 5.10 à Maverick Meerkat 10.10 et Windows définitivement supprimé depuis février 2006...

Hors ligne

#6 Le 29/01/2010, à 17:52

La Ligne Rouge

Re : [Tuto] Installer LabView 8

Je confirme également que cela ne semble plus être opérationnel sous Karmic 9.10 : j'ai essayé avec une version 8.2 fonctionnel (sous Ibex ou Jaunty) puis 8.6 et 8.5.
Chez moi, il me manque à chaque fois une librairie partagée "libbz2.so.1", le paquet libbz2 est pourtant bien installé sur Synaptic hmm. Il est vrai que je cumule également le fait d'être en 64 bits, c'est loin d'arranger la situation big_smile

Pour ton pb, certains paquets sont peut-être trop récents maintenant (glibc par exemple).
Essaye d'installer les paquets développement correspondants ou il te reste encore la méthode alien


"L'intelligence est la chose la mieux répartie chez l'homme puisque autant qu'il en soit pourvue, il a toujours l'impression d'en avoir assez, vu que c'est avec ça qu'y juge" Descartes revisité par Coluche

Natty Narwhal 64 bits sur Acer Aspire 5520 - NVIDIA GeForce 8400M G

Hors ligne

#7 Le 25/03/2010, à 20:46

zest

Re : [Tuto] Installer LabView 8

Pour installer LabView2009 sur karmic à partir du CD il faut tout d'abord réussir à lire le CD qui est une partition mac :

sudo mount -t hfsplus /dev/sr0 /media/cdrom

Ensuite on peut lancer l'installation :

cd /media/cdrom/Linux/labview_2009
sudo ./INSTALL

Après l'installation il faut démonter le CD avant de pourvoir l'éjecter :

sudo umount /media/cdrom

Pour les versions 64 bits l'install bloque avec un message d'erreur a propos de "libbz2.so.1". Il m'a suffit de créer un lien :

sudo ln /usr/lib32/libbz2.so.1.0 /usr/lib32/libbz2.so.1

puis de relancer l'installation comme indiqué ci-dessus.

Hors ligne

#8 Le 23/03/2012, à 16:33

zest

Re : [Tuto] Installer LabView 8

Pour installer Labview 2011 sous ubuntu 11.10  64 bit :

1/ monter le cd (partition mac) :

sudo mount -t hfsplus /dev/sr0 /media/cdrom

2/ créer un lien :

cd /usr/lib/
sudo ln -s ../lib32/libbz2.so.1.0 libbz2.so.1
sudo ldconfig

3/ lancer l'install :

sudo su -
cd /cdrom/linux/labview/
./INSTALL

Hors ligne

#9 Le 22/12/2012, à 16:04

adelghouari@hotmail.fr

Re : [Tuto] Installer LabView 8

salut a vous tous, mon probleme est tres compliqué, j'ai des instriments de mesures connectés a un PC bon juste, ici pour dire sous windows xp, via des ports de communication RS232 et 2 GPIB, les derniers temps j'ai ramacé cette application et j'ai mis ubuntu12.04, et j'ai commancer a charché pour trouver un moyen qui me permet de refaire l'application sous ubuntu12.04, j'ai trouvé beaucoup des idées, exemple rtlinux j'ai l'installé et ça marche, par ce que quand je vient de démmarer mon pc il me donne la possibilité pour faire un choix entre les plateformes win ou ubuntu ici il y a plusieurs versions l'une c'est real time linux, en effet, j'ai arrivé ici, j'ai trois choses a faire:
1- l'acquisition de données via RS232
2- l'acquisition de données via gpib (ici tout simplement on peut, pas par ce que la carte GPIB est très ancienne fonnctionne avec le connecteur ISA dans ce PC il est neveau il est équipé de connecteur PCI). mais bonne nouvelles j'ai récupéré une autres interface GPIB-USB (KUSB-488A KEITHLEY)), et j'ai telechargé le pilote linux-gpib-3.2.16 pour linux sur le site de KEITHLEY.
bon ce pilote c'est un dossier contient plusieur repartoires la vérité c'est très compliqué es ce que vous avez des idées des solution pour faire installer ce pilote sous ubuntu12.04.
merci a vous.

Hors ligne

#10 Le 29/10/2013, à 13:03

lverdier

Re : [Tuto] Installer LabView 8

Bonjour,
Pour ma part j'ai installé labview 2012 version linux sous Ubuntu et l'affichage est affreux, impossible d'y travailler car les caractères sont moches et petits. Quelqu'un a déjà eu ce problème ?

Hors ligne

#11 Le 05/11/2013, à 14:50

zest

Re : [Tuto] Installer LabView 8

Pour installer Labview 2012 sur ubuntu 13.10 64 bits :

Installer alien

sudo apt-get install alien

Monter le cd (partition mac) :

sudo mount -t hfsplus /dev/sr0 /cdrom

Installer la bibliothèque 32 bits lib32bz2-1.0 (seule la version 64 bits est installée par défaut)

sudo apt-get install lib32bz2-1.0

Créer un lien :

cd /lib/
sudo ln -s /usr/lib32/libbz2.so.1.0.4 libbz2.so.1
sudo ldconfig

Lancer l'install :

cd /cdrom/linux/labview/
sudo ./INSTALL

Après l'install de LabView il faut installer la version 32 bits de libXinerama :

sudo apt-get install libxinerama1:i386

Enfin LabView peut démarrer.

Dernière modification par zest (Le 19/11/2013, à 20:41)

Hors ligne

#12 Le 05/11/2013, à 19:22

zest

Re : [Tuto] Installer LabView 8

Pour régler les problèmes d'affichage il faut installer des fontes supplémentaires :

sudo apt-get install xfonts-75dpi xfonts-100dpi

et peut-être :

sudo apt-get install xfonts-75dpi-transcoded xfonts-100dpi-transcoded

puis redémarrer avant de lancer LabView

Dernière modification par zest (Le 19/11/2013, à 20:38)

Hors ligne

Haut de page ↑