Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 02/11/2013, à 13:11

toma

Imprimante Brother sur ubuntu 13.10 amd64

Bonjour,

Quelqu'un a-t-il réussi à installer une imprimante Brother sur Saucy Salamander en 64 bits ? Je n'avais eu aucun problème sur les anciennes versions d'ubuntu mais là ça bloque à cause des dépendances x86. Sur les versions antérieures le paquet ia32-libs semblait résoudre les problèmes, mais il n'existe plus. Il faut maintenant utiliser multiarch qui ne semble pas gérer les dépendances, par exemple libc6 ici :

$ sudo dpkg -i --force-all dcp7070dwlpr-2.1.0-1.i386.deb
Selecting previously unselected package dcp7070dwlpr.
(Reading database ... 210830 files and directories currently installed.)
Unpacking dcp7070dwlpr (from dcp7070dwlpr-2.1.0-1.i386.deb) ...
dpkg: dcp7070dwlpr: dependency problems, but configuring anyway as you requested:
 dcp7070dwlpr depends on libc6 (>= 2.3.4-1).

Setting up dcp7070dwlpr (2.1.0-1) ...
/var/lib/dpkg/info/dcp7070dwlpr.postinst: 3: /var/lib/dpkg/info/dcp7070dwlpr.postinst: /usr/local/Brother/Printer/DCP7070DW/inf/braddprinter: not found

Du coup je ne peux plus rien installer :

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 dcp7070dwlpr:i386 : Depends: libc6:i386 (>= 2.3.4-1) but it is not installed
E: Unmet dependencies. Try using -f.

Mais surtout ça n'imprime pas ! Les drivers ont bien l'air installés avec

$ sudo dpkg -l | grep Brother

mais ils ne fonctionnent pas. Ce qui n'est pas très étonnant vu les dépendances manquantes. J'ai désinstaller les drivers en attendant, mais j'aimerais bien utiliser mon imprimante...

Quelqu'un aurait-il une solution (à part réinstaller ubuntu en 32 bits ?)


... when you look long into an abyss, the abyss also looks into you.
-- Friedrich Nietzsch

Hors ligne

#2 Le 02/11/2013, à 13:48

alca94

Re : Imprimante Brother sur ubuntu 13.10 amd64

bonjour
Commencer par tout désinstaller en vous aidant de ces topics
post 2 ici
http://forum.ubuntu-fr.org/viewtopic.php?id=1383771
ou post 22 ici
http://forum.ubuntu-fr.org/viewtopic.php?id=734891&p=1
puis réinstaller a partir de ce script
http://forum.ubuntu-fr.org/viewtopic.php?id=652931

Hors ligne

#3 Le 02/11/2013, à 19:23

toma

Re : Imprimante Brother sur ubuntu 13.10 amd64

Merci pour ta réponse mais le script ne fonctionne pas car il a besoin de ia32-libs qui n'est plus disponible sur ubuntu 13.10. Étrangement il n'y a pas d'erreurs dans la suite du script, mais quand je demande une impression rien ne se passe.

Installation du paquet : ia32-libs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5 lib32bz2-1.0

Création du dossier : /var/spool/lpd
Installation des pilotes de l'imprimante
Téléchargement du fichier : dcp7070dwlpr-2.1.0-1.i386.deb
--2013-11-02 18:10:54--  http://www.brother.com/pub/bsc/linux/dlf/dcp7070dwlpr-2.1.0-1.i386.deb
Résolution de www.brother.com (www.brother.com)... 217.89.107.32, 217.89.107.33
Connexion vers www.brother.com (www.brother.com)|217.89.107.32|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Taille : 34954 (34K) [text/plain]
Enregistre : «./Packages/dcp7070dwlpr-2.1.0-1.i386.deb»

100%[=====================================================================================================>] 34 954      --.-K/s   ds 0,05s   

2013-11-02 18:10:54 (641 KB/s) - «./Packages/dcp7070dwlpr-2.1.0-1.i386.deb» enregistré [34954/34954]

Installation du fichier : dcp7070dwlpr-2.1.0-1.i386.deb
Sélection du paquet dcp7070dwlpr précédemment désélectionné.
(Lecture de la base de données... 214230 fichiers et répertoires déjà installés.)
Dépaquetage de dcp7070dwlpr (à partir de .../dcp7070dwlpr-2.1.0-1.i386.deb) ...
Paramétrage de dcp7070dwlpr (2.1.0-1) ...
Téléchargement du fichier : cupswrapperDCP7070DW-2.0.4-2.i386.deb
--2013-11-02 18:10:55--  http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7070DW-2.0.4-2.i386.deb
Résolution de www.brother.com (www.brother.com)... 217.89.107.33, 217.89.107.32
Connexion vers www.brother.com (www.brother.com)|217.89.107.33|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Taille : 13358 (13K) [text/plain]
Enregistre : «./Packages/cupswrapperDCP7070DW-2.0.4-2.i386.deb»

100%[=====================================================================================================>] 13 358      --.-K/s   ds 0,01s   

2013-11-02 18:10:55 (1,21 MB/s) - «./Packages/cupswrapperDCP7070DW-2.0.4-2.i386.deb» enregistré [13358/13358]

Installation du fichier : cupswrapperDCP7070DW-2.0.4-2.i386.deb
Sélection du paquet cupswrapperdcp7070dw précédemment désélectionné.
(Lecture de la base de données... 214247 fichiers et répertoires déjà installés.)
Dépaquetage de cupswrapperdcp7070dw (à partir de .../cupswrapperDCP7070DW-2.0.4-2.i386.deb) ...
Paramétrage de cupswrapperdcp7070dw (2.0.4-2) ...
 * Restarting Common Unix Printing System: cupsd                         [ OK ] 
Installation des pilotes du scanner
Téléchargement du fichier : brscan4-0.4.1-4.amd64.deb
--2013-11-02 18:10:58--  http://www.brother.com/pub/bsc/linux/dlf/brscan4-0.4.1-4.amd64.deb
Résolution de www.brother.com (www.brother.com)... 217.89.107.33
Connexion vers www.brother.com (www.brother.com)|217.89.107.33|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Taille : 72076 (70K) [text/plain]
Enregistre : «./Packages/brscan4-0.4.1-4.amd64.deb»

100%[=====================================================================================================>] 72 076       311KB/s   ds 0,2s   

2013-11-02 18:10:58 (311 KB/s) - «./Packages/brscan4-0.4.1-4.amd64.deb» enregistré [72076/72076]

Installation du fichier : brscan4-0.4.1-4.amd64.deb
Sélection du paquet brscan4 précédemment désélectionné.
(Lecture de la base de données... 214253 fichiers et répertoires déjà installés.)
Dépaquetage de brscan4 (à partir de .../brscan4-0.4.1-4.amd64.deb) ...
Paramétrage de brscan4 (0.4.1-4) ...
This software is based in part on the work of the Independent JPEG Group.

... when you look long into an abyss, the abyss also looks into you.
-- Friedrich Nietzsch

Hors ligne

#4 Le 02/11/2013, à 19:32

alca94

Re : Imprimante Brother sur ubuntu 13.10 amd64

pour le 64 bits il faut dans sources de logiciels activé le dépots "universe" vous l'aviez fait avant soit

Il faut activer les dépôts adéquats dans "Sources de logiciels" (Logithèque ----> Editions ---> sources de logiciels )
Onglets "Logiciels Ubuntu"  les 4 (main-universe-restricted-multiverse) sauf cd-rom
Onglets "Autres Logiciels"   les 4  (Partenaire x2 - Indépendants x2)
Onglets "Mise à jour"           les 3  (security-updates-backport) surtout pas "proposed" (version de test ; sauf si vous savez ce que vous faites!)

De plus il faut que l'imprimante soit Allumée et Connectée (sauf sur de l'USB 3 de couleur bleue)et lancez le script
il faut mieux recommencer en désinstallant le script avec

for i in $(dpkg -l | grep -i brother | awk '{print $2}'); do sudo dpkg -P $i; done

Hors ligne

#5 Le 02/11/2013, à 22:14

toma

Re : Imprimante Brother sur ubuntu 13.10 amd64

Bon finalement, ça fonctionne. J'ai résolu le problème des dépendances avec cette commande :

sudo apt-get install libc6:i386

Par contre j'ai eu un nouveau problème avec l'installation de l'imprimante, ça bugguait au moment de choisir pilotes local au lieu de gutenprint (de mémoire) du coup j'ai utilisé la détection automatique de l'imprimante et comme ça j'ai pu choisir mon driver.

Merci alca94 pour ton aide.


... when you look long into an abyss, the abyss also looks into you.
-- Friedrich Nietzsch

Hors ligne

#6 Le 11/11/2013, à 15:40

salival

Re : Imprimante Brother sur ubuntu 13.10 amd64

Salut, j'ai le même problème que toi. Installation impossible, imprimante et scanner, même en installant libc6:i386, et en suivant le post de demonipuch.
Pour tant jusqu'à la 13.04 64 bits tout fonctionnait à merveille. C'est pas très pratique d'avoir supprimé ia32-libs ! Ça servait beaucoup, et beaucoup de programmes pas encore à jour, ou plus maintenus s'en servent.

EDIT: c'est bon ça marche, j'avais mal copié les librairies !

Dernière modification par salival (Le 11/11/2013, à 16:21)


"Il ne faut jamais prendre les gens pour des cons, mais il ne faut pas oublier qu'ils le sont."  Les Inconnus

Hors ligne

#7 Le 25/12/2013, à 23:40

Nicky Lardon

Re : Imprimante Brother sur ubuntu 13.10 amd64

Salut à vous,

Il faut installer un dépôt sur lequel ce trouve ia32-libs il ne vous demandera pas de dépendances et passera à l’installation.
La solution proposé ]ici a fonctionné pour moi. 

Here is a workaround using ia32-libs from a previous distribution (13.04). This has been tested with the release candidate of 13.10 and all is well and functional.

    Install Synaptic from terminal window
    sudo apt-get install synaptic
    Launch synaptic and goto “settings > Repositories”
    click “other software > add”
    insert this line in the box "deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse"
    click ok and close synaptic
    in terminal “sudo apt-get update”
    in terminal “sudo apt-get install ia32-libs”

Bonne chance.

Dernière modification par Nicky Lardon (Le 25/12/2013, à 23:40)


_Netbook Clevo M1115 [4*Intel(R) Atom(TM) CPU N570   @ 1.66GHz, DDR3  2Go,Intel D4xxx Integrated Graphics Controller.]
> Ubuntu 12.04.2 64bit, Xfce 4.8.
_Portable LDLC (Clevo) Saturne SB6-I5-8-H5S1 : [Intel Core i5-3230M, DDR3 8 Go, NVIDIA GeForce GTX 660M]
>Xubuntu 14.04 64bits, Dual boot windows7.

Hors ligne

Haut de page ↑