Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 16/12/2013, à 22:46

dudukun

[Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Bonjour à tous,

Ce sont mes débuts sur ce forum, et je viens avec un joli problème.
J'essaye d'installer Ubuntu sur mon pc portable (reçu il y a 4 jours), un Dell XPS 15. Pas de lecteur CD oblige, j'ai tenté l'option Live USB (avec Linux Live USB creator), avec deux iso différents:

- linux-secure-13.04-64bit : ici le problème est simple puisqu'après avoir sélectionné le démarrage sur la clé USB, un écran noir s'affiche où il est marqué "Minimal BASH-like line editing is supported. For the forst word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.
grub>"
.

- ubuntu-12.04.3-desktop-amd64 : là j'arrive jusqu'à l'installation, mais elle bloque à la fin à cause d'un problème dû à GRUB.

Il semblerait que le problème vienne donc de GRUB ; pourquoi? et comment y remédier?

Deux choses à savoir que j'ai fait pendant ces 3 jours pendant lesquels j'ai galéré :

- la première est que Windows 8 était installé lors de la réception du pc, mais il ne l'est plus puisque lors de la tentative d'installation avec ubuntu-12.04.3-desktop-amd64 j'ai voulu remplacer Windows par Ubuntu (puis problème avant la fin de l'installation);
- la deuxième est que je suis obligé d'insérer dans les lignes de commandes (accessibles lorsqu'on nous laisse le choix entre un essai d'Ubuntu sans l'installer ou l'installation) "nomodeset", sinon l'écran s'éteint (un problème avec Nvidia Optimus qui n'ai pas apprécié par Linux apparemment).

J'ai un doute sur la clarté de mon message, mais je vous avoue qu'en ayant galéré pendant trois jours sans trop avoir avancé, je ne sais plus trop ce qu'il est important de mentionner.

Par avance merci.

dudukun

Dernière modification par dudukun (Le 17/12/2013, à 20:02)

Hors ligne

#2 Le 17/12/2013, à 11:08

malbo

Re : [Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Bonjour,
Il y a plusieurs modèles Dell XPS 15 dans la Liste des portables « Dell », je suppose que le tien est un modèle plus récent : peux-tu préciser le nom complet du modèle comme on peut voir dans la liste (du genre "XPS 15 (L521X)") ?

EDIT : dans ce post, jeffus énumère tout ce qu'il a dû faire pour être en mesure d'installer Ubuntu dans son Dell XPS 15 mais c'est peut-être un modèle différent du tien. Comme il a réussi avec Ubuntu 13.10, ce serait bien que tu te limites à tenter d'installer Ubuntu 13.10. Je propose une recette pour réussir une liveUSB Ubuntu 13.10 ici : http://forum.ubuntu-fr.org/viewtopic.ph … #p15304131

Dernière modification par malbo (Le 17/12/2013, à 11:18)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#3 Le 17/12/2013, à 19:59

dudukun

Re : [Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Bonsoir malbo,

Tout d'abord, merci d'avoir répondu si vite.
En effet c'est un modèle tout récent, c'est le XPS 15 9530.

J'ai continué  a galéré une bonne partie de la nuit sur ce problème, et j'ai fais une tentative, sans y croire vraiment, avec la version 13.10 d'Ubuntu. Et ça a marché! L'installation a fonctionné, le wifi fonctionne (ce qui n'était pas le cas en mode live avec les autres versions), ...
C'est juste un petit peu capricieux au démarage, puisque il lui arrive de rester bloqué au tout début du démarrage (page noir avec le logo Dell au centre), mais je pense que le plus dûr est fait.

En tout cas merci d'avoir répondu si rapidement, à quelques heures près tu aurais été mon sauveur malbo!

Hors ligne

#4 Le 17/12/2013, à 20:14

malbo

Re : [Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Pourrais-tu poster l'URL de ton Boot-Info : http://doc.ubuntu-fr.org/tutoriel/boot-info
Au lieu de faire ce Boot-Info depuis une session live comme proposé à l'étape 1, je te prie de le faire depuis ta session du Ubuntu installé.
cela permettra de donner un exemple d'installation réussie pour ceux qui ont le même modèle que toi.

Dernière modification par malbo (Le 17/12/2013, à 20:17)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 17/12/2013, à 20:48

dudukun

Re : [Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Et voici:
http://paste.ubuntu.com/6590489/

En espèrant que ça puisse éviter à des personnes les jours désespérant que j'ai vécu dernièrement!

Hors ligne

#6 Le 17/12/2013, à 20:55

malbo

Re : [Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Ton Boot-Info est là :

 Boot Info Script e7fc706 + Boot-Repair extra info      [Boot-Info 8Dec2013]


============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  According to the info in the boot sector, sda1 starts 
                       at sector 0. But according to the info from fdisk, 
                       sda1 starts at sector 2048.
    Operating System:  
    Boot files:        /EFI/ubuntu/MokManager.efi /EFI/ubuntu/grubx64.efi 
                       /EFI/ubuntu/shimx64.efi

sda2: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 13.10 
    Boot files:        /boot/grub/grub.cfg /etc/fstab

sda3: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 512.1 GB, 512110190592 bytes
255 heads, 63 sectors/track, 62260 cylinders, total 1000215216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1 1,000,215,215 1,000,215,215  ee GPT


GUID Partition Table detected.

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048       999,423       997,376 EFI System partition
/dev/sda2         999,424   966,858,751   965,859,328 Data partition (Linux)
/dev/sda3     966,858,752 1,000,214,527    33,355,776 Swap partition (Linux)

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/sda1        0C43-94DF                              vfat       
/dev/sda2        93963e6b-a733-4254-979b-3be2d6897939   ext4       
/dev/sda3        0e9ffdc5-1825-4aad-819f-1f9abe021e86   swap       

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda1        /boot/efi                vfat       (rw)
/dev/sda2        /                        ext4       (rw,errors=remount-ro)


=========================== sda2/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  93963e6b-a733-4254-979b-3be2d6897939
else
  search --no-floppy --fs-uuid --set=root 93963e6b-a733-4254-979b-3be2d6897939
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
  clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="${1}"
	if [ "${1}" = "keep" ]; then
		set vt_handoff=vt.handoff=7
	else
		set vt_handoff=
	fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-93963e6b-a733-4254-979b-3be2d6897939' {
recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  93963e6b-a733-4254-979b-3be2d6897939
	else
	  search --no-floppy --fs-uuid --set=root 93963e6b-a733-4254-979b-3be2d6897939
	fi
	linux	/boot/vmlinuz-3.11.0-14-generic.efi.signed root=UUID=93963e6b-a733-4254-979b-3be2d6897939 ro   quiet splash $vt_handoff
	initrd	/boot/initrd.img-3.11.0-14-generic
}
submenu 'Advanced options for Ubuntu' $menuentry_id_option 'gnulinux-advanced-93963e6b-a733-4254-979b-3be2d6897939' {
	menuentry 'Ubuntu, with Linux 3.11.0-14-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.0-14-generic-advanced-93963e6b-a733-4254-979b-3be2d6897939' {
	recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt2'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  93963e6b-a733-4254-979b-3be2d6897939
		else
		  search --no-floppy --fs-uuid --set=root 93963e6b-a733-4254-979b-3be2d6897939
		fi
		echo	'Loading Linux 3.11.0-14-generic ...'
		linux	/boot/vmlinuz-3.11.0-14-generic.efi.signed root=UUID=93963e6b-a733-4254-979b-3be2d6897939 ro   quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-3.11.0-14-generic
	}
	menuentry 'Ubuntu, with Linux 3.11.0-14-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.0-14-generic-recovery-93963e6b-a733-4254-979b-3be2d6897939' {
	recordfail
		load_video
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt2'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  93963e6b-a733-4254-979b-3be2d6897939
		else
		  search --no-floppy --fs-uuid --set=root 93963e6b-a733-4254-979b-3be2d6897939
		fi
		echo	'Loading Linux 3.11.0-14-generic ...'
		linux	/boot/vmlinuz-3.11.0-14-generic.efi.signed root=UUID=93963e6b-a733-4254-979b-3be2d6897939 ro recovery nomodeset 
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-3.11.0-14-generic
	}
	menuentry 'Ubuntu, with Linux 3.11.0-12-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.0-12-generic-advanced-93963e6b-a733-4254-979b-3be2d6897939' {
	recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt2'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  93963e6b-a733-4254-979b-3be2d6897939
		else
		  search --no-floppy --fs-uuid --set=root 93963e6b-a733-4254-979b-3be2d6897939
		fi
		echo	'Loading Linux 3.11.0-12-generic ...'
		linux	/boot/vmlinuz-3.11.0-12-generic root=UUID=93963e6b-a733-4254-979b-3be2d6897939 ro   quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-3.11.0-12-generic
	}
	menuentry 'Ubuntu, with Linux 3.11.0-12-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.0-12-generic-recovery-93963e6b-a733-4254-979b-3be2d6897939' {
	recordfail
		load_video
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt2'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  93963e6b-a733-4254-979b-3be2d6897939
		else
		  search --no-floppy --fs-uuid --set=root 93963e6b-a733-4254-979b-3be2d6897939
		fi
		echo	'Loading Linux 3.11.0-12-generic ...'
		linux	/boot/vmlinuz-3.11.0-12-generic root=UUID=93963e6b-a733-4254-979b-3be2d6897939 ro recovery nomodeset 
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-3.11.0-12-generic
	}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ "x${timeout}" != "x-1" ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
	fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
--------------------------------------------------------------------------------

=============================== sda2/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=93963e6b-a733-4254-979b-3be2d6897939 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=0C43-94DF  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sda3 during installation
UUID=0e9ffdc5-1825-4aad-819f-1f9abe021e86 none            swap    sw              0       0
--------------------------------------------------------------------------------

=================== sda2: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)


=============================== StdErr Messages: ===============================

cat: /tmp/BootInfo-c02KrZt8/Tmp_Log: No such file or directory

ADDITIONAL INFORMATION :
=================== log of boot-repair 2013-12-17__20h25 ===================
boot-repair version : 3.199~ppa39~saucy
boot-sav version : 3.199~ppa39~saucy
glade2script version : 3.2.2~ppa47~saucy
boot-sav-extra version : 3.199~ppa39~saucy
boot-repair is executed in installed-session (Ubuntu 13.10, saucy, Ubuntu, x86_64)
CPU op-mode(s):        32-bit, 64-bit
BOOT_IMAGE=/boot/vmlinuz-3.11.0-14-generic.efi.signed root=UUID=93963e6b-a733-4254-979b-3be2d6897939 ro quiet splash vt.handoff=7

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


=================== os-prober:
/dev/sda2:The OS now in use - Ubuntu 13.10 CurrentSession:linux

=================== blkid:
/dev/sda1: UUID="0C43-94DF" TYPE="vfat"
/dev/sda2: UUID="93963e6b-a733-4254-979b-3be2d6897939" TYPE="ext4"
/dev/sda3: UUID="0e9ffdc5-1825-4aad-819f-1f9abe021e86" TYPE="swap"


1 disks with OS, 1 OS : 1 Linux, 0 MacOS, 0 Windows, 0 unknown type OS.


WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util sfdisk doesn't support GPT. Use GNU Parted.


WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


=================== /etc/grub.d/ :
drwxr-xr-x  2 root root    4096 déc.  16 23:43 grub.d
total 72
-rwxr-xr-x 1 root root  7850 oct.  10 19:48 00_header
-rwxr-xr-x 1 root root  5949 août  15 10:26 05_debian_theme
-rwxr-xr-x 1 root root 11479 oct.  10 19:48 10_linux
-rwxr-xr-x 1 root root 10258 oct.  10 19:48 20_linux_xen
-rwxr-xr-x 1 root root  1798 juin  17  2013 20_memtest86+
-rwxr-xr-x 1 root root 11531 oct.  10 19:48 30_os-prober
-rwxr-xr-x 1 root root  1426 oct.  10 19:48 30_uefi-firmware
-rwxr-xr-x 1 root root   214 oct.  10 19:48 40_custom
-rwxr-xr-x 1 root root   216 oct.  10 19:48 41_custom
-rw-r--r-- 1 root root   483 oct.  10 19:48 README




=================== /etc/default/grub :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"



/boot/efi detected in the fstab of sda2: UUID=0C43-94DF   (sda1)

efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0004
Boot0002* ubuntu	HD(1,800,f3800,f40c111f-fcc5-460a-87b8-2b25ea249ac3)File(EFIubuntushimx64.efi)
Boot0004* Ubuntu	HD(1,800,f3800,f40c111f-fcc5-460a-87b8-2b25ea249ac3)File(EFIUbuntugrubx64.efi)
=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot enabled.


=================== PARTITIONS & DISKS:
sda2	: sda,	not-sepboot,	grubenv-ok	grub2,	signed grub-efi ,	update-grub,	64,	with-boot,	is-os,	not--efi--part,	fstab-without-boot,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot,	apt-get,	grub-install,	with--usr,	fstab-without-usr,	not-sep-usr,	standard,	farbios,	.
sda1	: sda,	not-sepboot,	no-grubenv	nogrub,	no-docgrub,	no-update-grub,	32,	no-boot,	no-os,	is-correct-EFI,	part-has-no-fstab,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot,	nopakmgr,	nogrubinstall,	no---usr,	part-has-no-fstab,	not-sep-usr,	standard,	not-far,	/boot/efi.

sda	: GPT,	no-BIOS_boot,	has-correctEFI, 	not-usb,	has-os,	2048 sectors * 512 bytes


=================== parted -l:

Model: ATA SAMSUNG SSD SM84 (scsi)
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system     Name  Flags
1      1049kB  512MB  511MB   fat32                 boot
2      512MB   495GB  495GB   ext4
3      495GB   512GB  17.1GB  linux-swap(v1)

=================== parted -lm:

BYT;
/dev/sda:512GB:scsi:512:512:gpt:ATA SAMSUNG SSD SM84;
1:1049kB:512MB:511MB:fat32::boot;
2:512MB:495GB:495GB:ext4::;
3:495GB:512GB:17.1GB:linux-swap(v1)::;


=================== mount:
/dev/sda2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /sys/firmware/efi/efivars type efivarfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sda1 on /boot/efi type vfat (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=damien)


=================== ls:
/sys/block/sda (filtered):  alignment_offset bdi capability dev device discard_alignment events events_async events_poll_msecs ext_range holders inflight power queue range removable ro sda1 sda2 sda3 size slaves stat subsystem trace uevent
/dev (filtered):  autofs block bsg btrfs-control bus char console core cpu cpu_dma_latency disk dri ecryptfs fb0 fd full fuse hidraw0 hidraw1 hidraw2 hpet input kmsg kvm log mapper mcelog mei mem net network_latency network_throughput null port ppp psaux ptmx pts random rfkill rtc rtc0 sda sda1 sda2 sda3 sg0 shm snapshot snd stderr stdin stdout tpm0 uhid uinput urandom usb v4l vga_arbiter vhost-net video0 zero
ls /dev/mapper:  control
ls /boot/efi/1:

=================== hexdump -n512 -C /dev/sda1
00000000  eb 58 90 6d 6b 64 6f 73  66 73 00 00 02 08 20 00  |.X.mkdosfs.... .|
00000010  02 00 00 00 00 f8 00 00  3f 00 ff 00 00 00 00 00  |........?.......|
00000020  00 38 0f 00 d0 03 00 00  00 00 00 00 02 00 00 00  |.8..............|
00000030  01 00 06 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000040  00 01 29 df 94 43 0c 4e  4f 20 4e 41 4d 45 20 20  |..)..C.NO NAME  |
00000050  20 20 46 41 54 33 32 20  20 20 0e 1f be 77 7c ac  |  FAT32   ...w|.|
00000060  22 c0 74 0b 56 b4 0e bb  07 00 cd 10 5e eb f0 32  |".t.V.......^..2|
00000070  e4 cd 16 cd 19 eb fe 54  68 69 73 20 69 73 20 6e  |.......This is n|
00000080  6f 74 20 61 20 62 6f 6f  74 61 62 6c 65 20 64 69  |ot a bootable di|
00000090  73 6b 2e 20 20 50 6c 65  61 73 65 20 69 6e 73 65  |sk.  Please inse|
000000a0  72 74 20 61 20 62 6f 6f  74 61 62 6c 65 20 66 6c  |rt a bootable fl|
000000b0  6f 70 70 79 20 61 6e 64  0d 0a 70 72 65 73 73 20  |oppy and..press |
000000c0  61 6e 79 20 6b 65 79 20  74 6f 20 74 72 79 20 61  |any key to try a|
000000d0  67 61 69 6e 20 2e 2e 2e  20 0d 0a 00 00 00 00 00  |gain ... .......|
000000e0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
00000200

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


=================== df -Th:

Filesystem     Type      Size  Used Avail Use% Mounted on
/dev/sda2      ext4      454G  5.2G  425G   2% /
none           tmpfs     4.0K     0  4.0K   0% /sys/fs/cgroup
udev           devtmpfs  7.8G  8.0K  7.8G   1% /dev
tmpfs          tmpfs     1.6G  1.3M  1.6G   1% /run
none           tmpfs     5.0M     0  5.0M   0% /run/lock
none           tmpfs     7.8G  244K  7.8G   1% /run/shm
none           tmpfs     100M   48K  100M   1% /run/user
/dev/sda1      vfat      487M  3.3M  483M   1% /boot/efi

=================== fdisk -l:

Disk /dev/sda: 512.1 GB, 512110190592 bytes
255 heads, 63 sectors/track, 62260 cylinders, total 1000215216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1000215215   500107607+  ee  GPT


EFI detected. Please check the options.
=================== Final advice in case of recommended repair
Please do not forget to make your BIOS boot on sda1/efi/.../grub*.efi file!

The boot files of [The OS now in use - Ubuntu 13.10] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (https://help.ubuntu.com/community/BootPartition)

=================== Default settings
Recommended-Repair
This setting would reinstall the grub-efi-amd64-signed of sda2, using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s

=================== Settings chosen by the user
Boot-Info
This setting will not act on the MBR.



No change has been performed on your computer.

C'est une installation en mode EFI de Ubuntu. Dommage que tu aies viré Windows 8 parce que je pense que les deux OS auraient pu cohabiter, tous les deux installés en mode EFI . C'est peut-être possible de l'installer après Ubuntu mais je ne suis pas trop sûr que ce soit possible. Autrement dit, si tu as l'intention de réinstaller un jour Windows 8 là-dedans, ce serait mieux de le faire tout de suite (oui, je sais tu as déjà beaucoup souffert...)

EDIT : j'ai ajouté le modèle XPS 15 (9530) dans la Liste des portables « Dell »

Dernière modification par malbo (Le 17/12/2013, à 21:10)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#7 Le 17/12/2013, à 21:12

dudukun

Re : [Résolu] Problème (Grub) lors de l'installation d'Ubuntu

Les deux auraient surement pu cohabiter, mais je ne vois pas l'utilité, dans mon cas, de garder Windows 8 (puis comme tu le dis si bien, j'ai assez souffert pour le moment...).
Peut-être un jour aurai-je besoin de le réinstaller, mais pour l'instant je vais plus me concentrer à régler les problèmes de démarrage (ou même de redémarrage je devrais dire, puisque j'ai remarqué que ça plantait surtout pendant les redémarrage).

Hors ligne

Haut de page ↑