Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 18/12/2013, à 20:47

crocoscore

Problème réinstallation lamp

Bonsoir, je voulais refaire une installation "propre" d'un serveur lamp. Pour commencer, j'ai désinstaller 1 par 1 tous les paquets et leurs dépendances (avec apt-get purge) et, à la main j'ai supprimé tous les dossiers du système portant le nom apache, php ou mysql.

Mais en réinstallant, voici ce qui s'affiche :

theophile@theophile-Satellite-Pro-L300:~$ sudo apt-get install apache2 php5 mysql-server libapache2-mod-php5 php5-mysql
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
apache2 est déjà la plus récente version disponible.
libapache2-mod-php5 est déjà la plus récente version disponible.
mysql-server est déjà la plus récente version disponible.
php5 est déjà la plus récente version disponible.
php5-mysql est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
6 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
Paramétrage de mysql-server-5.5 (5.5.34-0ubuntu0.13.10.1) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: erreur de traitement de mysql-server-5.5 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Paramétrage de php5-cli (5.5.3+dfsg-1ubuntu2.1) ...
Error: The new file /usr/share/php5/php.ini-production does not exist!
dpkg: erreur de traitement de php5-cli (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg: des problèmes de dépendances empêchent la configuration de php5-readline :
 php5-readline dépend de php5-cli (= 5.5.3+dfsg-1ubuntu2.1) ; cependant :
 Le paquet php5-cli n'est pas encore configuré.

dpkg: erreur de traitement de php5-readline (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Paramétrage de libapache2-mod-php5 (5.5.3+dfsg-1ubuntu2.1) ...
Error: The new file /usr/share/php5/php.ini-production does not exist!
dpkg: erreur de traitement de libapache2-mod-php5 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: erreur de traitement de mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg: des problèmes de dépendances empêchent la configuration de php5 :
 php5 dépend de libapache2-mod-php5 (>= 5.5.3+dfsg-1ubuntu2.1) | libapache2-mod-php5filter (>= 5.5.3+dfsg-1ubuntu2.1) | php5-cgi (>= 5.5.3+dfsg-1ubuntu2.1) | php5-fpm (>= 5.5.3+dfsg-1ubuntu2.1) ; cependant :
 Le paquet libapache2-mod-php5 n'est pas encore configuré.
  Le paquet libapache2-mod-php5filter n'est pas installé.
  Le paquet php5-cgi n'est pas installé.
  Le paquet php5-fpm n'est pas installé.

dpkg: erreur de traitement de php5 (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.5
 php5-cli
 php5-readline
 libapache2-mod-php5
 mysql-server
 php5
E: Sub-process /usr/bin/dpkg returned an error code (1)
theophile@theophile-Satellite-Pro-L300:~$ dkpg --configure
Commande 'dkpg' non trouvée, vouliez-vous dire :
 La commande 'dpkg' du paquet 'dpkg' (main)
dkpg : commande introuvable

Que faire ? Merci d'avance.


L'Open Source vaincra !

Hors ligne

#2 Le 18/12/2013, à 22:39

pires57

Re : Problème réinstallation lamp

Avec

dkpg

c'est clair que tu auras pas de résultat, la commande c'est

dpkg

le message d'erreur est clair.


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.

Hors ligne

#3 Le 19/12/2013, à 13:34

crocoscore

Re : Problème réinstallation lamp

Ah oui, j'avais pas fait attention que j'avais aussi mis cette partie, ce n'était pas volontaire. Donc d'après toi si je tape dpkg --configure, ça devrait résoudre les problèmes ?


L'Open Source vaincra !

Hors ligne

#4 Le 19/12/2013, à 13:51

bruno

Re : Problème réinstallation lamp

Tu peux essayer :

dpkg --configure -a

mais, à mon avis avis cela ne résoudra pas tes problèmes : mysql refuse de se lancer, et problèmes de dépendances avec php…

Hors ligne

#5 Le 19/12/2013, à 13:52

crocoscore

Re : Problème réinstallation lamp

Ma désinstallation a peut-être été un peu brutale, je reconnais... J'essaie

dpkg --configure -a

ce soir et je vous dis ce qu'il en ai.

Sinon, obligé de réinstaller l'OS ?


L'Open Source vaincra !

Hors ligne

#6 Le 19/12/2013, à 14:31

compte supprimé x0

Re : Problème réinstallation lamp

crocoscore a écrit :

...et, à la main j'ai supprimé tous les dossiers du système portant le nom apache, php ou mysql.

Ça, c'est une très mauvaise idée... Et il se peut bien que tu sois obligé de réinstaller le système (attends confirmation, quand même).

man apt-get a écrit :

apt-get purge
La commande purge est identique à remove mais les paquets indiqués sont supprimés et purgés (leurs fichiers de configuration sont également effacés).

Donc avec ça, le nécessaire a été fait. La seule nuance est que s'il y a des configurations dans /home/user, donc des configurations spécifiques à chaque utilisateur, celles-là ne sont pas effacées. Mais ça s'applique surtout à des logiciels "ordinaires", genre lecteur multi-média où chaque utilisateur peut définir ses propres trucs, pas à des logiciels "système", comme apache...

Dernière modification par Dr. Hugo Z. Hackenbush (Le 19/12/2013, à 14:33)

#7 Le 19/12/2013, à 15:45

pires57

Re : Problème réinstallation lamp

essayes cela .
Serais bien de nous donner les commandes exactes que tu as tapé.

apt-get remove --purge mysql-server* php5* apache2* && apt-get autoremove

C'est qui est bien avec linux (sa va finir par rentrer a force de le répeter) c'est qu'on est jamais obliger de tout réinstaller (ou presque)


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.

Hors ligne

#8 Le 19/12/2013, à 20:07

crocoscore

Re : Problème réinstallation lamp

Alors j'ai exécuté toutes le commandes que vous m'avez donné, dans l'ordre. Et lors de la réinstallation, plus de problème avec php mais avec mysql :

Paramétrage de php5 (5.5.3+dfsg-1ubuntu2.1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Que faire de plus ?


L'Open Source vaincra !

Hors ligne

#9 Le 19/12/2013, à 20:11

pires57

Re : Problème réinstallation lamp

salut,

http://doc.ubuntu-fr.org/probleme_apt a écrit :

Éditez le fichier /var/lib/dpkg/info/'le paquet qui bloque'.postrm
Puis remplacez "exit 1" par "exit 0" et s'il n'y a pas "exit 1" mettez "exit 0" à la fin. (ou l'inverse, etc.)
Si le fichier est vide, ajoutez-y :

 #!/bin/sh
 set -e
 exit 0

Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.

Hors ligne

#10 Le 20/12/2013, à 14:54

crocoscore

Re : Problème réinstallation lamp

Après maintes galères, j'ai préféré réinstaller Lubuntu. J'ai toujours l'impression d'avoir un système "impur" après l'avoir manipulé comme ça. Je veux dire qu'à chaque fois on laisse des fichiers, des configurations un peu partout sans le savoir, si bien qu'au moins maintenant je suis sur de plus avoir de problème !

Merci à vous quand même !


L'Open Source vaincra !

Hors ligne

#11 Le 20/12/2013, à 15:12

pires57

Re : Problème réinstallation lamp

Je veux dire qu'à chaque fois on laisse des fichiers, des configurations un peu partout sans le savoir

Certainement pas, les fichiers ne sont pas "un peu partout " comme tu dit mais exactement ou ils doivent l'être !


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.

Hors ligne

Haut de page ↑