Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 22/12/2013, à 13:29

ejouvin

Suite mise à jour 12.04, impossible d'installer de nouveaux paquets

Bonjour.

Contexte
Hier, j'ai voulu mettre à jour ma version de Mediawiki avec la 1.22.0 Celle-ci annonce qu'il faut le paquet php5-json. Donc je me lance dans un apt-get install php5-json.
Surprise, ce paquet n'est pas trouvé, mais il m'insique qu'i lest remplacé par php5-common.
Donc je suis un peu étonné, et en fait je me rends compte que je n'ai pas fais de mise à jour de la distribution et que je suis en 12.04

A l'époque, je me suis amusé à supprimer des paquets de la distribution, comme tout ce qui est graphique gnome ... Je ne l'utilise qu'en tant que "server" perso.

Actions et problème
Pas bien grave, je me dis que je vais lancer la mise à jour de celle ci en passant par les étape 12.10, 13.04 puis 13.10.
J'ai donc fait un do-release-upgrade en me disant que cela va aller sur la bonne version. Puis cela a finit par planter.
A ma grande surprise, la distribution aurait été mise à jour sur la branche de développement en :
lsb_release -d
Description:    Ubuntu Trusty Tahr (development branch)

Et sauf que les mises à jour plante systématiquement avec le message suivant:
dpkg : erreur : fichier des actions différées demandées en double avec le nom « /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders » pour le paquet « libgdk-pixbuf2.0-0:amd64 »
E: Sub-process /usr/bin/dpkg returned an error code (2)


J'ai essayé avec les combinaison des commandes:
appt-get clean
apt-get upgrade
apt-get dist-upgrade

Avec ou sans l'argument force, mais à chaque fois j'ai ce petit message d'erreur sur libgdk-pixbuf2.0-0


Donc pour le moment, je ne vais pas redémarrer le "server", mais est ce qu'il y aurait quelqu'un qui pourrait me venir en aide SVP pour voir comment corriger ce problème et pour que je sois un peu plus serein. AU passage, si je pouvais revenir sur la version 13.10, ce serait pas mal wink parce que la branche de développement ne m'interresse pas trop.


Bonne journée

Etienne

Hors ligne

#2 Le 22/12/2013, à 13:35

ejouvin

Re : Suite mise à jour 12.04, impossible d'installer de nouveaux paquets

Petit complément d'information.
Je viens de lancer apt-get dist-upgrade

Et un moment, j'ai ce message (trace putty):
Réception de : 12 http://fr.archive.ubuntu.com/ubuntu/ trusty/main upower amd64 0.9.23-2ubuntu1 [85,7 kB]

100% [12 upower 1 204 B/85,7 kB 1%]                                                                                                                                                      839 kB/s 0s
100% [En cours]                                                                                                                                                                          839 kB/s 0s
                                                                                                                                                                                                   
40,8 Mo réceptionnés en 49s (826 ko/s)
E: Impossible d'ouvrir le descripteur de fichier -1

Et après, les erreurs se déclenchent:
E: Prior errors apply to /var/cache/apt/archives/bzip2_1.0.6-5_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libbz2-1.0_1.0.6-5_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libsqlite3-0_3.8.2-1ubuntu1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/mount_2.20.1-5.1ubuntu11_amd64.deb

Hors ligne

#3 Le 24/12/2013, à 12:44

ejouvin

Re : Suite mise à jour 12.04, impossible d'installer de nouveaux paquets

Bon, j'ai un ami qui m'a aidé.

Mon problème était dans le fichier /var/lib/dpkg/File qui contenait un doublon. D'après lui, c'est un effet de bords du multi architecture. Et comme je suis "parti" sur une version de dev (ça je n'ai pas encore compris ce qui m'est arrivé) et bah je ne suis pas tant étonné que cela.

Par contre, après, c'est un peu galère avec:
* Modification de Apache, et quelques changement dans les configuration.
* Mise à jour de php qui fait que certaines applications que j'avais installé ne fonctionnent plus
* Et quelques modules php à réinstaller.
* ldap qui est parti aussi en vrac

Mais bon au final, c'est résolu, enfin j'ai encore du travail

Bonnes fêtes

Hors ligne

Haut de page ↑