Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 03/01/2014, à 21:32

38Guillaume

[Résolu] Jeux Steam : problème de luminosité (Nvidia Optimus)

Bonsoir
J'ai eu pour noël une Orange Box contenant Portal1, Half-Life2, et d'autres mais j'ai de gros problème de luminosité avec ces jeux : je joue comme si la lumière était éteinte. Après quelques recherches sur le forum, j'ai trouvé le même problème que moi mais hélas pas la solution hmm
Ma config est Ubuntu (avec Unity) 12.04LTS à jour avec bumblebee :

~$ lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation GF119M [GeForce GT 520MX] [10de:1051] (rev ff) (prog-if ff)


Je n'ai pas mis les derniers drivers proposés par Steam car j'ai peur de flinguer mon système...
EDIT : En fait si j'ai mis le PPA demandé par Steam : ppa:ubuntu-x-swat/x-updates

Si quelqu'un a une idée bug de luminosité je suis preneur !

Merci d'avance à toutes celles et ceux qui auront une idée smile

Dernière modification par 38Guillaume (Le 19/01/2014, à 13:25)


Ordi portable & Ordi bureau: 14.04 64bits Unity.
(L'aide pour ajouter [Résolu])
Mon p'tit blog : http://guillaume1996.free.fr/

Hors ligne

#2 Le 19/01/2014, à 13:23

38Guillaume

Re : [Résolu] Jeux Steam : problème de luminosité (Nvidia Optimus)

Résolu big_smile

En fait comme option de lancement j'ai mis uniquement

LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 optirun %command%

comme le dit cette page : la deuxième réponse de ce lien.
Je n'ai mis optirun nul part ailleurs dans steam. Pour lancer steam je fais simplement

steam

et pas optirun steam.
Ça marche avec Dota2, Portal1, Half-Life² ... Et sans doute tous les autres jeux big_smile



EDIT : pour ceux qui ont ce bug de luminosité mais qui n'ont pas optimus il faut mettre cette commande :

LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 %command%


J'ai mis la doc a jour.

Dernière modification par 38Guillaume (Le 03/03/2014, à 22:45)


Ordi portable & Ordi bureau: 14.04 64bits Unity.
(L'aide pour ajouter [Résolu])
Mon p'tit blog : http://guillaume1996.free.fr/

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » [Résolu] Jeux Steam : problème de luminosité (Nvidia Optimus)

Haut de page ↑