Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 24/02/2014, à 22:38

neoPixel

Authentification avec Postfix

Bonjour,

Je suis en train de me monter un service de mail perso pour moi, quelques amis...
Bref, j'ai suivi ce tutoriel suivant de manière a mettre en place la base de mon service de mail.

J'ai pris soins de m'auto-signer un certificat pour faire passer le imap en SSL/TLS et ça tourne a merveille. Pour le SMTP pareil, je reçois bien les mails que l'on m’envoie et je peu bien envoyer des mails depuis les serveurs apache et nginx.

Le problème qui se pose c'est que je ne peut pas envoyer de mails depuis l'extérieur (smartphone, pc du bureau ...). Le webmail tournant sur le apache, j'ai une solution de backup pour le moment mais je ne souhaite pas que delà dure.

J'ai donc fait le tour de la documentation et suivi plusieurs tuto sur "comment configurer SASL avec mysql" mais sans succès. Les solutions testés sont :

rimap -> http://www.zarafa.com/wiki/index.php/SM … IMAP_users
mysql -> http://doc.ubuntu-fr.org/postfix_mysql_tls_sasl#sasl

Niveau config j'ai actuellement :

master.cf

smtp      inet  n       -       n       -       -       smtpd
        -o content_filter=spamassassin
587       inet  n       -       n       -       -       smtpd
        -o content_filter=spamassassin
#...

main.cf

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/tls/smtpd.cert
smtpd_tls_key_file = /etc/postfix/tls/smtpd.key
biff = no
disable_vrfy_command = yes
smtpd_helo_required = yes
append_dot_mydomain = no
myhostname = 1.210.20.172.in-addr.arpa
myorigin = 1.210.20.172.in-addr.arpa
mydestination = 1.210.20.172.in-addr.arpa, localhost.localdomain, localhost
relayhost =
mynetworks = 127.0.0.0/8, 172.20.0.0/16
recipient_delimiter = +
inet_interfaces = all

virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_aliases.cf,mysql:/etc/postfix/mysql-virtual_aliases_comptes.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domaines.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_comptes.cf
virtual_mailbox_base = /var/spool/vmail/
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000

smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_path = smtpd

smtpd_sender_restrictions =
        permit_sasl_authenticated,
        permit_mynetworks,
        warn_if_reject reject_unverified_sender
smtpd_recipient_restrictions =
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_unauth_pipelining,
        reject_unauth_destination,
        reject_non_fqdn_recipient,
        permit
smtpd_client_restrictions =
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_unauth_pipelining,
        reject_non_fqdn_recipient,
        reject_unknown_recipient_domain,
        reject_unauth_destination,
        reject_rbl_client zen.spamhaus.org,
        reject_rbl_client bl.spamcop.net,
        permit

smtpd.conf

pwcheck_method: saslauthd
saslauthd_path: /var/run/saslauthd/mux
log_level: 7
mech_list: PLAIN LOGIN
# auxprop_plugin: rimap

saslauthd

START=yes
MECHANISMS="rimap"
MECH_OPTIONS="localhost"
OPTIONS="-c -r -m /var/spool/postfix/var/run/saslauthd"
THREADS=0

SASLAUTHD_OPTS="${SASLAUTH_MECH} -a rimap"
SASLAUTHD_OPTS="${SASLAUTHD_OPTS} -O localhost"

Et pour finir le type de log que j'ai dans auth.log

Feb 24 21:34:52 mail saslauthd[2053]: do_auth         : auth failure: [user=*****] [service=smtp] [realm=*********] [mech=rimap] [reason=remote server rejected your credentials]

Si vous avez une idée de pourquoi ça ne fonctionne pas, ou du comment solutionner mon problème je suis ouvert a toutes réponses wink

Hors ligne

Haut de page ↑