Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 22/02/2014, à 12:56

smallfred

[ résolu] plus de bureau

bonjour a tous,
bon je n'ai plus de bureau sur ubuntu precise12.04,pas de launcher,pas de barre du haut,reste juste mon fond d’écran.
la je suis passer par une clé usb pour ouvrir une fenêtre et accéder a internet par l'aide en ligne.
au secoure
fred

[modération] Discussion déplacée dans la section adéquate.

Dernière modification par smallfred (Le 26/02/2014, à 20:01)

Hors ligne

#2 Le 22/02/2014, à 13:28

FromBabylon

Re : [ résolu] plus de bureau

C'est arrivé comment ? Tu te log et hop plus de tout ça ?

Ctrl-Alt-F1 pour lancer une invite de commande (et ctrl-alt-f7 pour revenir au graphique)
Essayes un

sudo service lightdm restart

pour revenir au log de ta session

Sinon je parierais sur un problème avec compiz ça m'est déjà arrivé. As-tu tripatouiller dans le Compiz Config settings manager ?

Hors ligne

#3 Le 22/02/2014, à 13:37

smallfred

Re : [ résolu] plus de bureau

salut,
je n'ai pas toucher a compiz
ctrl-alt-f1 ne m'ouvre pas de terminal,mais un écran noir ou on me demande mon login  et password mais il refuse ce que je lui donne.
c'est arrivé hier soir aprés une mise a jour et un redémarrage.
merci a toi

FromBabylon a écrit :

C'est arrivé comment ? Tu te log et hop plus de tout ça ?

Ctrl-Alt-F1 pour lancer une invite de commande (et ctrl-alt-f7 pour revenir au graphique)
Essayes un

sudo service lightdm restart

pour revenir au log de ta session

Sinon je parierais sur un problème avec compiz ça m'est déjà arrivé. As-tu tripatouiller dans le Compiz Config settings manager ?

Hors ligne

#4 Le 22/02/2014, à 13:46

FromBabylon

Re : [ résolu] plus de bureau

Salut smile

L'écran noir est effectivement premièrement un login. Donc tu rentre ton nom de session puis ton mot de passe. C'est bizarre qu'il refuse ce que tu donne. C'est pas une histoire de majuscule au début du login ?

Dernière modification par FromBabylon (Le 22/02/2014, à 13:46)

Hors ligne

#5 Le 22/02/2014, à 13:57

smallfred

Re : [ résolu] plus de bureau

ok ben il a fallut que je rentre mon login une 15ene de x pour qu'il finisse par acceder.
la commande ne fait rien,et ce serait compiz ou peut-etre le pilote carte graphique(nvidia)???

FromBabylon a écrit :

Salut smile

L'écran noir est effectivement premièrement un login. Donc tu rentre ton nom de session puis ton mot de passe. C'est bizarre qu'il refuse ce que tu donne. C'est pas une histoire de majuscule au début du login ?

Hors ligne

#6 Le 22/02/2014, à 14:01

FromBabylon

Re : [ résolu] plus de bureau

La commande ne fait rien et ne retourne rien ?
As tu installé Compiz COnfig settings manager ? Alors essayes de le lancer  avec la commande ccsm.
Dans ccsm il faut vérifier que la case Unity Plugin est bien cochée.

En fait depuis le bureau, un Ctrl-Alt-T t'ouvre-t-il une invite de commande ?

Hors ligne

#7 Le 22/02/2014, à 14:11

smallfred

Re : [ résolu] plus de bureau

ok,donc ctrl-alt-t ne donne rien j'avais déjà essayé,pour ccsm bizarrement ça vient de ce réinstaller, mais je ne peux pas l'ouvrir.

FromBabylon a écrit :

La commande ne fait rien et ne retourne rien ?
As tu installé Compiz COnfig settings manager ? Alors essayes de le lancer  avec la commande ccsm.
Dans ccsm il faut vérifier que la case Unity Plugin est bien cochée.

En fait depuis le bureau, un Ctrl-Alt-T t'ouvre-t-il une invite de commande ?

Hors ligne

#8 Le 22/02/2014, à 14:17

FromBabylon

Re : [ résolu] plus de bureau

Tu dis que ça vient de se réinstaller sans que tu le demande ? T'es sûr parce que c'est très bizarre !

Alors dans le bureau en tapant Alt-F2 peux-tu lancer ""ccsm" et/ou "dconf-editor" ?

Hors ligne

#9 Le 22/02/2014, à 14:20

smallfred

Re : [ résolu] plus de bureau

non ,je viens de faire un sudo apt-get install ccsm,
et non je ne peu pas lancer ccsm(problème logiciel détecté)

FromBabylon a écrit :

Tu dis que ça vient de se réinstaller sans que tu le demande ? T'es sûr parce que c'est très bizarre !

Alors dans le bureau en tapant Alt-F2 peux-tu lancer ""ccsm" et/ou "dconf-editor" ?

Hors ligne

#10 Le 22/02/2014, à 14:25

FromBabylon

Re : [ résolu] plus de bureau

Essayes de lancer ces commandes :

sudo service lightdm stop
sudo service lightdm start

Si rien ne se passe essayes :

sudo service unity stop
sudo service unity start

Ça se passe comment au niveau de ta config pc pour la partie graphique ? Chipset processeur + carte nvidia ou seulement une carte nvidia ?

Dernière modification par FromBabylon (Le 22/02/2014, à 14:26)

Hors ligne

#11 Le 22/02/2014, à 14:39

smallfred

Re : [ résolu] plus de bureau

bon ,pour lightdm au moment du start c'est un retour sur mon joli bureau vide.
pour unity c'est du command not found
j'ai essayé de réinstaller unity mais pour réponse j'ai déjà la dernière version.
je suis plutôt débutant et je ne comprend pas t'a demande sur la config chipset pro+carte ou que carte

FromBabylon a écrit :

Essayes de lancer ces commandes :

sudo service lightdm stop
sudo service lightdm start

Si rien ne se passe essayes :

sudo service unity stop
sudo service unity start

Ça se passe comment au niveau de ta config pc pour la partie graphique ? Chipset processeur + carte nvidia ou seulement une carte nvidia ?

Hors ligne

#12 Le 22/02/2014, à 14:49

FromBabylon

Re : [ résolu] plus de bureau

Alors essayes :

unity --reset
sudo shutdown -r now

(La dernière commande redémarre ton pc)

Si en revenant rien n'a changé ou si la première commande ne se lance pas ou retourne une erreur :

sudo apt-get remove unity
sudo apt-get autoremove --purge unity
sudo apt-get install unity

et tu redémarres avec la commande d'avant

Désolé c'est vrai que j'explique pas grand chose.
Alors tape :

lspci | grep "VGA compatible controller"
cat /proc/cpuinfo

et donne le résultat.

En fait je demande simplement la configuration de ton pc donc quel processeur tu as ? Si c'est un récent c'est sûrement i3 ou i5 pour intel par exemple. Avec ces processeur tu as un "chipset graphique intégré" qui sera souvent accompagné d'autre part par une carte graphique (nvidia dans ton cas). Cette configuration peut être source de problèmes parfois

Dernière modification par FromBabylon (Le 22/02/2014, à 14:52)

Hors ligne

#13 Le 22/02/2014, à 16:29

smallfred

Re : [ résolu] plus de bureau

bon alors unity --reset me donne:
Warning:no display variable set,setting it to:o
unity-panel-service:aucun processus trouvé
libcompizconfig:dlopen:/usr/lib/compizconfig/backend/libconfig.so:cannot open
shared oject file:no such file or directory
backend:init
integration:true
profile:unity
adding plugions
Initializing core option...done

et la plus rien.
j'ai tapé les 3 commandes pour unity,redémarré et tjrs rien,et ça ne veut de nouveau plus mon login,donc pour l'instant je ne peux pas faire la suite

FromBabylon a écrit :

Alors essayes :

unity --reset
sudo shutdown -r now

(La dernière commande redémarre ton pc)

Si en revenant rien n'a changé ou si la première commande ne se lance pas ou retourne une erreur :

sudo apt-get remove unity
sudo apt-get autoremove --purge unity
sudo apt-get install unity

et tu redémarres avec la commande d'avant

Désolé c'est vrai que j'explique pas grand chose.
Alors tape :

lspci | grep "VGA compatible controller"
cat /proc/cpuinfo

et donne le résultat.

En fait je demande simplement la configuration de ton pc donc quel processeur tu as ? Si c'est un récent c'est sûrement i3 ou i5 pour intel par exemple. Avec ces processeur tu as un "chipset graphique intégré" qui sera souvent accompagné d'autre part par une carte graphique (nvidia dans ton cas). Cette configuration peut être source de problèmes parfois

Hors ligne

#14 Le 22/02/2014, à 16:48

FromBabylon

Re : [ résolu] plus de bureau

Hum.. Il se passe qqc au niveau de compiz. J'ai trouvé un sujet Fedora qui traite d'un problème pareil ou très similaire mais la solution ne s'applique pas à Ubuntu j'ai l'impression hmm

Essayes d'installer unity 2D et de lancer une session avec pour voir si c'est au niveau des effets/compiz :

sudo apt-get install unity-2d

Ensuite à l'écran de session tu devrais pouvoir choisir Unity 2D en cliquant sur la petit rond à côté de ton nom d'utilisateur

EDIT :

Je suis tombé là dessus :
http://askubuntu.com/questions/127782/u … ing-to-use

https://answers.launchpad.net/ubuntu/+question/194996

Ils recommandent de réinstaller les drivers nvidia :

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
sudo reboot

Si tu as déjà le plus récent c'est que le problème vient de ce pilote ou si en redémarrant il y a un quelconque problème il faut désinstaller ce pilote propriétaire pour utiliser le pilote libre :

sudo apt-get remove 'nvidia-*'

Si le propriétaire le plus récent et le pilote libre créés des problèmes il faudra revenir à l'ancienne version du pilote propriétaire.

Dernière modification par FromBabylon (Le 22/02/2014, à 17:00)

Hors ligne

#15 Le 22/02/2014, à 17:16

smallfred

Re : [ résolu] plus de bureau

alors apres 3 redémarrage ,login accepté.
lspci ça repond:
01:00.0 VGA compatible controller :NVidia corporation G96M [GeForce 9600M GT] (rev a1)
pour ce qui est de cat /proc/cpuinfo ça me donne:
physical id : 0
sibling : 2
core id : 1
cpu cores : 2
apicid : 1
fdiv_bug : no
hlt_bug : no
foof_bug : no
coma_bug : no
fpu : yes
fpu exception : yes
cpuid level : 10
wp : yes
flags : fpu vme cde pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 cflush dts apic mmx fxsr sse sse2 ss ht tm phe nx lm constant_tsc arch_perfmon pchs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm
bogomips : 3990.46
clflush size : 64
cache-alignement : 64
adress sizes : 36 bits physical,48 bits virtual
power management :



voila

Hors ligne

#16 Le 22/02/2014, à 17:26

FromBabylon

Re : [ résolu] plus de bureau

Tu as essayé les drivers (message précédent) ?

Hors ligne

#17 Le 22/02/2014, à 19:25

smallfred

Re : [ résolu] plus de bureau

donc,add-apt command not found
remove nvidia la plus rien,donc reinstal nvidia current et retour au même problème.
j'ai essayé les manips sur t'es liens ça ne fonctionne pas
a je vois que j'ai oublié unity 2d,je reviens.

FromBabylon a écrit :

Hum.. Il se passe qqc au niveau de compiz. J'ai trouvé un sujet Fedora qui traite d'un problème pareil ou très similaire mais la solution ne s'applique pas à Ubuntu j'ai l'impression hmm

Essayes d'installer unity 2D et de lancer une session avec pour voir si c'est au niveau des effets/compiz :

sudo apt-get install unity-2d

Ensuite à l'écran de session tu devrais pouvoir choisir Unity 2D en cliquant sur la petit rond à côté de ton nom d'utilisateur

EDIT :

Je suis tombé là dessus :
http://askubuntu.com/questions/127782/u … ing-to-use

https://answers.launchpad.net/ubuntu/+question/194996

Ils recommandent de réinstaller les drivers nvidia :

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
sudo reboot

Si tu as déjà le plus récent c'est que le problème vient de ce pilote ou si en redémarrant il y a un quelconque problème il faut désinstaller ce pilote propriétaire pour utiliser le pilote libre :

sudo apt-get remove 'nvidia-*'

Si le propriétaire le plus récent et le pilote libre créés des problèmes il faudra revenir à l'ancienne version du pilote propriétaire.

Hors ligne

#18 Le 22/02/2014, à 19:44

FromBabylon

Re : [ résolu] plus de bureau

sudo apt-add-repository

mais normalement add-apt marche aussi m'enfin.
Faut réinstaller nvidia current mais avec le ppa pour avoir la dernière version à jour. Et avec le pilote libre plus aucun affichage après un reboot ?

Hors ligne

#19 Le 22/02/2014, à 20:04

smallfred

Re : [ résolu] plus de bureau

et bien apt-add-repository ne fonctionne pas non plus (command not found)
en fait aucune manip fonctionne
merci pour t'on aide

FromBabylon a écrit :
sudo apt-add-repository

mais normalement add-apt marche aussi m'enfin.
Faut réinstaller nvidia current mais avec le ppa pour avoir la dernière version à jour. Et avec le pilote libre plus aucun affichage après un reboot ?

Hors ligne

#20 Le 22/02/2014, à 20:46

FromBabylon

Re : [ résolu] plus de bureau

Et un

sudo apt-get update

fonctionne ?

Hors ligne

#21 Le 22/02/2014, à 21:15

smallfred

Re : [ résolu] plus de bureau

oui update upgrade fonctionne mais ça ne change pas grand chose.
je crois que je v'ai être obligé de reinstaller Precise.

FromBabylon a écrit :

Et un

sudo apt-get update

fonctionne ?

Hors ligne

#22 Le 22/02/2014, à 21:24

FromBabylon

Re : [ résolu] plus de bureau

Bah écoutes je comprends pas trop y a 2 points vraiment bizarres :
Le fait qu'il faille que tu retape ton login pck il ne l'accepte pas
et sudo apt-add-repository qui ne fonctionne pas ...

Hors ligne

#23 Le 22/02/2014, à 21:46

smallfred

Re : [ résolu] plus de bureau

c'est sur ,c'est bizare .bon je stop pour ce soir et je pense que demain ce serra reinstallation totale.
merci pour t'on aide tout au long de cette jounrée.
bonne soirée

Hors ligne

#24 Le 23/02/2014, à 13:57

FromBabylon

Re : [ résolu] plus de bureau

Je dirais qu'il faut identifier l'ancien driver que tu utilisais, le télécharger et l'installer de manière manuelle. Tout devrait revenir à la normale.
Sinon tu peux essayer d'installer "python-software-properties" qui te permet d'utiliser apt-add-repository si cette commande retourne "Command not found" et ainsi retenter l'installation de nvidia-current

Hors ligne

#25 Le 26/02/2014, à 20:01

smallfred

Re : [ résolu] plus de bureau

salut,
et bien j'ai fait les manips pour remettre compiz ,unity,et le pilote nvidia,tous c'est bien réinstallé ,mais ça n'a pas fonctionné.Donc j'ai réinstallé Precise.
merci a toi FromBabylon de m'avoir accordé du temps.
bonne soirée et A+

FromBabylon a écrit :

Je dirais qu'il faut identifier l'ancien driver que tu utilisais, le télécharger et l'installer de manière manuelle. Tout devrait revenir à la normale.
Sinon tu peux essayer d'installer "python-software-properties" qui te permet d'utiliser apt-add-repository si cette commande retourne "Command not found" et ainsi retenter l'installation de nvidia-current

Hors ligne

Haut de page ↑