Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 21/04/2014, à 11:28

Sibe

[Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Si vous êtes sous Xubuntu, vous aurez certainement un problème qu'on appelle le "screen tearing" c'est a dire un déchirement d'écran comme ceci par exemple :
8b309ea1_darksiders_screentearing.jpeg

Ceci est du a un phénomène : une désynchronisation entre la carte graphique et l'écran, la carte graphique actualisant le contenu de la mémoire de l'écran alors que ce dernier affiche l'image. Le déchirement de l'écran vient du fait que l'écran a dans sa mémoire les infos de plusieurs images, l'image à l'écran est alors constituée de parties provenant de différentes images.

Pour régler ce problème il faut avoir la synchronisation verticale activé afin d'afficher la bonne image mais le problème c'est que sous certain environnement comme XFCE cela ne fonctionne pas a cause du compositeur d'affichage qui ne le gère pas, il y a bien une fonction qui a été ajouté depuis la 14.04 qui permet de "synchroniser le dessin a l'espace vide vertical" mais apparemment cette option a peu d'effet et les problèmes de "screen tearing" demeurent.

Le screen tearing n'est pas forcément très visible, par exemple si vous surfez sur le net vous ne le verrai peut être pas cet effet, c'est surtout en lançant des vidéo avec beaucoup de mouvement de caméra (par exemple film d'action ou course automobile) que vous vous rendrez compte du problème.

Si vous voulez savoir si vous avez bien le problème de screen tearing, il suffit de regarder la vidéo youtube ci-dessous :
https://www.youtube.com/watch?v=ceX18O9pvLs

- Si la barre blanche est propre sans déchirure, sans rayure apparante c'est que vous n'avez pas de problème de screen tearing
- Si au contraire la barre n'est pas propre avec des déchirures/rayures qui apparaissent c'est que vous avez ce problème.

Comment le résoudre ?

Le plus simple est de changer le compositeur d'affichage de XFCE et de le remplacer par "compton", un compositeur qui a l'avantage d'être léger et de pouvoir régler le problème de screen tearing.
(A noté que sous Lubuntu avec LXDE vous aurez aussi ce phénomène il faudra donc aussi faire la manip par contre les utilisateurs de KDE ne sont pas concerné par ce problème (il y a déjà ce qu'il faut contre le screen tearing sous KDE).

Avant d'utiliser compton, désactivez le compositeur d'affichage de XFCE, pour cela dans le panneau de configuration, cliquez sur "peaufinage des fenêtres" puis "compositeur" et décochez la case "activer le compositeur d'affichage".

Pour installer compton :

sudo apt-get install compton

(sur les vieilles versions de Xubuntu, compton n'était pas dans les dépôts mais maintenant c'est le cas, pas besoin d'utiliser de PPA donc)

Ensuite dans votre dossier personnel, vous allez créer un fichier .compton  et dedans vous allez mettre cette configuration :

backend = "glx"; # Enables Opengl backend
paint-on-overlay = true; # These 3 can improve performance, work well in most cases
glx-no-stencil = true;
glx-no-rebind-pixmap = true;
vsync = "opengl-swc"; # Enables one of the vsync methods. Check here for more info: https://github.com/chjj/compton/wiki/vsync-guide

# Shadow
shadow = true;            # Enabled client-side shadows on windows.
no-dock-shadow = true;        # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true;        # Don't draw shadows on DND windows.
clear-shadow = true;        # Zero the part of the shadow's mask behind the window (experimental).
shadow-radius = 7;        # The blur radius for shadows. (default 12)
shadow-offset-x = -7;        # The left offset for shadows. (default -15)
shadow-offset-y = -7;        # The top offset for shadows. (default -15)
shadow-exclude = [
 "! name~=''",
 "n:e:Notification",
 "n:e:Plank",
 "n:e:Docky",
 "g:e:Synapse",
 "g:e:Kupfer",
 "g:e:Conky",
 "n:w:*Firefox*",
 "n:w:*Chrome*",
 "n:w:*Chromium*",
 "class_g ?= 'Notify-osd'",
 "class_g ?= 'Cairo-dock'",
 "class_g ?= 'Xfce4-notifyd'",
 "class_g ?= 'Xfce4-power-manager'"
];

# Due to how compton draws shadows, some apps will have "glitchy" shadows. I've added all problem apps I ran into here.
#"! name~=''" excludes shadows on "unkown" windows, which fixes a shadow glitch with XFWM's alt tab switcher.

# Fading
fading = true; # Fade windows during opacity changes.
fade-delta = 4; # The time between steps in a fade in milliseconds. (default 10).
fade-in-step = 0.03; # Opacity change between steps while fading in. (default 0.028).
fade-out-step = 0.03; # Opacity change between steps while fading out. (default 0.03).
#no-fading-openclose = true; # Fade windows in/out when opening/closing

detect-client-opacity = true; #Fixes opacity in some apps, such as xfce4-notifyd

# Window type settings
# Disables shadows on tooltips and enables fading on tooltips

wintypes:
{
  tooltip = { fade = true; shadow = false; };
};

Compton n'a pas d'interface graphique pour le paramétrer, tout ce fait en ligne de commande, ce fichier vous permet d'avoir des bons réglages et surtout plus de screen tearing. Vous pouvez toujours modifier les valeurs pour régler les effets mais normalement il n'y a rien a changer dans la configuration.

Pour terminer il ne vous reste plus qu'a activer compton au démarrage, pour cela allez dans le panneau de configuration puis "session et démarrage" puis "démarrage automatique", faites "ajouter" et mettez :
nom : compton
description : ce que vous voulez par exemple "compositeur alternatif"
commande : compton -b

Il ne vous reste plus qu'a fermer la session et la rouvrir pour prendre en compte le changement.

Dernière modification par Sibe (Le 21/04/2014, à 11:46)


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#2 Le 21/04/2014, à 11:33

nam1962

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Merci Sibe.
Je mets un lien vers ton tuto dans celui de ma signature. (J-7)

Dernière modification par nam1962 (Le 21/04/2014, à 11:38)


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.10 sur portable, 14.04 sur fixe, 14.04 chez mes amis.
Score : 49 convertis IRL (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien, qui fait du T-shirt la nouvelle élégance ...bio en plus : http://goudronblanc.com

Hors ligne

#3 Le 21/04/2014, à 11:56

lepetit

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

est-ce qu'il est prévu par la suite une correction de ce bug dans xfce ?

Hors ligne

#4 Le 21/04/2014, à 11:59

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

lepetit a écrit :

est-ce qu'il est prévu par la suite une correction de ce bug dans xfce ?

Non ce n'est pas prévu car ils ne voient pas ça comme un bug.

Dernière modification par Sibe (Le 21/04/2014, à 11:59)


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#5 Le 21/04/2014, à 13:10

kurapika29

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Juste pour signaler que ça ne change absolument rien chez moi, le tearing est toujours là, était déjà là sous gnome est sera surement là si je test kde big_smile


Disponible sur IRC, sur le serveur irc.freenode.net salon ##ubuntu-voyager (et aussi sur plein d'autre serveur/salon)
Venez si vous avec besoin d'aide ou pour causer ;) suffit d'avoir Xchat ou un autre client IRC
Où sinon en cliquant sur se lien http://kiwiirc.com/client/irc.freenode. … tu-voyager

Hors ligne

#6 Le 21/04/2014, à 13:26

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

kurapika29 a écrit :

Juste pour signaler que ça ne change absolument rien chez moi, le tearing est toujours là, était déjà là sous gnome est sera surement là si je test kde big_smile

Non impossible, tu dois certainement te tromper ou penser que tu as le screen tearing alors que ce n'est pas le cas car il est bien corrigé avec compton et chez tout le monde qui l'utilise (vérifié par plein de personnes différentes). De plus j'ai testé sur 3 pc différent avec Xubuntu et ça a bien corrigé le problème de tearing dans les 3 cas. Quand a KDE, Kwin a l'option de synchro verticale intégré.

Dernière modification par Sibe (Le 21/04/2014, à 13:27)


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#7 Le 21/04/2014, à 14:55

kurapika29

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Je déconne pas hein hmm 1398084884.png
J'ai tout suivi le tuto et redémarrer, en testant la video mise dedans le trait est toujours dégueulasse ....
( bon après ça fait 2 ans que j'ai pas refait une install propre aussi )


Disponible sur IRC, sur le serveur irc.freenode.net salon ##ubuntu-voyager (et aussi sur plein d'autre serveur/salon)
Venez si vous avec besoin d'aide ou pour causer ;) suffit d'avoir Xchat ou un autre client IRC
Où sinon en cliquant sur se lien http://kiwiirc.com/client/irc.freenode. … tu-voyager

Hors ligne

#8 Le 21/04/2014, à 16:11

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

- Tu es bien sous Xubuntu ? Tu utilises la version 14.04 ?
- Tu as bien créer un fichier .compton (avec le "." devant) ? tu l'a bien mis dans ton dossier personne "~" c'est a dire que si ton compte c'est kurapika par ex, l'adresse du fichier doit être : /home/kurapika/.compton
- Tu as bien copié tout le contenu du fichier de configuration dans le .compton ?
- Tu as bien activé compton au démarrage avec un "compton -b" ?

Dernière modification par Sibe (Le 21/04/2014, à 16:12)


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#9 Le 21/04/2014, à 19:37

kurapika29

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Merci de me prendre pour un noob -_- tongue
(et sinon c'est oui à toute tes questions évidemment, et oui j'avais bien désactivé le compositeur de xfce aussi)

Dernière modification par kurapika29 (Le 21/04/2014, à 19:39)


Disponible sur IRC, sur le serveur irc.freenode.net salon ##ubuntu-voyager (et aussi sur plein d'autre serveur/salon)
Venez si vous avec besoin d'aide ou pour causer ;) suffit d'avoir Xchat ou un autre client IRC
Où sinon en cliquant sur se lien http://kiwiirc.com/client/irc.freenode. … tu-voyager

Hors ligne

#10 Le 21/04/2014, à 20:32

The Uploader

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

lepetit a écrit :

est-ce qu'il est prévu par la suite une correction de ce bug dans xfce ?

C'est pour Xfce 4.12.

À ce jour, Xfwm 4.11 (la version de développement de Xfwm 4.12) a une nouvelle option "Sync to VBlank" pour éviter le tearing, mais chez moi je n'ai vu aucun changement.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#11 Le 21/04/2014, à 20:48

Mister_J

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Salut Sibe,
Il y a beaucoup moins de déchirures d'image qu'avec le compositeur d'affichage d'Xfce activé, mais un peu plus que s'il était carrément désactivé.
Je crois que le problème, en ce qui concerne les vidéos Youtube en l'occurence, vient surtout d'une mauvaise gestion de flash sous Linux...

Dernière modification par Mister_J (Le 21/04/2014, à 20:49)


Xubuntu 14.04 : i5 4670K / 8Go DDR3 / GTX 750 & Asus Eee Pc 1025c - 4Go - SSD 60Go

Hors ligne

#12 Le 21/04/2014, à 20:49

kurapika29

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Pareil, j'ai même lu sur le forum ubuntu.com que l'activer par le GUI ne fonctionnais pas, ou du moins n'avait pas d'effet et qu'il fallait passer par xfconf

xfconf-query -c xfwm4 -p "/general/sync_to_vblank" -s true

Mais j'ai pas vu de différence non  plus sad

Dernière modification par kurapika29 (Le 21/04/2014, à 20:49)


Disponible sur IRC, sur le serveur irc.freenode.net salon ##ubuntu-voyager (et aussi sur plein d'autre serveur/salon)
Venez si vous avec besoin d'aide ou pour causer ;) suffit d'avoir Xchat ou un autre client IRC
Où sinon en cliquant sur se lien http://kiwiirc.com/client/irc.freenode. … tu-voyager

Hors ligne

#13 Le 21/04/2014, à 21:35

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Le problème de cette commande et qu'elle doit être lancé a chaque démarrage sinon si tu redémarres c'est pas pris en compte et en plus elle ne fonctionne que en mode "carte intel" mais pas avec la carte nvidia. La meilleur méthode ça reste donc compton qui fonctionne dans les 2 cas.

Dernière modification par Sibe (Le 21/04/2014, à 21:36)


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#14 Le 21/04/2014, à 21:39

Baltus

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Fonctionne très bien chez moi. Sinon il y a Mutter, mais je préfère Compton car Mutter est lié à Gnome et est bien plus lourd.

Voici mon fichier de config :

backend = "glx";
paint-on-overlay = true;
glx-no-stencil = true;
# New
# glx-no-rebind-pixmap = true;
# New
# glx-swap-method = "buffer-age";
vsync = "opengl-swc";

# Shadow
shadow = true; # Enabled client-side shadows on windows.
no-dock-shadow = true; # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true; # Don't draw shadows on DND windows.
clear-shadow = true; # Zero the part of the shadow's mask behind the window (experimental).
shadow-radius = 7; # The blur radius for shadows. (default 12)
shadow-offset-x = -7; # The left offset for shadows. (default -15)
shadow-offset-y = -7; # The top offset for shadows. (default -15)
# New
# The translucency for shadows. (default .75)
# shadow-opacity = 0.5;
shadow-exclude = [
  "n:e:Notification",
  "n:e:Docky",
  "n:e:Plank",
  "g:e:Synapse",
  "g:e:Conky",
  "n:w:*Firefox*",
  "n:w:*Chromium*",
  "n:w:*dockbarx*",
  "class_g ?= 'Cairo-dock'",
  "class_g ?= 'Xfce4-notifyd'",
  "class_g ?= 'Xfce4-power-manager'"
];

# New
# Opacity
# menu-opacity = 1;
# inactive-opacity = 1;
# active-opacity = 1;
# frame-opacity = 1;
# inactive-opacity-override = false;
# alpha-step = 0.06;

# Dim inactive windows. (0.0 - 1.0)
# inactive-dim = 0.2;
# Do not let dimness adjust based on window opacity.
# inactive-dim-fixed = true;
# Blur background of transparent windows. Bad performance with X Render backend. GLX backend is preferred.
# blur-background = true;
# Blur background of opaque windows with transparent frames as well.
# blur-background-frame = true;
# Do not let blur radius adjust based on window opacity.
blur-background-fixed = false;
blur-background-exclude = [
    "window_type = 'dock'",
    "window_type = 'desktop'"
];

# Fading
fading = true; # Fade windows during opacity changes.
fade-delta = 4; # The time between steps in a fade in milliseconds. (default 10).
fade-in-step = 0.03; # Opacity change between steps while fading in. (default 0.028).
fade-out-step = 0.03; # Opacity change between steps while fading out. (default 0.03).
#no-fading-openclose = true; # Fade windows in/out when opening/closing

# detect-client-opacity = true; #Fixes opacity in some apps, such as xfce4-notifyd

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; };
};

Hors ligne

#15 Le 22/04/2014, à 11:05

berserk

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

salut
je n'utilise pas le pilote proprio pour ma carte graphique nvidia, je me contente de nouveau.
je n'ai pas encore testé compton mais faut il installer le pilote proprio ou pas pour que compton soit efficace ?

Dernière modification par berserk (Le 22/04/2014, à 11:09)

Hors ligne

#16 Le 22/04/2014, à 11:20

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Non pas besoin d'installer le pilote proprio.


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#17 Le 22/04/2014, à 12:25

SpiKe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

kurapika29 a écrit :

Pareil, j'ai même lu sur le forum ubuntu.com que l'activer par le GUI ne fonctionnais pas, ou du moins n'avait pas d'effet et qu'il fallait passer par xfconf

xfconf-query -c xfwm4 -p "/general/sync_to_vblank" -s true

Mais j'ai pas vu de différence non  plus sad

Sur Xubuntu 14.04, pas besoin de passer par cette commande, l'activation par la GUI fonctionne.

J'ai pu tester le sync_to_blank avec une AMD HD4650 Mobility (pilotes libres radeon) et ça fonctionne plutôt très bien.
Le réglage est conservé après un redémarrage.
Par contre quand je verrouille l'écran avec LightLocker (Ctrl+Alt+Suppr) et que je reviens sur la session, je retrouve parfois - mais pas toujours - du tearing.

Même sur le PC de ma signature, avec les pilotes nVidia proprio, le fait d'activer cette option réduit le tearing (sans l'enlever complètement).

Je vais essayer Compton sur la HD4650, cela dit, pour comparer les deux méthodes smile

Dernière modification par SpiKe (Le 22/04/2014, à 12:26)


Utilisateur de Xubuntu 14.04 et ArchLinux + Xfce.
Membre de l'équipe de traduction Xfce francophone.
Xonotic --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#18 Le 22/04/2014, à 12:58

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Qu'appelle tu l'activation par le GUI Spike ? en allant ou ?

Si tu parles de l'option "synchroniser le dessin sur l'espace verticale" dans les options du compositeur de XFCE ça n'a aucun effet.


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#19 Le 22/04/2014, à 13:04

SpiKe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Sibe a écrit :

Qu'appelle tu l'activation par le GUI Spike ? en allant ou ?

Si tu parles de l'option "synchroniser le dessin sur l'espace verticale" dans les options du compositeur de XFCE ça n'a aucun effet.

Je parlais bien de ça.
J'ai bien lu à plusieurs endroits que cette option ne fonctionnait pas en passant par les paramètres du compositeur Xfce, mais chez moi ça marche, sur 2 PC différents cool

Dernière modification par SpiKe (Le 22/04/2014, à 13:05)


Utilisateur de Xubuntu 14.04 et ArchLinux + Xfce.
Membre de l'équipe de traduction Xfce francophone.
Xonotic --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#20 Le 22/04/2014, à 13:07

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

mais la vidéo youtube en plein écran en qualité hd 720p : https://www.youtube.com/watch?v=ceX18O9pvLs
tu es sûr que tu ne vois pas de rayure ?

car normalement cet option n'a aucun effet...


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#21 Le 22/04/2014, à 13:26

SpiKe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Sibe a écrit :

mais la vidéo youtube en plein écran en qualité hd 720p : https://www.youtube.com/watch?v=ceX18O9pvLs
tu es sûr que tu ne vois pas de rayure ?

car normalement cet option n'a aucun effet...

Alors, avec la nVidia, j'ai quelques rayures, mais j'en ai encore plus lorsque je décoche l'option dans les paramètres Xfce.

Avec la HD4650 et les pilotes radeon, par contre, je n'ai qu'une seule déchirure, tout en haut de l'écran, et d'après le commentaire #12 dans le rapport de bug Xfce, c'est normal.

De façon générale, je constate aussi beaucoup moins de déchirements quand je déplace une fenêtre ou quand je lis des vidéos.
Je vais tester Compton cette semaine, peut-être que ça permettra d'enlever complètement le tearing qu'il reste en haut de mon écran avec la HD4650.


Utilisateur de Xubuntu 14.04 et ArchLinux + Xfce.
Membre de l'équipe de traduction Xfce francophone.
Xonotic --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#22 Le 22/04/2014, à 13:38

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Ah mais si tu as une rayure, même une seule, tu as toujours le problème de screen tearing.

Moi aussi quand j'avais le screen tearing j'avais juste une rayure en haut (l'image que j'ai mis en illustration ou il y en a 2 visibles c'était juste un exemple mais dans la plupart des cas on en voit qu'une seule).

Avec compton je n'ai absolument aucune rayure.


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

#23 Le 22/04/2014, à 15:52

berserk

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Sibe a écrit :

Non pas besoin d'installer le pilote proprio.

OK smile

Hors ligne

#24 Le 22/04/2014, à 20:17

SpiKe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Bon, merci Sibe, j'ai essayé Compton et je l'ai adopté sur mon PC portable smile

Avec ma carte nVidia + pilotes proprio, les effets de tearing sont réduits, mais pas plus qu'en activant l'option "synchroniser le dessin a l'espace vide vertical" dans les paramètres Xfce.
J'imagine que le problème est directement lié aux pilotes nVidia, d'autant plus que les cartes des séries GTX 6xx et 7xx sont connues pour occasionner du tearing sous Linux.

Par contre, avec mon PC portable et le pilote libre radeon, c'est juste parfait, car je n'ai plus ce problème de tearing localisé tout en haut de l'écran. Du coup, j'ai remplacé Xfwm par Compton sur cette machine smile


Utilisateur de Xubuntu 14.04 et ArchLinux + Xfce.
Membre de l'équipe de traduction Xfce francophone.
Xonotic --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#25 Le 22/04/2014, à 20:22

Sibe

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Pour le pilote nvidia, il y a une option dans le pannel nvidia pour le vsync, il faut bien la cocher.

Dernière modification par Sibe (Le 22/04/2014, à 20:23)


Pc port1: Core i7 2.4GHz | 16 Go ram | GeForce 650m GT | SSD 256 Go + 1 To HD + 5 To en EXT | Linux Mint 17 x64 (Cinnamon)
Pc port2 (old): Core2duo 2.2GHz | 4 Go ram | GeForce 9600m GT | 500 Go HD | Xubuntu 14.04 x64 (Xfce)
Pc bur famille: Core2duo 3.2GHz | 4Go ram | GeForce 405 | 1 To HD | Debian 7 x64 (Kde)
Pc bur trav: Core i5 | 4 Go ram | GeForce 7600 GS | 250 Go HD | Debian 7 x64 (Mate)

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Haut de page ↑