Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/04/2014, à 16:47

Domeee

Bug Gnumeric 1.12.9 (*buntu 14.04)

Bonjour à tou(te)s,

j'avais vu ce bug dans une version dayly built de Lubuntu 14.04. Le pb, c'est que je viens de télécharger la version officielle, et en live USB, ça me fait pareil : vous faites un graphique à partir de données => pas de pb avec Guru. Si vous double-cliquez le graphique pour le modifier, ça donne un truc de ce genre :

2014-04-21-172514_562x655_scrot.png

Toutes les fenêtres des diverses options de Guru sont entachées du même bug, et même pas moyen de redimensionner la fenêtre.
Qq'un d'autre a eu ce pb sur une version installée (Lubuntu ou Xubuntu, ou autre…) ?

Hors ligne

#2 Le 22/04/2014, à 07:17

jbrefort

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

Bug connu dû à un changement de comportement de gtk+ et corrigé depuis dans goffice -0.10.10. Voir https://bugzilla.gnome.org/show_bug.cgi?id=719681

Hors ligne

#3 Le 22/04/2014, à 08:19

Domeee

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

Merci pour cette info. Concrètement, ça se passe comment avec Lubuntu 14.04 : ça va passer dans une mise à jour ? Je n'ai testé que le live usb, donc pas de maj possible.

Hors ligne

#4 Le 22/04/2014, à 16:23

jbrefort

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

Aucune idée. Dans le passé je n'ai pas souvenir d'avoir vu de mise à jour de Gnumeric dans une version d'Ubuntu, LTS ou pas.
Le patch est tout à fait trivial : https://bug719681.bugzilla-attachments. … ?id=263302

Hors ligne

#5 Le 24/04/2014, à 13:23

Domeee

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

jbrefort a écrit :

Le patch est tout à fait trivial

Bah, sans doute pour toi, mais moi je ne suis pas dev, qu'est-ce que je fais de ce charabia ?

Plus généralement, c'est très dommageable pour gnumeric, car ça veut dire que pour le commun des mortels, gnumeric n'est pas utilisable, et là, on parle de LTS. Déjà que les utilisateurs préfèrent à priori LO (sans savoir ce qu'ils perdent...), ça risque fort d'être fatal à mon tableur favori cette affaire. Si le patch ne passe pas dans une mise à jour, dur dur.

Hors ligne

#6 Le 24/04/2014, à 13:37

jbrefort

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

Il faut faire un rapport de bogue chez ubuntu, c'est la seule solution et donner le lien vers le rapport original. À moins qu'il exsite un PPA avec une version plus récente de gnumeric (la dernière est 1.12.14).

Hors ligne

#7 Le 24/04/2014, à 15:38

Domeee

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

À moins qu'il exsite un PPA avec une version plus récente de gnumeric (la dernière est 1.12.14)

Justement, j'ai recherché plusieurs fois ce genre de truc : je n'ai pas trouvé. J'ai même tenté une compil de la 1.12.14 (quand j'ai vu le bug), je n'y suis pas arrivé (il me manquait visiblement des trucs, et comme c'était sur une 13.04, c'est sûrement trop vieux…)
Je vais voir si je peux faire le rapport de bug chez ubuntu

Et sinon, c'est quoi le mode d'emploi de ton patch ?

Hors ligne

#8 Le 24/04/2014, à 15:51

jbrefort

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

C'est goffice-0.10.14 qu'il faut compiler. Cela devrait suffire à corriger le problème. Et c'est nécessaire pour pouvoir compiler gnumeric-1.12.14 de toute manière.

Hors ligne

#9 Le 27/04/2014, à 16:04

Domeee

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

Bonjour, j'ai chargé goffice-0.10.14, la compilation (sur ma 13.04) a foiré, il lui faut des bibliothèques cairo que je n'ai visiblement pas...
Sinon, j'ai eu une lueur d'espoir : ici, il y a gnumeric sous forme de paquet .deb (site debian sid = instable) => j'ai chargé la 1.12.14-1 => le dépaquetage n'a pas marché (dépendance non satisfaite, gnumeric-common 1.12.14-1) fermez le banc.
J'ai fait la même manip sur une 14.04 en live usb avec persistence, il m'a jeté avec le même motif...
A part ça, j'ai été voir pour déclarer un bug, si j'ai bien compris, c'est une inscription dans le team de dev's => pas pour moi. Bugzilla m'aurait mieux convenu.

Bref, entre le wifi qui ne marche pas et gnumeric non plus, je ne vais pas me bousculer sur la 14.04.

Hors ligne

#10 Le 27/04/2014, à 16:47

jbrefort

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

goffice n'a pas besoin d'une version particulièrement récente de cairo. 'apt-get build-dep goffice' devrait installer tout ce qui est nécessaire.

Hors ligne

#11 Le 27/04/2014, à 17:51

Domeee

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

@jbrefort : attention, j'étais sur ma 13.04, pas sur une 14.04 quand j'ai fait cette manip => ça explique sans doute cairo.

[Edit du 28/04/2014 : solution en ligne de commande, beaucoup plus rapide et avec moins d'effets secondaires qu'en passant par Gdebi]

Sinon, j'ai trouvé une solution : j'ai creusé la piste debian sid

- il faut télécharger les fichiers :
            libgoffice-0.10-10-common_0.10.14-1_all.deb  ici
            libgoffice-0.10-10_0.10.14-1_xxx.deb  ici
            gnumeric-common_1.12.14-1_all.deb  ici
            gnumeric_1.12.14-1_xxx.deb  ici
Il faut aller à la fin de ces pages, dans la rubrique téléchargement et choisir l'architecture de sa machine (i386 pour la plupart)
On est redirigé vers la page de téléchargement : choisissez un miroir et téléchargez le paquet

- allez dans votre dossier home, créez un dossier que vous nommerez "toto" (ou autre qui vous fait plaisir) et mettez ces 4 archives dedans 

- ouvrez une console (ctrl+alt+T) et tapez :

cd toto
sudo dpkg -i *.deb

(merci à frenchy82 pour son aide !)

Normalement, tout se passe bien et rapidement

- vous pouvez lancer Gnumeric par le menu, et vous avez une 1.12.14 sans le bug !
Abiword fonctionne aussi

J'ai testé ça avec une Lubuntu 14.04 en live usb persistente => si qq'un d'intéressé par ce pb pouvait tester sur une install finalisée, et aussi avec xubuntu (qui utilise aussi gnome office par défaut) et donner son retour, ça serait cool.
[Edit 3/05/2014] : j'ai installé Lubuntu 14.04 il y a quelques jours et j'ai testé Gnumeric assez intensivement : 0 bug à déplorer. La manip semble fiable (et rien à signaler non plus sur le reste du système). J'ai même fait une MAJ du système, RAS, mais la MAJ était très légère, donc on ne peut pas trop voir l'impact de la manip sur les MAJ pour l'instant.
[Edit 4/05/2014] : après un échec d'installation de la doc, j'ai trouvé une solution : d'abord installer yelp (le lecteur de la doc) via synaptic. Ensuite, charger le bon fichier de doc ici et l'installer avec Gdebi. La doc est fonctionnelle.
SURTOUT ne pas essayer d'installer la doc en direct à partir de synaptic, ça propose de désinstaller Gnumeric

Pour finir, j'ai essayé ce processus sur ma 13.04, je ne suis pas allé au bout: pas grave, on peut désinstaller les version de librairies modifiées (via synaptic ou avec Gdebi, en double-cliquant les fichiers .deb), faire un sudo apt-get autoclean dans la console et réinstaller les versions "normales" dans synaptic : je n'ai pas eu de pb.

Dernière modification par Domeee (Le 04/05/2014, à 21:05)

Hors ligne

#12 Le 15/08/2014, à 22:11

Domeee

Re : Bug Gnumeric 1.12.9 (*buntu 14.04)

Je redéterre ce topic...
Pour info, les liens ci-dessus pointent maintenant sur la 1.12.17 : rien de grave, ça marche tout pareil qu'indiqué.
Par contre, si, comme moi, vous avez essayé d'upgrader la 1.12.14 (ou autre), ça met un message d'erreur.
Solution : il faut d'abord désinstaller Gnumeric-doc (synaptic par ex), faire la manip du post #11 ci-dessus avec les 4 fichiers .deb, et réinstaller Gnumeric-doc (pareil, le lien pointe sur la dernière version 1.12.17). Nota : ça désinstalle aussi Gnumeric en même temps que la doc. Pas grave, on le réinstalle derrière. J'avais le paquet Gnumeric cassé suite à ma première tentative sans désinstaller la doc => aucun souci, ça se débrouille.

Version 1.12.17 recommandée, ça corrige des bugs d'affichage sur les graphiques (formats de nombres pas toujours cools pour les échelles).
En prime, il y a un graphique de plus : le graphe matriciel. Je m'en vais essayer ça !

Dernière modification par Domeee (Le 15/08/2014, à 22:13)

Hors ligne