Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 30/04/2008, à 11:35

Kirbal

Probleme avec l'extension X-Video

Salut, j'ai un probléme avec l'extension X-video
quand je veux lire une video avec mplayer il me sort :
(J'ai une Ati mobility radeon x1400 avec une Xubuntu 8.04 )

[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.

et donc au final mplayer me joue la video en playback  hmm
Quand je fais xvinfo j'ai le droit a un magnifique

X-Video Extension version 2.2
screen #0
 no adaptors present

pourtant j'ai bien l'acceleration graphique :

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1400
OpenGL version string: 2.1.7412 Release

j'avais essayer en installant Xgl, et la miracle sa avait marcher mais je tomber sur le bug qui m'obligé a utiliser MESA a la place de fglrx.
(ps: si quelqun pouvait me dire ou desactivez le bip sur xterm se serait sympas, la je sens que je vais devenir fous... neutral)

#2 Le 30/04/2008, à 18:06

sacrediou

Re : Probleme avec l'extension X-Video

Même problème chez moi, depuis la migration Xubuntu 7.10 vers 8.04. Voici ce que j'ai dans la section "Device" du fichier xorg.conf :

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option      "VideoOverlay" "on"
        Option      "OpenGLOverlay" "off"
EndSection

Dans mon cas, c'est lors de la lecture de vidéo dans VLC que ça se voit :
- taux d'occupation CPU très élevé => saccades vidéo en plein écran
- vidéo de mauvaise qualité en plein écran (un peu "aliasé")

Voici ce que me retourne la commande "fglrxinfo" :

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.1.7412 Release

Pour ce qui est du "bip" système, tu peux "blacklister" le module pour être tranquille. Pour cela, édite le fichier "/etc/modprobe.d/blacklist" ajoute ceci à la fin du fichier :

# disable PC speaker
blacklist pcspkr

Note : le réglage sera pris en compte au prochain démarrage d'Ubuntu. Tu peux aussi enlever le module directement en faisant :

$ sudo rmmod pcspkr

Dernière modification par sacrediou (Le 30/04/2008, à 18:08)

Hors ligne

#3 Le 01/05/2008, à 11:01

kirbal

Re : Probleme avec l'extension X-Video

Merci pour annihilationdu Bip, ma santé mentale ne s'en portera que mieux tongue
Sinon je séche toujours pour le probléme avec XV, si quelqu'un a la solution...

Hors ligne

#4 Le 01/05/2008, à 18:01

thibault de Palsambleu.fr

Re : Probleme avec l'extension X-Video

Bonjour,

J'ai migré de gutsy vers hardy aujourd'hui, et je me retrouve avec le même problème. J'ai une carte vidéo ATI avec le pilote proprio.

J'ai trouvé quelques idées de solutions ici :

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/150519

  * Ajouter Option "VideoKey" "0x01" dans la section Device du xorg.conf
  * Passer AIGLX à disabled


J'ai également trouvé la commande suivante :

sudo aticonfig --overlay-type=Xv

qui apparamment à résolu le problème pour beaucoup de monde (nécessite de redémarrer X).

Rien de tout ça n'a marché pour moi. La dernière solution qui me reste à tenter, c'est d'installer une ancienne version du paquet xserver-xorg-video-ati.

Quelqu'un sait comment installer la version gutsy d'un paquet dans hardy ?

Merci.


S'il vous plaît, ne visitez pas le blog du développeur.

Hors ligne

#5 Le 01/05/2008, à 18:44

thibault de Palsambleu.fr

Re : Probleme avec l'extension X-Video

Bon, je m'en sort en utilisant l'option

mplayer -vo gl

Ça marche, mais j'aimerais quand même trouver la bonne solution.

à++;


S'il vous plaît, ne visitez pas le blog du développeur.

Hors ligne

#6 Le 03/05/2008, à 10:32

Dromar

Re : Probleme avec l'extension X-Video

Bonjour! Après de longs mois passés sous windows, j'ai enfin eu l'occasion hier de réinstaller une linux, Hardy big_smile
Et quel soulagement... Je respire à nouveau

Je suis dans votre cas, les solutions sur ce topic n'ont pas marché, mais j'ai trouvée la solution miracle (pour mon cas) :
Il suffit d'ajouter la ligne
       Option "TexturedVideo" "on"
a la section device

Voici la source : https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.24/+bug/197639/comments/5

En espérant que ça vous aide également

Hors ligne

#7 Le 03/05/2008, à 16:49

kirbal

Re : Probleme avec l'extension X-Video

Ca marche !!! , Franchement merci Dromar  big_smile
Xvideo est reconnu par mplayer et je peut maintenant voir mes videos en fullscreen sans problémes cool
Bon j'ai toujours un bug qui fait clignoter la fenetre quand je quitte le fullscreen, mais rien de bien méchants. Ah je me sens mieux d'un seul coup roll

Hors ligne

#8 Le 03/05/2008, à 18:32

Dromar

Re : Probleme avec l'extension X-Video

Je viens d'activer compiz-fusion... Mauvaise surprise, cette sorte de flash noir qui apparaît sans cesse dans les vidéos mplayer, lorsqu'elles ne sont pas en fullscreen, je l'ai aussi =/ je repars à la pêche aux solutions... Mais en dehors de ça, tout passe à merveille.

Sinon Kirbal, ton problème de flash, il apparaît également lorsque les effets de bureau sont désactivés?

EDIT: Il semblerait que ce soit un problème plus général, on ne peux pas utiliser compiz (avec AIGLX) en même temps qu'un programme utilisant opengl/xv ... Tant pis, pour ma part j'abandonne compiz jusqu'à ce qu'une solution apparaisse.

Dernière modification par Dromar (Le 03/05/2008, à 19:17)

Hors ligne

#9 Le 05/05/2008, à 10:57

kirbal

Re : Probleme avec l'extension X-Video

Effectivement j'ai plus le probléme une fois compiz desactivé big_smile , tu peux toujours essayer avec Xgl à la place de AIGLX si tu veux compiz smile

Hors ligne

#10 Le 06/05/2008, à 18:55

sacrediou

Re : Probleme avec l'extension X-Video

Effectivement, l'ajout de

Option "TexturedVideo" "on"

a la section device a résolu le problème pour moi aussi. Maintenant "xvinfo" donne plein d'infos et l'extension xvideo fonctionne dans VLC et mplayer.

Merci beaucoup.

Note : je n'utilise pas compiz donc je n'ai pas constaté l'autre problème de flash...

Hors ligne

#11 Le 10/05/2008, à 12:44

teke

Re : Probleme avec l'extension X-Video

POur moi l'ajout de Option "TexturedVideo" "on" a considérablement péjoré le tout... avant les vidéo n'était "que" saccadées, maintenant j'ai une image qui passe comme un flash par seconde et le reste est beau noir...

Je ne sais plus quoi faire...

Hors ligne

#12 Le 10/05/2008, à 14:52

Galileo

Re : Probleme avec l'extension X-Video

Bonjour,
Si ça peut aider quelqu'un, voici la partie de mon xorg.conf que j'ai modifié pour faire marcher Xvideo avec une Radeon 9600Pro :

Section "Device"
       Identifier "Configured Video Device"
       Driver "fglrx"
       Option "VideoOverlay" "on"
       Option "OpenGLOverlay" "off"
       Option "TexturedVideo" "on"
       Option "XaaNoOffscreenPixmaps"
       Option "UseFastTLS" "2"
       Option "RenderAccel" "true"

A noter que je peut toujours lire les vidéos en utilisant l'extension x11 (option "-vo x11" de mplayer) sans aucun problème avec compiz big_smile


Keyboard not found,  press enter to continue :

Hors ligne

#13 Le 10/05/2008, à 23:58

Dromar

Re : Probleme avec l'extension X-Video

Lorsque je suis sous Compiz, je peux généralement lire les vidéos sans problème avec Xvideo mais uniquement lorsqu'elles sont en plein écran (je dit généralement car parfois, après une manipulation que j'ai déjà faite plusieurs fois sans réussir à la définir =/ même en plein écran ça flashote)

Et je peux également lire les vidéos en utilisant la sortie X11, mais je ne peux pas rédimensioner les vidéos avec ce mode... Ce qui fait que je peux difficilement l'utiliser, pas de plein écran etc... et les vidéos qui sont à la base d'un trop grande définition dépassent allégrement de mon p'tit écran ...

En combinant xvideo pour le plein écran et x11 pour le reste, on s'en sort, mais c'est plutôt bancal comme solution, j'ai preféré désactiver compiz.

EDIT: Juste après avoir écrit ce post, je me suis rendu compte que le seul truc qui me fait default c'est une sortie X11 qui me permette de changer la taille de la vidéo, et c'est alors que j'ai eu l'illumination yikes je me suis souvenu d'un logiciel quasi-parfait (pour moi x)), SMPlayer. Quasi-parfait car pour moi rien ne vaut mplayer en ligne de commande, mais bon. SMPlayer donc est une couche externe qui permet d'utiliser mplayer avec une interface graphique, et qui est à mille lieux de l'affreuse interface graphique qui est installé par default avec mplayer... (je ne comprend d'ailleurs vraiment pas pourquoi elle l'est, m'enfin). Ce logiciel permet me permet donc d'utiliser la sortie X11 et de mettre les vidéos en plein écran, les redimensionner etc...
Bref, pour ma part, problème résolu. Bien que j'attende tout de même la mise à jour pour régler le problème de AIGLX avec la sortie Xvideo, mais aparament c'est pas pour tout de suite =/

Dernière modification par Dromar (Le 11/05/2008, à 00:24)

Hors ligne

#14 Le 11/05/2008, à 12:06

Galileo

Re : Probleme avec l'extension X-Video

Dromar : Tu peux aussi redimensionner en utilisant VLC.

Sinon pour ceux qui utilisent la ligne de commande, vous pouvez aliaser mplayer pour qu'il appelle "mplayer -vo x11" en ajouter cette ligne dans votre fichier ~/.bashrc :

alias mplayer='mplayer -vo x11'

Keyboard not found,  press enter to continue :

Hors ligne

#15 Le 11/05/2008, à 14:38

Dromar

Re : Probleme avec l'extension X-Video

Je suis accro a mplayer ^^ mais c'est vrai que VLC est également un très très bon lecteur.
Et je viens de faire une découverte, pour redimensionner les vidéos lorsqu'on utilise la sortie x11, il faut le faire de façon logicielle, ce que mplayer sait évidemment faire :

mplayer -vo x11 -zoom

Et merci Galileo, je n'ai pas encore le réflexe de me faciliter la vie en utilisant les alias smile

Hors ligne

Haut de page ↑