Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#51 Le 29/04/2008, à 12:42

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

Ca marche !
Je suis loin d'avoir tout compris, mais ca marche !
Merci, merci, merci !

Hors ligne

#52 Le 29/04/2008, à 13:09

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

je vais tenter de créer une page simple pour cette carte avec rt73 usb en reprenant la solution.
Je ne pourrais pas détailler ne comprenant pas tout, mais ca pourra peut etre aider des personnes.
Si des personnes veulent m'aider...

Hors ligne

#53 Le 29/04/2008, à 13:55

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

En fait, il y a des changements avec avant :
La carte ne donne plus d'idée du power des réseaux, mais par contre est netemment plus stable.
Elle fait que de changer de channel. Aucune carte ne m'avait fait ca précédemment...
on fera avec !

Hors ligne

#54 Le 06/05/2008, à 15:25

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

Je reviens vers ce poste, car j'ai à nouveau des ennuis.

Je ne sais si ca vient du fait que j'ai installé wicd (j'ai une carte interne qui avec lspci donne ceci :

02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

et qui ne marchait que par alternance, mettant 1h à se connecter à mon réseau. D'ou installation de wicd qui chez d'autre avait résolu la situation -ce qui est mon cas, mais à bloqué le problème de ma carte wifi usb-) ou que j'ai fais des mises à jours, mais à nouveau ma carte wifi usb edimax chipset rt73 n'est plus détectée et ne fonctionne plus :-(

lsusb :

robert@XX:~$ lsusb
Bus 005 Device 003: ID 148f:2573 Ralink Technology, Corp. 
Bus 005 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 002: ID 0a5c:2101 Broadcom Corp. 
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 004: ID 04d9:1133 Holtek Semiconductor, Inc. 
Bus 001 Device 001: ID 0000:0000

iwconfig

robert@XX:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"labom"  Nickname:""
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:66:D9:E9:81   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Power Management:off
          Link Quality=99/100  Signal level=-25 dBm  Noise level=-59 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Je reessaye donc de réinstaller avec votre méthode qui est :

sudo aptitude install linux-headers-$(uname -r) checkinstall
cd ~
cd ~/rt73-test
wget http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
tar -zxvf rt73-cvs-daily.tar.gz
cd rt73-cvs*/Module
make    #donne le retour
strip -S rt73.ko
checkinstall -D    #répoonds n, puis la touche enter jusqu'à la fin
sudo dpkg -i module_20080429-1_i386.deb     #on installe le pilote
sudo modprobe rt73     #on lance le pilote

voici ce que ca donne :

root@XX:~/rt73-cvs-2008042904/Module# cd ~
root@XX:~# cd ~/rt73-test
bash: cd: /home/robert/rt73-test: Aucun fichier ou dossier de ce type
root@XX:~# wget http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
--15:22:05--  http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
           => `rt73-cvs-daily.tar.gz.4'
Résolution de rt2x00.serialmonkey.com... 208.100.15.174
Connexion vers rt2x00.serialmonkey.com|208.100.15.174|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Longueur: 308 459 (301K) [application/x-gzip]

100%[====================================>] 308 459        1.12M/s             

15:22:06 (1.12 MB/s) - « rt73-cvs-daily.tar.gz.4 » sauvegardé [308459/308459]

root@XX:~# tar -zxvf rt73-cvs-daily.tar.gz
rt73-cvs-2008042904/
rt73-cvs-2008042904/FAQ
rt73-cvs-2008042904/THANKS
rt73-cvs-2008042904/CHANGELOG
rt73-cvs-2008042904/CVS/
rt73-cvs-2008042904/CVS/Root
rt73-cvs-2008042904/CVS/Repository
rt73-cvs-2008042904/CVS/Entries.Log
rt73-cvs-2008042904/CVS/Entries
rt73-cvs-2008042904/LICENSE
rt73-cvs-2008042904/Module/
rt73-cvs-2008042904/Module/auth.c
rt73-cvs-2008042904/Module/rt73.h
rt73-cvs-2008042904/Module/rt73.bin
rt73-cvs-2008042904/Module/rt2x00debug.h
rt73-cvs-2008042904/Module/md5.c
rt73-cvs-2008042904/Module/rtusb_data.c
rt73-cvs-2008042904/Module/rtmp_main.c
rt73-cvs-2008042904/Module/rt_config.h
rt73-cvs-2008042904/Module/assoc.c
rt73-cvs-2008042904/Module/CVS/
rt73-cvs-2008042904/Module/CVS/Root
rt73-cvs-2008042904/Module/CVS/Repository
rt73-cvs-2008042904/Module/CVS/Entries
rt73-cvs-2008042904/Module/wpa.c
rt73-cvs-2008042904/Module/sync.c
rt73-cvs-2008042904/Module/rtmp_info.c
rt73-cvs-2008042904/Module/iwpriv_usage.txt
rt73-cvs-2008042904/Module/rtusb_bulk.c
rt73-cvs-2008042904/Module/mlme.h
rt73-cvs-2008042904/Module/connect.c
rt73-cvs-2008042904/Module/rtmp_tkip.c
rt73-cvs-2008042904/Module/auth_rsp.c
rt73-cvs-2008042904/Module/oid.h
rt73-cvs-2008042904/Module/rtmp_init.c
rt73-cvs-2008042904/Module/TESTING
rt73-cvs-2008042904/Module/rtusb_io.c
rt73-cvs-2008042904/Module/rtmp.h
rt73-cvs-2008042904/Module/mlme.c
rt73-cvs-2008042904/Module/md5.h
rt73-cvs-2008042904/Module/wpa.h
rt73-cvs-2008042904/Module/rtmp_wep.c
rt73-cvs-2008042904/Module/rtmp_def.h
rt73-cvs-2008042904/Module/Makefile
rt73-cvs-2008042904/Module/rtmp_type.h
rt73-cvs-2008042904/Module/rt2x00debug.c
rt73-cvs-2008042904/Module/sanity.c
rt73-cvs-2008042904/README
root@XX:~# cd rt73-cvs*/Module
root@XX:~/rt73-cvs-2008042904/Module# make    #donne le retour
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.24-17-generic »
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.24-17-generic »
*** Module rt73.ko built successfully
root@XX:~/rt73-cvs-2008042904/Module# strip -S rt73.ko
root@XX:~/rt73-cvs-2008042904/Module# checkinstall -D    #répoonds n, puis la touche enter jusqu'à la fin

checkinstall 1.6.1, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
           This software is released under the GNU GPL.


The package documentation directory ./doc-pak does not exist. 
Should I create a default set of package docs?  [y]: 
Should I create a default set of package docs?  [y]: n

*****************************************
**** Debian package creation selected ***
*****************************************
/usr/bin/checkinstall: line 1166: dpkg-architecture : commande introuvable

*** Warning: The package name "Module" contains upper case
*** Warning: letters. dpkg might not like that so I changed
*** Warning: them to lower case.

This package will be built according to these values: 

0 -  Maintainer: [ root@XX ]
1 -  Summary: [ Package created with checkinstall 1.6.1 ]
2 -  Name:    [ module ]
3 -  Version: [ 20080506 ]
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ checkinstall ]
7 -  Architecture: [ i386 ]
8 -  Source location: [ Module ]
9 -  Alternate source location: [  ]
10 - Requires: [  ]

Enter a number to change any of them or press ENTER to continue: 

Installing with make install...

========================= Installation results ===========================
*** Install module in /lib/modules/2.6.24-17-generic/extra ...
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.24-17-generic »
  INSTALL /home/robert/rt73-cvs-2008042904/Module/rt73.ko
  DEPMOD  2.6.24-17-generic
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.24-17-generic »
/sbin/depmod -a
*** Update /etc/modprobe.d/ralink alias for wlan*
*** Install firmware in /lib/firmware ...
*** Check old config ...

======================== Installation successful ==========================
grep: /var/tmp/TMmPrIiCLXmGLoHRNrrhd/newfile: Aucun fichier ou dossier de ce type

Copying files to the temporary directory...OK

Stripping ELF binaries and libraries...OK

Compressing man pages...OK

Building file list...OK

Kernel modules found. Calling depmod in the postinstall script

Building Debian package...OK

Installing Debian package... FAILED!

*** Failed to install the package

Do you want to see the log file?  [y]: 
Do you want to see the log file?  [y]: n

Erasing temporary files...OK

Writing backup package...OK

Deleting temp dir...OK

root@XX:~/rt73-cvs-2008042904/Module# sudo dpkg -i module_20080429-1_i386.deb     #on installe le pilote
dpkg: la zone de la base de données d'état est verrouillée par un autre processus
root@XX:~/rt73-cvs-2008042904/Module# sudo modprobe rt73     #on lance le pilote
FATAL: Module rt73 not found.
root@XX:~/rt73-cvs-2008042904/Module#
root@XX:~/rt73-cvs-2008042904/Module# lsmod | grep usbcore
usbcore               146028  5 usbhid,hci_usb,ehci_hcd,uhci_hcd
root@XX:~/rt73-cvs-2008042904/Module# sudo iwlist scannig
iwlist: unknown command `scannig' (check 'iwlist --help').
root@XX:~/rt73-cvs-2008042904/Module# sudo lshw -C network
  *-network               
       description: Wireless interface
       product: PRO/Wireless 3945ABG Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wmaster0
       version: 02
       serial: 00:18:de:75:47:c8
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 ip=192.168.1.102 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 5
       bus info: pci@0000:05:05.0
       logical name: eth0
       version: 02
       serial: 00:13:77:48:7f:4d
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=half ip=192.168.158.100 latency=32 link=no module=ssb multicast=yes port=twisted pair speed=10MB/s
root@XX:~/rt73-cvs-2008042904/Module# iwconfig

très long message...
j'ai essayé de tout reprendre...

Hors ligne

#55 Le 06/05/2008, à 17:22

ilcorsironero

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

Alors,

1-tu est en superutilisateur et tu utilises sudo devant les commandes

2-Il faut lire les retours du terminal, en plus en français
root@XX:~/rt73-cvs-2008042904/Module# sudo dpkg -i module_20080429-1_i386.deb     #on

installe le pilote
dpkg: la zone de la base de données d'état est verrouillée par un autre processus

J'en conclue que tu ne fais strictement rien pour te documenter et ni
chercher ce qui a été dit sur une quelconque erreur.

Trouve toi un sav

#56 Le 06/05/2008, à 18:13

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

c'est exact, je devrais retaper les commandes, mais je ne le fais pas par gain de temps. Fautif, mais bon, est ce vraiment important ?

Pour me documenter, si, j'y bosse bcp, et sur pleins de choses à la fois, sans doute mon erreur. Je ne peux pas tout savoir ni tout voir.

N'ayant sans doute pas le même niveau que toi, et au bout d'une heure à essayer, il est vrai que je m'emporte sans tout lire.

Hors ligne

#57 Le 07/05/2008, à 10:59

rtrryjujty

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

le niveau ça m'est égal
chacun a un passé différent

c'est juste qu'un minimum d'effort n'est pas la mer à boire.

redonne

sudo lshw -C network
lsmod
sudo modprobe rt73
sudo iwlist scanning

#58 Le 07/05/2008, à 14:58

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

je viens de reprendre du temps pour tenter de réussir, en n'utilisant "sudo" que quand il faut, et chaque opération séparée.
Il y a un problème à la ligne

robert@XX:~/rt73-cvs-2008042904/Module$ sudo dpkg -i module_20080429-1_i386.deb     #on installe le pilote
dpkg - avertissement : module mis à jour de la version 20080507-1 vers l'ancienne version 20080429-1.
(Lecture de la base de données... 121580 fichiers et répertoires déjà installés.)
Préparation du remplacement de module 20080507-1 (en utilisant module_20080429-1_i386.deb) ...
Dépaquetage de la mise à jour de module ...
[u]dpkg : module : avertissement - le conffile « etc/modprobe.d » n'est ni un
 vrai fichier ni un lien (= « /etc/modprobe.d »)
Paramétrage de module (20080429-1) ...
dpkg : module : avertissement - le conffile « /etc/modprobe.d » n'est ni un
 vrai fichier ni un lien (= « /etc/modprobe.d »)[/u]

cette fois, il n'y avait pas de processus en marche.

J'ai essayé de refaire l'étape qui ne marchait pas :

robert@XX:~/rt73-cvs-2008042904/Module$ sudo modprobe rt73     #on lance le pilote
FATAL: Could not open '/lib/modules/2.6.24-17-generic/extra/rt73.ko': No such file or directory
robert@XX:~/rt73-cvs-2008042904/Module$ cd ..
robert@XX:~/rt73-cvs-2008042904$ cd ..
robert@XX:~$ sudo dpkg -i module_20080429-1_i386.deb     #on installe le pilote
dpkg : erreur de traitement de module_20080429-1_i386.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 module_20080429-1_i386.deb
robert@XX:~$ sudo modprobe rt73     #on lance le pilote
FATAL: Could not open '/lib/modules/2.6.24-17-generic/extra/rt73.ko': No such file or directory
robert@XX:~$

Pour ce que tu demandes :

robert@XX:~$ sudo lshw -C network
  *-network               
       description: Wireless interface
       product: PRO/Wireless 3945ABG Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wmaster0
       version: 02
       serial: 00:18:de:75:47:c8
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 ip=192.168.1.102 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 5
       bus info: pci@0000:05:05.0
       logical name: eth0
       version: 02
       serial: 00:13:77:48:7f:4d
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=half ip=192.168.158.100 latency=32 link=no module=ssb multicast=yes port=twisted pair speed=10MB/s
robert@XX:~$ lsmod
Module                  Size  Used by
rfkill                  8592  0 
input_polldev           5896  0 
crc_itu_t               3072  0 
af_packet              23812  4 
arc4                    2944  2 
ecb                     4480  2 
blkcipher               8324  1 ecb
i915                   32512  2 
drm                    82580  3 i915
binfmt_misc            12808  1 
rfcomm                 41744  2 
l2cap                  25728  13 rfcomm
ppdev                  10372  0 
acpi_cpufreq           10796  0 
cpufreq_stats           7104  0 
cpufreq_conservative     8712  0 
cpufreq_ondemand        9740  2 
freq_table              5536  3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
cpufreq_userspace       5284  0 
cpufreq_powersave       2688  0 
sbs                    15112  0 
sbshc                   7680  1 sbs
container               5632  0 
dock                   11280  0 
iptable_filter          3840  0 
ip_tables              14820  1 iptable_filter
x_tables               16132  1 ip_tables
sbp2                   24072  0 
parport_pc             36260  0 
lp                     12324  0 
parport                37832  3 ppdev,parport_pc,lp
pcmcia                 40876  0 
joydev                 13120  0 
ipv6                  267780  10 
snd_hda_intel         344728  3 
hci_usb                16540  2 
snd_pcm_oss            42144  0 
snd_mixer_oss          17920  1 snd_pcm_oss
bluetooth              61156  7 rfcomm,l2cap,hci_usb
snd_pcm                78596  2 snd_hda_intel,snd_pcm_oss
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
snd_seq_dummy           4868  0 
snd_seq_oss            35584  0 
snd_seq_midi            9376  0 
snd_rawmidi            25760  1 snd_seq_midi
snd_seq_midi_event      8320  2 snd_seq_oss,snd_seq_midi
snd_seq                54224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              24836  2 snd_pcm,snd_seq
video                  19856  0 
output                  4736  1 video
iwl3945                89844  0 
iwlwifi_mac80211      219108  1 iwl3945
snd_seq_device          9612  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
serio_raw               7940  0 
snd                    56996  17 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
sdhci                  19076  0 
ricoh_mmc               4352  0 
mmc_core               51460  1 sdhci
yenta_socket           27276  1 
rsrc_nonstatic         13696  1 yenta_socket
pcmcia_core            40596  3 pcmcia,yenta_socket,rsrc_nonstatic
cfg80211               15112  1 iwlwifi_mac80211
iTCO_wdt               13092  0 
iTCO_vendor_support     4868  1 iTCO_wdt
battery                14212  0 
ac                      6916  0 
soundcore               8800  1 snd
pcspkr                  4224  0 
evdev                  13056  7 
button                  9232  0 
intel_agp              25492  1 
agpgart                34760  3 drm,intel_agp
shpchp                 34452  0 
pci_hotplug            30880  1 shpchp
psmouse                40336  0 
ext3                  136712  2 
jbd                    48404  1 ext3
mbcache                 9600  1 ext3
usbhid                 31872  0 
hid                    38784  1 usbhid
sg                     36880  0 
sr_mod                 17956  0 
cdrom                  37408  1 sr_mod
sd_mod                 30720  4 
ata_piix               19588  3 
ata_generic             8324  0 
b44                    28432  0 
pata_acpi               8320  0 
libata                159344  3 ata_piix,ata_generic,pata_acpi
scsi_mod              151436  5 sbp2,sg,sr_mod,sd_mod,libata
ohci1394               33584  0 
ieee1394               93752  2 sbp2,ohci1394
ssb                    32260  1 b44
mii                     6400  1 b44
ehci_hcd               37900  0 
uhci_hcd               27024  0 
usbcore               146028  5 hci_usb,usbhid,ehci_hcd,uhci_hcd
thermal                16796  0 
processor              36872  4 acpi_cpufreq,thermal
fan                     5636  0 
fbcon                  42912  0 
tileblit                3456  1 fbcon
font                    9472  1 fbcon
bitblit                 6784  1 fbcon
softcursor              3072  1 bitblit
fuse                   50580  3 
robert@XX:~$ sudo modprobe rt73
FATAL: Could not open '/lib/modules/2.6.24-17-generic/extra/rt73.ko': No such file or directory
robert@XX:~$ sudo iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:0F:66:D9:E9:81
                    ESSID:"labom"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=82/100  Signal level=-22 dBm  Noise level=-55 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=000000149c0fe78d

robert@XX:~$

Je commence à avoir d'autres bugs : notamment avec firefox.
Je faisais des recherches hier (5/6 onglets, rien de bien impressionnant face à ma config), et mon ordinateur etait en perpetuel recherche (disque dur qui tourne à fond pour rien).
Là, autre bug :
je réponds sur le forum, alors meme que la page est toute de grise vétu. Comme quand firefox bug (ce qui lui arrivait toutes les 5 min hier :s)...
Je suis pas mal perdus.
Je pense que je ne vais pas tarder à réinstaller la 8.04.
Lors des permiers tests pour cette carte, on m'avait dit de mettres toutes les sources de mises à jour (cocher toutes les cases), dois je continuer ?

Hors ligne

#59 Le 07/05/2008, à 16:28

schmilblik

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

Voila
tape

cd
sudo dpkg -r module
rm -rf rt73-cvs-2008042904
rm -rf rt73*

puis
Muni d\'une connexion

sudo apt-get update
sudo apt-get install build-essential linux-headers-$(uname -r)
cd ~
mkdir ~/rt73
cd ~/rt73
wget http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
tar -zxvf rt73-cvs-daily.tar.gz
cd rt73-cvs*/Module
echo \'blacklist rt73usb\' | sudo tee -a /etc/modprobe.d/blacklist
echo \'blacklist rt2500usb\' | sudo tee -a /etc/modprobe.d/blacklist
echo \'rt73\' | sudo tee -a /etc/modules
make
sudo ifconfig wlan0 down
sudo modprobe -r rt73usb
sudo modprobe -r rt2500usb
sudo make install
sudo mkdir /lib/modules/$(uname -r)/extra     
sudo cp rt73.ko /lib/modules/$(uname -r)/extra/rt73.ko    
sudo depmod -ae
sudo modprobe rt73
sudo ifconfig wlan1 up

Pour rappel, on ne peut utiliser network-manager
Il reste, soit à utiliser RutilT
soit à éditer le fichier des interfaces pour rentrer les paramètres du réseau:
(remplace wlan1 par le nom de l\'interface réseau gérant le rt73)

sudo gedit /etc/network/interfaces   #remplacer gedit par kate si tu es sous kubuntu

pour un cryptage WEP clé hexadécimale

auto lo
iface lo inet loopback

auto wlan1
iface wlan1 inet dhcp
wireless-essid le_essid_de_la_box    #à compléter
wireless-key La_clé_en_hexa    #à compléter

en WPAPSK TKIP

auto wlan1
iface wlan1 inet dhcp
pre-up iwconfig wlan1 essid \"mon ssid\"
pre-up iwpriv wlan1 set AuthMode=WPAPSK
pre-up iwpriv wlan1 set EncrypType=TKIP
pre-up iwpriv wlan1 set WPAPSK=\"Ma_cle_WPA_Ultra_Secrete_que_y\'a_que_moi_qui_sais\"

puis on redémarre ou on relance le réseau

sudo ifconfig wlan0 down
sudo ifdown wlan1
sudo ifup wlan1

#60 Le 07/05/2008, à 16:57

foluia

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

j'ai suivis ce que tu as marqué.
Plusieurs remarques :
- la console s'est mise en mode super administrateur sans que je lui ai demandé (root)
- dans les commandes : sudo modprobe -r rt73usb
sudo modprobe -r rt2500usb
il me mettait un "warning" avec à chaque fois les lignes 40-41, mais ayant fermé par erreur la console, je ne peux les copiers. Pas grave, ce que tu as fait semble marché. J'ai à nouveau wlan0 et wlan1 (pour le rt73).

"Pour rappel, on ne peut utiliser network-manager" tu parles ici pour ma carte rt73 j'imagine ? -dans ce cas, ce n'est pas grave, j'avais appris à me connecter tel que tu l'as noté dans ton mot merci :-) -
Pour la carte intégrée, cela ne changera rien ?

Je vais voir ce que cela donne sur plusieurs jours. J'espere que firefox arrêtera de planter.
Depuis ton opération, mon système me signale de nouvelles mises à jour.
Je vais les faire en espérant choisir la bonne option.

Merci de ton aide

Hors ligne

#61 Le 25/08/2008, à 15:01

dje007

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

bonjour,

Debutant sous linux, je me decide a poster pour mon probleme connection wifi impossible avec d-link rt73usb mad

j'ai suivit des indications ici : http://www.emiliengirault.fr/linux/ubuntu/drivers-rt73ubuntu-hardy/  tres bon tuto a mon gout

afin d'installer les drivers serialmonkey, tout c'est bien passer smile

j'ai editer le fichier blacklist en rajoutant en bas du fichier ceci:


blacklist rt73usb
blacklist rt2570
blacklist rt2500usb
blacklist rt2x00lib

et j'ai poursuivit l'installation des driver

le mode monitor est alor accessible mais depuis je ne parvient plus a me connecter a internet aurais-je oublier quelque chose ?

merci de m'aider a solutionner ce probleme

cordialement,

Hors ligne

#62 Le 25/08/2008, à 15:03

dje007

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

bonjour,

Debutant sous linux, je me decide a poster pour mon probleme connection wifi impossible avec d-link rt73usb mad

j'ai suivit des indications ici : http://www.emiliengirault.fr/linux/ubuntu/drivers-rt73ubuntu-hardy/

afin d'installer les drivers serialmonkey, tout c'est bien passer big_smile

j'ai editer le fichier blacklist en rajoutant en bas du fichier ceci:


blacklist rt73usb
blacklist rt2570
blacklist rt2500usb
blacklist rt2x00lib

et j'ai poursuivit l'installation des driver

le mode monitor est alor accessible mais depuis je ne parvient plus a me connecter a internet aurais-je oublier quelque chose ?

merci de m'aider a solutionner ce probleme

cordialement,

Hors ligne

#63 Le 25/08/2008, à 20:00

willy78

Re : 8.04 : chipset rt73 ne marche plus (carte ew 7318usg)

retour de

sudo lshw -C network
iwlist scan
cat /etc/network/interfaces

Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne