Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 05/08/2014, à 10:43

bird12358

Probleme de disparition d'icones

Bonjour,

J'ai développé sous Qt une application test pour l'affichage d'image sur mes icones.
Une fois compilé, mon application est mise dans un dossier toto/bin et mes images des icones dans toto/images.

Dans mon programme mes images des icones sont appelé comme ceci:

... Icon("../images/monimage.png") 

Quand je lance le fichier mon application dans /toto/bin je vois bien mes images dans mes icones.

Ensuite j'ai essayé de faire un raccourcie de mon application sur mon bureau et de la relancé.

Mais là, les icônes n'apparaissent plus, comment je peux gérer ce problème de lien?

Si quelqu'un a une solution?

D'avance merci.

Hors ligne

#2 Le 05/08/2014, à 10:47

pingouinux

Re : Probleme de disparition d'icones

Bonjour,
Essaye de remplacer "../images/monimage.png" par le chemin complet.

Hors ligne

#3 Le 05/08/2014, à 15:02

bird12358

Re : Probleme de disparition d'icones

Merci pour la réponse.

Je suis sur que dans ce cas, ca va fonctionner.
Mais pourquoi quand j'utilise un raccourcie, n'utilise-t-il plus la position dans l'arborescence de mon appli mais celui du raccourcie?

Hors ligne

Haut de page ↑