Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 13/05/2008, à 22:08

Alv

La lecture video fait complètement planter l'affichage

Bonjour,

j'ai un petit problème bien ennuyant. Lorsque je lance une vidéo avec vlc, il plante aléatoirement (je dirais une fois sur cinq) mais le pire c'est que tout l'affichage part avec. Ce que je veux dire c'est qu'on voit bien l'ordi tourner comme si rien, mais rien ne répond à l'écran à part bouger la souris (je clique dans le vide si j'essaye, pareil pour le clavier).
Je suis habitué à utiliser vlc assez souvent, c'est pourquoi j'aimerais régler ce problème.
Si quelqu'un a une quelconque idée. Merci d'avance.

EDIT: Il semble que c'est un problème lié au gestionnaire de composite. Donc si compiz-fusion ou xcompgr est lancé, il y a de grandes chances que ça plante à la lecture d'une vidéo. Le chipset intégré Intel est principalement touché par ce problème.

Dernière modification par Alv (Le 09/01/2009, à 20:30)

Hors ligne

#2 Le 13/05/2008, à 23:02

phanux

Re : La lecture video fait complètement planter l'affichage

Bonsoir Alv,

C'est un soucis que je partage en parti comme beaucoup d'autre d'après ce que j'ai pu voir.

Dans les préférences de vlc, "Vidéo", "Modules de sortie" (Options avancées=coché), vérifie si tu n'utilise pas "OpenGL". Si c'est le cas remplace par "X11" ou "XVideo", cela devrait marcher mieu. (au détriment de la qualitée hélas...)


Ubuntu 8.04 64, AMD Sempron 2800+, Nvidia Gforce 6200 ...

Hors ligne

#3 Le 13/05/2008, à 23:12

Alv

Re : La lecture video fait complètement planter l'affichage

Merci de ta réponse. Malheureusement, le problème ne doit pas venir de là puisque j'avais déjà XVideo en module de sortie video. sad

Hors ligne

#4 Le 27/05/2008, à 18:53

Alv

Re : La lecture video fait complètement planter l'affichage

J'up ce sujet car malgré mes recherches, je n'ai pas trouvé de réponse.
De plus, il semblerait que ce soit un problème généralisé à la lecture vidéo avec n'importe quel lecteur puisque résigné à devoir laisser vlc, j'ai eu exactement le même genre de plantages avec totem (à savoir seulement l'affichage qui freeze, puisque le son de la vidéo continue malgré l'impossiblité de faire quoi que ce soit d'autre et je suis forcé d'éteindre brutalement).
Ce que j'ai pu remarquer, c'est que quand j'étais sous feisty, je n'avais jamais eu ce problème. Mais depuis gutsy et maintenant sur hardy, je rencontre ce problème malgré quelques réinstallations complètes du système que j'ai du faire.

Hors ligne

#5 Le 27/05/2008, à 20:36

guigoz

Re : La lecture video fait complètement planter l'affichage

je suis dans le même cas, mais uniquement depuis hardy hmm

Hors ligne

#6 Le 30/05/2008, à 20:59

Alv

Re : La lecture video fait complètement planter l'affichage

Un petit up. big_smile
C'est quand même un peu lourd d'avoir un système stable qui plante à cause d'un programme aussi simple que vlc. sad

Sinon petite précision, maintenant que tu le dis guigoz, c'est possible que ça ne soit que depuis Hardy (et non aussi Gutsy comme j'ai dit au-dessus).

Hors ligne

#7 Le 30/05/2008, à 21:24

bilbo858

Re : La lecture video fait complètement planter l'affichage

C'est un soucis que je partage en parti comme beaucoup d'autre d'après ce que j'ai pu voir.

En effet, j'ai exactement le même problème, je sais que ça fait toujours plaisir de ne pas se sentir seul tongue

Et effectivement, vlc n'est pas le seul à faire ce genre de blague, j'ai même eu le soucis avec rhythmbox lorsque j'ai voulu tester la visualisation ... Si ça peut aider.

J'ai un laptop, avec une carte graphique intel

Dernière modification par bilbo858 (Le 30/05/2008, à 21:28)

Hors ligne

#8 Le 30/05/2008, à 21:55

guigoz

Re : La lecture video fait complètement planter l'affichage

carte graphique intel +1

en revanche, j'ai tout passé en xvideo, j'ai moins de merde

Hors ligne

#9 Le 31/05/2008, à 22:07

Alv

Re : La lecture video fait complètement planter l'affichage

Pareil, chipset graphique intel. hmm
Et je suis depuis longtemps en XVideo (j'ai d'ailleurs essayé X11 pour voir, mais ça plante toujours autant).

Hors ligne

#10 Le 02/06/2008, à 19:37

Alv

Re : La lecture video fait complètement planter l'affichage

Un petit up? tongue

Hors ligne

#11 Le 05/06/2008, à 14:55

bilbo858

Re : La lecture video fait complètement planter l'affichage

Toujours personne..

Une chose est sur, changer opengl en x11 avec vlc, ne change rien au problème, c'est vraiment un nprobleme aléatoire et je n'arrive toujours pas a cerner pourquoi ca passe et parfois pas.

Le problème déjà présenté avec vlc, rhytmbox, totem, firefox avec les différents plugins pour visionner des videos.


Perso j'ai essayer de passer en xine à la place de gstreamer, ca passe maintenant... mais tout à l'heure.. même si je doute franchement que le problème viennent du moteur.

Ca me parrait quand un problème assez grave...Si quelqu'un a une idée???pulseAudio??xine/gstreamer??chipset Intel/openGL/X11??

Hors ligne

#12 Le 05/06/2008, à 16:53

Alv

Re : La lecture video fait complètement planter l'affichage

pulseaudio: je ne crois pas puisque j'ai tout mis en alsa (à cause du fameux plantage de firefox sur les vidéos flash).

chipset intel: sûrement puisque nous l'avons tous les trois.

En revanche j'ai une petite différence avec toi: je n'ai jamais eu de plantage avec rhythmbox (pourtant je le lance plutôt souvent).

Ah et petite dernière chose, des fois (qui au début étaient plutôt rares, mais qui dernièrement sont un peu plus fréquentes) mon système plante complètement (mais vraiment complètement puisque même SEIUB ne donne aucune réponse, obligé d'utiliser le bouton du courant) et la led du caps lock se met à clignoter. Une idée sur ce que ça peut être? (peut-être que c'est aussi lié au même problème que celui du sujet)

Hors ligne

#13 Le 05/06/2008, à 17:11

bilbo858

Re : La lecture video fait complètement planter l'affichage

En revanche j'ai une petite différence avec toi: je n'ai jamais eu de plantage avec rhythmbox (pourtant je le lance plutôt souvent).

Seulement quand je choisi l'option "visualisation", c'est vrai j'aurai du préciser wink

même SEIUB ne donne aucune réponse, obligé d'utiliser le bouton du courant) et la led du caps lock se met à clignoter

Ca j'ai jamais eu  yikes

Hors ligne

#14 Le 05/06/2008, à 17:24

Alv

Re : La lecture video fait complètement planter l'affichage

bilbo858 a écrit :

Seulement quand je choisi l'option "visualisation", c'est vrai j'aurai du préciser wink

Ah ouais exact, je mets jamais la visualisation, normal que ça plante pas alors. tongue

Hors ligne

#15 Le 07/06/2008, à 14:10

Alv

Re : La lecture video fait complètement planter l'affichage

Bon je remonte ce sujet avec une autre mésaventure. sad
Hier j'ai fait une réinstallation complète à cause d'un problème qui n'a rien à voir avec ce sujet. Je me dis donc "peut-être qu'avec un peu de chance, je n'aurai plus de plantages avec les vidéos".
Et bien j'ai eu un peu trop d'espoir. Je me fais une soirée visionnage et tout va bien pendant deux heures, en ouvrant et fermant pas mal de fois le lecteur, aucun problème. Et puis en plein dans une vidéo, paf, plantage total (son qui se répète comme un disque rayé + extinction à l'arrache avec le bouton du courant).
Je me dis "zut pas de chance". Je redémarre donc et je décide d'aller un peu sur internet avant de reprendre a vidéo. Je tombe sur une page avec de la vidéo (divx je crois, donc avec le lecteur mozilla-mplayer) et paf replantage alors que ça faisait à peine 5 minutes que j'avais redémarré (cette fois-ci j'ai pu faire la manip SEIUB).
Evidemment énervé j'ai laissé tomber et j'ai arrêté ma soirée là.

Tout ça pour dire que ça devient assez irritant à la longue d'avoir des plantages aléatoire sur une chose aussi bête qu'est la lecture vidéo. hmm

N'y a-t-il vraiment pas de solution? Je n'ai franchement pas envie de revenir sur gutsy rien que pour ça. >_<
Y'a pas un log du crash qui pourrait être analysable quelquepart?

Dernière modification par Alv (Le 07/06/2008, à 14:11)

Hors ligne

#16 Le 08/06/2008, à 06:36

fred44

Re : La lecture video fait complètement planter l'affichage

C'est effectivement un bug serieux... Je suis dans le meme cas, avec un laptop et un chipset graphique intel. Il semblerait donc, d'apres les precedents posts, que ce probleme soit lié aux drivers intel, (associé à l'utilisation de Compiz ?)

Notez-vous une difference si Compiz n'est pas activé ?  (systeme-->preferences-->apparence/onglet "effets visuels"-->cochez "aucun"

Hors ligne

#17 Le 08/06/2008, à 08:44

bilbo858

Re : La lecture video fait complètement planter l'affichage

essaie de passer sur xine aussi, c'est p-ê juste de la chance mais depuis que j'ai posté le dernier message càd, depuis 3 jours je n'ai plus eu aucun soucis...

Manip :
--------
- laisser compiz
- supprimé totem-gstreamer pour totem-xine
- installer toutes les librairies xine
- installer les codec w32
- installer la lib pour la lecture de dvd (libdvdcss)
- placer vlc en X11
- installer gxine pour tester d'autres lecteurs
- ne pas activer la visualisation sur rhytmbox par que lui ne tourne qu'en gstreamer.

Etant donné qu'on ne sait pas d'où vient le problème je test et pour l'instant ca tourne.

Faites ce que j'ai fais et dites moi si le probleme continue

Hors ligne

#18 Le 08/06/2008, à 11:02

guigoz

Re : La lecture video fait complètement planter l'affichage

moi, depuis que j'ai tout mis en xvideo, il ne plante en sortie de veille maintenant, sinon il plante plus

Dernière modification par guigoz (Le 08/06/2008, à 11:03)

Hors ligne

#19 Le 08/06/2008, à 12:58

Alv

Re : La lecture video fait complètement planter l'affichage

fred44 => j'ai déjà essayé, mais ça ne change rien hmm
bilbo858 => Le X11 me fait planter quand même et en plus il est aliasé sad
guigoz => Je suis en XVideo depuis le début lol

Hors ligne

#20 Le 08/06/2008, à 14:07

bilbo858

Re : La lecture video fait complètement planter l'affichage

fred44 => j'ai déjà essayé, mais ça ne change rien hmm
bilbo858 => Le X11 me fait planter quand même et en plus il est aliasé sad
guigoz => Je suis en XVideo depuis le début lol

et le reste que je te propose?

Hors ligne

#21 Le 08/06/2008, à 14:33

Alv

Re : La lecture video fait complètement planter l'affichage

J'ai déjà tout fait mais maintenant que tu me le dis, je n'ai pas encore essayé avec les librairies xine.
Mais comme j'utilise mplayer, je ne sais pas comment faire pour qu'il utilise xine et non gstreamer


PS: Le problème du plantage avec la led du caps lock qui clignote ne semble pas venir de la vidéo mais de mon wifi. Donc au final c'est le même genre de plantage que vous que j'ai avec les vidéos.
PS2: On m'a dit d'essayer sur un autre forum de lancer mplayer avec la commande mplayer -vo xv -ao alsa. Pour l'instant je n'ai pas de plantage. Affaire à suivre donc.

Dernière modification par Alv (Le 08/06/2008, à 14:41)

Hors ligne

#22 Le 09/06/2008, à 15:27

Alv

Re : La lecture video fait complètement planter l'affichage

Bon et bien apparemment, en faisant gmplayer -vo xv -ao alsa, aucun problème. Comme quoi, vaut mieux forcer les sorties video et audio en ligne de commande que de le faire par l'interface graphique.
Je vous laisse essayer. (Si vous avez un autre player, faites --help pour voir les commandes disponibles et ainsi savoir lesquelles utiliser pour les sorties audio et video)

Hors ligne

#23 Le 09/06/2008, à 15:37

blahnotblahblah

Re : La lecture video fait complètement planter l'affichage

tous les programmes qui plantent de temps en temps, lancez les en console avec la commande strace pour piéger l'erreur, ex :
strace [cheminAbsoluNomProg]  > nomProg.strace

y a de bonnes chances d'en savoir plus ce que qui provoque le pb .


proverbe ashanti: "Quand la maison brûle, on ne perd pas de temps à pérorer".

Hors ligne

#24 Le 14/06/2008, à 05:52

fred44

Re : La lecture video fait complètement planter l'affichage

Il semble que le probleme aie disparu avec la mise à jour du paquet "xserver-xorg-video-intel" (2:2.2.1-1ubuntu13.4) ?

Hors ligne

#25 Le 14/06/2008, à 10:17

guigoz

Re : La lecture video fait complètement planter l'affichage

+1

Hors ligne

Haut de page ↑