Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/01/2006, à 20:33

Ricou

[Résolu]erreur avec Latex

Bonsoir,

j'obtiens ce message quand j'essaye de compiler mon premier fichier .tex (je débute) et je ne sais pas ce qu'il faut faire...

"ricou@ubuntu:~$ latex premier
This is e-TeX, Version 3.14159-2.1 (Web2C 7.4.5)
entering extended mode
(./premier.tex
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, catalan, croatian, czech, danish, dutch, finnish, greek, iceland
ic, irish, italian, latin, magyar, norsk, norsk, portuges, romanian, russian, s
lovak, slovene, spanish, swedish, turkish, ukrainian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size11.clo))

! LaTeX Error: File `inputment.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:
"

voici ce que contient mon fichier .tex:

\documentclass[french,12pt]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\begin{document}
Bonjour, Monde!
\end{document}

merci de votre aide

Dernière modification par Ricou (Le 22/01/2006, à 00:53)

Hors ligne

#2 Le 21/01/2006, à 20:50

Skippy le Grand Gourou

Re : [Résolu]erreur avec Latex

Enlève le french de ton \documentclass, remplace le par a4paper, et rajoute [french] devant {babel}. wink


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#3 Le 21/01/2006, à 21:46

Ricou

Re : [Résolu]erreur avec Latex

J'effectue les changements mais j'ai toujours le meme message d'erreur.
Peut être qu'il me manque un package...?

Hors ligne

#4 Le 21/01/2006, à 22:06

Mathieu147

Re : [Résolu]erreur avec Latex

Ceci:

\documentclass[a4paper,12pt]{article}
\usepackage[T1]{fontenc}
\usepackage[french]{babel}
\begin{document}
Bonjour, Monde!
\end{document}

compile parfaitement bien chez moi, aucune erreur.

As-tu bien installé tetex-bin, tetex-base et tetex-extra ?

inputment.sty, je ne sais pas ce que c'est, je n'ai pas ce fichier sur mon ordi hmm


Pffff…

Hors ligne

#5 Le 21/01/2006, à 22:21

Ricou

Re : [Résolu]erreur avec Latex

J'ai bien installé tetex-bin tetex-base tetex-extra et j'obtient toujours le meme message...

Hors ligne

#6 Le 21/01/2006, à 22:31

Mathieu147

Re : [Résolu]erreur avec Latex

Voilà ce que donne ma compilation:

This is e-TeX, Version 3.14159-2.1 (Web2C 7.4.5)
entering extended mode
(./test.tex
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, catalan, croatian, czech, danish, dutch, finnish, greek, iceland
ic, irish, italian, latin, magyar, norsk, norsk, portuges, romanian, russian, s
lovak, slovene, spanish, swedish, turkish, ukrainian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size12.clo))
(/usr/share/texmf/tex/latex/base/fontenc.sty
(/usr/share/texmf/tex/latex/base/t1enc.def))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/frenchb.ldf
(/usr/share/texmf/tex/generic/babel/babel.def)
*************************************
* Local config file frenchb.cfg used
*
(/usr/share/texmf/tex/generic/babel/frenchb.cfg))) (./test.aux)
(/usr/share/texmf/tex/latex/cyrillic/ot2wncyr.fd) [1] (./test.aux) )
Output written on test.dvi (1 page, 240 bytes).
Transcript written on test.log.

C'est pas normal de voir «/usr/share/texmf/tex/latex/base/size11.clo» dans la sortie de ta compilation. Tu as demandé 12pt... Moi il met «/usr/share/texmf/tex/latex/base/size12.clo».

Je sais, ça ne doit pas t'avancer des masses mais je ne vois pas trop hmm

Qu'y a-t-il dans le fichier de log?

Dernière modification par Mathieu147 (Le 21/01/2006, à 22:32)


Pffff…

Hors ligne

#7 Le 21/01/2006, à 22:38

Ricou

Re : [Résolu]erreur avec Latex

Pour le 12pt c'est normal car j'ai changé légèrement le contenu mais cà ne change rien à mon problème...

J'ai bien un fichier premier.log qui est créé mais il est vide.

Dernière modification par Ricou (Le 21/01/2006, à 23:41)

Hors ligne

#8 Le 21/01/2006, à 22:50

bernez

Re : [Résolu]erreur avec Latex

J'ai la même sortie que toi mathieu147

J'ai un autre tetex tetex-frogg qui donne un style français roll

Running `LaTeX' on `essai' with ``latex  "\nonstopmode\input{essai.tex}"''
This is e-TeX, Version 3.14159-2.1 (Web2C 7.4.5)
entering extended mode
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, catalan, croatian, czech, danish, dutch, finnish, greek, iceland
ic, irish, italian, latin, magyar, norsk, norsk, portuges, romanian, russian, s
lovak, slovene, spanish, swedish, turkish, ukrainian, nohyphenation, loaded.

(./essai.tex (/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size12.clo))
(/usr/share/texmf/tex/latex/base/fontenc.sty
(/usr/share/texmf/tex/latex/base/t1enc.def))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/frenchb.ldf
(/usr/share/texmf/tex/generic/babel/babel.def)
*************************************
* Local config file frenchb.cfg used
*
(/usr/share/texmf/tex/generic/babel/frenchb.cfg))) (./essai.aux)
(/usr/share/texmf/tex/latex/cyrillic/ot2wncyr.fd) [1] (./essai.aux) )
Output written on essai.dvi (1 page, 240 bytes).
Transcript written on essai.log.

LaTeX finished at Sat Jan 21 21:40:33

Ricou, si j'osais je te dirais bien de relancer ta machine après les modif .. wink


vyé kanari ka fè bonsoup.
Kenavo. A galon !

Hors ligne

#9 Le 21/01/2006, à 23:16

Ricou

Re : [Résolu]erreur avec Latex

j ai installé le tetex-frogg et toujours rien!!

Par contre j'ai appuyé sur entrée apres l'affichage de l'erreur et ça donne cela:
ricou@ubuntu:~$ latex premier.tex
This is e-TeX, Version 3.14159-2.1 (Web2C 7.4.5)
entering extended mode
(./premier.tex
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, catalan, croatian, czech, danish, dutch, finnish, greek, iceland
ic, irish, italian, latin, magyar, norsk, norsk, portuges, romanian, russian, s
lovak, slovene, spanish, swedish, turkish, ukrainian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size11.clo))

! LaTeX Error: File `inputment.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:

! LaTeX Error: Unknown option `latin1' for package `inputment'.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
...

l.4 \usepackage
               [T1]{fontenc}
? ! Interruption.
\GenericError  ...
                                                  \endgroup
l.4 \usepackage
               [T1]{fontenc}
?


Je ne sais pas si ça peut être utile...
Puis après je refais entré et j'ai à la suite:

(/usr/share/texmf/tex/latex/base/fontenc.sty
(/usr/share/texmf/tex/latex/base/t1enc.def))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/frenchb.ldf
(/usr/share/texmf/tex/generic/babel/babel.def)
*************************************
* Local config file frenchb.cfg used
*
(/usr/share/texmf/tex/generic/babel/frenchb.cfg)))
No file premier.aux.
(/usr/share/texmf/tex/latex/cyrillic/ot2wncyr.fd) [1] (./premier.aux) )
Output written on premier.dvi (1 page, 352 bytes).
Transcript written on premier.log.
ricou@ubuntu:~$


Et donc là j'ai bien les fichiers: premier.aux, premier.div, premier.log qui se créent et le fichier 
div semble correct que je le visualise...
J'avoue ne pas comprendre car ça semble marcher mais pas façon normale...ce que j'aimerais bien regler!!

Hors ligne

#10 Le 21/01/2006, à 23:34

Achille

Re : [Résolu]erreur avec Latex

Regarde si ça va mieux avec ceci:
\usepackage[frenchb]{babel}
c'est-à-dire en remplaçant l'option french par frenchb.

Hors ligne

#11 Le 21/01/2006, à 23:38

Ricou

Re : [Résolu]erreur avec Latex

J'ai bien effectué le changement mais rien à faire, toujours le meme message d'erreur mad sad

Dernière modification par Ricou (Le 21/01/2006, à 23:48)

Hors ligne

#12 Le 21/01/2006, à 23:58

Skippy le Grand Gourou

Re : [Résolu]erreur avec Latex

vérifie que tu as bien le fichier fontenc.sty :

sudo locate -u    (si tu l'as jamais fait ou pas depuis avoir installé LaTeX)
locate fontenc.sty

EDIT : ou regarde simplement dans le dossier /usr/share/texmf/tex/latex/base/ ...

Dernière modification par Skippy le Grand Gourou (Le 22/01/2006, à 00:00)


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#13 Le 22/01/2006, à 00:11

Ricou

Re : [Résolu]erreur avec Latex

J'ai bien le fichier fontenc.sty.

Par contre, par rapport à ce que j'ai dis plus haut le fichier log n'est pas vide ,pourquoi tout a l'heure il l'était je ne sais pas mais quand j ai reconpilé une fois de plus il contenait cela:

This is e-TeX, Version 3.14159-2.1 (Web2C 7.4.5) (format=latex 2006.1.21)  21 JAN 2006 23:04
entering extended mode
**test.tex
(./test.tex
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, catalan, croatian, czech, danish, dutch, finnish, greek, iceland
ic, irish, italian, latin, magyar, norsk, norsk, portuges, romanian, russian, s
lovak, slovene, spanish, swedish, turkish, ukrainian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size11.clo
File: size11.clo 2001/04/21 v1.4e Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)

! LaTeX Error: File `inputment.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:
! Emergency stop.
<read *>
         
l.4 \usepackage
               [T1]{fontenc}^^M
End of file on the terminal!


Here is how much of TeX's memory you used:
200 strings out of 95370
2012 string characters out of 1188185
47266 words of memory out of 1000001
3343 multiletter control sequences out of 10000+50000
3940 words of font info for 15 fonts, out of 500000 for 1000
198 hyphenation exceptions out of 1000
21i,0n,19p,110b,36s stack positions out of 1500i,500n,5000p,200000b,5000s
No pages of output.



Voilà ce que j'ai.

Je viens de me rendre compte que mon contenu du fichier .tex est pas celui que j'avais mis au premier message hmm roll en fait c'est celui-ci:

\documentclass[a4paper,11pt]{article}

\usepackage[latin1]{inputment}
\usepackage[T1]{fontenc}
\usepackage[frenchb]{babel}

\begin{document}

Voici mon premier document avec \LaTeX.

\end{document}



Ce qui parait deja beaucoup correspondre à mon message d'erreur car j'utilise bien "inputment". Je vous pris de bien vouloir m'exuser pour cette erreur qui vous fais chercher pour rien... hmm hmm

Et donc le probleme est que ce n'est pas "inputment" qu'il faut utiliser mais "inputenc". Le probleme est que j'utilise un manuel en pdf pour debuter Latex et que j ai du faire une erreur avec le copier coller... roll

Encore merci pour votre aide mais la le probleme viens de moi pour le coup...

Dernière modification par Ricou (Le 22/01/2006, à 00:42)

Hors ligne

#14 Le 22/01/2006, à 00:31

Mathieu147

Re : [Résolu]erreur avec Latex

Et ton fichier, il est bien enregistré en iso-8859-1 ?


Pffff…

Hors ligne

#15 Le 22/01/2006, à 00:33

Skippy le Grand Gourou

Re : [Résolu]erreur avec Latex

Bizarre... Vérifie que tu as aussi les fichiers :

/usr/share/texmf/tex/latex/base/t1enc.def
/usr/share/texmf/tex/generic/babel/babel.sty
/usr/share/texmf/tex/generic/babel/frenchb.ldf
/usr/share/texmf/tex/generic/babel/babel.def

(et en particulier t1enc.def)

Au fait, je viens de relire ton premier post, et je vois que tu débutes totalement en LaTeX, aussi tu n'es peut-être pas au courant (donc je te le dis) qu'il y a des compilateurs pour LaTeX qui sont plein d'options très pratiques, telles que les raccourcis visuels vers de nombreuses commandes ou la "compilation+visualisation" en un clic... Je pense en particulier à Kile. wink (m'enfin certains préfèrent XEmacs pour ses raccourcis clavier, malgré la compilation en ligne de commande... roll )


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#16 Le 22/01/2006, à 00:40

Skippy le Grand Gourou

Re : [Résolu]erreur avec Latex

Mathieu147 a écrit :

Et ton fichier, il est bien enregistré en iso-8859-1 ?

Je viens d'essayer iso-8859-1, iso-8859-15, WINDOWS-1252, IBM850, et j'utilise par défaut UTF8, et à part pour UTF7 et UTF16 il n'y a pas eu de problème... (et pour ces deux derniers le problème ne vient pas de là)


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#17 Le 22/01/2006, à 00:44

Achille

Re : [Résolu]erreur avec Latex

Alors là, tout devient très clair! C'est cette ligne:

\usepackage[latin1]{inputment}

qu'il faut remplacer par

\usepackage[latin1]{inputenc}

ce qui correspond à un fichier enregistré en ISO-8859-1.

Sinon, vu que tu débutes sous LaTeX, je te recommande très vivement, si ce n'est déjà fait, de t'intéresser à l'éditeur Kile.

Dernière modification par Achille (Le 22/01/2006, à 00:46)

Hors ligne

#18 Le 22/01/2006, à 00:45

Ricou

Re : [Résolu]erreur avec Latex

J ai modifier mon dernier message plus haut ou j ai trouvé l'erreur: rien d'extraordinire juste une faute d' inattention roll qui vous a fais perdre du temps hmm hmm
désolé... et merci quand meme!

Hors ligne

#19 Le 22/01/2006, à 00:49

Skippy le Grand Gourou

Re : [Résolu]erreur avec Latex

roll
-> [Résolu] wink

-> Kile big_smile


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#20 Le 22/01/2006, à 00:51

Mathieu147

Re : [Résolu]erreur avec Latex

Pas de problème wink

Mais installe quand-même Kile! Si t'es sous Gnome, Winefish n'est pas mal non plus (indisponible via Synaptic mais un .deb traîne quelque part), quoique un peu moins pratique tout de même.


Pffff…

Hors ligne

#21 Le 22/01/2006, à 00:53

Skippy le Grand Gourou

Re : [Résolu]erreur avec Latex

Kile fonctionne sans problème avec gnome. wink


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#22 Le 22/01/2006, à 02:14

Mathieu147

Re : [Résolu]erreur avec Latex

Oui je sais, mais Winefish est mieux intégré quand-même.


Pffff…

Hors ligne