Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 21/12/2004, à 20:04

Pierre

[RÉSOLU] Taper du texte en chinois sur une Ubuntu française

J'ai placé ce sujet ici, mais je pense qu'il est commun à plusieurs catégories de ce forum.

J'ai donc installé ma distrib Ubuntu 4.10 en français, et, par défaut, je peux lire japonais, chinois et coréen sur mon PC sans problème (testé sous des applis GTK comme GAIM, mais aussi sous Firefox).

Par contre, j'aimerais pouvoir écrire en chinois...
Sous Windows (bouuuh !), on peut installer un système de saisie qui permet de taper le texte en pin yin (un système de romanisation de la langue chinoise), qui permet facilement à un occidental de taper du chinois, puisqu'il fait ensuite la conversion pin yin --> idéogrammes en temps réel, en fonction d'autres paramètres (notamment le ton utilisé, puisque le chinois mandarin est une langue tonale !)

Est-ce possible de faire de même sous Ubuntu/Gnome ? Si oui, quelle est la manipulation à effectuer ?

Un ami m'a dit qu'il était possible d'installer un outil de saisie, mais il n'est compatible qu'avec les applications GTK... or OpenOffice.org n'est pas en GTK, je crois...

J'espère que vous pourrez m'aider, car je n'ai pas trouvé grand'chose sur le Net francophone à ce sujet ; toutefois, si vous avez des adresses traitant du sujet (même en anglais, je me débrouille plus que bien), vous pouvez les laisser ici pour en faire profiter tout le monde !

Hors ligne

#2 Le 06/01/2005, à 19:18

severino

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Yudit permet en effet de saisir dans un seul et meme document des textes en alphabets latin, cyrillique, arabe, hebreu, japonais, chinois, etc. [...] Ces documents sont ensuite manpulables avec OpenOffice, Mozilla, et tous les logiciels qui acceptent l’UTF-8.

http://www.framasoft.net/article1637.html

Des dépôts Ubuntu, ici :
http://www.google.com/search?hl=en&q=yu … Search&lr=

Il y a un autre sujet sur les langues asiatique ici :
http://forum.ubuntu-fr.org/viewtopic.php?id=43

Tout ça pour demander quand est-ce que le web, et punBB en particulier, passe en UTF-8, y'en a marre du iso-8859-1 et &#unicode machin illisible dans le source :-(

Hors ligne

#3 Le 10/01/2005, à 09:58

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Arf même question que Pierre.

Scim et Smart Pinyin marchent nickel sous mandrake 10.1 (gnome 2.6), on peut passer de l'input français à chinois d'un simple CTRL+space pour n'importe quel logiciel, Open Office inclu.

Malheureusement après de nombreux tests et essais, je suis incapable d'arriver à un tel résultat sous ubuntu.

j'ai bien essayé le howto pour le japonais => http://www.ubuntulinux.org/wiki/JapaneseInputHowto

Mais ça marche pas gégé en chinois et surtout je suis incapable de l'utiliser sous OOo!

Marchi pour vos lumières!

Dernière modification par DuKefeng (Le 10/01/2005, à 10:03)

Hors ligne

#4 Le 14/01/2005, à 09:56

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

eheh, après moult recherches j'ai trouvé cet howto qui fonctionne pas mal. Un grand merci à Mu Rongjun.

C'est écrit pour Debian mais ça fonctionne bien sous Ubuntu, en plus c'est simple à mettre en oeuvre.

Ayant tellement fait d'essai, je vais réinstaller notre distro favorite propement pour etre sùr et je vous concocte une petite traduction en français.

Hors ligne

#5 Le 14/01/2005, à 15:08

Cougar

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Tu peux rajouter "Résolu"  à ton sujet. Merci !


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#6 Le 15/01/2005, à 15:08

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Presque résolu en fait, ça fonctionne bien mais mon ~/.xsession doit correspondre à ça pour que ça fonctionne:

LANG=fr_FR.iso88591
LC_ALL=zh_CN.GB2312
LC_CTYPE=zh_CN.GB2312
KDE_LANG=zh_CN.GB2312
export LANG LC_ALL LC_CTYPE KDE_LANG
scim -d    # start scim as daemon
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=SCIM        # sets GTK2 IM Module as SCIM
exec gnome-session

et oui, ça marche que lorsque LC_ALL est en chinois, ce qui fait par exemple que azureus est en chinois.
De plus j'ai pas encore réussi à mettre un bonne table d'insertion fidèle au pinyin du style "smart pinyin".

Faut encore passer du temps pour règler ces détails.

Dernière modification par DuKefeng (Le 16/01/2005, à 11:47)

Hors ligne

#7 Le 16/01/2005, à 23:27

Pierre

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

OK ! Préviens-moi ici quand ça sera résolu ! smile
Je suis en pleine période d'examens, j'ai pas encore eu le temps de tester ça sur mon portable...

Hors ligne

#8 Le 19/01/2005, à 09:58

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Après d'autres essais, cris et larmes, voici mon meilleur résultat qui ne me satisfait pas pleinement. Mais bon ça à le mérite de fonctionner et facile à mettre en place.

Je vous conseille vivement de créer un utilisateur dédié pour écrire en chinois, mettez le dans la liste des sudoers. (http:/ubuntustartguide.online.fr/#usersadministration)

Et c'est parti:

1) Assurez-vous d'avoir ajouté les dépots supplémentaires (http://ubuntustartguide.online.fr/#extrarepositories) :

2) Installer via Synaptics pour simplifier et vérifier si c'est pas déjà fait (http://ubuntustartguide.online.fr/#synaptic) :

- locales
- xfonts-intl-chinese
- xfonts-intl-chinese-big   
- ttf-arphic-gbsn00lp
- ttf-arphic-gkai00mp
- ttf-arphic-bkai00mp
- ttf-arphic-bsmi00lp
- cpanel

Installer aussi les dépendances proposées.

3) Reconfigurer les locales, dans une console:

$sudo dpkg-reconfigure locales

Cochez: fr_FR, fr_FR.utf8, zh_CN GB2312 ou zh_TW BIG5 pour le chinois traditionnel.
Sélectionnez: fr_FR

4) Dans une console, surtout pas en sudo pour ne pas affecter tout le système :

$ cpanel

Un message "Gdk.warning:..." s'affiche, il faut patienter le logiciel va se lancer.

Cliquez "OK" sur le message vous invitant à relancer CPanel en vous logguant en root.
Suivez la fenêtre vous permettant de configurez CPanel, pour les polices, GB pour le chinois simplifé, Big5 pour le chinois traditionnel (j'ai un faible pour "ar pl kaitim gb"), pour les "locales", zh_CN.GB2312 pour le simplifié zh_CN.Big5 pour le traditionnel.

Vous pouvez maintenant quitter CPanel.

5) Relancer la session (ctrl-alt-suppr) et relogguez-vous.

6) Lancez OpenOffice, Firefox, ce que vous voulez et ensuite un simple ctrl-space fera apparaître "Xcin".

Note:
- pour écrire en chinois dans OOo word processor.
Outils=>Options=>Paramètres linguistiques=>Langues: activer le support des langues asiatiques et choisir quel type de chinois on souhaite.
Outils=>Options=>Texte=>Polices Standard (Asiatique): changer les polices pour "AR PL Kaitim GB" par exemple. wink

- j'arrive pas à paramètrer OOo spreadsheet, mais l'input chinois fonctionne sous Gnumeric.

7) Vous remarquerez que les polices des applications en général ne sont pas terribles.
Pour y remédier, Poste de travail => Préférences du bureau => Police, et choisissez vos préférées.

On peut considérer le sujet comme résolu, scim-chinese (le fameux paquet contenant smart-pinyin) n'étant pas encore proposé pour ubuntu et n'arrivant pas à faire fonctionner le paquet debian correspondant.

EDIT 20 janv. 2005: j'avais oublié de reconfigurer les locales et OOo...
EDIT 25 janv. 2005: erreur de mézigue concernant les locales, merci de la remarque "je"
EDIT 01 mars 2005: comme tableur, OOo marche pas mais gnumeric oui

Dernière modification par DuKefeng (Le 01/03/2005, à 10:56)

Hors ligne

#9 Le 19/01/2005, à 10:18

Pierre

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Merci !
Je verrai ça la semaine prochaine ; pourquoi préconises-tu de créer un nouvel utilisateur pour taper en chinois ?

Hors ligne

#10 Le 19/01/2005, à 16:18

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Je conseille de créer un nouvel utilisateur, car pour que le Xcin fonctionne il faut que les locales soit en chinois, tu te retrouves donc avec la date et certaines applications tout en chinois.

Si tu es seul à utiliser ton ordinateur, ou que ça te dérange pas, fonce! Mais sache que ma méthode utilisant Cpanel, je n'ai pas pu revenir en arrière même en désinstallant ce logiciel.

Etant un débutant solo sur linux, je préfère toujours bidouillé sur un deuxième utilisateur et là pour le coup ça paye.

Hors ligne

#11 Le 20/01/2005, à 17:29

severino

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Et en passant par Yudit, ça ne fait pas l'affaire ?

Hors ligne

#12 Le 21/01/2005, à 05:52

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Je n'ai pas réussi à configurer Yudit proprement, je n'y ai pas passé énormèment de temps non plus remarque.

Si une bonne âme se sent l'âme d'un aventurier...

Pour ma part, je remettrai les mains dans le cambouis pour Hoary si "scim-chinese" est disponible.

Hors ligne

#13 Le 22/01/2005, à 15:09

je

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Salut je pense qu'il y a une erreur :

3) Reconfigurer les locales, dans une console:

$sudo reconfigure locales

Ce doit etre :
sudo dpkg-reconfigure locales

En tout cas merci beaucoup ca marche très bien !!!

Hors ligne

#14 Le 25/01/2005, à 10:39

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Au temps pour moi, merci pour la remarque, c'est corrigé. wink

Hors ligne

#15 Le 01/03/2005, à 03:23

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Pour le classeur, j'utilise gnumeric, ça marche bien.

Un modo peut-il mettre [résolu à moitié] en face du titre passque bon, le bordel fonctionne quand même. tongue

Hors ligne

#16 Le 28/03/2005, à 21:16

Pierre

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Ça y est ! ça fonctionne très bien, dans les appli à base de GTK (pour les autres, il suffit de faire du copier/coller à partir d'une appli GTK wink).
J'ai fait un petit billet sur mon blog pour expliquer tout ça. DuKefeng, teste, et si ça marche chez toi, je mets le topic en [résolu] !

Et pas besoin de se prendre la tête avec les fichiers de conf, ni avec un nouvel utilisateur... Voilà voilà big_smile

edit : ouais, j'avoue, je suis sous Hoary, et avant ça marchait pas pour la raison sus-citée (problème de package dans Warty).

Dernière modification par Pierre (Le 28/03/2005, à 21:19)

Hors ligne

#17 Le 05/04/2005, à 09:53

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Un peu léger tout de même, seules les applis GTK fonctionnent... roll
On va pas aller loin avec tout ça.

Scim doit fonctionner sous firefox, thunderbird, OpenOffice et tout le reste, sinon c'est toujours du [+/- résolu]

Les mains dans le cambouis pour la version officielle de Hoary! cool

Hors ligne

#18 Le 05/04/2005, à 10:43

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Deux solutions:

1) Creuser dans ce topic dans le forum des anglois. Ils ont réussi à faire fonctionner le chinois dans mozilla et arrive au but pour OOo

2) Remplacer:
OOo par Abiword et Gnumeric smile
Thunderbird par Evolution big_smile
Firefox par Epiphany hmm

J'arrête là, je m'étais promis de pas me relancer là dedans avant Hoary officielle. tongue

Hors ligne

#19 Le 05/04/2005, à 19:29

Pierre

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Bon smile

Perso, ça me convient pour l'instant (c'était principalement pour discuter avec mes amis chinois/taiwanais sur GAIM). Mais j'attends de voir ce que ça va donner avec Hoary smile

Hors ligne

#20 Le 07/04/2005, à 03:46

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

TUTORIEL pour écrire en chinois sur Ubuntu Hoary:

1) installer via synaptics ou en ligne de commande:
    * scim
    * scim-chinese
    * scim-config-socket
    * scim-frontend-socket
    * scim-gtk2-immodule
    * scim-server-socket
    * scim-tables-zh (optionnel)
    * xfonts-intl-chinese
    * xfonts-intl-chinese-big   
    * ttf-arphic-gbsn00lp
    * ttf-arphic-gkai00mp
    * ttf-arphic-bkai00mp
    * ttf-arphic-bsmi00lp

en acceptant évidemment toutes les dépendances nécessaires.

2) Ensuite à partir de la barre d'outil:
System=>Préférences=>Sessions=>Startup Programs
Add: scim -d
Order: 80

3) Redémarrer Gnome: CTRL+ALT+SUPPR

4) Ouvrez n'importe quel logiciel et un simple CTRL+SPACE fait apparaître le graal. tongue

----------------------------------------------------------------------------------------------------------------------

Si ça ne fonctionne pas, remplacer l'étape deux par la suivante:

2)alt+F2, gedit

taper ces quelques lignes:

scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
gnome-session

Sauvegarder dans "Home" en nommant le fichier: .xsession

Ouvrez un terminal et taper:

$chmod +x .xsession

----------------------------------------------------------------------------------------------------------------------

Notes


Paramétrage de toute la suite OpenOffice

Outils=>Options=>Paramètres linguistiques=>Langues: activer le support des langues asiatiques et choisir quel type de chinois on souhaite.
Outils=>Options=>Texte=>Polices Standard (Asiatique): changer les polices pour "AR PL Kaitim GB" par exemple.


Ajouter une police "clean"
Installer la police de Firefly, "AR PL New Sung"

$wget http://firefly.idv.tw/apt/firefly-font/fireflysung-1.3.0.tar.gz
$tar zxvf fireflysung-1.3.0.tar.gz
$sudo cp fireflysung-1.3.0/fireflysung.ttf /usr/share/fonts/truetype/
$sudo fc-cache -f -v

Si ça rame au téléchargement, essayez un autre Dépôt

$wget http://cle.linux.org.tw/fonts/FireFly/fireflysung-1.3.0.tar.gz
ou
$wget http://apt.nc.hcc.edu.tw/pub/FC_src/fireflysung-1.3.0.tar.gz
ou
$wget http://www.study-area.org/apt/firefly-font/fireflysung-1.3.0.tar.gz

Ajouter des polices supplémentaires
Installer msttcorefonts, ouvrez un terminal et tapez:

$sudo apt-get install msttcorefonts

Merci à pierre et à tzutolin

Dernière modification par DuKefeng (Le 20/04/2005, à 08:28)

Hors ligne

#21 Le 07/04/2005, à 03:57

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

TUTORIAL for Hoary, howto input chinese in UBUNTU:

Dernière modification par DuKefeng (Le 11/04/2005, à 02:39)

Hors ligne

#22 Le 09/04/2005, à 21:07

Pierre

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Ça fonctionne bien, sauf que du coup, on se tape les nombres avec la font chinoise par défaut, qui est vraiment moche !
Et si je mets en commentaire la ligne :
export LC_CTYPE=zh_CN.UTF-8

ça ne fonctionne plus...

Y'a pas une solution ?

Hors ligne

#23 Le 10/04/2005, à 05:37

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Pierre a écrit :

Ça fonctionne bien, sauf que du coup, on se tape les nombres avec la font chinoise par défaut, qui est vraiment moche !

Suffit de changer de police chinoise. wink
Installe les polices Microsoft ($sudo apt-get msttcorefonts) ou va jeter un coup d'oeil aux dépots firefly.

Pierre a écrit :

Et si je mets en commentaire la ligne :
export LC_CTYPE=zh_CN.UTF-8

ça ne fonctionne plus...

Y'a pas une solution ?

Un peu plus de précision stp.

En effet normalement c'est si on ne met pas cette fameuse ligne que ça ne fonctionne pas.

Mon .xsession ressemble à ça et tout fonctionne comme sur des roulettes sur une Hoary finale:

scim -d
export LC_CTYPE=zh_CN.UTF-8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=SCIM
gnome-session

Hors ligne

#24 Le 11/04/2005, à 02:47

DuKefeng

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

Grace à tzutolin du forum officiel, j'ai simplifié le howto, plus besoin de créer à la main de .xsession

C'est mieux comme ça non?

Dernière modification par DuKefeng (Le 11/04/2005, à 02:47)

Hors ligne

#25 Le 11/04/2005, à 19:10

Pierre

Re : [RÉSOLU] Taper du texte en chinois sur une Ubuntu française

DuKefeng a écrit :
Pierre a écrit :

Ça fonctionne bien, sauf que du coup, on se tape les nombres avec la font chinoise par défaut, qui est vraiment moche !

Suffit de changer de police chinoise. wink
Installe les polices Microsoft ($sudo apt-get msttcorefonts) ou va jeter un coup d'oeil aux dépots firefly.

Mon problème concerne en fait l'interface graphique. Regarde :
ubuntuchineseproblem3ga.th.jpg

Ça fait la même chose avec plein d'applications (dont Gimp, ce qui est vraiment ennuyeux pour lire les nombres !). Ce n'est pas un problème d'OOo...

J'ai modifié la police de mes applis dans Gnome, j'ai mis Bitsream Vera Sans, et ça résoud mon problème, mais je comprends pas pourquoi la police Sans utilise les nombres d'une police chinoise... Bizarre !

DuKefeng a écrit :
Pierre a écrit :

Et si je mets en commentaire la ligne :
export LC_CTYPE=zh_CN.UTF-8

ça ne fonctionne plus...

Y'a pas une solution ?

Un peu plus de précision stp.

Et bien, lorsque je désactive la ligne en question, je ne peux plus taper du texte chinosi partout. Mais comme j'ai reglé mon problème de police, je vais pouvoir activer cette ligne smile

En tout cas, merci pour ce tutorial, c'est super wink

Hors ligne

Haut de page ↑