Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 26/01/2006, à 16:15

démosthène

[Support] : Wifi : Carte Ma401

Bonjour,

Ce post est destiné à recevoir les questions concernant la carte Netgear Ma401 listée sur la page de synthèse des cartes Wifi.

http://wiki.ubuntu-fr.org//materiel/wifi/liste_carte

Cette carte fonctionne chez moi, je ne suis pas bon techniquement mais j'essaierai de vous aider si vous avez des problèmes avec cette carte.


Si vous possédez cette carte Ma401 n'hésitez pas à vous abonnez à ce post


P.S. C'est un essai de jonction automatique entre la documentation et le forum.
Le principe que je propose est de vous abonner aux matériels composant votre ordinateur pour être prévenu par mail dès que quelqu'un rencontre un problème.


Je vous jure, j'ai rien à dire :)

Hors ligne

#2 Le 12/05/2006, à 09:22

Billybug

Re : [Support] : Wifi : Carte Ma401

Exellente idée!

J'ai rajouté la carte TEW-423PI de TrendNET dans ton tableau avec le lien ver sa page
Personnelement, je n'ai pas encore tester... peutètre ce soir, je confirmerais alor son fonctionnement.

Dernière modification par Billybug (Le 12/05/2006, à 09:25)


Linux est à Windows ce que l'électrécité serait au pétrole !

BillyBUG

Hors ligne

#3 Le 14/10/2006, à 12:05

Ju.org

Re : [Support] : Wifi : Carte Ma401

Bonjour,

Depuis quelque temps, je rencontre quelques problèmes avec ma Netgear MA401RA.
Ma migration en Ubuntu 6.06, mon changement de canal pour m'isoler des voisins et le passage de mon ancien routeur wifi netgear à ma freebox s'était passé sans problème.
Maintenant, impossible de me connecter.
L'association semble OK. (iwlist scanning me donne bien les réseaux avoisinant et Kismet fonctionne correctement)
Par contre impossible d'avoir l'IP (dhcp, ip statique).

Et là, je tourne en rond.

Une idée ?

merci d'avance,

Hors ligne

#4 Le 14/10/2006, à 14:56

Ju.org

Re : [Support] : Wifi : Carte Ma401

Re

Voilà quelques informations complémentaires.

# iwconfig eth1
eth1      IEEE 802.11b  ESSID:"totototo"  Nickname:"Prism  I"
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:07:CB:51:9A:D9
          Bit Rate:11 Mb/s   Sensitivity:1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX   Security mode:restricted
          Power Management:off
          Link Quality=66/92  Signal level=-42 dBm  Noise level=-147 dBm
          Rx invalid nwid:0  Rx invalid crypt:25  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

# ifconfig eth1
eth1      Lien encap:Ethernet  HWaddr 00:09:5B:3E:A0:6F
          inet adr:192.168.0.200  Bcast:192.168.0.255  Masque:U255.255.255.0
          adr inet6: fe80::209:5bff:fe3e:a06f/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 b) Octets transmis:3770 (3.6 KiB)
          Interruption:3 Adresse de base:0xe100

# cat /proc/net/wireless
Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
 face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 19
  eth1: 0000   60.  205.  108.       0     67      0      0      0        0

En lisant l'excellent howto cité plus haut, je me rend compte qu'il s'agit d'un problème d'encryption.
Je me suis quand même pas lamentablement planté de clé WEP 128 roll.
Je vérifie tout de même.

A+

Hors ligne

#5 Le 14/10/2006, à 15:41

Ju.org

Re : [Support] : Wifi : Carte Ma401

Eh bien non, pas de pb de clé WEP mais je m'apperçoit dans /var/log/syslog de la chose suivante :

Oct 14 12:45:35 localhost kernel: [17179592.800000] Yenta: CardBus bridge found at 0000:02:01.0 [1028:00d4]
Oct 14 12:45:35 localhost kernel: [17179592.800000] Yenta: Using CSCINT to route CSC interrupts to PCI
Oct 14 12:45:35 localhost kernel: [17179592.800000] Yenta: Routing CardBus interrupts to PCI
Oct 14 12:45:35 localhost kernel: [17179592.800000] Yenta TI: socket 0000:02:01.0, mfunc 0x05033002, devctl 0x64
Oct 14 12:45:35 localhost kernel: [17179593.032000] Yenta: ISA IRQ mask 0x0418, PCI irq 11
Oct 14 12:45:35 localhost kernel: [17179593.032000] Socket status: 30000006
Oct 14 12:45:35 localhost kernel: [17179593.032000] pcmcia: parent PCI bridge I/O window: 0xe000 - 0xffff
Oct 14 12:45:35 localhost kernel: [17179593.032000] cs: IO port probe 0xe000-0xffff: clean.
Oct 14 12:45:35 localhost kernel: [17179593.032000] pcmcia: parent PCI bridge Memory window: 0xf4000000 - 0xfbffffff
Oct 14 12:45:35 localhost kernel: [17179593.032000] pcmcia: parent PCI bridge Memory window: 0x50000000 - 0x54ffffff
Oct 14 12:45:35 localhost kernel: [17179593.032000] ACPI: PCI Interrupt 0000:02:01.1[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
Oct 14 12:45:35 localhost kernel: [17179593.032000] Yenta: CardBus bridge found at 0000:02:01.1 [1028:00d4]
Oct 14 12:45:35 localhost kernel: [17179593.032000] Yenta: Using CSCINT to route CSC interrupts to PCI
Oct 14 12:45:35 localhost kernel: [17179593.032000] Yenta: Routing CardBus interrupts to PCI
Oct 14 12:45:35 localhost kernel: [17179593.032000] Yenta TI: socket 0000:02:01.1, mfunc 0x05033002, devctl 0x64
Oct 14 12:45:35 localhost kernel: [17179593.264000] Yenta: ISA IRQ mask 0x0418, PCI irq 11
Oct 14 12:45:35 localhost kernel: [17179593.264000] Socket status: 30000010
Oct 14 12:45:35 localhost kernel: [17179593.264000] pcmcia: parent PCI bridge I/O window: 0xe000 - 0xffff
Oct 14 12:45:35 localhost kernel: [17179593.264000] cs: IO port probe 0xe000-0xffff: clean.
Oct 14 12:45:35 localhost kernel: [17179593.264000] pcmcia: parent PCI bridge Memory window: 0xf4000000 - 0xfbffffff
Oct 14 12:45:35 localhost kernel: [17179593.264000] pcmcia: parent PCI bridge Memory window: 0x50000000 - 0x54ffffff
Oct 14 12:45:35 localhost kernel: [17179593.916000] pccard: PCMCIA card inserted into slot 1
Oct 14 12:45:35 localhost kernel: [17179593.916000] cs: memory probe 0xf4000000-0xfbffffff: excluding 0xf4000000-0xf8ffffff
Oct 14 12:45:35 localhost kernel: [17179593.916000] pcmcia: registering new device pcmcia1.0
Oct 14 12:45:35 localhost kernel: [17179594.012000] cs: IO port probe 0x100-0x4ff: excluding 0x170-0x177 0x300-0x307 0x370-0x37f
Oct 14 12:45:35 localhost kernel: [17179594.012000] cs: IO port probe 0xc00-0xcf7: clean.
Oct 14 12:45:35 localhost kernel: [17179594.012000] cs: IO port probe 0xa00-0xaff: clean.
Oct 14 12:45:35 localhost kernel: [17179594.016000] cs: IO port probe 0x100-0x4ff: excluding 0x170-0x177 0x300-0x307 0x370-0x37f
Oct 14 12:45:35 localhost kernel: [17179594.016000] cs: IO port probe 0xc00-0xcf7: clean.
Oct 14 12:45:35 localhost kernel: [17179594.016000] cs: IO port probe 0xa00-0xaff: clean.
Oct 14 12:45:35 localhost kernel: [17179594.068000] orinoco 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
Oct 14 12:45:35 localhost kernel: [17179594.072000] orinoco_cs 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: Hardware identity 800c:0000:0001:0000
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: Station identity  001f:0006:0001:0003
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: Firmware determined as Intersil 1.3.6
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: Ad-hoc demo mode supported
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: IEEE standard IBSS ad-hoc mode supported
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: WEP supported, 104-bit key
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: MAC address 00:09:5B:3E:A0:6F
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: Station name "Prism  I"
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: ready
Oct 14 12:45:35 localhost kernel: [17179594.308000] eth1: index 0x01: Vcc 5.0, irq 3, io 0xe100-0xe13f
Oct 14 12:45:35 localhost kernel: [17179594.380000] ieee80211_crypt: registered algorithm 'NULL'
Oct 14 12:45:35 localhost kernel: [17179594.428000] hostap_cs: 0.4.4-kernel (Jouni Malinen <jkmaline@cc.hut.fi>)
...

C'est le ieee80211_crypt: registered algorithm 'NULL' qui me choque.

Car je n'ai pas de ieee80211_crypt: registered algorithm 'WEP' par exemple.

Je reboot et je tente les modprobe qui vont bien.

A+

Dernière modification par Ju.org (Le 14/10/2006, à 16:04)

Hors ligne

#6 Le 14/10/2006, à 16:03

Ju.org

Re : [Support] : Wifi : Carte Ma401

cool
Ca marche !

# modprobe ieee80211_crypt_wep
# cat /var/syslog
...
Oct 14 15:53:08 localhost kernel: [17180000.936000] ieee80211_crypt: registered algorithm 'WEP'
...
# /etc/init.d/networking stop
# /etc/init.d/networking start

Et c'est reparti !

reste à savoir pourquoi ce module ne se load plus tout seul...
hmm

Hors ligne

#7 Le 11/11/2006, à 11:34

Ju.org

Re : [Support] : Wifi : Carte Ma401

Voilà le petit script qui me permet de contourner le problème. (pas très plug & play tout ça)

cat /sbin/sh/wifistartup.sh

#!/bin/bash

modprobe ieee80211_crypt_wep
iwconfig eth1 key open "MaCleWepPasSecureMaisMa CarteNeSupporteQueCa"
dhclient eth1

Je vais mettre à jour en ubuntu 6/10 pour voir.

Il faut que je pense aussi à changer mon portable, mais alors j'ai de longues heures en perspectives pour choisir un chipset wifi bien supporté...

A+

Hors ligne

#8 Le 07/12/2007, à 13:48

ziedhaouala

Re : [Support] : Wifi : Carte Ma401

bonjour a tous, je viens d'installer ubuntu 7.10, sur un dell inspiron 1200,tout fonctionne bien à part une carte wifi pcmcia broadcom 802.11 qui n'est pas reconnu par le system, j ai essayé toutes les méthode, ndiswrapper, fwcutter, ngdis pour importer un pilote de windows (.inf), mais ça marche pas, please help me  merci

#9 Le 14/12/2007, à 00:09

Ju.org

Re : [Support] : Wifi : Carte Ma401

Désolé de ne pas pouvoir aider mais  je ne connais pas ce matériel.
Pour info mon upgrade en 7.10 ne résoud pas le problème et je suis encore obligé d'utiliser le script si dessus pour loader le module WEP.

Bon courage.

Ju

Hors ligne

#10 Le 07/03/2009, à 02:03

ThorgalAegirsson

Re : [Support] : Wifi : Carte Ma401

J'avais une vieille carte netgear ma401 qui utilise un chipset intersil prism. Au debut, bien que mon reseau est en WPA, je ne pouvais choisir WPA comme methode de chiffrement lorsque je cliquais sur mon reseau dans NetworkManager. J'ai reussi a faire marcher le WPA avec cette carte apres une mise a jour du firmware. Voici la marche a suivre:

# apt-get install hostap-utils
$ wget http://www.red-bean.com/~proski/firmware/Latest-prism.tar.bz2
$ tar xvfj  Latest-prism.tar.bz2
$ cd Latest-prism/
# prism2_srec -f wlan0 -O /proc/net/hostap/wlan0/pda primary-FLASH/pk010101.hex secondary-FLASH/sf010804.hex

Taper la commande suivante avant et apres pour verifier que la mise a jour s'est bien passee.

# hostap_diag wlan0

Et un how-to plus complet est disponible ici http://linux.junsun.net/intersil-prism/

Mathieu

Haut de page ↑