Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 05/06/2008, à 10:30

dav999

[Résolu] Canon I250 et Hardy (Cups-missing-filter)

Bonjour à tous,

je viens de mettre à jour ma gusty vers hardy, tout s'est très bien passé pas de soucis, sauf pour ma canon I250, elle ne fonctionne plus.

Je suis allé sur la page de dépannage - installation de l'imprimante, mais elle n'a pas été mise à jour, j'ai donc pensé que la procédure d'install restait la même, mais j'ai plusieurs erreurs.

Dans la barre en haut à droite, j'ai l'icone de l'imprimante et le message d'erreur "cups-missing-filter"

lors de l'installation, voiçi ce que je fais (j'essaye d'installer une dépendance en pensant que c'est ca qui fout le souc, mais ce n'est pas possible) :

da@da-laptop:/home/david/Divers/Logiciels Installes manuellement/Canon I250$ sudo dpkg -i bjfilteri250_2.3-1_i386.deb
Sélection du paquet bjfilteri250 précédemment désélectionné.
(Lecture de la base de données... 178989 fichiers et répertoires déjà installés.)
Dépaquetage de bjfilteri250 (à partir de bjfilteri250_2.3-1_i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de bjfilteri250 :
 bjfilteri250 dépend de libglib1.2 (>= 1.2.0) ; cependant :
  Le paquet libglib1.2 n'est pas installé.
dpkg : erreur de traitement de bjfilteri250 (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 bjfilteri250

da@da-laptop:/home/david/Divers/Logiciels Installes manuellement/Canon I250$ sudo apt-get install libglib1.2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libglib1.2 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  libglib1.2ldbl
E: Aucun paquet ne correspond au paquet libglib1.2

da@da-laptop:/home/david/Divers/Logiciels Installes manuellement/Canon I250$ sudo apt-get install libglib1.2ldbl
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libglib1.2ldbl est déjà la plus récente version disponible.
libglib1.2ldbl passé en « installé manuellement ».
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
  bjfilteri250: Dépend: libglib1.2 (>= 1.2.0) mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).

Si quelqu'un à une idée

je ne sais pas s'il faut utiliser la même technique qu'avec le lien symbolique avec "sudo ln" mais je ne connais pas assez bien la mécanique ubuntu pour me débrouiller seul sur ce point

Merci
David

Dernière modification par dav999 (Le 07/06/2008, à 20:04)


Toshiba L670

Hors ligne

#2 Le 07/06/2008, à 20:07

dav999

Re : [Résolu] Canon I250 et Hardy (Cups-missing-filter)

Ok le problème semble être reglé (j'ai pas pu tester mais j'ai plus l'erreur et le driver s'est bien installé dans le panneau de config des imprimantes), en fait j'ai trouvé la solution sur ce forum :
https://bugs.launchpad.net/ubuntu/+source/glib1.2/+bug/207798/comments/7


voiçi le message :

I've found a possible workaround in debian bug tracker. It is dealing with a similar issue (canon ip1500). The debian package you've posted was converted from a rpm one, using alien. Alien picked up the dependencies that where present on the system, the package was initially created (e.g. gutsy), therefore it depends on libglib1.2 and not on libglib1.2ldbl, which is now the name of the library. To get it work, download the driver from canon website and convert the package using alien on your hardy-install (with all needed dependencies already installed).
see:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=434264#20

Pour les non anglais :
il faut recompiler les rpm de chez canon avec alien sur le poste avec hardy installé, car il va utiliser les bonne librairies et donc ca fonctionnera, (ne pas utiliser les ancien paquets créées sous gutsy)

@+
David

Dernière modification par dav999 (Le 07/06/2008, à 20:07)


Toshiba L670

Hors ligne

#3 Le 13/06/2008, à 15:53

321guyver

Re : [Résolu] Canon I250 et Hardy (Cups-missing-filter)

Bonjour, j'ai aussi une i250, et je suis aussi passé sous hardy.
J'ai utilisé tes indications (de mon mieux, je suis loin de maitriser) : récupéré
- i250 Linux Driver v.Linux
A set of bjfilter sources.
- i250 Linux Driver v.Linux
A set of additional modules for CUPS.
sur http://www.canon.co.nz/products/printers/colour_bj_printers/i250_drivers.aspx

alien puis dpkg -i à chaque fois.

Mais dans système - administration - impression, toujours pas de driver.

As-tu réussi à faire marcher ton imprimante sous Hardy ?

Peux-tu me dire ce que je fais de travers ?

Merci


Ce serait sans doute l'une des plus grandes opportunités ratées de notre siècle si le logiciel libre ne servait à libérer que du code : http://donnons.org/, http://www.agoravox.fr/, http://www.artisansdumonde.org/, http://www.couchsurfing.org/, http://esperanto-france.org/, http://www.mouvement-zeitgeist.fr/

Hors ligne

#4 Le 13/06/2008, à 19:56

dav999

Re : [Résolu] Canon I250 et Hardy (Cups-missing-filter)

Chez moi j'ai bien les drivers version 2.3 des I250 et I255

Oui il me semble qu'elle a fonctionné sans trop de soucis, je vais réésayer je te tiens au jus.

par contre je suis un gros naze sous linux me demande pas ou tu t'es planté je ne pourrais pas te répondre

@+


Toshiba L670

Hors ligne

#5 Le 14/06/2008, à 10:00

dav999

Re : [Résolu] Canon I250 et Hardy (Cups-missing-filter)

Bon je viens de restester aucun problème pour l'impression avec open office

par contre j'ai activé ces options dans les imprimantes (menu système -admin - impression) :

Sous l'onglet "Comportements", cocher la case :
Validation des taches d'impression
et en faire le choix par défaut

autrement je peux pas t'en dire plus si tu n'arrives pas à l'utiliser et que tu as bien suivi le cheminement.

quand tu cherches les drivers tu choisi bien Canon et dans la liste "I250 v2.3" ?
Pour l'installation tu te base sur cette page : http://doc.ubuntu-fr.org/imprimante_canon_i250

@+
david

Dernière modification par dav999 (Le 14/06/2008, à 10:03)


Toshiba L670

Hors ligne

#6 Le 03/10/2008, à 22:14

321guyver

Re : [Résolu] Canon I250 et Hardy (Cups-missing-filter)

Bonjour,
je suis toujours en rade avec cette imprimante.
Mon nouveau problème est que je suis sous architecture 64 bits, donc le driver bjfilteri250_2.3-1_i386.deb ne m'est pas utile.
Que puis-je faire ?
Merci


Ce serait sans doute l'une des plus grandes opportunités ratées de notre siècle si le logiciel libre ne servait à libérer que du code : http://donnons.org/, http://www.agoravox.fr/, http://www.artisansdumonde.org/, http://www.couchsurfing.org/, http://esperanto-france.org/, http://www.mouvement-zeitgeist.fr/

Hors ligne

#7 Le 04/10/2008, à 14:24

dav999

Re : [Résolu] Canon I250 et Hardy (Cups-missing-filter)

Sous 32bits elle fonctionne ?

si oui installe toi une petite partition en 32bits, sinon je ne sais pas plus

bye


Toshiba L670

Hors ligne

Haut de page ↑