Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 12/06/2008, à 20:40

I'm_an_ent

[Résolu] - Problème Synaptic & aptitude suite à...

Bonjour à tous,
voili voilou désirant installer une imprimante lexmark x1250 j'ai recherché le moyen d'installer et vu qu'il était tout à fait possible de l'installer en utilisant le pilote lexmark z600. J'ai donc suivi ce tuto : http://doc.ubuntu-fr.org/imprimante_lexmark_z600.
tout va bien jusqu'à l'installation des paquets .deb créés par allien. il m'affiche l'erreur suivante (celle-ci est après demande de réinstallation...) :

imanent@imanent-laptop:~/lexmark$ sudo dpkg -i z600cups-1.0-1.i386.deb
Sélection du paquet z600cups précédemment désélectionné.
(Lecture de la base de données... 206802 fichiers et répertoires déjà installés.)
Préparation du remplacement de z600cups 1.0-2 (en utilisant z600cups-1.0-1.i386.deb) ...
Dépaquetage de la mise à jour de z600cups ...
/var/lib/dpkg/info/z600cups.postrm: 2: /etc/init.d/cups: not found
dpkg : avertissement - ancien script post-removal a retourné un code d'erreur de sortie 127
dpkg - tentative d'exécution du script du nouveau paquet à la place ...
/var/lib/dpkg/tmp.ci/postrm: 2: /etc/init.d/cups: not found
dpkg : erreur de traitement de z600cups-1.0-1.i386.deb (--install) :
le sous-processus nouveau script post-removal a retourné une erreur de sortie d'état 127
/var/lib/dpkg/tmp.ci/postrm: 2: /etc/init.d/cups: not found
dpkg : erreur lors du nettoyage :
le sous-processus post-removal script a retourné une erreur de sortie d'état 127
Des erreurs ont été rencontrées pendant l'exécution :
z600cups-1.0-1.i386.deb

lorsque je tente d'installer un programme, que ça soit avec aptitude ou synaptics, il me demande de réinstaller le package z600cups, et donc l'erreur ci-dessus m'est renvoyée ...
ci dessous l'erreur lors de la maj de la bdd de synaptics :

Supprimer le paquet en état incorrect
Le paquet « z600cups » est dans un état incohérent et doit être réinstallé, mais aucune archive n'a pu être trouvée pour celui-ci. Voulez-vous supprimer ce paquet maintenant pour pouvoir continuer ?

en répondant oui il me redemande de désinstaller z600cups manuellement et avec non il plante synaptics.

voila si quelqu'un à une idée ...

Dernière modification par I'm_an_ent (Le 13/06/2008, à 14:52)


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#2 Le 12/06/2008, à 21:01

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

J'ai oublié de préciser que j'ai tenté aussi de le désinstaller manuellement :

imanent@imanent-laptop:~$ sudo dpkg -r z600cups
[sudo] password for imanent:
dpkg : erreur de traitement de z600cups (--remove) :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d'essayer de le supprimer.
Des erreurs ont été rencontrées pendant l'exécution :
z600cups


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#3 Le 12/06/2008, à 21:16

denis_aec

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Essaie ça (grand nettoyage du paquet en question) :
sudo dpkg -P z600cups-1.0-1.i386.deb

Hors ligne

#4 Le 13/06/2008, à 08:13

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Merci pour l'astuce, je viens d'essayer mais rebelotte !

imanent@imanent-laptop:~$ sudo dpkg -P z600cups
dpkg : erreur de traitement de z600cups (--purge) :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d'essayer de le supprimer.
Des erreurs ont été rencontrées pendant l'exécution :
z600cups

c'est un peu lourd de plus rien pouvoir installer...


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#5 Le 13/06/2008, à 08:22

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

je me suis posé une question :
lorsque allien transforme les .rpm en .deb, le nom change qqpeu (genre des _ au lieu des - ou des numéros qui sont incrémentés), est-ce possible que ça soit lié à ça ? j'ai tenté en changeant manuellement le nom mais ça ne fonctionne toujours pas !


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#6 Le 13/06/2008, à 10:45

denis_aec

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Un tour dans la doc :
http://pwet.fr/man/linux/commandes/dpkg

A priori, option --force-remove-reinstreq : Supprime un paquet, même défectueux et marqué comme demandant une réinstallation. Il se peut, dès lors, que des éléments du paquet restent dans le système et soient oubliés par dpkg.

Attention :
--force-quelque-chose | --no-force-quelque-chose | --refuse-quelque-chose
Forcer ou refuser (no-force et refuse signifient la même chose) de faire quelque chose. quelque-chose est une liste d'actions séparées par des virgules, décrites ci-après. --force-help affiche un message qui les décrit. Les actions marquées d'un (*) sont forcées par défaut.

Ca pourrait donner ça :
sudo dpkg --force-remove-reinstreq z600cups-1.0-1.i386.deb

Hors ligne

#7 Le 13/06/2008, à 11:48

Panzer7

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Je suis tombé dans le même piège, et j'ai essayé la commande, sans résultats :

dpkg: requiert une option d'action

Sinon j'ai essayé ceci : sudo dpkg --force-all --purge z600cups_1.0-2_i386
Et j'ai eu droit à :

dpkg - avertissement : requête ignorée : suppression de z600cups_1.0-2_i386, qui n'est pas installé.

Cela veut-il dire qu'il faut enlever les fichiers un à un ?

Hors ligne

#8 Le 13/06/2008, à 12:10

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

En fait avec dpkg il faut entrer le nom du programme et pas du package lorsqu'on désinstalle ou purge,
j'ai donc tenté ton idée et voici ce que j'obtient avec la commande

sudo dpkg --force-all --purge z600cups

:

imanent@imanent-laptop:~$ sudo dpkg --force-all --purge z600cups
dpkg - avertissement, problème contourné à cause de --force :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 206801 fichiers et répertoires déjà installés.)
Suppression de z600cups ...
/var/lib/dpkg/info/z600cups.postrm: 2: /etc/init.d/cups: not found
dpkg : erreur de traitement de z600cups (--purge) :
le sous-processus post-removal script a retourné une erreur de sortie d'état 127
Des erreurs ont été rencontrées pendant l'exécution :
z600cups

en fait c'est un peu un problème bouclé pcq ce pq il ne veut pas désinstaller c'est le même problème que pour l'installation : 

/etc/init.d/cups: not found

ou du moins il me semble...

Dernière modification par I'm_an_ent (Le 13/06/2008, à 12:49)


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#9 Le 13/06/2008, à 13:04

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

sudo apt-get -f install z600cups & sudo apt-get -f install z600cups_1.0-2_i386 ne fonctionnent pas non plus.
la fonction -f permet d'installer un package avec les dépendances ... on ne sait jamais


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#10 Le 13/06/2008, à 13:34

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Bon j'ai trouvé une piste intéressante. dans la docu d'une autre imprimante lexmark, la z705, dont l'installation est semblable à la z600, ils précisent que si la commande dpkg renvoie une erreur de type 127, il faut faire ceci :

sudo gedit /var/lib/dpkg/infolexmark-z700-cups-driver.postinst

et changer "cups" en "cupsys" pcq la commande de lancement de cups est cupsys ici.
Malheureusement je ne trouve pas de fichier ressemblant à cela pour le driver z600...
voici la page : http://doc.ubuntu-fr.org/lexmark_z705
je vais chercher pcq je suis persuadé que la clé est ici...
j'ai déjà fait une recherche avec "cups" et rien de tel est trouvé non plus ... je vous dit quoi si je trouve


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#11 Le 13/06/2008, à 14:17

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

alors suite à ceci j'ai su installer le pilote (je l'ai pas encore testé) :
http://ubuntuforums.org/showthread.php?t=49714
cependant ça ne supprime pas le problème des packages insupprimables !


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#12 Le 13/06/2008, à 14:17

Panzer7

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Sur ce fichier :

gksudo gedit '/var/lib/dpkg/info/z600cups.postrm'

Au moins c'est bon pour le désinstaller.

Hors ligne

#13 Le 13/06/2008, à 14:50

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

oui je viens de le trouver en fait ... il est possible de régler cela plus "proprement" en rajoutant _bad à l'extension du fichier...
j'ai trouvé ça ici : http://forum.ubuntu-fr.org/viewtopic.php?id=66321&p=1
j'ai tenté en rajoutant "ys" à cups mais je ne sais pas relancer l'install par après... dc j'ai tt désintallé et de toute manière j'ai su l'installer avec les tar.gz donc nickel !
merci pour l'aide...


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#14 Le 19/06/2008, à 17:29

joggerfou

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Bonjour
J'ai eu approximativement les mêmes problèmes que vous (je parle au niveau suppression des fichiers)
J'ai donc en suivant vos conseils renommer le fichier z600cups.postrm en z600cups.postrm_bad puis j'ai reussi à le supprimer. Fallait-il le faire avec d'autres fichiers ?


Par contre
J'ai tenté d'installer ma lexmark 1270 avec la méthode anglo saxonne
http://ubuntuforums.org/showthread.php?t=49714

Mais contrairement à vous j'ai des messages d'erreurs comme par exemple

Warning: alien is not running as root!

meme si après un message m'indiquait que le fichier avait été généré

J'ai donc continué jusqu'à l'étape permettant de redémarrer le daemon Cups

 /etc/rc2.d/S19cupsys restart

Message d'erreur : Aucun fichier ou dossier de ce type

En allant voir ce qui se cachait dans le dossier /etc/rc2.d/ j'ai vu un fichier S20cupsys
Mais en faisant

 /etc/rc2.d/S20cupsys restart

j'obtiens

open: Permission denied
 * Restarting Common Unix Printing System: cupsd                                start-stop-daemon: warning: failed to kill 5224: Operation not permitted
cupsd: Child exited with status 1!

Que puis-je faire ?
Par avance merci


J'ai découvert Ubuntu et j'en suis fan
Ubuntu 13.04 32 bits
Utilisateur de libreoffice : http://fr.libreoffice.org/
http://www.lolica.org

Hors ligne

#15 Le 20/06/2008, à 09:08

joggerfou

Re : [Résolu] - Problème Synaptic & aptitude suite à...

C'est bon résolu
Juste un problème de sudo

Merci pour le fil très instructif

A bientôt


J'ai découvert Ubuntu et j'en suis fan
Ubuntu 13.04 32 bits
Utilisateur de libreoffice : http://fr.libreoffice.org/
http://www.lolica.org

Hors ligne

#16 Le 22/06/2008, à 14:57

Sunlight1971

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Bonjour,

J'ai moi aussi le meme souci et n'arrive pas a desinstaller z600cups...
je suis un newbie sur Ubuntu et ne reussi pas a renomer le fichier en z600cups.postrm_bad en effet dans le systeme des fichiers je n'ai pas l'option renommer fichier activée... Je viens du monde windows donc je ne sais pas s'il y a un autre moyen de renomer.

Merci de me donner un coup de pouce.
A+;)

Hors ligne

#17 Le 23/06/2008, à 08:46

joggerfou

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Pour renommer il faut utiliser la commande mv
Il faut également se placer en sudo

A+


J'ai découvert Ubuntu et j'en suis fan
Ubuntu 13.04 32 bits
Utilisateur de libreoffice : http://fr.libreoffice.org/
http://www.lolica.org

Hors ligne

#18 Le 25/06/2008, à 03:07

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

ou alors tu peux toujours faire "sudo gedit emplacement_du_fichier" et l'enregistrer sous le nouveau nom et supprimer l'autre...


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#19 Le 10/07/2008, à 19:56

Nicorider

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Salut,


J'ai modifié la documentation pour l'installation sur hardy heron http://doc.ubuntu-fr.org/imprimante_lexmark_z600 voir 2ème méthode pour l'installation des paquets.


Distribution : Ubuntu Hardy Heron 8.04
GNU/linux with 1391402 :).

Hors ligne

#20 Le 27/07/2008, à 14:22

NorSi

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Nicorider a écrit :

Salut,


J'ai modifié la documentation pour l'installation sur hardy heron http://doc.ubuntu-fr.org/imprimante_lexmark_z600 voir 2ème méthode pour l'installation des paquets.

Bonjour,
J'ai installé sur mon PC il y a peu de temps Ubuntu 8.04 car je veux me désintoxiquer de Microsoft. J'ai une imprimante-scanner DEL A920 (pour laquelle il faut utiliser les pilotes de la Lexmark Z600, comme je l'ai lu sur le forum ...). J'avais essayé en juin 2008 la méthode sur http://doc.ubuntu-fr.org/imprimante_lexmark_z600. Malheureusement sans succès ... Aujourd'hui, j'ai suivi la méthode http://doc.ubuntu-fr.org/imprimante_lexmark_z600 voir 2ème méthode pour l'installation des paquets. Mais quand je veux installer les paquets à partir de http://doc.ubuntu-fr.org/_media/z600cups_1.0-2_i386.deb, j'ai le message d'erreur suivant:
"Echec de l'installation du paquet z600cups_1.0-2_i386(5).deb .... il n'y a pas de script dans cette nouvelle version du paquet - abandon". Etant nul sur l'utilisation de Linux (lourd passé d'assisté avec Windows ...), que faire ? si quelqu'un pouvait m'aider ... Merci d'avance !


*** LUBUNTU : génial pour un ordinateur peu puissant ! ***

Hors ligne

#21 Le 17/08/2008, à 22:00

I'm_an_ent

Re : [Résolu] - Problème Synaptic & aptitude suite à...

je ne sais pas, désolé
Pour revenir sur la Lexmark, mon installation a marché mais l'ordi ne reconnaît pas l'imprimante... j'ai donc laissé tombé !


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#22 Le 24/07/2009, à 13:42

Argusus

Re : [Résolu] - Problème Synaptic & aptitude suite à...

I'm_an_ent a écrit :

ou alors tu peux toujours faire "sudo gedit emplacement_du_fichier" et l'enregistrer sous le nouveau nom et supprimer l'autre...

Vous avez la solution à mon problème, mais pour renommer c'est pas gagné ! En fait j'ai réussi à arriver sur le fichier avec gedit (ca m'a ouvert un genre de bloc note) j'ai renommé en ajoutant _bad au fichier et fais un "enregistrer sous", donc je me retrouve bien avec un fichier z600cups.postrm_bad, mais le problème c'est qu'il reste toujours un fichier z600cups.postrm et que je n'ai pas le droit de le supprimer ... (l'option renommer et supprimer est grisée).

Quelqu'un pourrait-il me donner la commande exacte à taper dans la console pour renommer et écraser le fichier voire le supprimer ?

Parce que là je vais m'arracher les cheveux de la tête.

Merci.

Hors ligne

#23 Le 24/07/2009, à 14:16

Argusus

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Problème résolu.

Encore merci pour ce treath.

Ne faudrait-il pas virer l'information sur ce paquet corrompu de la doc de Ubuntu ??? 3 jours pour régler le prob ...

Hors ligne

#24 Le 30/08/2009, à 23:45

Josué93

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Argusus, quand tu dis problème résolu, tu n'expliques pas comment, j'en suis au même pb que toi dans le poste d'avant : "Quelqu'un pourrait-il me donner la commande exacte à taper dans la console pour renommer et écraser le fichier voire le supprimer ?"
Alors c'est quoi la solution stp ?
Merci

Hors ligne

#25 Le 05/01/2010, à 22:40

juju.manue

Re : [Résolu] - Problème Synaptic & aptitude suite à...

Bonjour a Tous,

J'avais installé le pilote Z600 sur un Ubuntu 8.04 sans (trop) de difficultés.
J'ai changé de machine et suis passé sur un ordi X64, et l'install n'a pas marché....je suis passé par toutes les galères que vous décrivez.

La méthode anglo-saxonne a fonctionné (il faut utiliser sudo), le pilote est visible, mais l'imprimante ne fonctionne pas.
Est ce que ça peut etre du au changement de processeur ? Lexmark fait des drivers spéciaux pour VISTA et WINDOWS7 en x64......

Please help!
Merci.
Julien.

Hors ligne

Haut de page ↑