Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 15/04/2005, à 09:20

Touns

[Résolu ] Dépendances mal gérer par apt

Bonjour,

je viens ici avec beaucoup d'espoir, venant du monde debian, et convaincu qu'apt est un outils formiable, quelle surprise j'ai eu lorsque j'ai voulu installer ces packets :

apt-get install asterisk asterisk-chan-capi asterisk-chan-misdn asterisk-config asterisk-dev asterisk-doc asterisk-gtk-console asterisk-h323 asterisk-prompt-fr asterisk-sounds-main asterisk-web-vmail  apache2 php4 php4-mysql  mysql-server  mysql-common  mysql-client


ça avais l'air de marcher, mais il y a eu apperement un problème, j'ai donc voulu les desinstaller :

apt-get remove asterisk asterisk-chan-capi asterisk-chan-misdn asterisk-config asterisk-dev asterisk-doc asterisk-gtk-console asterisk-h323 asterisk-prompt-fr asterisk-sounds-main asterisk-web-vmail  apache2 php4 php4-mysql  mysql-server  mysql-common  mysql-client
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Le paquet asterisk-chan-capi n'est pas installé, et ne peut donc être supprimé
Le paquet asterisk-chan-misdn n'est pas installé, et ne peut donc être supprimé
Le paquet asterisk-prompt-fr n'est pas installé, et ne peut donc être supprimé
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
  apache2-common: Dépend: openssl mais ne sera pas installé
                  Dépend: ssl-cert (>= 1.0-7) mais ne sera pas installé
  apache2-mpm-prefork: Dépend: libpcre3 (>= 4.5) mais ne sera pas installé
  apache2-utils: Dépend: libpcre3 (>= 4.5) mais ne sera pas installé
  libapache2-mod-php4: Dépend: libpcre3 (>= 4.5) mais ne sera pas installé
  libapr0: Dépend: libpcre3 mais ne sera pas installé
  libmysqlclient10: Dépend: mysql-common
  libmysqlclient12: Dépend: mysql-common (>= 4.0.23-3ubuntu2) ou
                             mysql-common-4.1 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


ARGGGGGG!!! ça commence à me parler de aptget -f ! là je sais que si on touche à ça avec la debian on casse tous!!! j'ai seulement rajouté universe et multiverse aux sources!

comment faire pour la reparer svp?  merci d'avance pour votre aide.

Touns

#2 Le 15/04/2005, à 09:26

Touns

Re : [Résolu ] Dépendances mal gérer par apt

precision : lorsque j'ai fait apt-get install : il m'as dit qu'il allait installer les nouveau packets suivants :

  apache-common apache-perl apache2 apache2-common apache2-mpm-prefork apache2-utils asterisk asterisk-chan-capi asterisk-chan-misdn asterisk-config asterisk-dev asterisk-doc asterisk-gtk-console
  asterisk-h323 asterisk-prompt-fr asterisk-sounds-main asterisk-web-vmail libapache-mod-perl libapache2-mod-php4 libapr0 libcapi20-2 libdbd-mysql-perl libdbi-perl libdevel-symdump-perl
  libglib1.2 libgtk1.2 libgtk1.2-common libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libltdl3 libnet-daemon-perl libpcre3 libplrpc-perl libpri1 libtonezone1 liburi-perl libwww-perl
  mysql-client mysql-server odbcinst1 openssl php4 php4-common php4-mysql php4-universe-common ssl-cert unixodbc

#3 Le 15/04/2005, à 10:19

Touns

Re : [Résolu ] Dépendances mal gérer par apt

je me suis sauvé la vie avec apt-get buil-dep smile

merci Touns wink

bon je me reponds, parce que c'est désagréable de trouver des gens qui ont le même problème sous google, mais qui ne donne pas la solution lorsqu'il ont trouvé...

#4 Le 11/05/2005, à 13:30

jano

Re : [Résolu ] Dépendances mal gérer par apt

bonjour a tous
ben voila je suis un vrai debutant sur linux et ubuntu en particulier
j essai d installer asterisk car j en ai besoin pour faire des test mais je n y arrive pas
aidez moi svp
merci

Modo => aidez le ici

Hors ligne

#5 Le 11/05/2005, à 13:42

yeKcim

Re : [Résolu ] Dépendances mal gérer par apt

J'ajoute Résolu


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#6 Le 08/12/2005, à 11:41

Maximiliano

Re : [Résolu ] Dépendances mal gérer par apt

il vous manque les librairies apr:

apr-devel-0.9.6-3.i386.rpm  apr-util-devel-0.9.6-2.i386.rpm  pcre-devel-5.0-4.i386.rpm

Haut de page ↑