Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 06/02/2006, à 10:10

fougamou

[Resolu] Encore un pb de son sur Asus A6VC

Bonjour,
je suis nouveau sur linux. J'ai installé Kubuntu mais de temps en temps le contenu des fenêtres était brouillé et je suis donc passé à ubuntu. Ici pas de pb d'affichage. Mais par contre je n'arrive pas à installer le alsa pour la carte son.

Quand je lance ./configure --with-cards=hda-intel,usb-audio && make && sudo make install comme expliqué à cette page (http://doc.ubuntu-fr.org/materiel/chipset_intel_hda_realtek?s=a6vc) la console retourne :
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

voilà, si quelqu'un peut me dépatouiller.

Philippe

Dernière modification par fougamou (Le 24/02/2006, à 13:41)

Hors ligne

#2 Le 06/02/2006, à 11:35

bapoumba

Re : [Resolu] Encore un pb de son sur Asus A6VC

Bonjour,

pour le son :
http://doc.ubuntu-fr.org/installation/son

pour gcc (tu peux installer build-essential par synaptic et les linux-headers correspondants à ta version. Pour la connaitre, fais uname -a dans un terminal), tu auras peut-être des problèmes de version. Alors regarde ceci :
http://forum.ubuntu-fr.org/viewtopic.php?id=26287


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#3 Le 06/02/2006, à 17:05

fougamou

Re : [Resolu] Encore un pb de son sur Asus A6VC

J'ai bien mis la version de linux-headers avec synaptic
ma version Linux ubuntu 2.6.12-10-386
j'ai bien mis build-essential
et maintenant

/usr/src/alsa-driver-1.0.10$ ./configure --with-cards=hda-intel,usb-audio
checking for gcc... gcc-3.4
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.

même en faisant

CC=gcc-3.4 ./configure --with-cards=hda-intel,usb-audio                     
ou
CGC=gcc-3.4 ./configure --with-cards=hda-intel,usb-audio

par contre çà l'a fait avant de rebooter, et quand je lance CC=gcc-3.4 make
çà le fait mais à un moment  j'ai çà

make[3]: entrant dans le répertoire « /usr/src/alsa-driver-1.0.10/pcmcia/vx »
make[3]: quittant le répertoire « /usr/src/alsa-driver-1.0.10/pcmcia/vx »
make[2]: quittant le répertoire « /usr/src/alsa-driver-1.0.10/pcmcia »
make[1]: quittant le répertoire « /usr/src/alsa-driver-1.0.10 »
make -C /lib/modules/2.6.12-10-386/build SUBDIRS=/usr/src/alsa-driver-1.0.10  modules
/usr/src/linux-headers-2.6.12-10-386/scripts/gcc-version.sh: line 11: gcc-3.4: command not found
/usr/src/linux-headers-2.6.12-10-386/scripts/gcc-version.sh: line 12: gcc-3.4: command not found
make[1]: gcc-3.4 : commande introuvable

bref pas terrible.
A en croire les autres post il semblait que l'installation est "plus délicate" dixit http://doc.ubuntu-fr.org/materiel/chipset_intel_hda_realtek mais faisable.

Hors ligne

#4 Le 06/02/2006, à 23:34

bapoumba

Re : [Resolu] Encore un pb de son sur Asus A6VC

Salut,
j'avais pas tout lu. Excuse-moi. Si tu as une carte intel HDA, ce lien peut t'aider :
http://system76.com/knowledge/index.php … ntu_Breezy

ça semble marcher aussi pour les realtek


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#5 Le 06/02/2006, à 23:57

SamheG

Re : [Resolu] Encore un pb de son sur Asus A6VC

A mon avis c'est parce que tu n'as pas la bonne version de gcc d'installée!
Tu n'as sûrement "que" gcc-4.0 d'installé
-> Lance adept ou synaptic et installe gcc-3.4.


LMAA
Bye ... ça veut dire CIAO en anglais !
Kansas Of Elsass

Hors ligne

#6 Le 07/02/2006, à 08:52

fougamou

Re : [Resolu] Encore un pb de son sur Asus A6VC

Ca y est.

Merci à bapoumba, SamheG.

Un petit résumé :
http://fr.wikibooks.org/wiki/Tout_sur_l … _Asus_A6VA
http://forum.ubuntu-fr.org/viewtopic.php?id=18650
http://doc.ubuntu-fr.org/materiel/chips … da_realtek


1er étape
Désactiver la carte son avant de commencer l'installation ; il faut savoir que le chipset son ALC880 ne sera pas reconnu, et bloquera le boot à l'étape : hotplug subsystem.

- Pour remedier à ce problème : rentrer dans le BIOS ==> Security ==> I/O interface ==> AUDIO/MODEM : LOCKED
- Ensuite BOOT : mettez le lecteur DVD-ROM comme premier peripherique de boot.
- Et enfin EXIT ==> Save and Reboot

2eme étape
Lancer adept ou synaptic et installer
gcc-3.4.
build-essential
linux-headers correspondants à la version, pour la connaitre, fais uname -a dans un terminal

3eme étape
Copier les fichiers dans le lien suivant :
http://system76.com/knowledge/index.php … ntu_Breezy
et suivre les instructions.

4eme étape
ne pas oublier de réactiver la carte son au prochain démarrage.

Que du bonheur !

Dernière modification par fougamou (Le 24/02/2006, à 14:00)

Hors ligne

#7 Le 07/02/2006, à 09:43

SamheG

Re : [Resolu] Encore un pb de son sur Asus A6VC

Pourrais-tu rajouter un petit [Résolu] stp  wink


LMAA
Bye ... ça veut dire CIAO en anglais !
Kansas Of Elsass

Hors ligne

#8 Le 07/02/2006, à 12:06

SpoN

Re : [Resolu] Encore un pb de son sur Asus A6VC

fougamou a écrit :

Ca y est.

Merci à bapoumba, SamheG.

[...]

1er étape
Désactiver la carte son avant de commencer l'installation ; il faut savoir que le chipset son ALC880 ne sera pas reconnu, et bloquera le boot à l'étape : hotplug subsystem.

- Pour remedier à ce problème : rentrer dans le BIOS ==> Security ==> I/O interface ==> AUDIO/MODEM : LOCKED
- Ensuite BOOT : mettez le lecteur DVD-ROM comme premier peripherique de boot.
- Et enfin EXIT ==> Save and Reboot

[...]

Que du bonheur !

Oh mais c'est moi qui est écris sa big_smile

Tu l'as pris sur le WIki Tout sur l'A6VA ?

Dernière modification par SpoN (Le 07/02/2006, à 12:08)


Asus A6VA

Hors ligne

#9 Le 07/02/2006, à 13:28

fougamou

Re : [Resolu] Encore un pb de son sur Asus A6VC

Oui SpoN c'est de toi
J'avais bien cité la source mais pas le nom car je ne le trouvais pas.
Si je me suis permis de te recopier c'est tout simplement pour qu'un éventuel utilisateur de ubuntu avec un A6VC puisse reprendre la demarche pas à pas.

Donc merci aussi à SpoN

Par contre SamheG je ne sais pas intoduire Resolu sur le titre. Comment fait on ?

Hors ligne

#10 Le 07/02/2006, à 13:30

SpoN

Re : [Resolu] Encore un pb de son sur Asus A6VC

De rien, on m'avait citer une autre source sur ce forum, j'ai fais quelques changement et rulez smile

Pour editer tu click sur Modifier sur ton premier post et rajoute [RESOLU] dans le titre wink


Asus A6VA

Hors ligne

#11 Le 24/02/2006, à 12:36

fougamou

Re : [Resolu] Encore un pb de son sur Asus A6VC

Bonjour,
Le résultat n'est malheureusement pas celui escompté. En effet comme je suis nouveau sous linux j'ai fait bien des choses et pas que des bonnes. J'ai donc TOUT réinstallé. Mais cette fois ci pas de résultat. Pourtant j'ai tout fait comme la premiere fois. Et tout semble s'être installé.

Mais au moment de choisir la carte avec la commande :

sudo alsaconf

Il me répond

No supported PnP or PCI card found.
Would you like to probe legacy ISA sound cards/chips ?

Alors qu'avant je n'avais plus qu'à choisir la carte en question ?

Avez vous une piste ?

Merci d'avance.

Hors ligne

#12 Le 24/02/2006, à 13:34

fougamou

Re : [Resolu] Encore un pb de son sur Asus A6VC

Resolu, mais ceci me fait poser une autre question.

J'ai deux linux-header installés ?
le 2 6 12 9
et le 2 6 12 10

Qu'en est il ?

Est ce normal ?

Hors ligne

#13 Le 24/02/2006, à 13:57

SamheG

Re : [Resolu] Encore un pb de son sur Asus A6VC

Oui !
A l'install c'est le noyau 2.6.12-9 qui a été installé.
Ensuite tu as fais une mise à jour de ton système et du coup il t'a installé le noyau 2.6.12-10
Celà te permet un retour en arrière éventuel en cas de plantage.
En effet, si après une mise à jour de ton noyau tu constates que pour x raisons ton système n'est plus fonctionnel tu peux toujours booter depuis l'ancien noyau.
Si tout fonctionne bien, tu peux ensuite supprimer l'ancien sans problèmes.
Pour ma part je garde toujours deux versions du noyau !


LMAA
Bye ... ça veut dire CIAO en anglais !
Kansas Of Elsass

Hors ligne

Haut de page ↑