Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 08/01/2017, à 13:06

Feedmeoil

Problèmes carte graphique/pilotes Nvidia

Bonjour à tous,
je me suis rendu compte il n'y a pas si longtemps de l'absence de ma carte graphique dans les réglages Ubuntu,
J'ai alors rechercher l'état des "Warnings" de ma carte graphique avec :

cat /var/log/Xorg.0.log | grep "(WW)"

qui m'a donner a ma grande surprise :

	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    27.311] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    27.311] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    27.311] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    27.311] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    27.311] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    27.739] (WW) Falling back to old probe method for modesetting
[    27.739] (WW) Falling back to old probe method for fbdev
[    27.740] (WW) Falling back to old probe method for vesa

De plus il n'y a aucunes erreurs car le retour de

cat /var/log/Xorg.0.log | grep "(EE)"

est nul.
J'ai essayer de remettre a jour mes pilotes graphiques mais rien n'y fait, ma carte graphique est en grève ..

Pour plus d'info je suis sur un Acer Aspire series, 8 Gio de RAM, Carte graphique Geforce GT 720M, Processer i7 4 Core, 68bits, UBUNTU 14.04 LTS.
Merci aux réponses qui me seront données ! cool


Matthieu

Hors ligne

#2 Le 08/01/2017, à 14:26

Laurent85

Re : Problèmes carte graphique/pilotes Nvidia

Bonjour, installe inxi et donne le rapport sur le système et le matériel,

installation d'inxi :

sudo apt install inxi

génération du rapport :

inxi -Fxz

donne aussi les pilotes disponibles :

ubuntu-drivers devices

Hors ligne

#3 Le 08/01/2017, à 18:08

Feedmeoil

Re : Problèmes carte graphique/pilotes Nvidia

Voila pour le rapport :

  System :  Host: matthieu-Aspire-E5-771G Kernel: 4.4.0-57-generic x86_64 (64 bit, gcc: 4.8.4) 
           Desktop: Gnome Distro: Ubuntu 14.04 trusty
Machine:   System: Acer product: Aspire E5-771G
           Mobo: Acer model: EA70_HB version: Type2 - A01 Board Version Bios: Insyde version: V1.07 date: 06/04/2014
CPU:       Dual core Intel Core i7-4510U CPU (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10399.6 
           Clock Speeds: 1: 1013.695 MHz 2: 1089.968 MHz 3: 887.656 MHz 4: 1977.625 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.1hz 
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1: Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2: Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 
           Sound: Advanced Linux Sound Architecture ver: k4.4.0-57-generic
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k bus-ID: 05:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: 4000 bus-ID: 04:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1000.2GB (39.6% used) 1: id: /dev/sda model: WDC_WD10JPVX size: 1000.2GB temp: 43C 
Partition: ID: / size: 909G used: 369G (43%) fs: ext4 ID: swap-1 size: 8.51GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 246 Uptime: 8 min Memory: 893.8/7906.7MB Runlevel: 2 Gcc sys: 4.8.4 
           Client: Shell (bash 4.3.11) inxi: 1.9.17 

Les drivers disponibles sont :

== /sys/devices/pci0000:00/0000:00:1c.4/0000:01:00.0 ==
modalias : pci:v000010DEd00001140sv00001025sd00000881bc03sc02i00
model    : GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M]
vendor   : NVIDIA Corporation
driver   : nvidia-340 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

J'utilise acctuellement les drivers Nvidia
Merci Laurent pour ta rapidité !

Dernière modification par Feedmeoil (Le 08/01/2017, à 18:25)


Matthieu

Hors ligne

#4 Le 08/01/2017, à 18:13

Feedmeoil

Re : Problèmes carte graphique/pilotes Nvidia

Cette ligne-ci me donne bien la carte intégrée au PC ?

Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.1hz 
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes

Car là je suis de loin dépassé par mes compétences en la matière .. mad


Matthieu

Hors ligne

#5 Le 08/01/2017, à 18:26

Laurent85

Re : Problèmes carte graphique/pilotes Nvidia

Le rapport inxi ne voit pas la carte Nvidia mais c'est probablement un défaut d'inxi avec cette carte. C'est la puce intégrée graphique Intel qui est actuellement utilisée.

Tu l'as installé le pilote recommandé nvidia-340 disponible dans Pilotes additionnels ? Et surtout vérifie bien que Secure boot est désactivé dans le bios de l'ordi.

Dernière modification par Laurent85 (Le 08/01/2017, à 18:27)

Hors ligne

#6 Le 08/01/2017, à 18:31

Feedmeoil

Re : Problèmes carte graphique/pilotes Nvidia

Le pilote nvidia-340 est installé oui !
J'ai préalablement activé le Secure Boot également.


Matthieu

Hors ligne

#7 Le 08/01/2017, à 18:35

Laurent85

Re : Problèmes carte graphique/pilotes Nvidia

Feedmeoil a écrit :

J'ai préalablement activé le Secure Boot également.

Il faut le désactiver sinon le noyau Linux ne pourra pas charger le pilote nvidia. Le pilote est compilé localement lors de l'installation et n'est donc pas signé.

Hors ligne

#8 Le 08/01/2017, à 18:39

Feedmeoil

Re : Problèmes carte graphique/pilotes Nvidia

Je le retire et je reviens, j'ai mal lu excuse moi mad


Matthieu

Hors ligne

#9 Hier à 12:40

Feedmeoil

Re : Problèmes carte graphique/pilotes Nvidia

Bonjour je m'excuse du retard, après avoir retiré Secure Boot je me suis retrouvé sans environnement graphique (eeuuuuh oui WTF ?),
J'ai donc réinstallé mes pilotes, j'ai a nouveau l'environnement graphique sans PB mais toujours pas ma GeForce ...
Le pilote utilisé est le pilote nvidia-340 recommandé.


Matthieu

Hors ligne

#10 Hier à 15:25

andso

Re : Problèmes carte graphique/pilotes Nvidia

bonjour,
bon, moi y' a un truc que je comprend pas:
ton écran est branché sur quoi....
parce que tout semble ok

si tu lances NVIDIA X Serversettings ( ds paramétres) il te dis quoi?

ou renvoies le log de X complet

Dernière modification par andso (Hier à 15:27)


IMPORTANT: Booster votre (X et K)ubuntu:
http://forum.ubuntu-fr.org/viewtopic.php?id=241092 (pfou!...)
à essayer
et... demain debian? http://fr.wikipedia.org/wiki/Demain_les_chiens

Hors ligne

#11 Aujourd'hui à 15:43

Feedmeoil

Re : Problèmes carte graphique/pilotes Nvidia

J'ai un pc portable donc sur l'ordit ?? tongue

Alors pour Nvidia X Server Settings :
Enable ToolTips : Activé
Display Status Bar : A
Slider Text Entries : A
Include X Dispay Names in the Config File : Désactivé
Show "Really Quit?" Dialog : A
Update Rules when an Application Profile Name changes : A

Pour ce qui est du retour de X :

(EE) 
Fatal server error:
(EE) Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) 

Pas très concluent comme retour je suppose ? roll


Matthieu

Hors ligne