Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 31/10/2008, à 00:18

kwakosaure

Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

Salut,

si comme moi vous avez un chipset graphique pourri de la marque via, vous avez sûrement
été bloqués après l'installation du CD alternate, au moins pour la Release Candidate (le live CD, faut même pas essayer).

clem@ubuntu:~$ lspci|grep KM400
00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01)

En fait, le driver openchrome est installé, mais le fichier xorg.conf fait planter le tout.
Je vous livre un fichier de conf qui a fonctionné chez moi après pas mal de galères, l'astuce étant de ne pas mettre de driver dans la section "Device"

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"fr"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-51
	VertRefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice     "stylus" "SendCoreEvents"
	InputDevice     "cursor" "SendCoreEvents"
	InputDevice     "eraser" "SendCoreEvents"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Voilà, bonne chance !

Dernière modification par kwakosaure (Le 31/10/2008, à 00:20)

Hors ligne

#2 Le 31/10/2008, à 10:09

genma

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

Ok. merci pour l'info.


"Lorsque tu as découvert le libre, tu sais que tu ne pourras plus jamais revenir en arrière".
Utilisateur d'Ubuntu depuis la version 4.10 !
Mon blog ?      http://genma.free.fr
Mon twitter?     http://twitter.com/genma

Hors ligne

#3 Le 31/10/2008, à 10:10

michael.fr

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

je teste merci d'avance, j'ai une via s3

Hors ligne

#4 Le 31/10/2008, à 12:55

michael.fr

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

C'est tout bon ca fonctionne.

Hors ligne

#5 Le 31/10/2008, à 15:02

kwakosaure

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

cool
Je pense qu'on peut supprimer toutes les lignes concernant les tablettes WACOM, je testerai ce soir.

Hors ligne

#6 Le 31/10/2008, à 21:20

michael.fr

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

kwakosaure a écrit :

cool
Je pense qu'on peut supprimer toutes les lignes concernant les tablettes WACOM, je testerai ce soir.

Oui je confirme il ne me reste plus qu'un petit message d'erreur mais rien qui n'empeche le serveur X de démarrer

Hors ligne

#7 Le 31/10/2008, à 21:37

michael.fr

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

c'est un post a ne pas perdre on ne doit pas etre les seuls

Hors ligne

#8 Le 04/11/2008, à 01:08

kwakosaure

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

J'ai reporté le bug https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/293326
Merci de confirmer ce bug si vous l'avez aussi expérimenté, ça aura plus d'impact sur l'équipe de launchpad wink

Hors ligne

#9 Le 05/11/2008, à 20:07

quentin2 9217

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

Bonjours
Je pense que je suis dans le même cas que vous. j'ai une carte graphique via qui marche très bien sous hardy mais lors de ma mise a jour vers ibex mon PC plante dès l'affichage de ma page d'accueil .
Le probleme c'est quand mode console en faisant ALT F1 je n'arrive pas aéditer mon fichier XORG

  Si quelqu'un peut m'aider
  Merci d'avance

Quentin2 9217

#10 Le 05/11/2008, à 20:43

quentin2 9217

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

Bon j'ai réussi a accéder à mon fichier "XORG" .
   Je rentre dedans et la surprise il y a presque rien !!!
   
   Qu'est ce que je doit  mettre dedans svp ?
   
   Ou alors comment je peut copier et coller la configuration de "kwakosaure"

   Besoin d'aide SVP

   Quentin2 9217

#11 Le 27/12/2008, à 11:59

CDB111111

Re : Ubuntu 8.10 RC avec carte VIA : pas d'interface graphique [Résolu]

J' hésite entre merci... Merci.... MERCI !
Bon ça aide pas au schmilblick mais P... de sa mère tu viens de débloquer une salle situation big_smile

MERCI BEAUCOUP !

Haut de page ↑