Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/02/2017, à 15:51

ilou

Proxmox et configuration de bind

Bonjour,

J’ai un serveur sous proxmox avec une seule ip publique et sans possibilités d’en avoir d’autres (serveur low cost qui ne propose plus d'ipfo depuis quelques années).
Je fais du NAT de ports entre l’hôte et les vm afin qu'elles accèdent et soient accessibles à l'extérieur.
Une vm s’occupe de la partie web
Une autre vm s’occupe de la partie mail (zimbra sur ubuntu 14)
Les autres vm, a priori on s'en fout (pas concernées par mon problème)

Enfin, je suis autodidacte et il manque des bases qui pourraient vous paraître acquises pour toute personne montant un serveur. J’ai réussi à paramétrer bind sur mon précédent serveur (qui ne faisait pas tourner de VM), mais la je sèche : j’accède à mon serveur web, j'accède aux différentes vm depuis l'extérieur, j’envoie des mails, mais je n’en reçois pas. Vérification faite à plusieurs reprises : les bons ports sont forwardés vers la bonne VM. Du coup je me dis que c'est p'têtre bien bind qui est mal configuré.

Je l'ai configuré comme sur mon précédent serveur (sous debian, sans vm). J'ai tenté une conf dans une vm (en forwardant le port 53) sans succès, donc j'ai essayé dans la machine hôte (sans plus de succès).

- Je fais fausse route, le problème ne vient pas de bind mais de [X] ?

Je vois juste et dans ce cas :
- Dois-je installer bind sur l’hôte, sur une vm, peu importe, sur toutes les VM, ou la réponse D ?
- En fonction de la réponse :    + Dois-je supprimer bind éventuellement installé par défaut sur les machines autres que la réponse  à la précédente question ?
                                + Rediriger le port 53 vers la machine qui « héberge » bind est-il suffisant ?
- Dois-je préciser dans les  fichiers de conf de bind sur quelle machine (ip locale) se trouve le MX où le NAT réalisé à partir de l’hôte suffit ?

Une fois de plus je suis conscient de mes lacunes mais justement, j'ai pris ce serveur pour apprendre (mon petit loisir à moi). J'ai cherché (peut-être mal), mais tout ce que j'ai trouvé parle d'IPFO dont je ne peux bénéficier sur cette gamme de serveur.

Je suis persuadé qu'il ne manque pas grand chose pour que ça fonctionne, mais je sèche sur ce pas grand chose depuis plusieurs jours. Si quelqu'un a ne serais-c qu'un début de piste je serais ravis et je le remercie d'avance.

Hors ligne

#2 Le 27/02/2017, à 16:27

outcast

Re : Proxmox et configuration de bind

Tu dois procéder à un debug réseau.
C'est à dire lancer tcpdump sur ton serveur et sur la machine virtuelle.
Envoyer un mail.
Regarder jusqu'ou il ira.
A priori il devrait atteindre le serveur mais pas la machine virtuelle.
ça veut dire que le forwarding sur le serveur n'est pas bon.
Si le mail n'atteint même pas le serveur, ça veut dire que ta configuration MX dans les DNS n'est pas bonne.
Si ton registrar a un service DNS, tu n'as pas besoin d'avoir le tien.
Je ne pense pas que le problème vient de ton bind que je recommande de désinstaller et laisser le registrar gérer les DNS avec son bind à lui.

Hors ligne