Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 20/03/2017, à 12:21

charlene

[Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

bonjour,
je débute sur ubuntu et ne suis pas une geek. Je passe donc par les commandes graphiques.
Voilà mon problème :
J'ai deux écrans synchronisés (ordi portable et écran externe), ils sont connectés par un câble hdmi.
Quand je clique sur "les paramètres", mes deux écrans se désynchronisent systématiquement.
J'utilise ubuntu depuis 3 mois et ça se produit à chaque fois que j'ouvre les paramètres, sans exception.

Voyez-vous une solution ?

Bonne journée à tous

Dernière modification par charlene (Le 17/04/2017, à 10:30)

Hors ligne

#2 Le 20/03/2017, à 12:59

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Salut !


peux tu donner le retour des commandes suivantes (via le terminal), en utilisant les balises codes :

uname -r

modèle de carte graphique :

lspci -nnk | grep -Ei -A 4 "VGA|3D|Display"

xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#3 Le 20/03/2017, à 13:10

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Merci pour la réponse.
Voilà ce que me dit le terminal :

00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
    Subsystem: ASUSTeK Computer Inc. Haswell-ULT Integrated Graphics Controller [1043:167d]
    Kernel driver in use: i915
    Kernel modules: i915
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
--
03:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 840M] [10de:1341] (rev a2)
    Subsystem: ASUSTeK Computer Inc. GM108M [GeForce 840M] [1043:167d]
    Kernel modules: nvidiafb, nouveau

Hors ligne

#4 Le 20/03/2017, à 13:17

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

et

uname -r

la version est importante par rapport aux pilotes.

peux-tu éditer ton message pour utiliser les balises code pour les retours de commande (icone <> sur la ligne au dessus du champ de saisie).

Dans "logiciels et mises à jour", onglet pilotes additionnels, est-il proposé un pilote nvidia ?

exemple :
https://doc.ubuntu-fr.org/_media/nvidia … trusty.png


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix et hostingpics le permettent).

Dernière modification par cqfd93 (Le 20/03/2017, à 14:11)


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#5 Le 20/03/2017, à 13:41

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

J'ai cliqué sur <> puis j'ai collé le message du terminal.
C'est ça ?
Ou faut-il faire autrement... ?
(je suis une vraie débutante !! smile


00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
	Subsystem: ASUSTeK Computer Inc. Haswell-ULT Integrated Graphics Controller [1043:167d]
	Kernel driver in use: i915
	Kernel modules: i915
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
--
03:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 840M] [10de:1341] (rev a2)
	Subsystem: ASUSTeK Computer Inc. GM108M [GeForce 840M] [1043:167d]
	Kernel modules: nvidiafb, nouveau

Hors ligne

#6 Le 20/03/2017, à 14:01

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

et sinon, dans "logiciels et mises à jour", j'ai bien un pilote nvidia.

Hors ligne

#7 Le 20/03/2017, à 14:08

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

1490015289.png

Edit : lien avec miniature

Dernière modification par cqfd93 (Le 20/03/2017, à 14:12)

Hors ligne

#8 Le 20/03/2017, à 15:08

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Tente le pilote 367

Sinon c'est ok pour les balises codes

Dernière modification par tarkan99 (Le 20/03/2017, à 15:15)


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#9 Le 20/03/2017, à 15:34

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

non malheureusement, le problème persiste.

Hors ligne

#10 Le 20/03/2017, à 15:36

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

même après un redémarrage de l'ordi

Hors ligne

#11 Le 20/03/2017, à 15:46

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

qu'entends tu par "se désynchronisent " ?

et tu n'as donné il me semble le retour de

uname -r

Dernière modification par tarkan99 (Le 20/03/2017, à 15:47)


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#12 Le 20/03/2017, à 15:51

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Quand je synchronise mes écrans, je vais dans
Paramètres > affichage > détecter les écrans.
Et là je peux partager le bureau de mon ordi avec mon écran externe.

Par la suite, quand je reclique sur l'icone "paramètres" (pour effectuer d'autres opérations), mes écrans se désynchronisent.
Je veux dire que le partage d'écran se désactive tout seul.
je n'ai plus rien qui s'affiche sur l'écran externe
Toutes les fenêtres s'affichent alors sur mon ordi.

Hors ligne

#13 Le 20/03/2017, à 15:53

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

j'insiste sur le retour de

uname -r

xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#14 Le 20/03/2017, à 15:54

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

voici l'info pour uname

4.4.0-67-generic

Hors ligne

#15 Le 20/03/2017, à 16:03

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

ta version d'ubuntu est à jour.

après une désynchro, peux tu
attendre 10s
lancer
dmesg | tail -n 20
et donner le retour.

comme le pilote nvidia ne résoud pas le pb, il va falloir attendre l'aide d'un expert double écran, avec ce qui a été fait ci dessus.


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#16 Le 20/03/2017, à 16:08

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

charlene@charlene:~$ dmesg | tail -n 20
[   67.637818] cfg80211: World regulatory domain updated:
[   67.637821] cfg80211:  DFS Master region: unset
[   67.637822] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   67.637824] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   67.637825] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   67.637827] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   67.637828] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   67.637830] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   67.637831] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   67.637832] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   67.637833] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   67.639965] wlp2s0: associate with 68:a3:78:6c:91:22 (try 1/3)
[   67.644097] wlp2s0: RX AssocResp from 68:a3:78:6c:91:22 (capab=0x411 status=0 aid=6)
[   67.645082] wlp2s0: associated
[  804.860830] snd_hda_codec_hdmi hdaudioC0D0: HDMI: ELD buf size is 0, force 128
[  804.860870] snd_hda_codec_hdmi hdaudioC0D0: HDMI: invalid ELD data byte 0
[  946.287983] snd_hda_codec_hdmi hdaudioC0D0: HDMI: ELD buf size is 0, force 128
[  946.288021] snd_hda_codec_hdmi hdaudioC0D0: HDMI: invalid ELD data byte 0
[ 2834.318341] snd_hda_codec_hdmi hdaudioC0D0: HDMI: ELD buf size is 0, force 128
[ 2834.318380] snd_hda_codec_hdmi hdaudioC0D0: HDMI: invalid ELD data byte 0

Hors ligne

#17 Le 21/03/2017, à 06:27

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

je reviens sur l'utilisation du pilote nvidia : vu qu'il y a aussi un chipset intel, celui ci est peu être actif par défaut.

tu as gardé le paramétrage sur pilote nvidia ?

avec ce réglage, que donne

sudo nvidia-settings

si une fenêtre s'ouvre, regarde les différents réglages, cherche si quelque part s'il y a un choix entre nvidia et intel.


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#18 Le 21/03/2017, à 09:23

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Merci de suivre cette question de près !
Alors, voici les résultats du terminal :

charlene@charlene:~$ sudo nvidia-settings
[sudo] Mot de passe de charlene : 
** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Hors ligne

#19 Le 21/03/2017, à 09:26

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Et voici la fenêtre qui s'ouvre :

1490084745.png

Hors ligne

#20 Le 21/03/2017, à 13:34

tarkan99

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

as-tu testé le choix nvidia  dans la fenêtre ci dessus ?


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#21 Le 17/04/2017, à 10:23

charlene

Re : [Résolu] Quand j'ouvre les parametres, mes 2 écrans se désynchronisent

Cher Tarkan,
j'ai finalement changé d'écran et j'utilise à présent un câble hdmi/hdmi pour le relier à mon pc portable.
Et tout fonctionne !
Merci beaucoup pour ton aide
bonne journée

Hors ligne